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Introduction

This section contains these chapters:

• IDE User’s Guide Overview

• CodeWarrior IDE Overview
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1
IDE User’s Guide Overview

This chapter of the CodeWarrior™ IDE User’s Guide is a high-level description of 
documentation and training resources for learning to use the IDE:

• CodeWarriorU.com—free, Internet-based instruction for CodeWarrior products. 
Use this resource to learn more about the CodeWarrior Integrated Development 
Environment (IDE) and computer programming.

• Documentation structure—a guide to the various CodeWarrior manuals 
available. This guide notes the location of generic and specific product 
documentation.

• Common conventions—some common typographical conventions used in this 
manual and other Metrowerks documentation.

This chapter has these sections:

• “Release Notes” on page 15

• “CodeWarriorU.com” on page 15

• “Documentation Structure” on page 16

• “Manual Conventions” on page 17

Release Notes
Please read the release notes. They contain important last-minute additions to the 
documentation. The Release Notes folder on the CodeWarrior CD contains the 
information.

CodeWarriorU.com
CodeWarriorU.com offers a wide range of free, Internet-based courses in a wide 
variety of computer programming topics. Use this supplement to the CodeWarrior 
documentation to acquire more experience using CodeWarrior products.
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Documentation Structure
CodeWarriorU.com courses have these features:

• Text-based instruction

• Expert instructors

• A variety of self-assessment and study materials

• Interactive message boards for communicating with instructors and fellow 
students

CodeWarriorU offers many courses, such as these:

• Learn Programming in C

For beginning programmers. Take this course to learn how to create C software.

• Introduction to Java

For beginning and experienced programmers. Take this course to learn how to 
create Java software.

• Introduction to C++

For beginning and experienced programmers. Take this course to learn how to 
create C++ software.

• Intermediate C++

For programmers who completed the Introduction to C++ course and have basic 
C++ programming knowledge. Take this course to learn the foundation needed to 
create more sophisticated C++ software.

To find out more, visit this web site:

http://www.CodeWarriorU.com/

Documentation Structure
CodeWarrior products include an extensive documentation library of user guides, 
targeting manuals, and reference manuals. Take advantage of this library to learn how 
to efficiently develop software using the CodeWarrior programming environment.

Documentation Formats
CodeWarrior documentation presents information in various formats:

• Print—Printed versions of CodeWarrior manuals, including the IDE User’s 
Guide, MSL C Reference, C/C++ Reference, and product-focused
Targeting manuals.
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Manual Conventions
• PDF (Portable Document Format)—Electronic versions of CodeWarrior 
manuals. The CodeWarrior CD Documentation folder contains the electronic 
PDF manuals.

• HTML (Hypertext Markup Language)—HTML or Compressed HTML (.CHM) 
versions of CodeWarrior manuals.

Documentation Types
Each CodeWarrior manual focuses on a particular information type:

• User guides—User guides provide basic information about the CodeWarrior user 
interface. User guides include information that supports all host platforms on 
which the software operates, but do not include in-depth platform-specific 
information. An example is the PowerParts User Guide.

• Targeting manuals—Targeting manuals provide specific information required 
to create software that operates on a particular platform or microprocessor. 
Examples include the Targeting Windows, Targeting Java, and Targeting 
DSP56800 manuals.

• Reference manuals—Reference manuals provide specialized information that 
supports coding libraries, programming languages, and the IDE. Examples 
include the C Compiler Reference, MSL C Reference, and Extending the 
CodeWarrior IDE manuals.

• Core manuals—Core manuals explain the core technologies available in the 
CodeWarrior IDE. Examples include:

– IDE User’s Guide

– C/C++ Compilers Reference

– MSL C Reference and MSL C++ Reference

– Extending the CodeWarrior IDE

– Command-Line Tools Reference

Manual Conventions
This section explains conventions in the IDE User’s Guide.

Figure Conventions
The CodeWarrior IDE employs a virtually identical user interface across multiple 
hosts. For this reason, illustrations of common interface elements use images from any 
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host. However, some interface elements are unique to a particular host. In such cases, 
clearly labelled images identify the specific host.

Keyboard Conventions
The CodeWarrior IDE accepts keyboard shortcuts, or key bindings, for frequently used 
operations. For each operation, this manual lists corresponding key bindings by 
platform. Hyphens separate multiple keystrokes in each key binding.

Special note for Solaris users and Linux 
users
The Solaris and Linux IDE use Macintosh symbols to represent modifier keys in key 
bindings. Table 1.1 shows the relationship between the Macintosh symbols and the 
equivalent modifier keys on Solaris and Linux computers.

Solaris and Linux computers can map a modifier key to any key on the keyboard. The 
preceding table reflects the default modifier key configuration for these computers. 
Remember that custom mappings supersede the default configuration noted in
the table.

Table 1.1  Macintosh modifier-key equivalents for Solaris and Linux

Symbol Macintosh 
Name

Solaris 
Equivalent

Linux 
Equivalent

Control Control Ctrl

Option Alt Alt

Command Meta Alt

Shift Shift Shift
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CodeWarrior IDE Overview

The CodeWarrior™ Integrated Development Environment (IDE) provides an efficient 
and flexible software-development tool suite. This chapter explains the advantages of 
using the CodeWarrior IDE and provides brief descriptions of the major tools that 
make up the IDE.

This chapter contains these sections:

• “Development Cycle” on page 19

• “CodeWarrior IDE Advantages” on page 21

• “IDE Tools Overview” on page 22

Development Cycle
A software developer follows a general development process:

• Begin with an idea for new software.

• Implement the new idea in source code.

• Have the IDE compile source code into machine code.

• Have the IDE link machine code and form an executable file.

• Correct errors (debug).

• Compile, link, and release a final executable file.

The stages of the development cycle correspond to one or more chapters in this 
manual.

Figure 2.1 on page 20 depicts the development cycle as a flowchart. Table 2.1 on page 
21 details the different stages and their corresponding sections in this manual.
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Development Cycle
Figure 2.1  The Development Cycle diagram
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CodeWarrior IDE Advantages
Software developers take advantage of CodeWarrior IDE features during software 
development:

• Cross-platform development

Develop software to run on multiple operating systems, or use multiple hosts to 
develop the same software project. The IDE runs on popular operating systems, 
including Windows, Macintosh, Solaris, and Linux. The IDE uses virtually the 
same graphical user interface (GUI) across all hosts.

• Multiple-language support

Choose from multiple programming languages when developing software. The 
IDE supports high-level languages, such as C, C++, and the Java programming 
language, as well as in-line assemblers for most processors.

Table 2.1  Stage descriptions and related sections in the IDE User’s Guide

Stage Description Related Sections

Create Create the initial project, source files, 
and build targets that implement an 
idea for new software.

• “Projects” on page 25

• “Preferences and Target 
Settings” on page 315

• “Menus” on page 437

Edit Transform the idea into working 
source code, organize interface 
elements, and correct errors.

• “Editor” on page 85

• “Browser” on page 155

Compile Compile the source code into 
machine format that operates on the 
target host.

“Compilers and Linkers” on page 305

Link Link the separate compiled modules 
into a single binary executable file.

“Compilers and Linkers” on page 305

Debug Find and resolve all coding and logic 
errors that prevent the program from 
operating as designed.

“Debugger” on page 197

Release Release for public use. Beyond the scope of this manual.
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• Consistent development environment

Port software to new processors without having to learn new tools or lose an 
existing code base. The IDE supports many common desktop and embedded 
processor families, including x86, PowerPC, MIPS, and many others.

• Plug-in tool support

Extend the capabilities of the IDE by adding a plug-in tool that supports new 
services. The IDE currently supports plug-ins for compilers, linkers, pre-linkers, 
post-linkers, preference panels, version controls, and other tools. Plug-ins make it 
possible for the CodeWarrior IDE to process different languages and support 
different processor families.

IDE Tools Overview
The CodeWarrior IDE is a tool suite that provides sophisticated tools for software 
development. This section explains the standard tools available in the IDE:

• a project manager

• an editor

• a search engine

• a source browser

• a build system

• a debugger

Table 2.2 on page 23 explains the purpose of these tools and lists corresponding 
CodeWarrior IDE features.
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Table 2.2  IDE tools and features

Tool Purpose CodeWarrior IDE Features

Project Manager Manipulate items 
associated with
a project

• Handles top-level file management for 
the software developer

• Organizes project items by major group, 
such as files and targets

• Tracks state information (such as file-
modification dates)

• Determines build order and inclusion of 
specific files in each build

• Coordinates with plug-ins to provide 
version-control services

Editor Create and 
modify source 
code

• Uses color to differentiate 
programming-language keywords

• Allows definition of custom keywords for 
additional color schemes

• Automatically verifies parenthesis, 
brace, and bracket balance

• Allows use of menus for navigation to 
any function or into the header files 
used by the program

Search Engine Find and
replace text

• Finds a specific text string

• Replaces found text with substitute text

• Allows use of regular expressions

• Provides file-comparison and 
differencing functionality

Source Browser Manage and view 
program symbols

• Maintains a symbolics database for the 
program. Sample symbols include 
names and values of variables and 
functions.

• Uses the symbolics database to assist 
code navigation

• Links every symbol to other locations in 
the code related to that symbol

• Processes both object-oriented and 
procedural languages
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Build System Convert source 
code into an 
executable file

• Uses the compiler to generate object 
code from source code

• Uses the linker to generate a final 
executable file from object code

Debugger Resolve errors • Uses the symbolics database to provide 
source-level debugging

• Supports symbol formats such as 
CodeView, DWARF (Debug With 
Arbitrary Records Format), and SYM 
(SYMbolic information format)

Table 2.2  IDE tools and features (continued)

Tool Purpose CodeWarrior IDE Features
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Projects

This section contains these chapters:

• Working with Projects

• Project Window

• Working with Files

• Dockable Windows

• Workspaces

• Creating Console Applications
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3
Working with Projects

This chapter explains how to work with projects in the CodeWarrior™ IDE. Projects 
organize several file types associated with a computer program:

• Text files—files that contain any kind of text. Sample text files include Read Me 
files and source files.

• Source files—files that contain source code only. Sample source files include 
C++ files and Java files.

• Library files—files that contain special code designed to work together with a 
particular programming language or operating environment.

• Generated files—files created by the IDE while building or debugging the 
project.

This chapter contains these sections:

• “About Projects” on page 27

• “Managing Projects” on page 31

• “Advanced Projects” on page 38

About Projects
The IDE uses build targets and a Project Manager to organize source code and support 
files. This section explains both components.

Project Manager
The IDE gathers source, library, resource, and other files into a project. The Project 
Manager manipulates the information stored in the project.

Figure 3.1 on page 28 diagrams Project Manager interactions with IDE tools. Table 
3.1 on page 28 explains the interactions.
27IDE 5.5 User’s Guide



Working with Projects
About Projects
Figure 3.1  Project Manager

Table 3.1  Project Manager interactions

IDE Tool Project Manager Interactions

Editor • Coordinating internal data flow among editor windows, the 
search engine, and the source browser

• Matching find-and-replace results between related header files 
and source files

• Associating functions and variables with their corresponding 
source code

Compiler • Synchronizing with source code a symbolics database of 
program functions, variables, and values

• Coordinating internal data flow between the symbolics 
database and the source browser

• Determining the files to include in the build process

The build system generates
symbolics information for
a program. The debugger
generates a database from
the symbolics information.

Build System

Search 
Engine

Editor

Source 
Browser

Compiler

Symbolics 
Information

Linker Debugger

Main IDE tool

Support tool

Information that the
IDE generates

Development flow

Legend

IDE internal data flow

Additional information
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Build Targets
For any given build, the project manager tracks:

• files and libraries

• link order

• dependencies

• compiler, linker, and other settings

The IDE stores this information in a build target. As the project changes, the project 
manager automatically updates the build target. The project manager also coordinates 
program builds, using the build-target information to call the appropriate tools in the 
correct order with the specified settings.

For example, the project manager directs the build system to compile only those 
source files that rely on the information in a modified file.

Note that all of this operation happens automatically. The software developer does not 
need to remember makefile syntax or semantics, and never has to debug makefile 
syntax errors. The IDE simplifies the process, making it easier to develop software.

The project manager also supports multiple build targets within the same project file. 
Each build target can have its own unique settings, and even use different source and 
library files. For example, it is common to have both debug and release build targets in 
a project.

Figure 3.2 on page 30 shows a sample project with debug and release build targets.

Linker • Sending compiled object code to the linker for conversion to 
executable code

• Setting the link order for processing compiled object code

Debugger • Matching debugging data to source code

• Updating the symbolics database to reflect changing values 
during a debugging session

Table 3.1  Project Manager interactions (continued)

IDE Tool Project Manager Interactions
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Figure 3.2  Project with multiple build targets

Project

Build Target - Debug

File #1 File #2

File #3 Object Code

Settings Browser Data

Build Target - Release

File #1 File #2

File #4 Object Code

Settings Browser Data

...

Note that both build targets
share File #1 and File #2.
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Managing Projects
Use these tasks to manage projects:

• Create a new project

• Open an existing project

• Save an existing project

• Close an open project

• Inspect an open project

• Print an open project

Creating New Projects using Project Stationery

Use the project stationery provided with the IDE to quickly create new projects. The 
stationery contains everything needed for a minimal, ready-to-run project. Use project 
stationery as a foundation upon which to add features for each new programming 
endeavor.

1. Choose File > New.

2. Click the Project tab and select a project type.

3. Enter a project name (include the .mcp extension) in the Project Name field and 
set the Location for the new project.

4. Click OK in the New window.

5. Select the appropriate project stationery from the New Project window.

6. Click OK in the New Project window.

The IDE uses the selected project stationery as a template to create a new project.
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Creating New Projects from Makefiles

Use the Makefile Importer wizard provided with the Windows, Solaris, and Linux IDE 
to convert most Visual C nmake or GNU make files into projects. The wizard 
performs these tasks:

• Parses the makefile to determine source files and build targets

• Creates a project

• Adds the source files and build targets determined during parsing

• Matches makefile information, such as output name, output directory, and access 
paths, with the newly created build targets.

• Selects a project linker

1. Choose File > New.

2. Click the Project tab.

3. Select Makefile Importer Wizard.

4. Enter a project name (include the .mcp extension) in the Project Name field and 
set the Location for the new project.

5. Click OK in the New window.

6. Enter the path to the makefile in the Makefile location field or click Browse to 
navigate to the makefile.

7. Choose the tool set used for makefile conversion and linker selection.

• Tool Set Used In Makefile—Choose the tool set whose build rules form the 
basis of the makefile.

• Metrowerks Tool Set—Choose the linker tool set to use with the generated 
project.

8. Select the desired diagnostic settings.

• Log Targets Bypassed—Select to log information about makefile build targets 
that the IDE fails to convert to project build targets.

• Log Build Rules Discarded—Select to log information about makefile rules that 
the IDE discards during conversion.
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• Log All Statements Bypassed—Select to log targets bypassed, build rules 
discarded, and other makefile items that the IDE fails to convert.

9. Click Finish, then Generate.

The Makefile Importer wizard performs the conversion process and displays 
additional information.

Creating Empty Projects

Unlike project stationery, empty projects do not contain a pre-configured collection of 
template source files, library files, or build targets. Empty projects allow advanced 
software engineers to custom-build new projects from scratch.

NOTE Avoid creating empty projects. Instead, modify a project created with 
project stationery. Project stationery pre-configures complicated 
settings to quickly get started.

1. Choose File > New.

2. Click the Project tab and select Empty Project.

3. Enter a project name (include the .mcp extension) in the Project Name field and 
set the Location for the new project.

4. Click OK in the New window.

The IDE creates an empty project. Add files and libraries, create build targets, and 
choose the appropriate target settings to complete the new project.

Opening Projects

Use the IDE to open previously saved projects. CodeWarrior projects normally end in 
the Metrowerks CodeWarrior Project extension of .mcp. Open projects to add, 
remove, or modify files to enhance the capabilities of the final executable file.

1. Choose File > Open.

2. Find and select the project to open.
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3. Click Open.

The IDE opens the project and displays its Project window.

NOTE The IDE prompts you for confirmation to update projects created in 
older CodeWarrior versions.

Opening Projects Created on Other Hosts

CodeWarrior projects whose names end in .mcp are cross-platform. However, the 
object code stored inside each project folder is not cross-platform. Use these procedure 
to properly open the project on a different host computer.

1. If not present, add the .mcp file-name extension to the project name.

2. Copy the project folder from the original host to the new host.

3. Delete the Data folder inside the newly copied project folder.

4. Open the newly copied project on the new host IDE.

5. Recompile the project to generate new object code.

Saving Projects

The IDE automatically saves projects and updates project information after 
performing these actions:

• Closing the project

• Applying or saving a preference or target-setting option

• Adding, deleting, or compiling a file

• Editing group information

• Removing or compacting object code

• Quitting the IDE
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Inspecting Project Files

Use the Project Inspector command to review and configure source-file attributes 
and target information in the Project Inspector window.

1. Select a file in the Project window.

2. Open the Project Inspector window, as explained in Table 3.2.

3. Examine the source-file attributes and target settings.

• Click the Attributes tab to view the file attributes.

• Click the Targets tab to view the build targets that use the file.

Printing Projects

The Project Manager can print a complete listing of the Files, Designs, Link Order, 
or Targets tab currently displayed in the Project window.

1. Select the Project window.

2. Click the Files, Designs, Link Order, or Targets tab.

3. Choose File > Print.

4. Set the print options in the print dialog.

5. Print the Project window contents, as explained in Table 3.3.

Table 3.2  Opening the Project Inspector window

On this host… Do this…

Windows Select View > Project Inspector.

Macintosh Select Window > Project Inspector.

Solaris Select Window > Project Inspector.

Linux Select Window > Project Inspector.
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The IDE prints the contents of the selected tab in the Project window.

Choosing a Default Project

The IDE allows multiple open projects at the same time. However, a given source file 
can belong to more than one open project, making it ambiguous as to which project a 
source-file operation applies.

To resolve ambiguity, choose the default project to which the IDE applies operations.

1. If only one project is open, it automatically becomes the default project.

2. If more than one project is open, choose Project > Set Default Project to select 
the desired default project.

In ambiguous situations, the IDE applies operations to the selected default 
project.

Exporting Projects to XML Files

The IDE can export a project to an Extensible Markup Language (XML) file. Use this 
capability to store projects in text-oriented environments, such as a version control 
system.

1. Bring forward the project to export.

2. Choose File > Export Project.

Table 3.3  Printing the Project window contents

On this host… Do this…

Windows Click OK.

Macintosh Click Print.

Solaris Click Print.

Linux Click Print.
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3. Name the exported XML file and save it in the desired location.

The IDE converts the project to an XML file.

Importing Projects Saved as XML Files

The IDE can import a project previously saved in Extensible Markup Language 
(XML) format. Use this capability to recreate projects stored in text-oriented 
environments, such as a version control system.

1. Choose File > Import Project.

2. Create a new folder in which to save the converted project and all of its generated 
files.

3. Find the XML file that you want to import.

4. Save the XML file in the newly created folder.

The IDE converts the XML file to a project.

Closing Projects

Use the Close command to close a CodeWarrior project file at the end of a 
programming session. The IDE automatically saves changes to a closed project.

1. Select the Project window to close.

2. Close the project.

• Choose File > Close.

• Click the close box in the Project window.

The IDE closes the project.
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Advanced Projects
Advanced projects deal with these topics:

• Custom project stationery—modified project stationery tailored to advanced 
programming needs.

• Subprojects—projects within projects.

• Strategies—obtaining the maximum benefit from advanced projects.

Custom Project Stationery
Use custom project stationery to develop streamlined templates to meet advanced 
programming needs:

• Pre-configure new project stationery to include often-used files, libraries, and 
source code

• Configure build targets and options to any desired state

• Set up a reusable template to use for creating projects

NOTE Custom project stationery requires in-depth knowledge about project 
structure and operation. Before creating custom stationery, be sure to 
fully understand existing project stationery included with the 
CodeWarrior product.

Creating Custom Project Stationery

Use custom project stationery to develop a convenient template for creating new 
projects. An efficient way to develop custom stationery is to modify existing project 
stationery and save it under a new name in the Stationery or Project Stationery 
folder.

1. Follow the usual process for creating a project from project stationery.

See “Creating New Projects using Project Stationery” on page 31 for more 
information.

2. Choose File > Save A Copy As.

3. Find the Project Stationery folder in the CodeWarrior installation.
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4. Create a folder inside the Project Stationery folder to store the newly created 
project.

5. Save the project to its new folder. Use a descriptive project name with the .mcp 
extension.

6. Customize the newly saved project so that it becomes a template for creating 
other projects:

• Add source files to the project. Save these files in the same folder as the project 
itself.

• Add build targets for building the project with frequently used settings.

• Configure other project preferences as desired.

7. Close the customized project to save it.

8. Open the customized project folder inside the Project Stationery folder.

9. Find and delete the _Data folder.

The IDE now treats the customized project as project stationery. The descriptive 
name appears in the Project tab of the New window.

Subprojects
A subproject is a project nested inside a parent project. Subprojects organize source 
code for the IDE to build prior to building the parent project. For example, the IDE 
builds subprojects for an application’s plug-ins before building the parent project for 
the application itself.

Adding Subprojects to a Project

Use a subproject to organize a separate set of source files and build targets inside a 
parent project.

1. Open the parent project in which to add a subproject. The parent Project window 
opens.

2. Click the Files tab in the Project window.
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3. If the parent project has more than one build target, use the build-target list box in 
the Project window toolbar to choose the desired build target.

4. Add a separate project to the Project window:

• Drag and drop the .mcp file of the separate project into the Project window, or

• Choose Project > Add Files to add the .mcp file of the separate project.

The IDE treats the added project as a subproject. The subproject appears in the 
Files view of the parent Project window.

Opening Subprojects

The IDE can open a subproject from the parent Project window. Use this feature to 
more conveniently open the subproject.

1. Double-click the subproject in the Files view of the parent Project window.

2. The IDE opens the subproject in its own Project window.

Strategies
Projects can organize files into build targets or subprojects. Each of these structures 
has its own advantages. Choose the structure best suited to the programming need.

Build Targets
Build targets organize collections of files inside a project. Build targets have these 
advantages:

• Using multiple build targets inside a single project allows access to all source 
code for that project.

• Build targets organize different collections of build settings for a single project.

• Each project accommodates up to 255 build targets.

Subprojects
Subprojects incorporate separate, standalone projects into parent projects. Subprojects 
have these advantages:
40 IDE 5.5 User’s Guide



Working with Projects
Advanced Projects
• Subprojects separate distinct parts of a complex program, such as an application 
and its various plug-ins.

• Using subprojects streamlines a complicated build. For example, create a project 
that builds all plug-ins for an application. Add this project as a subproject of the 
main application. The IDE then builds all plug-ins before building the main 
application.

• Use subprojects to break down a complicated project that approaches the 255 
build-target limit. Organize related build targets into different subprojects to 
improve build speed.
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Project Window

This chapter explains how to work with the Project window in the CodeWarrior™ 
IDE. The Project window provides these features:

• view and modify all files created for use with a computer program.

• manipulate files arranged by type.

• control the way the IDE handles files.

This chapter contains these sections:

• “About the Project Window” on page 43

• “Project Window Pages” on page 45

• “File, Group, Layout, and Target Management” on page 49

• “Build-Target Management” on page 53

About the Project Window
The Project window organizes files in a computer program. Use this window to 
control various aspects of each file. The window includes these items:

• Project window toolbar

• Tabs

• Columns

Figure 4.1 on page 44 shows a sample Project window. Table 4.1 on page 44 explains 
the items in the Project window.

NOTE The number and names of the tabs in the Project window depend on 
the current build target and on the installed IDE plug-ins.
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Figure 4.1  Project window

Table 4.1  Project window—items

Item Icon Explanation

Current Target Use to specify the build target that you want 
to modify.

Target Settings Click to view and edit the settings for the 
current build target.

Synchronize 
Modification Dates

Click to check the modification dates of 
each project file and mark those files that 
need compilation.

Make Click to compile and link all modified and 
manually selected (touched) project files.

Debug Click to debug the current build target.

Run Click to compile and link the current build 
target, then run the program.

Project Inspector Click to view project information and edit 
file-specific information.
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Project Window Pages
The Project window uses pages to organize items:

• Files

• Link Order

• Targets

• Frameworks (for projects supporting code frameworks)

Files Page
The Files page shows information about individual files in a project. The Files page 
shows information about these file types:

• Text files—files that contain any type of text. Sample text files include Read Me 
files and source files.

• Source files—files that contain source code only. Sample source files include 
C++ files and Java files.

• Library files—files that contain special code designed to work together with a 
particular programming language or operating environment.

Table 4.2 explains the items in the Files page.

Files Click to display the Files page. This page 
shows a list of files in the project and their 
associated properties.

Link Order Click to display the Link Order page. This 
page shows the link order of files in the 
current build target.

Frameworks Click to display the Frameworks page. This 
page shows available programming 
frameworks to link against. The Frameworks 
tab appears only for projects that support 
frameworks.

Targets Click to display the Targets page. This page 
shows a list of all build targets, sub-projects, 
and target-linking information.

Table 4.1  Project window—items (continued)

Item Icon Explanation
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Table 4.2  Files page—items

Item Icon Explanation

Touch Indicates the touch status of each file. Click in this column to toggle 
touching a file. Touching a file manually selects it for compilation 
during the next build. Click the Touch icon to sort files by touch 
status.

File Displays a hierarchical view of the file and group names used by 
the project. Click the column title to sort files by name. Double-click 
a file to open it. Use the hierarchical controls to display and hide 
group contents.

Code Displays the size, in bytes or kilobytes, of the compiled executable 
object code for files and groups. Click the column title to sort files 
by code size.

Data Displays the size, in bytes or kilobytes, of non-executable data in 
the object code for files in the project. Click the column title to sort 
files by data size.

Target Indicates whether each file belongs to the current build target. 
Click in this column to toggle inclusion status. Click the Target icon 
to sort files by inclusion status. The Target column appears only 
when the project has more than one build target.

Debug Displays debugging status. Click in this column to toggle 
generation of debugging information for a file or group. Click the 
Debug icon to sort files by debugging status.

Checkout 
Status

Displays icons representing the current file status in a version-
control system. The Checkout Status column appears only when 
the project uses a version-control system to manage files.

Interfaces Click to display a list of files inside a group or a list of #include 
files inside a source file. Choose a file to
open it.

Sort Order Click to toggle sorting between ascending and descending order 
for the active column. The icon indicates the current sort order.
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Viewing a File Path

To distinguish between two files that have identical names but reside in different 
folders, examine the file path.

To view the complete file path of a file, perform the task explained in Table 4.3.

The File Path submenu shows the path to the file.

Link Order Page
The Link Order page shows information about the order in which the IDE links
project files. Manipulate the files in this page to change the link order. For example,
if file B depends on file A in order to function, move file B below file A in the
Link Order page.

Table 4.4 on page 48 explains the items in the Link Order page.

Table 4.3  Viewing a file path

On this host… Do this…

Windows Right-click the filename and select
Open in Windows Explorer

Macintosh Control-click the filename and select File Path.

Solaris Click and hold on the filename, then select File Path.

Linux Click and hold on the filename, then select File Path.
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Targets Page
The Targets page presents information about the build targets in a project. Use this 
page to create, manage, or remove build targets. Different build targets can store 
different IDE settings. For example, two build targets can handle the same project. 
One build target handles debugging the software, while the other build target handles 
building the software for final release.

Table 4.5 explains the items in the Targets page.

Table 4.4  Link Order page—items

Item Explanation

Synchronize Modification 
Dates

To update the modification dates of the files stored in a project 
file, click the checkmark icon.

Use the Synchronize Modification Dates command to update 
files modified outside of the CodeWarrior IDE, perhaps by a 
third-party editor which cannot notify the CodeWarrior IDE of 
the changes.

Synchronize Status To update version-control status information, click the Pencil 
icon.

Table 4.5  Targets page—items

Item Explanation

Targets Displays all build targets and subprojects that the IDE processes 
to create a binary file. These icons denote build-target status:

•  active build target

• inactive build target

Link Indicates the dependencies between build targets
and subprojects.
48 IDE 5.5 User’s Guide



Project Window
File, Group, Layout, and Target Management
File, Group, Layout, and Target 
Management

Use these tasks to manage files, groups, layouts, and targets:

• Create an item.

• Delete an item.

• Move an item.

• Rename an item.

• Touch an item.

• Manage items.

• Set default items.

• Configure item settings.

Removing Files/Groups/Layouts/Targets

The Remove command deletes files, groups, layouts, and build targets from the 
Project window. Removing files from the Files tab removes them from the project 
itself and from all build targets that use the files. Removing a file from the Link 
Order, Segments, or Overlays tab only removes the file from the current build target.

Removing files/groups/layouts/targets from a project

1. Click the Files, Designs, or Targets tab in the Project window.

2. Select the item to remove.

3. Remove the selected item from the project, as explained in Table 4.6.

Table 4.6  Removing a selected item from a project

On this host… Do this…

Windows Select Edit > Delete.

Macintosh Select Edit > Clear.

Solaris Select Edit > Clear.

Linux Select Edit > Clear.
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The IDE removes the selected item from the project. For deleted files, the IDE updates 
all build targets that formerly used the file. For deleted build targets, the IDE deletes 
build-target information and leaves files intact.

Removing files from a build target

1. Click the Link Order, Segments, or Overlays tab in the Project window.

2. Select the item to remove.

3. Remove the selected item from the active build target, as explained in Table 4.7.

The IDE removes the file from the build target, but leaves the file itself intact. The file 
can be re-assigned to other build targets in the project.

Moving Files/Groups/Layouts/Targets

Reposition files, groups, layouts, or build targets in the Files, Design, Link Order, or 
Targets pages with the cursor.

1. Select one or more files, groups, layouts, or build targets to move with the pointer.

2. Drag the selected items to a new position in the current page, using the focus bar 
as a guide.

3. Release the mouse button.

The IDE repositions the selected files, groups, layouts, or build targets to the new 
location.

Table 4.7  Removing a selected item from the active build target

On this host… Do this…

Windows Select Edit > Delete.

Macintosh Select Edit > Clear.

Solaris Select Edit > Clear.

Linux Select Edit > Clear.
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NOTE In the Link Order page, repositioning files changes the link order 
that the Make command uses to build the final executable file.

Renaming Files/Groups/Targets

The Rename command renames files, groups, or build targets in the project.

Rename files

1. Open the file to rename.

2. Choose File > Save As.

3. Type a new filename in the Name text box.

4. Click Save.

The IDE saves the file under the new name. The new filename appears in the Project 
window. Subsequent modifications affect the renamed file, leaving the original file 
intact.

Rename one or more groups

1. Click the Files tab in the Project window.

2. Select the group(s) to rename.

3. Press the Enter key.

4. Type a new name into the Enter Group Name text box of the Rename Group 
window.

5. Click OK.

The IDE renames the group. For selections of more than one group, the Rename 
Group window appears for each group.

Rename build targets

1. Click the Targets tab in the Project window.

2. Choose Edit > targetname Settings.
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3. Select Target Settings in the Target Settings Panels list.

4. Type a new name in’ the Target Name text box.

5. Click Save.

The Project window displays the new build-target name.

Touching Files and Groups

The Touch command manually selects source files or groups for compilation during 
the next Bring Up To Date, Make, Run, or Debug operation. A red check mark in the 
Touch column of the Project window indicates a touched file.

1. Click the Files tab in the Project window.

2. Touch a source file or group for compilation. 

• Click the Touch column next to the file or group name.

OR

• Choose Touch from the Interface menu for the file or group.

A red check mark appears in the Touch column next to the file or group name.

Touch all project files for recompiling

1. Perform the task explained in Table 4.8 on page 52.

2. Red check marks appear next to all files and groups.

Table 4.8  Touching all project files for recompiling

On this host… Do this…

Windows Alt-click the Touch column.

Macintosh Option-click the Touch column.

Solaris Alt-click the Touch column.

Linux Alt-click the Touch column.
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Untouching Files and Groups

The Untouch command manually excludes source files or groups from compilation 
during the next Bring Up To Date, Make, Run, or Debug operation.

1. Click the Files tab in the Project window.

2. Untouch a source file or group to remove it from the compilation list.

• Click the red check mark in the Touch column next to the file or group name.

OR

• Choose Untouch from the Interface menu for the file or group.

The red check mark disappears from the Touch column next to the file or group name.

Untouch all project files

1. Perform the task explained in Table 4.9.

2. The red checkmarks next to all files and groups disappear.

Build-Target Management
These tasks help you manage build targets:

• Create a build target.

• Remove a build target.

• Set the default build target.

• Rename a build target.

Table 4.9  Untouching all project files

On this host… Do this…

Windows Alt-click a red checkmark in the Touch column.

Macintosh Option-click a red checkmark in the Touch column.

Solaris Alt-click a red checkmark in the Touch column.

Linux Alt-click a red checkmark in the Touch column.
53IDE 5.5 User’s Guide 



Project Window
Build-Target Management
• Configure build-target settings.

Creating Build Targets

The Create Target command adds new build targets to a project.

1. Open the Project window.

2. Click the Targets tab in the Project window.

3. Choose Project > Create Target.

4. Type a name in the Name text box of the New Target window.

5. Select the Empty target or Clone Existing Target radio button as desired.

• Empty Target—create a new build target from scratch.

• Clone Existing Target—duplicate an existing build target in the New Target 
window.

6. Click OK.

The IDE adds the new build target to the project.

Removing Build Targets from a Project

The Remove command deletes unneeded build targets from the Project window.

1. Click the Targets tab in the Project window.

2. Select the item to remove.

3. Remove the selected item from the active build target, as explained in Table 4.10.

Table 4.10  Removing the selected item from the active build target

On this host… Do this…

Windows Select Edit > Delete.

Macintosh Select Edit > Clear.

Solaris Select Edit > Clear.

Linux Select Edit > Clear.
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The IDE removes the file from the build target, but leaves the file itself intact. The file 
can be re-assigned to other build targets in the project.

Setting the Default Build Target

The CodeWarrior Project Manager can handle up to 255 build targets in a single 
project. One build target must be defined as the default target when more than one 
project is open. The default target is the target affected by project commands, such as 
Make and Run.

The Project menu

1. Choose Project > Set Default Target > buildtarget.

2. A checkmark indicates the default target.

Using the Project window toolbar

1. Enable the Project window.

2. Choose the build-target name from the Current Target pop-up menu. 

The build-target name appears in the pop-up menu.

The Targets page

1. Enable the Project window.

2. Click the Targets tab.

3. Click the desired build-target icon.

The icon changes to indicate that the build target is now the default.

Renaming Build Targets

The Rename command renames build targets in a project.

1. Click the Targets tab in the Project window.
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2. Choose Edit > targetname Settings.

3. Select Target Settings in the Target Settings Panels list.

4. Type a new name in the Target Name text box.

5. Save the new name, as explained in Table 4.11.

The new build-target name appears in the Project window.

Configuring Build Target Settings 

The Target Settings panel options determine:

• The compiler used to process the project and produce object code

• The linker used to combine object code and produce a binary file

• The pre-linker and post-linker options that further process the object code

• The name assigned to a build target

Follow these steps to configure build-target settings.

1. Choose Edit > targetname Settings.

2. Select Target Settings from the Target Setting Panels list.

3. Specify target options as desired.

4. Save the new options, as explained in Table 4.12.

Table 4.11  Saving a new name for a build target

On this host… Do this…

Windows Click OK.

Macintosh Click Save.

Solaris Click Save.

Linux Click Save.
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NOTE The panels available in the Target Settings Panels list update to 
reflect the choices in the Target Settings panel.

Table 4.12  Saving the build-target settings

On this host… Do this…

Windows Click OK.

Macintosh Click Save.

Solaris Click Save.

Linux Click Save.
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Working with Files

This chapter explains how to work with files in the CodeWarrior™ IDE. Most 
computer programs use these file types:

• Text files—files that contain any type of text. Example text files include Read Me 
files and source files.

• Source files—files that contain source code only. Example source files include 
C++ files and Java files.

Managing Files
These tasks manage files:

• Create a new file.

• Open an existing file.

• Save a file.

• Close a file.

• Print a file.

• Revert a file to a previously saved state.

Creating Text Files (Windows)

The New command opens a window from which you create new text files. You can 
use new text files as source files in a project or as plain-text files.

1. Select File > New.

The New window appears.

2. Click the File tab in the New window.

3. Select Text File in the list.

4. Type a filename into the File name text box.
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5. Click Set to specify the location to save the new file.

6. Click OK.

The IDE creates the new text file and displays its contents in a new editor window.

TIP Use the Customize IDE Commands window to add the New Text 
File menu command to the File menu. Adding this menu command 
reduces the process of creating a new text file to one step: select File 
> New Text File. See “Customizing the IDE” on page 317 for more 
information about using the Customize IDE Commands window.

Creating Text Files (Macintosh, Solaris, Linux)

The New Text File command creates new text files. You can use new text files as 
source files in a project or as plain-text files.

Select File > New Text File to create a new text file. The IDE creates the new text file 
and displays its contents in a new editor window.

Opening Source Files

The Open command opens one or more editable source files at a time. Each open file 
appears in its own editor window.

NOTE The CodeWarrior editor cannot open files that prohibit editing. For 
example, the editor cannot open library files.

From the File menu

1. Choose File > Open.

2. Windows: Use the Files of type pop-up menu to select All Files.

3. Select a file.

4. Click Open.

The IDE displays the file in an editor window.
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From the Project window

1. Perform one of these:

• Double-click a filename in the Files tab of the Project window, or

• Select an interface filename from the Interface menu.

2. The IDE finds, opens, and displays the selected source file in an editor window.

From an editor window

1. Select an interface filename from the Interface menu.

2. The IDE selects, opens, and displays the source file in an editor window.

NOTE The menu does not show files that lack source code or are not
yet compiled.

Using Find and Open Files

1. Select text in an editor window containing the name of an interface file.

2. Choose File > Find and Open File.

The IDE finds, opens, and displays in an editor window the source file matching 
the text selection.

To open a recent file or project

1. Choose File > Open Recent > recentfilename | recentprojectname.

2. The IDE finds and opens the selected source file or project.

Saving Files

Use the Save command to save source files to ensure their continued existence 
between development sessions.

1. Choose File > Save.
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NOTE If the file has no title, a save dialog appears. Type a filename and 
specify a location for the file, then click Save.

2. The IDE saves the file.

Saving All Modified Files

Use the Save All command to save the contents of all modified files. This command is 
useful for saving all files at the same time, rather than saving each file individually.

1. Save all currently opened and modified files, as explained in Table 5.1.

2. The IDE saves the files.

Saving File Copies

Use the Save a Copy As command to save a back-up copy of a project or file before 
modifying the original. Working on a copy of the original file provides a way to return 
to the original copy should modifications fail.

1. Choose File > Save A Copy As.

2. Type a new filename in the Name text box.

3. Click Save.

The IDE creates a copy of the file under the new name, leaving the original file 
unchanged.

Table 5.1  Saving all currently opened and modified files

On this host… Do this…

Windows Select File > Save All.

Macintosh While pressing Option, select File > Save All.

Solaris While pressing Alt, select File > Save All.

Linux While pressing Alt, select File > Save All.
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Closing Files

The Close command closes open source files when you finish working on them. Close 
editor windows to close a file.

1. Select an editor window to close.

2. Close the file window.

• Choose File > Close, or

• Click the close box.

NOTE The IDE displays an alert if the file is modified. The alert asks 
whether to save changes to the file.

The IDE closes the file window.

Closing All Files

The Close All command closes all currently open files. This command is useful for 
closing all files at the same time, rather than closing each file individually.

1. Close all currently open files, as explained in Table 5.2.

2. The IDE closes the files.

Table 5.2  Closing all currently open files

On this host… Do this…

Windows Select Window > Close All or
Window > Close All Editor Windows.

Macintosh While pressing Option, select File > Close All.

Solaris While pressing Alt, select File > Close All.

Linux While pressing Alt, select File > Close All.
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Printing Source Files

The Print command prints the entire contents of a selected file window.

1. Activate the desired editor window to print.

2. Choose File > Print.

3. Set print options in the Print dialog.

4. Print the file, as explained in Table 5.3.

The IDE prints the selected file.

NOTE Use the same process to print the contents of a window, such as a 
Project window.

Printing Source-File Selections

The Print command prints the currently selected contents in an editor window.

1. Activate the desired editor window to print.

2. Select the portion of text to print.

3. Choose File > Print.

4. Set print options in the Print dialog.

5. Print the file, as explained in Table 5.4.

Table 5.3  Printing a source file

On this host… Do this…

Windows Click OK.

Macintosh Click Print.

Solaris Click Print.

Linux Click Print.
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The IDE prints the selected text in the file.

Reverting Files

Use the Revert command to replace the current file with its previously saved version.

1. Choose File > Revert.

2. Click OK in the Revert changes to file dialog.

The IDE replaces the file with its previous version. The replaced file appears in the 
editor window.

Table 5.4  Printing a source-file selection

On this host… Do this…

Windows Click OK.

Macintosh Click Print.

Solaris Click Print.

Linux Click Print.
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6
Dockable Windows

This chapter explains how to work with dockable windows in the Windows-hosted 
CodeWarrior™ IDE. Use dockable windows to do these tasks:

• Organize—attach, or dock, various windows to the edges of the screen for quick 
access.

• Group—dock windows of the same type to create a single window with multiple 
tabs, where each tab represents one of the original docked windows.

NOTE The dockable windows feature is available in Multiple Document 
Interface (MDI) mode only. This feature is not available in Floating 
Document Interface (FDI) mode. Toggle the Use Multiple 
Document Interface option in the IDE Extras preference panel to 
change between these two modes.

This chapter contains these sections:

• “About Dockable Windows” on page 67

• “Working with Dockable Windows” on page 69

• “Dock Bars” on page 74

About Dockable Windows
You can dock certain windows to the edges of the main frame window of the IDE. 
Table 6.1 on page 68 explains possible states for dockable windows. Figure 6.1 on 
page 68 shows the different window states.

In MDI mode, the IDE occupies a main window frame, or client area. IDE windows 
normally appear within this client area as you work. These windows are called child 
windows of the IDE’s client area.
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Figure 6.1  Window states

Table 6.1  Window states

State Characteristics

Docked • Attached to the left, right, top, or bottom edge of the client area

• restricted to the client area

• resizable

• has a dock bar instead of a title bar

Floating • Rests above all docked windows and MDI child windows

• movable outside the client area, like a floating palette

• has a thin title bar

• does not have Minimize or Maximize buttons

MDI Child • Normal child window of the client area, when running in MDI mode

• restricted to the client area

Floating windowMDI child windowDocked window
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Table 6.2 explains the difference between dockable windows and non-dockable 
windows. In this table, the term non-modal refers to a window that does not require 
your attention before allowing the IDE to proceed with other operations.

NOTE The default setting for project windows is to dock to an edge of the 
client area. You can undock these windows.

Compound windows that have more than one pane dock as a group. 
You cannot separately dock individual panes from these windows. 
For example, you can dock the Thread Window, but you cannot dock 
the Stack Crawl pane separately from the Thread Window.

Working with Dockable Windows
You can dock windows in one of two ways:

• dragging a floating window to a docking position

• using a contextual menu to dock a window

You can resize docked windows and undock them to floating windows or MDI child 
windows.

This section explains how to perform tasks with dockable windows.

Table 6.2  Differences between dockable and non-dockable windows

Window Type Required Criteria Sample Windows

Dockable All of these:

• non-modal

• resizable

• maximizable

• Thread

• Project

• Component Catalog

Non-dockable Any of these:

• modal

• non-resizable

• non-maximizable

• IDE Preferences

• Find

• About Box
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Docking a Window By Using a Contextual Menu

Use a contextual menu to dock a floating window or MDI child window to one of the 
four edges of the client area.

1. Right-click the window title bar.

A contextual menu appears.

2. Choose Docked from the contextual menu.

NOTE The Docked command appears in the contextual menu for dockable 
windows only.

The window docks to an edge of the client area. You can resize the docked window or 
move it to a different edge of the client area.

Docking a Window By Using Drag and Drop

You can drag a docked window or a floating window to one of the four edges of the 
client area to dock it.

1. Drag the window to one edge of the client area.

Drag a floating window by its title bar. Drag a docked window by its dock bar.

2. A window outline appears near the client-area edge, showing the final position 
after you release the window.

Use the outline as a visual cue that the IDE will dock the window. If an outline 
does not appear, you cannot dock the window.

3. Release the window to dock it to the edge.

The window appears in the position indicated by the window outline.
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Docking Windows of the Same Kind

You can dock two or more windows of the same kind inside a single docked window. 
In this arrangement, tabs inside the single docked window represent each of the 
original docked windows. You can undock each tab individually from the single 
docked window.

1. Dock the first of two or more windows of the same kind to an edge of the client 
area.

2. Dock the second window to the same edge as the first window.

Use the window outline that appears as a visual cue that the IDE will dock the 
second window to the same edge as the first window.

3. Dock subsequent windows to the same edge as the first window.

Each additional docked window appears as a tab inside the first docked window. 
Click a tab to view its contents. The frontmost tab appears in bold font.

Figure 6.2 shows two projects represented as tabs in a single docked window.

Figure 6.2  Two projects in a single docked window
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Undocking a Window

Use a contextual menu to undock a window from an edge of the client area to a 
floating window or MDI child window.

1. Right-click the tab inside the docked window that represents the window you want 
to undock.

A contextual menu appears.

Figure 6.3  Contextual menu

2. Choose Floating or MDI Child from the contextual menu.

• Floating—undock the window so that it becomes a floating window

• MDI child—undock the window so that it becomes an MDI child window of the 
client area

The window undocks and becomes the chosen window type.

Alternately, double-click the tab to undock the corresponding window to a floating 
window.

Floating a Window

Use a contextual menu to float a docked window or MDI child window.

1. Right-click the tab in the docked window or the title bar of the MDI child window.

A contextual menu appears.

2. Choose Floating from the contextual menu.
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NOTE The Floating command appears in the contextual menu for floatable 
windows only.

The window becomes a floating window (that you can drag outside the client area).

Alternately, double-click the tab in a docked window to float its corresponding 
window.

Unfloating a Window

Use a contextual menu to dock a floating window or make it an MDI child window.

1. Right-click the title bar of the floating window.

A contextual menu appears.

2. Choose Docked or MDI Child from the contextual menu.

• Docked—dock the floating window

• MDI child—unfloat the window so that it becomes an MDI child window

The window unfloats and becomes the chosen window type.

Alternately, drag the floating window to an edge of the client area to dock it.

Making a Window an MDI Child

Use a contextual menu to make a docked window or floating window an MDI child 
window.

1. Right-click the tab in the docked window or the title bar of the floating window.

A contextual menu appears.

2. Choose MDI Child from the contextual menu.

The docked window or floating window becomes an MDI child window.
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Suppressing Dockable Windows

Suppress dockable windows to drag a window to any location onscreen without 
docking it to an edge of the client area.

1. Hold down the Ctrl key while dragging or floating an MDI child window.

The thin window outline that normally indicates docked-window placement 
becomes a heavy window outline. Use this heavy outline as a visual cue that the 
IDE suppresses dockable windows.

2. Release the window at its final position.

The window appears in the position indicated by the heavy window outline.

3. Release the Ctrl key.

Dock Bars
A docked window has a dock bar instead of a title bar. Use the dock bar to perform 
these tasks:

• move the docked window to a different edge of the client area

• collapse or expand view of the docked window

• close the docked window

Figure 6.4 shows a dock bar.

Figure 6.4  Dock Bar

Collapsing a Docked Window

If two or more distinct docked windows occupy the same edge of the client area, you 
can collapse one docked window to view more contents of the other docked windows.
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1. Dock two or more windows to the same edge of the client area.

The windows’ contents must appear in separate docked windows, not as tabs in a 
single docked window.

2. Click the collapse button  on the dock bar of the docked window that you 

want to collapse.

3. The docked window collapses to hide its contents.

Expanding a Docked Window

If you previously collapsed a docked window, you can expand it and view its contents 
once again.

1. Click the expand button on the dock bar: 

2. The docked window expands to restore its original view.

Moving a Docked Window

Use the gripper in a docked window’s dock bar to move the docked window to a 
different edge of the client area.

1. Drag the docked window by the gripper in its dock bar: 

2. Release the docked window at its new position.

Closing a Docked Window

Close a docked window directly from its dock bar.

1. Click the close button on the dock bar: 

2. The docked window closes.

Re-opening the window later restores its docked position.
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Workspaces

This chapter explains how to work with workspaces in the CodeWarrior™ IDE. Use 
workspaces to do these tasks:

• Organize—save the state of all windows onscreen for later reuse

• Migrate across computers—transfer your workspace from one computer to 
another 

This chapter contains these sections:

• “About Workspaces” on page 77

• “Using Workspaces” on page 77

About Workspaces
A workspace stores information about the current state of the IDE. This information 
consists of the size, location, and the docked state (Windows) of IDE windows. If you 
save a workspace during an active debugging session, the workspace also stores 
information about the state of debugging windows.

The IDE can use a default workspace, or it can use a workspace that you create. The 
IDE works with one workspace at a time. You can save and re-apply a workspace from 
one IDE session to the next.

Using Workspaces
You use menu commands to perform these workspace tasks:

• save a new workspace

• open an existing workspace

• close the current workspace
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Using the Default Workspace

Use the default workspace to preserve IDE state from one session to the next. The IDE 
saves and restores the default workspace automatically.

1. Choose Edit > Preferences.

The IDE Preferences window opens.

2. Select IDE Extras in the IDE Preference Panels list.

The IDE Extras preference panel appears.

3. Configure the Use default workspace option.

• Selected—the IDE saves its state at the time you quit, then restores that state the 
next time you launch the IDE

• Cleared—the IDE always launches with the same default state: no windows 
visible

Saving a Workspace

Save a workspace to store information about the current state of onscreen windows, 
recent items, and debugging.

1. Arrange your workspace.

Move windows to your favorite positions and start or finish a debugging session.

2. Choose File > Save Workspace.

A Save dialog box appears.

3. Enter a name for the current workspace

NOTE Add the extension .cww to the end of the workspace name, for 
example, myworkspace.cww. This extension helps you readily 
identify the workspace file. Furthermore, the Windows-hosted IDE 
requires this extension to recognize the file as a
CodeWarrior workspace.

4. Save the workspace to a location on your hard disk.
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The IDE now uses your saved workspace. In subsequent programming sessions, you 
can open the workspace and apply its settings to the IDE.

Opening a Workspace

Open a workspace to apply its settings to the IDE.

1. Choose File > Open Workspace.

An Open dialog box appears.

2. Open the workspace.

Use this dialog box to navigate your hard disk and select a workspace file. These 
files end in the .cww extension.

The IDE opens the selected workspace and applies its settings.

Saving a Copy of a Workspace

Save a copy of a current workspace to save an existing workspace under a different 
name.

1. Open an existing workspace.

2. Choose File > Save Workspace As.

A Save As dialog box appears.

3. Enter a name for the copy of the current workspace

NOTE Add the extension .cww to the end of the workspace name, for 
example, myworkspace.cww. This extension helps you readily 
identify the workspace file. Furthermore, the Windows-hosted IDE 
requires this extension to recognize the file as a
CodeWarrior workspace.

4. Save the workspace to a location on your hard disk.

The IDE saves a copy of the current workspace under the name you specified.
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Closing a Workspace

Close the current workspace after you finish working with it.

1. Choose File > Close Workspace.

2. The IDE closes the current workspace.

NOTE You cannot close the default workspace, however, the IDE Extras 
preference panel contains an option that determines whether the IDE 
uses the default workspace.

You can now open a different workspace or quit the IDE.

Opening a Recent Workspace

You can have the IDE display recently used workspaces in the Open Recent 
submenu. The IDE Extras preference panel contains an option that determines the 
number of recent workspaces that the IDE displays.

1. Choose File > Open Recent.

A submenu appears. This submenu lists recently used workspaces. A checkmark 
appears next to the active workspace.

2. Choose a recent workspace from the Open Recent submenu.

The IDE applies the workspace that you select.
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Creating Console 
Applications

This chapter explains how to work with console applications in the CodeWarrior™ 
IDE. Console applications provide these benefits to novice programmers:

• Simplicity—console applications are computer programs that use a simple text-
mode interface. The simplicity of console-mode applications free novice 
programmers to learn a programming language without having to learn graphical 
user interface programming at the same time.

• Foundation—understanding console applications provides the basis for more 
advanced computer programming. Advanced programmers readily understand 
console applications.

Read this chapter to learn more about typical tasks for working with console 
applications.

This chapter contains these sections:

• About Console Applications

• Creating Console Applications

About Console Applications
A console application is a simple, text-based computer program. Console applications 
do not usually employ a graphical user interface (GUI). Instead, the applications rely 
on plain-text input and output to complete tasks.

Console applications are ideal for novice programmers. The applications are easier to 
program because they lack a GUI. If problems arise, the programmer can use text-
based feedback together with the debugger to correct problems.

Figure 8.1 on page 82 shows output from a sample console application.
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Figure 8.1  Console application

Creating Console Applications
Create a console application to begin working with a text-based computer program. 
The CodeWarrior IDE provides pre-configured project stationery for creating console 
applications. Project stationery simplifies the project-creation process. This section 
explains how to create a console application.

Creating a Console Application

Use the New command to create a new project. The project stores information about 
the files in the console application.

1. Choose File > New.

The New window appears.

2. Click the Project tab.

3. Select a project stationery file.

For example, select Win32 C Stationery to create a C console application.
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4. Enter a project name in the Project name field and add the .mcp extension.

For example, name the project test.mcp.

5. Click Set.

Save the project in the desired location.

6. Click OK.

The New Project window appears.

7. Select a specific stationery file.

For example, expand Win32 Console App and select C Console App.

8. Click OK.

The IDE creates a console application from the selected stationery. The Project 
window for the console application appears.

9. Expand the Sources group.

This group contains placeholder source files.

10. Remove placeholder source files.

For example, select main.c and choose Edit > Delete.

11. Create a new source file, as explained in Table 8.1.

12. Enter source code.

For example, enter this source code shown in Listing 8.1.

Listing 8.1  Sample source code

/* A minimal Win32 console application */
#include <stdio.h>
int main( void )

Table 8.1  Creating a new source file

On this host… Do this…

Windows Press Ctrl-N.

Macintosh Press Command-N.

Solaris Press Meta-N.

Linux Press Ctrl-N.
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{
   printf(“Hello World!”);
   return 0;
}

13. Save the source file, as explained in Table 8.2.

Enter a name for the source code. For example, enter Hello.c. Then click Save.

14. Choose Project > Add Hello.c to Project.

The Add Files window appears.

15. Add the file to all build targets in the project.

Select all checkboxes to add the file to all build targets, then click OK.

16. Drag the source file inside the Sources group.

17. Choose Project > Run.

The IDE compiles, links, then runs the console application.

Table 8.2  Saving the source file

On this host… Do this…

Windows Press Ctrl-S.

Macintosh Press Command-S.

Solaris Press Meta-S.

Linux Press Ctrl-S.
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III

Editor

This section contains these chapters:

• The CodeWarrior Editor

• Editing Source Code

• Navigating Source Code

• Finding and Replacing Text
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The CodeWarrior Editor

This chapter explains how to work with the editor in the CodeWarrior™ IDE. Use the 
editor to perform these tasks:

• Manage text files—the editor includes common word-processing features for 
creating and editing text files. Sample text files include Read Me files and release 
notes.

• Manage source files—the editor includes additional features for creating and 
editing source files. The IDE processes source files to produce a program.

This chapter contains these sections:

• “Editor Window” on page 87

• “Editor Toolbar” on page 89

• “Other Editor Window Components” on page 93

Editor Window
Use the editor window to create and manage text files or source files. The window 
contains these major parts:

• Editor toolbar

• Text-editing area

• Line and column indicator

• Pane splitter controls

Figure 9.1 on page 88 shows the editor window. Table 9.1 on page 88 explains the 
items in the editor window.
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Editor Window
Figure 9.1  Editor window

Table 9.1  Editor window—items

Item Icon Explanation

Interfaces Menu Displays a list of referenced interface files or header 
files for the source file.

Functions Menu Displays a list of functions defined in the source file.

Markers Menu Displays a list of markers defined in the file.

Document Settings Menu Displays file-format options and a syntax-coloring 
toggle.
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Editor Toolbar
Use the editor toolbar to complete these tasks:

• Open interface and header files

• Find function definitions

• Set and clear markers

• Modify file formats

• Control syntax coloring

• Execute version-control operations

• Determine a file’s save state

This section explains how to expand and collapse the toolbar, and how to perform each 
toolbar task.

Version Control System 
Menu

Displays a list of available Version Control System 
(VCS) commands. Choose a command to apply to 
the source file.

Path Caption Displays the complete path to the file.

File Modification Icon This icon indicates an unchanged file since the
last save.

This icon indicates a file with modifications not
yet saved.

Breakpoints Column Displays breakpoints for the file.

Text Editing Area Shows the text or source-code content of the file.

Line and Column 
Indicator

Displays the current line and column number of the 
text-insertion cursor

Pane Splitter Controls Drag to split the window into panes.

Table 9.1  Editor window—items (continued)

Item Icon Explanation
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Expanding and Collapsing the Editor Window Toolbar

To expand the editor window toolbar, click this icon in the right-hand top corner 
of the editor window. Figure 9.2 on page 90Figure 9.2 shows an editor window 
with an expanded toolbar.

Figure 9.2  Editor window toolbar (expanded)

To collapse the Editor Window Toolbar, click this icon in the right-hand top 
corner of the Editor window. Figure 9.3 on page 91 shows an editor window 
with a collapsed toolbar.
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Editor Toolbar
Figure 9.3  Editor window toolbar (collapsed)

Interfaces Menu
The Interfaces menu lists the source files included in the current source file.

See “Finding Interface Files” on page 112 for information on navigating source code 
with the Interfaces menu.

Functions Menu
The Functions menu lists the functions (routines) defined in the current file.

See “Locating Functions” on page 112 for information on navigating source code with 
the Functions pop-up.

Markers Menu
The Marker menu in lists the markers placed in the current file. Use markers to scroll 
to specific items in source code and find code segments by intuitive names.
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See “Using Markers” on page 115 for information on navigating source code with 
Markers.

Document Settings Menu
The Document Settings menu shows whether the IDE applies syntax coloring to the 
window text, as well as the format in which the IDE saves the file.

Using the Document Settings Menu

Use the Document Settings pop-up in editor windows to toggle syntax coloring on or 
off for the current file, and set the EOL (end-of-line) format for saving a text file. 

The EOL formats are:

• Macintosh: <CR>

• DOS: <CR><LF>

• UNIX: <LF>

To toggle syntax coloring
• Choose Document Settings > Syntax Coloring.

The editor window updates to display the new syntax color setting.

To specify the EOL format for the file
• Choose the EOL format for the file.

The IDE applies the specified EOL format to the file the next time it gets saved.

Version Control System Menu
The version control system pop-up in editor windows lists options provided by a 
version control system (VCS) compatible with the IDE. Use a VCS to manage 
multiple versions of files. VCS packages are available separately for use with the IDE.
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Using the Version Control System Menu

Use the Version Control System (VCS) pop-up in editor windows to access version 
control commands related to the editor window’s file. If a version control system is not 
enabled for a project, the only item on the VCS menu is No Version Control 
Available. See additional VCS documentation for more information about using a 
VCS package with the IDE.

• Choose VCS > VCScommand.

The IDE executes the VCS command.

Other Editor Window Components
Use other editor window components to perform these tasks:

• Determine the path to a file.

• Determine the modification status of a file.

• Set or clear breakpoints.

• Edit text or source code.

• Find the text-insertion point.

This section explains these additional editor window components.

Path Caption
The Path caption shows the path to the active file. The directory delimiters follow host 
conventions. For example, slashes separate directories for a path on a Windows 
computer.

File Modification Icon
The File Modification icon indicates the save status of the file:

• The  icon indicates an unchanged file since the last Save.

• The  icon indicates a file with modifications not yet saved.
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Breakpoints Column
The Breakpoints column shows breakpoints defined in the current file. Each marker in 
the column indicates the line of source code at which the debugger suspends program 
execution.

Text Editing Area
The text editing area behaves the same way as it does in a word processor. Enter text 
or source code, perform edits, and copy or paste selections.

Line and Column Indicator
The Line and Column indicator shows the current position of the text-insertion point. 
Click the indicator to specify a line to scroll into view.

Pane Splitter Controls
Use the pane splitter controls to perform these tasks:

• Add panes to editor windows.

• Adjust pane size.

• Remove panes from editor windows.

This section explains how to perform each task.

Adding Panes to an Editor Window

Use the Pane Splitter controls to add additional view panes in an editor window and 
view two or more sections of a source file at the same time.

1. Click and drag a Pane Splitter control to add a view pane.

2. The IDE adds a new view pane to the editor window.
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Resizing Panes in an Editor Window

Use the Pane Resize controls to resize the panes in an editor window.

1. Click and drag a vertical or horizontal Pane Resize control.

2. The IDE resizes the selected view pane.

Removing Panes from an Editor Window

Use the Pane Resize controls to remove additional view panes from an editor window. 

1. Remove an editor window pane.

• Double-click the Pane Resize control to remove the pane.

OR

• Click and drag the Pane Resize control to the left or top edge of the editor 
window.

2. The IDE removes the view pane from the editor window.
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Editing Source Code

This chapter explains how to edit source code in the CodeWarrior™ IDE. The IDE 
provides these features to help you edit source code:

• Select and indent text—the editor can select text by line, routine, or rectangular 
selection. The editor also handles text indentation.

• Balance punctuation—the editor can find matching pairs of parentheses, 
brackets, and braces. Most programming languages, such as C++, produce syntax 
errors for punctuation that lacks a counterpart.

• Complete code—the IDE can suggest ways to complete the symbols you enter in 
a source file

Read this chapter to learn more about editing source code.

This chapter contains these sections:

• “Text Manipulation” on page 97

• “Punctuation Balancing” on page 101

• “Code Completion” on page 102

Text Manipulation
Manipulate text files to manage their contents from the IDE. Use these tasks to 
manipulate text files:

• Select text

• Overstrike text

• Use virtual space

• Indent text

This section explains how to perform each task.
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Selecting Text in Editor Windows

The editor lets you select text in several ways while you edit source files.

NOTE Enable the Left margin click selects line option in the Editor 
Settings preference panel to use the right-pointing arrow cursor.

Lines
Follow these steps to select a line of text:

• Triple-click anywhere on a line, or

• Click the right-pointing cursor in the left margin of the line.

These actions select the line of text.

Multiple lines
Follow these steps to select multiple lines of text:

• Drag the cursor over the contiguous range of text and release, or

• Position the cursor at the beginning of a selection range, then Shift-click the end 
of the selection range to select all text between the two points, or

• Drag the right-pointing cursor to select lines of text.

These actions select the lines of text.

Rectangular text selections
Table 10.1 explains how to select rectangular portions of text.

Table 10.1  Selecting a rectangular portion of text

On this host... Do this...

Windows Alt-drag the cursor over the portion of text.

Macintosh Command-drag the cursor over the portion of text.
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Entire routines
Follow these steps to select an entire routine:

1. Hold down the Shift key.

2. Choose a function name from the Function list menu.

This action selects the function.

Overstriking Text (Windows)

Use the Overstrike command to toggle between text insertion and text overwriting 
mode when entering text.

1. Press the Ins key to toggle overstrike mode.

2. Overstrike mode toggles.

Using Virtual Space

Use the Virtual Space feature to place the cursor anywhere in the white space of a 
line of source code and enter text at that position.

For example, consider the line of C++ code shown in Listing 10.1.

Listing 10.1  Sample C++ source code

void aFunction (const char * inMessage)        virtualspace

Toggling virtual space changes the cursor behavior:

• enabled—clicking in the virtualspace places the cursor at the location that you 
clicked. You can enter text at that location.

Solaris Alt-drag the cursor over the portion of text.

Linux Alt-drag the cursor over the portion of text.

Table 10.1  Selecting a rectangular portion of text (continued)

On this host... Do this...
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• disabled—clicking in the virtualspace places the cursor just after the last 
character on the line (in the example, just after the closing parenthesis). To place 
the cursor beyond this character, you must repeatedly press the space bar on your 
keyboard.

To use virtual space, follow these steps:

1. Select Edit > Preferences.

The IDE Preferences window opens.

2. Select Editor Settings in the IDE Preference Panels list.

The Editor Settings preference panel appears.

3. Configure the Enable Virtual Space option:

• select to use virtual space

• clear to not use virtual space

4. Click Apply or Save to save your changes to the preference panel.

5. Close the IDE Preferences window.

Indenting and Unindenting Text Blocks

Use the Shift Left and Shift Right commands to shift a selected block of text to the 
left or right. You can indent or unindent one or more lines using these commands. The 
Tab Size option specifies the amount of indentation.

1. Select the text to be shifted.

2. Indent or unindent the selected text.

• To unindent text: Choose Edit > Shift-Left.

• To indent text: Choose Edit > Shift-Right.

The IDE shifts the text block.

Symbol Editing Shortcuts
You can use the browser contextual menu to enhance source-code editing in the IDE. 
Use this menu to streamline text entry in editor windows. You can enter the first few 
letters of a function name, then use the browser contextual menu to complete the entry.

The IDE also provides these keyboard shortcuts with the browser enabled:
100 IDE 5.5 User’s Guide



Editing Source Code
Punctuation Balancing
• Find symbols with prefix—find symbols matching the selected prefix

• Find symbols with substring—find symbols matching the selected substring

• Get next symbol—obtain the next symbol from the browser database

• Get previous symbol—obtain the previous symbol from the browser database

See the IDE Quick Reference card for more information about these keyboard 
shortcuts.

Punctuation Balancing
Balance punctuation to ensure that each opening parenthesis, bracket, or brace has a 
corresponding closing counterpart. This section explains how to balance punctuation.

Balancing Punctuation

Use the Balance option when editing source code to make sure that every parenthesis 
(( )), bracket ([ ]), and brace ({ }) has a mate.

1. Position the cursor between the suspect punctuation.

2. Check for the matching punctuation.

• Choose Edit > Balance.

OR

• Double-click the parenthesis, bracket, or brace character to check for a matching 
character.

From a text insertion point, the editor searches forward until it finds a parenthesis, 
bracket, or brace, then it searches in the opposite direction until it finds the matching 
punctuation. When double-clicking on a parenthesis, bracket, or brace, the editor 
searches in the opposite direction until it finds the matching punctuation.

When it finds a match, it highlights the text between the matching characters. If the 
insertion point is not enclosed or if the punctuation is unbalanced, the computer beeps.

Toggling Automatic Punctuation Balancing

Use the Editor Settings to enable or disable the punctuation balancing feature.
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Figure 10.1  Editor Settings (Balance While Typing)

To toggle automatic punctuation balancing, follow these steps:

1. From the Edit menu in the Main Toolbar, select Preferences.

This opens the IDE Preferences window.

2. In the IDE Preference Panels list, select Editor.

3. Choose Editor Settings.

4. In the Other Settings area of Editor Settings, select or clear the Balance While 
Typing checkbox.

Code Completion
Use code completion to have the IDE automatically suggest ways to complete the 
symbols you enter in a source file. By using code completion, you avoid referring to 
other files to remember available symbols.
102 IDE 5.5 User’s Guide



Editing Source Code
Code Completion
Code Completion Configuration
You can activate, deactivate, and customize code-completion operation. Use these 
tasks to configure code completion:

• Activate automatic code completion

• Trigger code completion from the IDE menu bar

• Trigger code completion from the keyboard

• Deactivate automatic code completion

Activating Automatic Code Completion

Activate automatic code completion to have the IDE display a Code Completion 
window that helps you complete the symbols you enter in source code. The Code 
Completion preference panel configures the Code Completion window behavior.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Code Completion preference panel in the IDE Preference Panels list.

The Code Completion preference panel appears.

3. Select the Automatic Invocation option.

Selecting this option configures the IDE to automatically open the Code 
Completion window.

4. Enter a delay in the Code Completion Delay field.

This delay determines how long the IDE waits between the time you type a trigger 
character and the time the Code Completion window appears. If you perform any 
action during this delay time, the IDE cancels the Code Completion operation.

5. Save your preferences.

Click the Save or Apply button.

6. Choose File > Close.

The IDE Preferences window closes.

The Code Completion window now appears automatically to help you complete code 
in editor windows.
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Triggering Code Completion from the IDE Menu Bar

Trigger code completion from the main IDE menu bar to open the Code Completion 
window.

1. Bring forward an editor window.

2. Place the insertion point at the end of the source code that you want to complete.

3. Choose Edit > Complete Code.

The Code Completion window appears. Use it to complete the symbol at the 
insertion point.

Triggering Code Completion from the Keyboard

Trigger code completion from the keyboard to bypass opening the Code Completion 
window.

1. Bring forward an editor window.

2. Place the insertion point at the end of the source code to complete.

3. Press the appropriate code-completion key binding.

Table 10.2 on page 104 lists the default code-completion key bindings for each 
IDE host. Use the Customize IDE Commands window to change these key 
bindings.

Table 10.2  Code Completion key bindings

Host Get Next 
Completion

Get Previous 
Completion

Complete Code

Windows Alt-/ Alt-Shift-/ Alt-.

Macintosh Control-/ Control-Shift-/ Control-.
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Deactivating Automatic Code Completion

Deactivate automatic code completion to prevent the IDE from displaying the Code 
Completion window as you edit source code. The Code Completion preference panel 
configures Code Completion window behavior.

You can still manually trigger code-completion functionality from the keyboard or 
from the main IDE menu bar.

NOTE To dismiss the Code Completion window after it automatically 
opens, press the Esc key or click outside the active editor window.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Code Completion preference panel in the IDE Preference Panels list.

The Code Completion preference panel appears.

3. Clear the Automatic Invocation option.

Clearing this option prevents the IDE from automatically opening the Code 
Completion window.

4. Save your preferences.

Click the Save or Apply button.

5. Choose File > Close.

The IDE Preferences window closes.

The IDE now requires you to manually open the Code Completion window from the 
keyboard or from the main menu bar.

Code Completion Window
The Code Completion window displays possible symbols based on the context of the 
insertion point.

Figure 10.2 shows the Code Completion window. Table 10.3 on page 106 explains the 
items in the Code Completion window. Table 10.4 on page 107 explains the icons that 
appear in the Code Completion list.
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Figure 10.2  Code Completion window

Table 10.3  Code Completion window—items

Item Icon Explanation

Code Completion list Lists available variables and methods or functions along 
with their corresponding return types or parameters. 
This list changes based on the context of the insertion 
point in the active editor window. Icons help distinguish 
items in the list.

Disclosure Triangle Click to toggle display of the Documentation pane for 
those programming languages that support it.

Resize Bar Drag to resize the Code Completion list and the 
Documentation pane.

Documentation pane Displays summary information or documentation for the 
selected item in the Code Completion list. This pane 
appears only for programming languages that support 
summary information or documentation.
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Navigating the Code Completion Window

Navigate the Code Completion window by mouse or keyboard. You can perform these 
tasks:

• Resize the window

• Navigate the window by keyboard

• Refine the Code Completion list by keyboard

1. Bring forward an editor window.

2. Place the insertion point at the end of the source code to complete.

3. Choose Edit > Complete Code.

The Code Completion window appears.

4. Use the mouse to resize the Code Completion window.

The new window size remains in effect until you refine the Code Completion list or 
close the Code Completion window. You refine the Code Completion list by typing 
additional characters in the active editor window.

5. Use the keyboard to navigate the Code Completion list.

Table 10.5 explains how to navigate the Code Completion list by keyboard.

Table 10.4  Code Completion window—icons

Icon Code Type Icon Code Type

Class Method

Function Namespace

Global Variable None

Language Keyword Package

Local Variable Variable
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6. Use the keyboard to refine the Code Completion list.

The Code Completion list updates as you add or delete characters in the active editor 
window. Continue adding characters to narrow the list, or delete existing characters to 
broaden the list. Press the Backspace key to delete characters.

Selecting an Item in the Code Completion Window

Select an item in the Code Completion window to have the IDE enter that item in the 
active editor window at the insertion point.

1. Bring forward an editor window.

2. Place the insertion point at the end of the source code to complete.

3. Choose Edit > Complete Code.

The Code Completion window appears. The Code Completion list in this window 
shows possible symbol matches for the text in the active editor window.

4. Select an item in the Code Completion list.

Use the mouse or the keyboard to navigate the Code Completion list and select an 
item.

5. Enter the item into the active editor window.

Press the Return or Enter keys on the keyboard or double-click the item to have 
the IDE insert that item into the editor window.

Table 10.5  Navigating the Code Completion list by keyboard

Key Action

Up Arrow Select the previous item

Down Arrow Select the next item

Page Up Scroll to the previous page

Page Down Scroll to the next page
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Completing Code for Data Members

Complete code for data members for those programming languages that support it. For 
example, in the Java programming language you can complete code for data members 
through the . character.

1. Bring forward an editor window.

2. Place the insertion point at the end of the class to complete.

3. Type a data-member trigger character.

The character depends on the programming language you use. In the Java 
programming language, for example, type a period.

4. The Code Completion window appears.

Use this window to complete the data member for the class.

Completing Code for Parameter Lists

Complete code for parameter lists for those programming languages that support it. 
For example, in the Java programming language you can complete code for parameter 
lists through the ( character.

1. Bring forward an editor window.

2. Place the insertion point at the end of the function or method to complete.

3. Type a parameter-list trigger character.

The character depends on the programming language you use.In the Java 
programming language, for example, type an open parenthesis.

4. The Code Completion window appears.

The upper portion of this window lists different (overloaded) versions of the 
function or method. The lower portion shows possible parameter lists for the 
selected function or method in the top portion. Use this window to complete the 
parameter list for the function or method.
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Navigating Source Code

This chapter explains how to navigate source code in the CodeWarrior™ IDE. 
Navigate source code to accomplish these tasks:

• Find specific items—the editor finds interface files, functions, and lines of source 
code.

• Go to a specific line—the editor can scroll to a specific line of source code.

• Use markers—the editor allows labelling of specific items of text. These labels, 
or markers, provide intuitive navigation of text.

Read this chapter to learn more about typical tasks for navigating source code.

This chapter contains these sections:

• “Finding Interface Files, Functions, and Lines” on page 111

• “Going Back and Forward” on page 114

• “Using Markers” on page 115

• “Symbol Definitions” on page 117

• “Reference Templates (Macintosh)” on page 119

Finding Interface Files, Functions, and 
Lines

Find interface files, functions, and lines of source code to expedite programming. You 
can find these types of items:

• interface files

• functions

• lines of source code

This section explains how to perform each task.
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Finding Interface Files
Find interface (header) files to view files referenced by the current source code. Some 
programming languages, such as C++, use interface files in conjunction with source 
code. Interface files typically define functions or objects used in the source code. 
Interface files also separate function or object declarations from implementations. This 
section explains how to find interface files.

Using the Interface Menu

Use the Interface menu in editor windows to open interface or header files referenced 
by the current file. The project file must be open for the Interface menu to operate.

1. Click the Interface menu.

2. Select the filename of the interface file that you want to open.

If found, the file is opened in an editor window. If not found, an alert sounds.

NOTE Only source code interface files can be opened. Libraries and pre-
compiled header files can not be opened.

Locating Functions
Find functions to expedite source-code editing. Most source files contain several 
functions that divide a complicated task into a series of simpler tasks. The editor 
allows scrolling to individual functions within the current source file. This section 
explains how to find functions.

Using the Functions Menu

Use the Functions menu in editor windows to quickly navigate to specific functions or 
routines in the current source file.

1. Click the Functions menu.

2. Select the routine name to view.

The editor scrolls to display the selected routine.
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Alphabetizing Functions Menu with the Mouse and Keyboard

The default behavior of the Functions menu is to list functions in order of appearance 
in the source file. You can use the mouse and keyboard to list functions in alphabetical 
order.

Table 11.1 Alphabetizing the Functions listexplains how to use the mouse and 
keyboard to alphabetize functions in the Functions menu.

Alphabetizing Functions Menu Order

The default behavior of the Functions menu is to list functions in order of appearance 
in the source file. You can select the Sort function popup option in the Editor 
Settings preference panel to list functions in alphabetical order.

1. Open the IDE Preferences window.

Choose Edit > IDE Preferences.

2. Select the Editor Settings preference panel.

3. Select the Sort function popup option.

4. Save your modifications to the Editor Settings panel, as explained in Table 11.2 
on page 114.

Table 11.1  Alphabetizing the Functions list

On this host... Do this...

Windows Ctrl-click the Functions menu.

Macintosh Option-click the Functions menu.

Solaris Alt-click the Functions menu.

Linux Alt-click the Functions menu.
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Going Back and Forward
Go back and forward in source files to edit existing code. Most source files contain 
more than one screen of code. The editor always counts the number of lines in the 
source files. Go to a particular line to scroll a particular item into view.

Going to a Particular Line

Use the Goto Line command to navigate to a specific source line in an editor window 
if you know its number. Lines are numbered consecutively, with the first line 
designated as line 1. The Line Number control at the bottom of the editor window 
shows the number of the line where the text insertion point is positioned.

1. Open the Line Number window.

• Click the Line and Column Indicator control.

OR

• Choose Search > Go To Line.

2. Type a line number in the Line Number text box.

3. Click OK.

NOTE If a line number does not exist, the insertion point jumps to the last 
line of the source file.

Table 11.2  Saving changes to the IDE Preferences window

On this host… Do this…

Windows Click Apply, then OK.

Macintosh Click Save, then close the IDE Preferences window.

Solaris Click Save, then close the IDE Preferences window.

Linux Click Save, then close the IDE Preferences window.
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Using Markers
Markers behave like labels in the editor, identifying specific parts of source code. Use 
these tasks to work with markers:

• Add markers to a source file

• Navigate to a marker

• Remove some or all markers from a source file

Remove Markers Window
Use the Remove Markers window to manage the use of destination markers in source 
files. Figure 11.1 shows the Remove Markers window. Table 11.3 explains the items 
in the window.

Figure 11.1  Remove Marker window

Table 11.3  Remove Markers window—items

Item Explanation

Markers list Displays a list of all markers in the current source file.

Remove button Click to remove all selected markers.
115IDE 5.5 User’s Guide 



Navigating Source Code
Using Markers
Adding Markers to a Source File

Use the Add Marker command to add a marker to a file to identify specific line 
locations by name.

1. Position the cursor on a line.

2. Choose Marker > Add Marker.

3. Type a name for the new marker.

4. Click Add.

The IDE adds the marker to the file.

Navigating to a Marker

Once you add a marker, you can use the Marker menu to return to it later.

1. Select the marker name from the Marker menu.

2. The editor window scrolls to display the selected marker.

Removing a Marker from a Source File

Use the Remove Marker command to remove one or more markers from a source 
file.

1. Choose Marker > Remove Markers.

2. Select the marker name to remove from the list.

Cancel button Click to close the Remove Markers window without applying 
changes.

Done button Click to close the Remove Markers window and apply 
changes.

Table 11.3  Remove Markers window—items (continued)

Item Explanation
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3. Click Remove.

The IDE removes the selected marker.

Removing All Markers from a Source File

Use the Remove Marker command to remove one or more markers from a source 
file.

1. Choose Marker > Remove Markers.

2. Select all markers in the Markers list, as explained in Table 11.4.

3. Click Remove.

The IDE removes all markers.

Symbol Definitions
You can find a symbol definition in your project’s source code. For the Mac OS, you 
can also look up a symbol definition using the online documentation viewer in the 
IDE Extras selection in the IDE Preferences panel.

Supported online reference viewers include HTMLHelp (Windows) and QuickHelp 
(Mac OS), as well as older online help systems such as QuickView (Mac OS) and 
THINK Reference (Mac OS).

TIP You can also use the browser to look up symbol definitions.

Table 11.4  Selecting all markers in the Markers list

On this host… Do this…

Windows Shift-click each marker name in the list.

Macintosh Select Edit > Select All.

Solaris Select Edit > Select All.

Linux Select Edit > Select All.
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Figure 11.2  Find Definition

Looking Up Symbol Definitions

To look up the definition of a selected symbol, follow these steps:

1. From the Search menu in the Main Toolbar, choose Find Definition.

2. Enter the symbol definition.

3. Click OK.

CodeWarrior searches all of the files in your project for the symbol definition.

If CodeWarrior finds a definition, it opens an editor window and highlights the 
definition for you to examine.

TIP To return to your original location after viewing a symbol definition, 
press Shift-Ctrl B (Windows) or Shift-Command B (Mac OS). This 
key binding is equivalent to the Go Back menu command.

Mac OS, Solaris, and Linux You can also use the Find Reference and Find 
Definition & Reference commands to look up symbol definitions. After you select a 
symbol and choose the Find Reference command, CodeWarrior searches the online 
documentation for the symbol definition. After you select a symbol and choose the 
Find Definition & Reference command, the IDE searches both the project files and the 
online documentation for the symbol definition. If CodeWarrior does not find a 
definition or reference, it notifies you with a beep.
118 IDE 5.5 User’s Guide



Navigating Source Code
Reference Templates (Macintosh)
Reference Templates (Macintosh)
If you look up a routine (such as an operating system call) in the QuickView or 
THINK Reference online viewers, you can paste the template for the call into the 
active editor window at the text-insertion point. If you know the name of the call that 
you want to add to your source code, but are not familiar with the call parameters, this 
technique is useful.

Listing 11.1 shows a sample routine template.

Listing 11.1  Sample routine template

SetRect (r,  left,  top,  right,  bottom);

Inserting a Reference Template

To insert a reference template into your code, follow these steps:

1. From the online viewer window, type the routine name that you want to insert.

2. Select the name you just typed.

3. Choose Insert Reference Template from the Edit menu.

The IDE searches for the routine in either QuickView (Mac OS) or THINK 
Reference (Mac OS), starting the required application if it is not already running. 
If the IDE finds the routine, the IDE copies the template to the active editor 
window and replaces the text you selected with the template.
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12
Finding and Replacing Text

This chapter explains how to work with the find-and-replace features in the 
CodeWarrior™ IDE.

This chapter contains these sections:

• “Single-File Find” on page 121

• “Single-File Find and Replace” on page 124

• “Multiple-File Find and Replace” on page 127

• “Search Results Window” on page 138

• “Text-Selection Find” on page 140

• “Regular-Expression Find” on page 142

• “Comparing Files and Folders” on page 145

Single-File Find
Use the Find window to search for text within a single file:

• The Find operation returns a single instance of matching text.

• The Find All operation returns all instances of matching text.

Figure 12.1 shows the Find window. Table 12.1 on page 122 explains the items in the 
Find window.

Figure 12.1  Find window
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Table 12.1  Find window—items

Item Explanation

Find text/list box Enter a search string. Click the arrow symbol to select a search 
string that you entered previously.

Find button Click to start a search operation using the string in the Find text/
list box. 

Find All button Click to search for all matches in the active editor window.

Cancel button Click to close the Find window without performing a search.

Match whole word
checkbox

Check to search for whole-word matches only, ignoring matches 
within words.

Clear to search for all matches of the search string, including 
matches within words.

Case sensitive
checkbox

Check to consider text case during the search. The search 
operation distinguishes between a capital letter and the same 
letter in lower case.

Clear to disregard text case during the search. The search 
operation does not distinguish between a capital letter and the 
same letter in lower case.

Regular expression
checkbox

Check to treat the search string as a regular expression.

Clear to treat the search string as plain text.

Stop at end of file
checkbox

Check to stop a search at the end of a file and not wrap around to 
the beginning of the file.

Clear to wrap around to the beginning of the file and continue a 
search. The search stops at the first match or at the current
cursor position.

Search up
checkbox

Check to perform a search operation back from the
current selection.

Clear to perform a search operation forward of the
current selection

Search selection only
checkbox

Check to search only the currently selected text and not the
entire file.

Clear to search the entire file.

All text
option button

Select to search all text in the file.
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Searching Text in a Single File

Use the Find command to search for text in the active editor window.

1. Click Search > Find.

The Find window appears.

NOTE (Mac OS, Solaris, and Linux) Use the Customize IDE Commands 
window to activate the Find menu command.

2. Enter search text into Find text/list box.

3. Set search options.

4. Click the Find or Find All button to start the search.

The IDE searches the current file until it finds a match or reaches the end of the search. 
A single match appears highlighted in the editor window, or multiple matches appear 
in a Search Results window. The IDE beeps if it does not find any matching text.

TIP If you clicked the Find button to start the search, click Search >
Find Next to find the next match in the file.

Code only
option button

Select to search only source code in the file.

Comments only
option button

Select to search only comments in the file.

Table 12.1  Find window—items (continued)

Item Explanation
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Single-File Find and Replace
Use the Find and Replace window to perform these tasks:

• Search a single file.

• Replace found text in a single file.

Figure 12.2 shows the Find and Replace window. Table 12.2 explains the items in the 
Find and Replace window.

Figure 12.2  Find and Replace window

Table 12.2  Find and Replace window—items

Item Explanation

Find text/list box Enter a search string. Click the arrow symbol to select a search 
string that you entered previously.

Replace with
text/list box

Enter the replacement string. Click the arrow symbol to select a 
replacement string that you entered previously.

Find button Click to start a search operation using the string in the Find text/
list box. 

Replace button Click to replace the current match with the replacement string.

Replace All button Click to replace all matches with the replacement string.

Cancel button Click to close the Find and Replace window without performing
a search.

Match whole word
checkbox

Check to search for whole-word matches only, ignoring matches
within words.

Clear to search for all matches of the search string, including 
matches within words.
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Case sensitive
checkbox

Check to consider text case during the search. The search 
operation distinguishes between a capital letter and the same 
letter in lower case.

Clear to disregard text case during the search. The search 
operation does not distinguish between a capital letter and the 
same letter in lower case.

Regular expression
checkbox

Check to treat the search string as a regular expression.

Clear to treat the search string as plain text.

Stop at end of file
checkbox

Check to stop a search at the end of a file and not wrap around to 
the beginning of the file.

Clear to wrap around to the beginning of the file and continue a 
search. The search stops at the first match or at the current
cursor position.

Search up
checkbox

Check to perform a search operation back from the
current selection.

Clear to perform a search operation forward of the
current selection

Search selection only
checkbox

Check to search only the currently selected text and not the
entire file.

Clear to search the entire file.

All text
option button

Select to search all text in the file.

Code only
option button

Select to search only source code in the file.

Comments only
option button

Select to search only comments in the file.

Table 12.2  Find and Replace window—items (continued)

Item Explanation
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Replacing Text in a Single File

Use the Replace command to replace matching text.

1. Click Search > Replace or Search > Find and Replace.

The Find window appears.

2. Enter search text into the Find text/list box.

3. Enter replacement text into the Replace with text/list box.

4. Set search options.

5. Find and replace text:

a. Click the Find button to search for matching text.

The IDE searches the current file until it finds a match or reaches the end of 
the search. A single match appears highlighted in the editor window. The IDE 
beeps if it does not find any matching text.

b. Click the Replace or Replace All button to replace the matching text.

Click the Replace button to replace the current match. Click the Replace 
button repeatedly to replace subsequent matches. Click the Replace All button 
to replace all matching text in the file.

To replace consecutive matches, click the Find button to find the first match, then 
repeatedly click the Replace button. To replace one match at a time, or to replace non-
consecutive matches, click the Find button to find a match, then click the Replace 
button as needed.

TIP If you clicked the Find button to start the search, click Search > 
Find Next to find the next match in the file.
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Multiple-File Find and Replace
Use the Find in Files window to perform these tasks:

• Search several files.

• Replace found text in multiple files, folders, symbolics files, or projects.

• Replace found text in files within a specific build target.

Figure 12.3 shows the Find in Files window. Table 12.3 explains the items in
the window.

Figure 12.3  Find in Files window

Table 12.3  Find in Files window—items

Item Explanation

Find text/list box Enter a search string. Click the arrow symbol to select a search 
string that you entered previously.

Replace with
text/list box

Enter the replacement string. Click the arrow symbol to select a 
replacement string that you entered previously.

Find button Click to start a search operation using the string in the Find text/
list box. 
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Find All button Click to search for all matches in the selected items.

Replace button Click to replace the current match with the replacement string.

Replace All button Click to replace all matches with the replacement string.

Stop button Click to stop the current operation.

Match whole word
checkbox

Check to search for whole-word matches only, ignoring matches 
within words.

Clear to search for all matches of the search string, including 
matches within words.

Case sensitive
checkbox

Check to consider text case during the search. The search 
operation distinguishes between a capital letter and the same 
letter in lower case.

Clear to disregard text case during the search. The search 
operation does not distinguish between a capital letter and the 
same letter in lower case.

Regular expression
checkbox

Check to treat the search string as a regular expression.

Clear to treat the search string as plain text.

All text
option button

Select to search all text in the selected items.

Code only
option button

Select to search only source code in the selected items.

Comments only
option button

Select to search only comments in the selected items.

In Folders tab Click to bring forward the In Folders page. Use this page to search 
specific folders in the host computer’s file system.

In Projects tab Click to bring forward the In Projects page. Use this page to 
search active projects and build targets.

In Symbolics tab Click to bring forward the In Symbolics page. Use this page to 
search files containing symbolics (debugging and browsing) 
information generated by the IDE.

In Files tab Click to bring forward the In Files page. Use this page to search 
files contained in custom file sets.

Table 12.3  Find in Files window—items (continued)

Item Explanation
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In Folders
Use the In Folders page to search folder contents for matching text. Figure 12.4 
shows the In Folders page. Table 12.4 explains the items in the page.

Figure 12.4  Find in Files window—In Folders page

Table 12.4  Find in Files window—In Folders items

Item Explanation

Search in
text/list box

Enter the path to the folder that you want to search. Click the 
arrow symbol to select a path that you entered previously.

Browse button Click to open a dialog box that lets you pick the folder that you 
want to search.

Search sub-folders
checkbox

Check to search sub-folders of the selected folder.

Clear to search the selected folder only, ignoring any sub-folders it 
may contain.

By type
text/list box

Enter the filename extensions of the files that you want to search. 
Click the arrow symbol to select a set of filename extensions.
The search ignores files whose filename extensions do not 
appear in this text/list box.
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Searching for Text Across Multiple Folders

Use the In Folders page to search for text in folder contents.

1. Click Search > Find in Files.

The Find in Files window appears.

2. Enter search text into the Find text/list box.

3. Enter replacement text into the Replace with text/list box.

4. Set general search options.

5. Set the In Folders page search options:

a. Enter a folder path into the Search in text/list box, or click the Browse button 
to select a folder.

b. Check or clear the Search sub-folders checkbox.

c. Enter filename extensions into the By type text/list box.

6. Find and replace text:

a. Click the Find or Find All button to search for matching text.

The IDE searches the specified folder contents until it finds a match or 
reaches the end of the search. A single match appears highlighted in an editor 
window, or multiple matches appear in a Search Results window. The IDE 
beeps if it does not find any matching text.

b. Click the Replace or Replace All button to replace the matching text.

Click the Replace button to replace the current match. Click the Replace 
button repeatedly to replace subsequent matches. Click the Replace All button 
to replace all matching text.

To replace consecutive matches, click the Find button to find the first match, then 
repeatedly click the Replace button. To replace one match at a time, or to replace non-
consecutive matches, click the Find button to find a match, then click the Replace 
button as needed.

TIP If you clicked the Find button to start the search, click Search >
Find Next to find the next match.
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In Projects
Use the In Projects page to search active projects and build targets for matching text. 
Figure 12.5 shows the In Projects page. Table 12.5 explains the items in the page.

Figure 12.5  Find in Files window—In Projects page

Table 12.5  Find in Files window—In Projects items

Item Explanation

Project list box Specify the projects that you want to search.

Target list box Specify the build targets that you want to search.

Project sources
checkbox

Check to search the source-code files of the selected projects.

Clear to ignore source-code files of the selected projects.

Project headers
checkbox

Check to search the header files of the selected projects.

Clear to ignore header files of the selected projects.

System headers
checkbox

Check to search system header files.

Clear to ignore system header files.

Search cached sub-
targets checkbox

Check to search sub-targets that the IDE cached for the selected 
build targets.

Clear to ignore the sub-targets that the IDE cached for the 
selected build targets.

File list This list shows the files that the IDE will search. To remove a file 
from this list, select it and press Backspace or Delete. To open a 
file in this list, double-click its name.
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Searching for Text Across Multiple Projects

Use the In Projects page to search for text in active projects and build targets.

1. Click Project > Make.

The IDE updates the project data to correctly list source-code files, header files, 
and build targets in the In Projects page of the Find in Files window.

2. Click Search > Find in Files.

The Find in Files window appears.

3. Enter search text into the Find text/list box.

4. Enter replacement text into the Replace with text/list box.

5. Set general search options.

6. Set the In Projects page search options:

a. Use the Project list box to specify the projects that you want to search.

b. Use the Target list box to specify the build targets that you want to search.

c. Check or clear the checkboxes to refine your search criteria.

d. Remove files from the File list as needed.

7. Find and replace text:

a. Click the Find or Find All button to search for matching text.

The IDE searches the specified projects and build targets until it finds a match 
or reaches the end of the search. A single match appears highlighted in an 
editor window, or multiple matches appear in a Search Results window. The 
IDE beeps if it does not find any matching text.

b. Click the Replace or Replace All button to replace the matching text.

Click the Replace button to replace the current match. Click the Replace 
button repeatedly to replace subsequent matches. Click the Replace All button 
to replace all matching text.

To replace consecutive matches, click the Find button to find the first match, then 
repeatedly click the Replace button. To replace one match at a time, or to replace non-
consecutive matches, click the Find button to find a match, then click the Replace 
button as needed.
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TIP If you clicked the Find button to start the search, click Search >
Find Next to find the next match.

In Symbolics
Use the In Symbolics page to search files containing symbolics information for 
matching text. Figure 12.6 shows the In Symbolics page. Table 12.6 explains the items 
in the page.

Figure 12.6  Find in Files window—In Symbolics page

Table 12.6  Find in Files window—In Symbolics items

Item Explanation

Symbolics list box Specify the symbolics files that you want to search.

Symbolics list This list shows the symbolics files that the IDE will search. To 
remove a file from this list, select it and press Backspace or 
Delete. To open a file in this list, double-click its name.
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Searching for Text Across Multiple Symbolics Files

Use the In Symbolics page to search for text in symbolics files. You must generate 
browser data in order to search symbolics files.

1. Enable browser data for the build targets that you want to search.

Use the Build Extras target settings panel to Generate Browser Data From a 
compiler or language parser, then Apply or Save your changes. Configuring this 
option enables browser data.

2. Click Project > Debug.

Starting a debugging session causes the IDE to generate browser data for
the project.

NOTE The IDE does not generate browser data for some files, such
as libraries.

3. Click Debug > Kill.

The debugging session ends.

4. Click Search > Find in Files.

The Find in Files window appears.

5. Enter search text into the Find text/list box.

6. Enter replacement text into the Replace with text/list box.

7. Set general search options.

8. Set the In Symbolics page search options:

a. Use the Symbolics list box to specify the symbolics files that you want
to search.

b. Remove symbolics files from the Symbolics list as needed.

9. Find and replace text:

a. Click the Find or Find All button to search for matching text.

The IDE searches the specified symbolics files until it finds a match or 
reaches the end of the search. A single match appears highlighted in an editor 
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window, or multiple matches appear in a Search Results window. The IDE 
beeps if it does not find any matching text.

b. Click the Replace or Replace All button to replace the matching text.

Click the Replace button to replace the current match. Click the Replace 
button repeatedly to replace subsequent matches. Click the Replace All button 
to replace all matching text.

To replace consecutive matches, click the Find button to find the first match, then 
repeatedly click the Replace button. To replace one match at a time, or to replace non-
consecutive matches, click the Find button to find a match, then click the Replace 
button as needed.

TIP If you clicked the Find button to start the search, click Search >
Find Next to find the next match.

In Files
Use the In Files page to search file sets for matching text. Figure 12.7 shows the In 
Files page. Table 12.7 on page 136 explains the items in the page.

Figure 12.7  Find in Files window—In Files page
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Searching for Text Across Multiple Files

Use the In Files page to search for text in file sets.

1. Click Search > Find in Files.

The Find in Files window appears.

2. Enter search text into the Find text/list box.

3. Enter replacement text into the Replace with text/list box.

4. Set general search options.

5. Set the In Files page search options:

a. Use the File Set list box to specify the file set that you want to search.

b. Use the buttons to manage the File Set list as needed.

Table 12.7  Find in Files window—In Files items

Item Explanation

File Set list box Specify the file set that you want to search. Select New File Set to 
create a new set.

File Set list This list shows the files that the IDE will search. To remove a file 
from this list, select it and press Backspace or Delete. To add files 
to this list, click the Add Files button, or drag and drop files and 
folders into the list. To open a file in this list, double-click its name.

Add Files button Click to open a dialog box that lets you add files to the current file 
set. To enable this button, select from the File Set list box an 
existing file set or the New File Set option.

Clear List button Click to clear the current File Set list. To enable this button, select 
from the File Set list box a file set that has at least one file.

Save This Set button Click to save the current file set under a specific name. The file set 
must have at least one file. The name appears in the File Set list 
box. To enable this button, modify the current file set or select an 
existing file set from the File Set list box.

Remove a Set button Click to open a dialog box that lets you remove file sets that you
created previously. The removed file sets no longer appear in the 
File Set list box. To enable this button, select from the File Set list 
box an existing file set or the New File Set option.
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c. Remove files from the File Set list as needed.

6. Find and replace text:

a. Click the Find or Find All button to search for matching text.

The IDE searches the specified files until it finds a match or reaches the end of 
the search. A single match appears highlighted in an editor window, or 
multiple matches appear in a Search Results window. The IDE beeps if it does 
not find any matching text.

b. Click the Replace or Replace All button to replace the matching text.

Click the Replace button to replace the current match. Click the Replace 
button repeatedly to replace subsequent matches. Click the Replace All button 
to replace all matching text.

To replace consecutive matches, click the Find button to find the first match, then 
repeatedly click the Replace button. To replace one match at a time, or to replace non-
consecutive matches, click the Find button to find a match, then click the Replace 
button as needed.

TIP If you clicked the Find button to start the search, click Search >
Find Next to find the next match in the file.
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Search Results Window
Use the Search Results window to explore multiple matches that the IDE finds. The 
IDE opens this window automatically after it finds multiple matches. Also use this 
window to stop searches in progress.

Figure 12.8 shows the Search Results window. Table 12.8 explains the items in the 
window.

Figure 12.8  Search Results window

Table 12.8  Search Results window—items

Item Icon Explanation

Result Count text box Shows the total number of search results.

Search Criteria text 
box

Shows the search criteria.
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Warnings button Click to display complier and linker 
warnings in the Results pane. The text 
box to the right of this button shows the 
total number of warnings.

Stop button Click to stop the search in progress.

Previous Result 
button

Click to select the previous search result.

Next Result button Click to select the next search result.

Results pane Lists individual search results.

Source Code pane
disclosure triangle

Click to show or hide the Source Code 
pane.

Pane resize bar Drag to resize the Results and Source 
Code panes.

Source Code pane Shows the source code corresponding to 
the selected item in the Results pane. 
This pane operates the same way as an 
editor window without pane-splitter 
controls.

Table 12.8  Search Results window—items (continued)

Item Icon Explanation
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Text-Selection Find
After you use the Find, Find and Replace, or Find in Files windows to perform a 
successful search, you can use menu commands to apply the same search criteria to 
additional searches. This way, you do not have to open the windows again to use the 
same search criteria. You select text in the active editor window to define the
search string.

Using the Find Next Command

When searching for text, you can use the Find Next command to have the IDE find the 
next match:

1. Start a search with the Find, Find and Replace, or Find in Files windows.

2. After the IDE finds a match, click Search > Find Next to find a
subsequent match.

Using the Find Previous Command

When searching for text, you can use the Find Previous command to have the IDE 
find the previous match. You must enable the Find Previous command in the 
Customize IDE Commands window.

1. Click Edit > Commands & Key Bindings.

The Customize IDE Commands window opens.

2. Click the Commands tab in the Customize IDE Commands window.

The Commands page appears.

3. Expand the Search item in the Commands pane tree structure.

4. Select the Find Previous item in the expanded list.

Scroll as needed in order to see the Find Previous item. After you select the Find 
Previous item, its settings appear in Details pane.

5. Check the Appears in Menus checkbox.

The Find Previous command will appear in the Search menu in the main IDE 
menu bar.
140 IDE 5.5 User’s Guide



Finding and Replacing Text
Text-Selection Find
6. Click Save to confirm your changes.

7. Close the Customize IDE Commands window.

You can now select the Find Previous command in the Search menu. You can also 
use the key binding associated with the command.

NOTE (Macintosh) Hold down the Shift key in order to click
Search > Find Previous.

Changing the Find String

Use the Enter Find String command to change the current find string.

1. Select the text that you want to use as the new find string.

2. Click Search > Enter Find String.

The selected text replaces the find string that you specified in the Find, Find and 
Replace, or Find in Files windows.

You can now use the new find string to perform find and replace operations.

Searching with a Text Selection

Use the Find Selection command to search the active editor window for selected text.

1. Select the text that you want to use as the search string.

2. Click Search > Find Selection.

The IDE searches the active editor window until it finds a match or reaches the end of 
the search. A single match appears highlighted in the editor window. The IDE beeps if 
it does not find any matching text.

You can also use the Find Next and Find Previous commands to search for additional 
matching text.
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Regular-Expression Find
Use regular expressions to search text according to sophisticated text-matching rules. 
A regular expression is a text string used as a mask for matching text in a file. To use 
regular expressions, select Regular expression in the Find, Find and Replace, or 
Find in Files windows. Certain characters are operators with special meanings in a 
regular expression.

TIP For an in-depth description of regular expressions, refer to Mastering 
Regular Expressions by Jeffrey E.F. Friedl, published by O’Reilly & 
Associates, Inc. On a UNIX system, also refer to the man pages
for regexp.

Table 12.9 explains the regular-expression operators that the IDE recognizes.

Table 12.9  Regular-expression operators recognized by the IDE

Operat
or

Name Explanation

. match any Matches any single printing or non-printing character 
except newline and null.

* match zero
or more

Replaces the smallest/preceding regular expression with a 
sub-expression.

+ match one
or more

Repeats the preceding regular expression at least
once and then as many times as necessary to match
the pattern.

? match zero
or one

Repeats the preceding regular expression once or
not at all.

\n back reference Refers to a specified group (a unit expression enclosed in 
parentheses) in the find string. The digit n identifies the 
nth group, from left to right, with a number from 1 to 9.

| alternation Matches one of a choice of regular expressions. If this 
operator appears between two regular expressions, the 
IDE matches the largest union of strings.

^ match beginning 
of line

Matches items from the beginning of a string or following a 
newline character. This operator also represents a list 
operator when enclosed within brackets.

$ match end of line Matches items from the end of a string or preceding a 
newline character.
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Table 12.10 shows various examples of using regular expressions to match particular 
text in a text sample.

[...] list Defines a set of items to use as a match. The IDE does not 
allow empty lists.

(...) group Defines an expression to be treated as a single unit 
elsewhere in the regular expression.

- range Specifies a range. The range starts with the character 
preceding the operator and ends with the character 
following the operator.

Table 12.10  Examples of using regular expressions

Example Type This regular 
expression...

...matches this 
text...

...in this text sample:

Matching simple 
expressions

ex ex sample text

[(][.]stack[)] (.stack) ADDR(.stack)

Matching any character var. var1
var2

cout << var1;
cout << var2;

c.t cut
cot

cin >> cutF;
cin >> cotG;

Repeating expressions s*ion ion
ssion

information
the session

s+ion sion
ssion

confusion
the session

Grouping expressions ris ris surprise

r( i)s r is theVar is

Choosing one 
character from many

[bls]ag sag bag lag sagging bag lagged

[[aeiou][0-9] [2 u9 cout << a[2] << u9;

[^bls]ag rag sagging rag lagged

[-ab]V aV -V aVal-Val;

Table 12.9  Regular-expression operators recognized by the IDE (continued)

Operat
or

Name Explanation
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Using the Find String in the Replace String
Use the & operator to incorporate matching text into a replacement string. The IDE 
substitutes the matching text for the & operator. Use \& to indicate a literal ampersand 
in the replacement string.

Table 12.11 shows examples of using the find string in the replace string of regular 
expressions.

.

Remembering Sub-expressions
Use the \n construct to recall sub-expressions from the find string in the replacement 
string. The digit n ranges from 1 to 9 and represents the nth sub-expression in the find 
string, counting from left to right. Enclose each sub-expression in parentheses.

Consider these sample definitions:

• Find string: \#define[ \t]+(.+)[ \t]+([0-9]+);

• Replace string: const int \1 = \2;

Matching line 
beginnings and 
endings

^([\t]*cout) cout
   cout

cout << "no tab";
   cout << "tab";

(l*;)$ l;
;

a-ct; a = battLvl;
b-ct;

Table 12.11  Examples of using the find string in the replace string

Find string Replace string Matching text After replacement

var[0-9] my_& var1 my_var1

tgt \&target tgt &target

Table 12.10  Examples of using regular expressions (continued)

Example Type This regular 
expression...

...matches this 
text...

...in this text sample:
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• Sub-expression \1: (.+)

• Sub-expression \2: ([0-9]+)

These definitions show a replacement operation that recalls two sub-expressions. 
Table 12.12 shows the result of applying these sample definitions to some text.

Comparing Files and Folders
The IDE can compare files or folder contents and graphically show you the differences 
between them. You can perform these tasks:

• Compare two files.

• Compare the contents of two folders.

You perform the comparison by specifying a source item and a destination item. You 
can apply or unapply the changes in the source item to the destination item.

Comparison Setup
You use the Compare Files Setup window to enter information about the files or 
folders that you want to compare. Figure 12.9 on page 146 shows the Compare Files 
Setup window. Table 12.13 on page 146 explains the items in the window.

Table 12.12  Remembering sub-expressions

Before replacement \1 matches 
this text

\2 matches 
this text

After replacement

#define var1 10; var1 10 const int var1 = 10;

#define a 100; a 100 const int a = 100;
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Figure 12.9  Compare Files Setup window

Table 12.13  Compare Files Setup window—items

Item Explanation

Source box Click the Choose button to specify the source file or folder for the 
comparison, or drag and drop a file or folder into the box. Click the 
selector to the left of the Choose button to specify a file in an open 
editor window.

Destination box Click the Choose button to specify the destination file or folder for 
the comparison, or drag and drop a file or folder into the box. Click 
the selector to the left of the Choose button to specify a file in an 
open editor window.

Case sensitive
checkbox

Check to consider text case during the compare operation.
The comparison distinguishes between a capital letter and the 
same letter in lower case.

Clear to disregard text case during the compare operation.
The comparison does not distinguish between a capital letter and 
the same letter in lower case.

Ignore extra space
checkbox

Check to consider extra spaces and tabs during the compare 
operation. The comparison distinguishes differences in the 
number of spaces and tabs in the compared files.

Clear to disregard extra spaces and tabs during the compare 
operation. The comparison does not distinguish differences in the 
number of spaces and tabs in the compared files.
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Choosing Files to Compare

Use the Compare Files command to specify two files that you want to compare.

1. Click Search > Compare Files.

The Compare Files Setup window appears.

2. Specify a source file for the comparison.

Click the Choose button in the Source box or drag and drop the file into the 
Source box. To specify a file in an open editor window, click the selector in
the Source box.

3. Specify a destination file for the comparison.

Click the Choose button in the Destination box or drag and drop the file into the 
Destination box. To specify a file in an open editor window, click the selector in
the Destination box.

4. Configure the checkboxes in the Text Compare Options group.

Check the Case sensitive checkbox to distinguish between a capital letter and the 
same letter in lower case. Check the Ignore extra space checkbox to disregard 
extra spaces or tabs in the files.

Only show different 
files checkbox

Check to have the Folder Compare Results window show only 
the differences between the compared folders. The Files in Both 
Folders pane stays blank.

Clear to have the Folder Compare Results window show all files 
from the compared folders as well as the differences between 
those folders. The Files in Both Folders pane shows the 
common files between the compared folders.

Compare text file 
contents checkbox

Check to identify differences in terms of a byte-by-byte 
comparison of the files.

Clear to identify differences in terms of only the sizes and 
modification dates of the files.

Compare button Click to compare the specified files or folders.

Table 12.13  Compare Files Setup window—items (continued)

Item Explanation
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5. Click the Compare button.

The IDE performs the file comparison. The File Compare Results
window appears.

Choosing Folders to Compare

Follow these steps to specify two folders that you want to compare:

1. Click Search > Compare Files.

The Compare Files Setup window appears.

2. Specify a source folder for the comparison.

Click the Choose button in the Source box or drag and drop the folder into the 
Source box.

3. Specify a destination folder for the comparison.

Click the Choose button in the Destination box or drag and drop the folder into 
the Destination box.

4. Configure the checkboxes in the Text Compare Options group.

These options apply to the files inside the compared folders. Check the
Case sensitive checkbox to distinguish between a capital letter and the same letter 
in lower case. Check the Ignore extra space checkbox to disregard extra spaces 
or tabs in the files.

5. Configure the checkboxes in the Folder Compare Options group.

These options apply to the contents of the compared folders. Check the
Only show different files checkbox to have the Folder Compare Results 
window show only the files that differ between the source folder and destination 
folder. Check this option to have the Files in Both Folders pane of the Folder 
Compare Results window stay blank.

Check the Compare text file contents checkbox to have the IDE perform a 
content-based comparison of the text files in the compared folders. Check this 
option to have the Folder Compare Results window show differences in terms of 
file content instead of file sizes and modification dates.
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6. Click the Compare button.

The IDE performs the folder comparison. The Folder Compare Results
window appears.

CAUTION The compare operation ignores folders matching the criteria that you 
specify in the Shielded Folders preference panel.

File Comparison
The IDE file-comparison feature identifies additions, changes, and deletions between 
two text files. In addition, this feature allows you to apply the differences in the source 
file to the destination file.

You can also use this feature to merge changes between two versions of the same
text file. Specify one version of the text file as the source file and the other version of 
the text file as the destination file. Then you can apply changes from the source file to 
the destination file. The destination file becomes the merged file.

After you use the Compare Files Setup window to specify two files for comparison, 
click the Compare button. The File Compare Results window appears. You use this 
window to see the differences between the source file and destination file and apply or 
unapply those differences to the destination file.

The File Compare Results window shows file differences in the form of highlighted 
portions of text. The highlighting tracks with the text as you scroll through the 
compared files.

Figure 12.10 on page 150 shows the File Compare Results window. Table 12.14 on 
page 150 explains the items in the window.
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Figure 12.10  File Compare Results window

Table 12.14  File Compare Results window—items

Item Icon Explanation

Source pane Shows the contents of the source file.
You cannot edit the contents of this pane.

Destination pane Shows the contents of the destination file. 
You can edit the contents of this pane.

Pane resize bar Drag to resize the Source and
Destination panes.

Apply button Click to apply the selected Differences pane 
items to the destination file.

Unapply button Click to unapply the selected Differences 
pane items from the destination file.
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Applying File Differences

Use the Apply Difference command to apply the selected items in the Differences 
pane to the destination file.

NOTE You cannot alter the source file. You can change the destination file 
by applying differences from the source file or by editing the 
contents of the Destination pane.

1. Select the items in the Differences pane that you want to apply to the
destination file.

2. Click Search > Apply Difference or click the Apply button in the File 
Compare Results window.

The Destination pane updates to reflect the differences that you applied to the 
destination file. The applied items in the Differences pane change to an
italicized font.

TIP Use the Customize IDE Commands window to assign a key binding 
to the Apply Difference command. This way, you can use the 
keyboard to apply differences.

Undo button Click to undo your last text edit in the 
Destination pane.

Redo button Click to redo your last text edit in the 
Destination pane.

Differences pane Shows the differences between the Source 
pane and the Destination pane. Select an 
item to highlight it in the Source and 
Destination panes. Applied items appear in 
an italicized font

Table 12.14  File Compare Results window—items (continued)

Item Icon Explanation
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Unapplying File Differences

Use the Unapply Difference command to unapply the selected items in the 
Differences pane from the destination file.

NOTE You cannot alter the source file. You can change the destination file 
by unapplying differences from the source file or by editing the 
contents of the Destination pane.

1. Select the items in the Differences pane that you want to unapply from the
destination file.

Items that you can unapply appear in an italicized font.

2. Click Search > Unapply Difference or click the Unapply button in the File 
Compare Results window.

The Destination pane updates to reflect the differences that you unapplied from 
the destination file. The unapplied items in the Differences pane no longer appear 
in an italicized font.

TIP Use the Customize IDE Commands window to assign a key binding 
to the Unapply Difference command. This way, you can use the 
keyboard to unapply differences.

Folder Comparison
The IDE folder-comparison feature identifies the differences between the contents of 
two folders. It reports the files in both folders, the files only in the source folder, and 
the files only in the destination folder.

You can also use this feature to analyze the differences between two different releases 
of a folder of software. Specify one release of the software folder as the source folder 
and the other release of the software folder as the destination folder. Then you can 
analyze the differences between the source and destination folders.

After you use the Compare Files Setup window to specify two folders for 
comparison, click the Compare button. The Folder Compare Results window 
appears. You use this window to see the differences between the source folder and 
destination folder.
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The Folder Compare Results window shows folder differences in the form of
three panes. Italicized items in these panes indicate non-text files.

Figure 12.11 shows the Folder Compare Results window. Table 12.15 explains the 
items in the window.

Figure 12.11  Folder Compare Results window

Table 12.15  Folder Compare Results window—items

Item Icon Explanation

Pane Expand box Click to enlarge the pane to fill the window.

Pane Collapse box Click to reduce an expanded pane to its 
original size.

Pane resize bar Drag to resize the panes on either side of 
the bar.
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Examining Items in the Folder Compare Results Window

You can use the Folder Compare Results window to open text files and compare
file differences.

Double-click a text file to view and change its contents in an editor window.

A file whose contents differ between the source and destination folders has a bullet 
next to its name. Double click the file to open a File Comparison Results window. 
Use this window to examine the differences between the file contents.

Files in Both Folders 
pane

Shows the items that are in both the source 
folder and the destination folder. A bullet 
next to an item indicates that the item 
content differs between the two folders.

Files Only in Source
pane

Shows the items that are in the source
folder only.

Files Only in Destination 
pane

Shows the items that are in the destination 
folder only.

Selected item
group

Shows file and difference information for the 
selected item in the window panes.

Table 12.15  Folder Compare Results window—items (continued)

Item Icon Explanation
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Browser

This section contains these chapters:

• Using the Browser

• Using Class Browser Windows

• Using Other Browser Windows

• Using Browser Wizards
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Using the Browser

This chapter explains how to work with the browser in the CodeWarrior® IDE. Use 
the browser to perform these tasks:

• Generate a browser database—the browser stores collected symbol information 
in a browser database for the project. You can generate browser data from the 
compiler or the language parser.

• Collect symbol information—symbols include functions, variables, and objects. 
Enable the browser to collect information about the symbols in a project.

Read this chapter to learn more about typical tasks for working with the browser.

This chapter contains these sections:

• “Browser Database” on page 157

• “Browser Symbols” on page 160

Browser Database
The browser database contains information about the symbols in a program, which 
include—depending on the program language—global variables, functions, classes, 
and type declarations, among others.

Some IDE windows require that the project contain a browser database. For example, 
the Class Hierarchy window only displays information for a project that contains a 
browser database. This section explains how to configure a project to generate its 
browser database.

NOTE Generating a browser database increases the project’s size. To 
minimize the project’s size, generate the browser database only for 
the targets you frequently use.
157IDE 5.5 User’s Guide



Using the Browser
Browser Database
Browser Data
Browser data contains symbolic and relationship information about the project code. 
The browser uses this data to access the code information.

Use the Generate Browser Data From menu (Figure 13.1) in the Build Extras 
target settings panel to enable and disable browser data generation. This drop-down 
menu provides these options, which determine where the IDE generates browser data:

• None—The IDE does not generate browser data. Use None to disable browser 
data. Select None to generate faster compiles (with no browser features).

• Compiler—The Compiler generates the browser data. While it compiles more 
slowly, the compiler generates the most accurate browser data.

• Language Parser—The Code Completion plug-in associated with the project’s 
programming language generates the browser data.

Figure 13.1  Generate Browser Data From menu

Generating Browser Data

You can select an option in the Generate Browser Data From drop-down menu to 
establish what the IDE uses to generate browser data for a project file.

To generate browser data, follow these steps:

1. Choose Edit > Target Settings.

2. From the Target Settings Panels list, select Build Extras.

3. Choose Compiler or Language Parser from the Generate Browser Data 
From menu.
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a. Compiler—The compiler generates browser data.

NOTE Some compilers do not generate browser data.

If you enable Dump internal browse information after compile, the 
generated browser data appears in a log window after you compile a file.

• Language Parser—The Code Completion plug-in associated with the project’s 
programming language generates the browser data. Browser data and the 
#include pop-up window update as you edit.

NOTE Choose Language Parser for C/C++ code completion.

Applicable only to C/C++ Code Completion: the Prefix and Macro files (Figure 
13.2).

Figure 13.2  Generate browser data from language parser

• Prefix file—Similar to that used in the C/C++ Language Settings panel, the 
Prefix file contains header files that help the C/C++ Code Completion plug-in 
parse code. The Prefix file should only include text files (not pre-compiled header 
files).

• Macro file—Contains C/C++ macro files that help the Code Completion plug-in 
resolve any #ifdefs found in the source code or in the header files.

4. If you selected Compiler, choose Project > Bring Up To Date or Make.

The IDE generates browser data for the project.

If you selected Language Parser, the IDE generates browser data in the 
background.
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Disabling Browser Data

Select None to disable browser data and stop the IDE from generating browser 
information for the project.

1. Choose Edit > Target Settings.

2. Select Build Extras from the Target Settings Panels list.

3. In the Generate Browser Data From drop-down menu, select None.

4. Click Save.

5. Choose Project > Make.

The IDE stops generating browser information.

Browser Symbols
Navigate browser symbols to open browser views, find symbol definitions, and 
examine inheritance.

You can navigate browser symbols in these ways:

• Use the Browser contextual menu to open various browser windows for a 
selected symbol.

• Double-click a symbol name in the Class Browser window to open the file that 
contains the declaration of that symbol.

• Use the class hierarchy windows to determine the ancestors or descendants of a 
selected symbol.

Browser Contextual Menu
Use the IDE’s browser contextual menu to enhance source-code editing in the IDE. 
Use this menu to streamline text entry in editor windows. You can enter the first few 
letters of a function name, then use the browser contextual menu to complete the entry.
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Using the Browser Contextual Menu

Use a contextual menu in the browser to enhance source-code editing.

1. Open the browser contextual menu, as explained in Table 13.1.

2. Select a command from the contextual menu.

The IDE performs the selected command.

Identifying Symbols in the Browser Database

As a shortcut, you can use browser coloring to help recognize if a symbol resides in 
the browser database. When you activate a browser, you can see browser-database 
symbols because they appear in the editor and browser windows according to the 
colors you select.

TIP The default color setting is identical for all eight types of browser-
database symbols. You can choose a different color for each symbol 
type.

To change the browser symbol colors the editor uses, follow these steps:

1. Choose Edit > Preferences.

2. Select the Text Colors panel from the IDE Preference Panels list.

3. Select the Activate Syntax Coloring option.

4. Select the Activate Browser Coloring option.

Table 13.1  Opening a browser contextual menu

On this host... Do this...

Windows Right-click a symbol name.

Macintosh Click and hold on a symbol name.

Solaris Click and hold on a symbol name.

Linux Click and hold on a symbol name.
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5. Click the color swatch next to the symbol name to set that symbol's color.

6. Click Save.
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Windows

This chapter explains how to work with the Class Browser windows in the 
CodeWarrior™ IDE. Use the Class Browser to perform these tasks:

• View browser data—the class browser collects information about the elements of 
a computer program. Such elements include functions, variables, and classes. The 
class browser displays these elements in organized lists.

• Show data relationships—the class browser shows the relationships between 
classes, data members, and methods. The class browser also updates the display 
to reflect changes in class scope.

Read this chapter to learn more about typical tasks for working with Class Browser 
windows.

This chapter contains these sections:

• “Class Browser window” on page 163

• “Classes pane” on page 169

• “Member Functions pane” on page 171

• “Data Members pane” on page 172

• “Source pane” on page 172

• “Status Area” on page 173

Class Browser window
Use the Class Browser window to view information about the elements of a computer 
program. This section explains how to use the Class Browser window to view browser 
data, assuming knowledge about activating the browser.

Figure 14.1 on page 164 shows the Class Browser window. Table 14.1 on page 164 
explains the items in the window. Table 14.2 on page 166 explains the options in the 
Browser Access Filters list box.
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Figure 14.1  Class Browser window

Table 14.1  Class Browser window—items

Item Icon Explanation

Go Back button Click to return to the preceding browser view.

Go Forward button Click to move to the succeeding browser view.

Browser Contents 
button

Click to open the Browser Contents window.

Class Hierarchy 
button

Click to open the Multi-class Hierarchy window.

Single Class 
Hierarchy Window 
button

Click to open the Single-class Hierarchy window for the 
selected class.
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Browser Access 
Filters list box

Select filters for displaying items in class-browser panes.

Show Inherited Select to show inherited items in the Member Functions 
pane and Data Members pane. Clear to hide inherited 
items from these panes.

Classes pane Lists all classes in the project browser database.

Member Functions 
pane

Lists all member functions defined in the currently 
selected class.

Data Members pane Lists all data members defined in the selected class.

Source pane Displays the source code for the currently selected item.

Status Area Displays various status messages and other information.

Display toggle 
buttons

Alphabetical

Hierarchical

Toggles the Classes display between alphabetical and 
hierarchical listings.

New Item button Opens wizards to create new items (e.g., classes, data 
members, member functions).

Pane Expand box Expands the pane to the width of the full window.

Pane Collapse Box Collapses the pane to its original size.

Classes Pane button Lists all classes in the project browser database.

Class Declaration 
button

Opens a window that shows declarations for all classes 
in the project.

Open File button Opens the current source file in a new editor window.

VCS list pop-up With a version control system enabled, choose the 
version-control command to execute on the displayed 
source file.

Table 14.1  Class Browser window—items (continued)

Item Icon Explanation
165IDE 5.5 User’s Guide 



Using Class Browser Windows
Class Browser window
Viewing Class Data from the Browser Contents Window

To view class data for a project in the Browser Contents window, follow these steps:

1. Open the Browser Contents window, as explained in Table 14.3 on page 166.

2. Select a class in the Browser Contents window.

3. Open a contextual menu for the selected class, as explained in Table 14.4.

Table 14.2  Browser access filters

Filter Icon Show items with this access:

Public Private Protected

View as implementor • • •

View as subclass • •

View as user •

Show public •

Show protected •

Show private •

Table 14.3  Opening the Browser Contents window

On this host… Do this…

Windows Select View > Browser Contents.

Macintosh Select Window > Browser Contents.

Solaris Select Window > Browser Contents.

Linux Select Window > Browser Contents.
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A contextual menu like the one shown in Figure 14.2Figure 14.2 appears.

Figure 14.2  Browser Contents window—contextual menu
 

4. Select Open browser for class classname from the contextual menu.

The classname is the name of the class that you selected.

A Class Browser window appears.

Viewing Class Data from Hierarchy Windows

To view class data from a hierarchy window, follow these steps:

Table 14.4  Opening a contextual menu for the selected class

On this host… Do this…

Windows Right-click the selected class.

Macintosh Control-click the selected class.

Solaris Click and hold on the selected class.

Linux Click and hold on the selected class.
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1. Open a Single-Hierarchy or Multi-Class Hierarchy window:

a. Click the Single Class Hierarchy Window button  in the browser 

toolbar, or

b. Click the Class Hierarchy button  in the browser toolbar.

2. In the Single- or Multi-Class Hierarchy window, double-click a class name.

A Class Browser window appears.

Expanding Browser Panes

Click the Pane Expand box (just above the scroll bar in the upper right-hand corner of 
the pane) to expand the Classes, Function Members, Data Members, or Source panes 
in a Browser window.

1. Click the Pane Expand box  to expand a pane.

This pane expands to fill the Browser window.

2. Use the enlarged pane to view data.

Alternately, you can use the resize bar between the panes to enlarge each pane 
(although the pane does not fill the Browser window).

1. Rest the cursor over the resize bar.

The cursor icon changes to this: 

2. Hold down the mouse button.

3. Drag the resize bar to enlarge or shrink the pane.

Collapsing Browser Panes

Click the Pane Collapse box (just above the scroll bar in the upper right-hand corner 
of the pane) to collapse the Classes, Function Members, Data Members, or Source 
panes in a Browser window.
168 IDE 5.5 User’s Guide



Using Class Browser Windows
Classes pane
1. Click the Pane Collapse box  to collapse a pane.

The chosen pane collapses to its original size.

2. You can now view other panes in a Browser window.

Alternately, you can use the resize bar between the panes to collapse each pane 
(although the pane does not fill the Browser window).

1. Rest the cursor over the resize bar.

The cursor icon changes to this: 

2. Hold down the mouse button.

3. Drag the resize bar to collapse the pane.

Classes pane
Use the Classes pane to perform these tasks:

• Create a new class

• Toggle viewing of classes

• Sort classes

Figure 14.1 on page 164 shows the Classes pane. Table 14.5 explains the items in
the pane.

Table 14.5  Classes pane—items

Item Icon Explanation

New Item Click to create a new class using the New Class Wizard.

Sort Alphabetical Click to sort the Classes list in alphabetical order.

Sort Hierarchical Click to sort the Classes list in hierarchical order.
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Creating a New Class

Use the New Class wizard to specify the name, declaration, and location for a new 
class. Click Finish in any screen to apply default values to any remaining parameters 
and complete the process. The New Class wizard creates the files that define the class.

1. From the Classes pane, click the New Item button .

2. Enter the Name and Location in the New Class window.

3. To create a more complex class, click Next (optional).

Follow the on-screen directions to further define the class.

4. Click Finish to complete the New Class process.

Showing the Classes Pane

Use the Show Classes button to expand the Classes pane.

1. Click the Show Classes button: 

2. The Classes pane appears in the Class Browser window.

Hiding the Classes Pane

Use the Hide Classes button to collapse the Classes pane.

1. Click the Hide Classes button: 

2. The Classes pane disappears from the Class Browser window.

Sorting the Classes List

Use the Sort Alphabetical and Sort Hierarchical commands to specify the sort order 
of classes in the Classes pane. The displayed icon always represents the alternate sort 
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order. For example, when the Classes list appears in alphabetical order, the Sort 
Hierarchical icon is visible.

• Click the Sort Alphabetical icon .

The IDE sorts the Classes list in alphabetical order.

• Click the Sort Hierarchical icon .

The IDE sorts the Classes list in hierarchical order.

Member Functions pane
Use the Member Functions pane to perform these tasks:

• Create a new member function

• Determine the inheritance type of a member function

Creating a New Member Function

Use the New Member Function wizard to specify the name, return type, and 
parameters for a new member function. Click Finish in any screen to apply default 
values to any remaining parameters and complete the process.

1. Click the New Item button  in the Member Functions pane.

2. Enter the Member Function Declarations in the New Member Function 
window.

3. Click Next.

Table 14.6  Member Function and Data Member identifier icons

Meaning Icon The member is…

static a static member

virtual a virtual function that can be overridden, or an override of an 
inherited function

pure virtual
or abstract

a member function that must be overridden in a subclass to create 
instances of that subclass
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4. Enter Member function file locations and Include Files information.

5. Click Finish.

6. Review the settings summary, then click Generate.

The IDE adds the new member function to the class declaration.

Data Members pane
Use the Data Members pane to create a new data member. This section explains how 
to create the data member.

Click the New Item button in the Data Members pane to open the New Data Member 
wizard. See Table 14.6 for a complete list of identifier icons that appear in the Data 
Members pane.

Creating a New Data Member

Use the New Data Member wizard to specify the name, type, and initializer for the 
new data member. Specify other options to further refine the data member. Click 
Finish in any screen to apply default values to any remaining parameters and complete 
the process.

1. From the Data Members pane, click the New Item button: 

2. Enter the Data Member Declarations in the New Data Member window.

3. Click Next.

4. Enter Data Member file locations and #include files information.

5. Click Finish.

6. Review the settings summary, then click Generate.

The IDE adds the new data member to the class declaration.

Source pane
Use the Source pane to view the source code that corresponds to the selected class, 
member function, or data member. This section explains the items in the
Source pane.
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Figure 14.1 on page 164 shows the Source pane. Table 14.7 explains the items in
the pane.

For information on editing source code, see “Editing Source Code” on page 97.

Status Area
Use the status area to perform these tasks:

• Toggle viewing of the Classes pane

• View class declarations

• View classes according to public, private, or protected access

Figure 14.1 on page 164 shows the status area. Table 14.8 on page 173 explains the 
items in the status area.

Table 14.7  Source pane—items

Item Icon Explanation

Open File Click to open the current source file in a new editor window.

VCS menu Enable a version-control system in order to activate this menu. Use 
this menu to select and execute a version-control command on the 
source file.

Table 14.8  Status area—items

Item Icon Explanation

Show Classes Pane Click to display the Classes pane in the Class Browser window.

Hide Classes Pane Click to hide the Classes pane in the Class Browser window.

Class Declaration Click to show the declaration of the
current class.

Access Filter Display Displays the access state of the current class.
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Windows

This chapter explains how to work with the Class Hierarchy windows in the 
CodeWarrior™ IDE. Use Class Hierarchy windows to perform these tasks:

• View hierarchical browser data—the class hierarchy window shows a graphical 
representation of hierarchical structure. Object-oriented languages, such as C++ 
and Java, allow hierarchical relationships between classes.

• Analyze inheritance structure—the class hierarchy window shows the inheritance 
structure of classes. This structure reveals the data-handling capabilities of a 
particular class.

Read this chapter to learn more about typical tasks for working with Class Hierarchy 
windows.

This chapter contains these sections:

• “Multiple-Class Hierarchy Window” on page 175

• “Single-Class Hierarchy Window” on page 178

• “Browser Contents window” on page 179

• “Symbols window” on page 181

Multiple-Class Hierarchy Window
Use the Multi-Class Hierarchy window to visually examine the structure of every class 
in the browser database. Each class name appears in a box, and lines connect boxes to 
indicate related classes. The left-most box is the base class, and subclasses appear to 
the right.

Figure 15.1 on page 176 shows the Multi-Class Hierarchy window. Table 15.1 on page 
176 explains the items in the window.
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Figure 15.1  Multi-Class Hierarchy window

Viewing Browser Data by Inheritance

Use a Hierarchy window to view data in graphical form and better understand class 
relationships. Use the expand and collapse arrows to enlarge or shrink the class views.

1. Activate the browser.

2. Update the browser database by using the Bring Up To Date, Make, Run, or 
Debug command.

Table 15.1  Multi-class hierarchy window—items

Item Icon Explanation

Hierarchy Control Click to expand or collapse the subclasses displayed for 
a specific class.

Ancestor menu Click and hold on a class or subclass box to display a 
menu. Select a class from this menu in order to display 
that class.

Line button Click to toggle the lines that connect classes between 
diagonal and straight lines.
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3. Open a graphical Hierarchy window, as explained in Table 15.2.

Printing Class Hierarchies

To print the contents of a Class Hierarchy window, save an image of the window 
contents, then print the image file from a graphics-processing application. 

The IDE saves the image in a graphics-file format based on the host platform, as 
shown in Table 15.3.

1. Open the Class Hierarchy window.

2. Choose File > Save a Copy As.

3. Save the image to a file.

4. Open the image file in an graphics-processing application.

5. Print the image file.

The graphics-processing application prints the image of the class hierarchy.

Table 15.2  Opening the Hierarchy window

On this host… Do this…

Windows Select View > Class Hierarchy.

Macintosh Select Window > Class Hierarchy.

Solaris Select Window > Class Hierarchy.

Linux Select Window > Class Hierarchy.

Table 15.3  Graphics-file format for host platforms

Host Graphics-file Format

Windows EMF (Enhanced Metafile)

Macintosh PICT (Picture)

Solaris PICT (Picture)

Linux PICT (Picture)
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Changing Line Views in a Hierarchical Window

Use the Diagonal Line and Straight Line commands to change the appearance of the 
connecting lines between classes and subclasses in a hierarchical window display.

• Click the Diagonal Line icon .

The Hierarchical window display updates to use diagonal lines.

• Click the Straight Line icon .

The Hierarchical window display updates to use straight lines.

Single-Class Hierarchy Window
Use the Single-Class Hierarchy window to examine the structure of a single class in 
the browser database. The Single-Class Hierarchy window operates identically to the 
Multi-Class Hierarchy window, but restricts the display to a single class.

The Single-Class Hierarchy window contains the same components as the Multi-Class 
Hierarchy window.

Figure 15.2  Single-Class Hierarchy window
178 IDE 5.5 User’s Guide



Using Other Browser Windows
Browser Contents window
Opening a Single-Class Hierarchical window

Use one of these methods to open a Single-Class Hierarchical window:

• Click the Show Single-Class Hierarchy icon  in a Browser toolbar.

• Use the Browser Contextual menu in one of these windows:

• New Class Browser window.

• Browser Contents window.

• Multi-Class Hierarchical window.

A Single-Class Hierarchical window appears.

Browser Contents window
Use the Browser Contents window to view browser data sorted by category into an 
alphabetical list. This section explains how to use the Browser Contents window to 
view browser data, assuming knowledge about activating the browser.

Figure 15.3 shows the Browser Contents window. Table 15.4 explains the items in
the window.
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Figure 15.3  Browser Contents window

Viewing Browser Data by Contents

Use the Browser Contents window to display symbol information stored in the 
browser database, listed in alphabetical order. You can choose from these categories:

• classes

• constants

• enumerations

• functions

Table 15.4  Browser Contents window—items

Item Icon Explanation

Symbols list box Select the type of symbol to display in the 
Symbols list.

Symbols list Double-click a symbol name to display the 
source file in a new editor window that 
defines the symbol.
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• global variables

• macros

• function templates

• type definitions

1. Activate the browser.

2. Use the Bring Up To Date, Make, Run, or Debug command to update the 
browser database.

3. Open the Browser Contents window, as explained in Table 15.5.

4. Select a category from the Category list pop-up.

The symbol information for the selected category appears in alphabetical order in 
the Symbols list.

Symbols window
The Symbols window displays information from project browser databases. With the 
browser enabled, the IDE generates a browser database for a project during the build 
process.

The Symbols window displays symbols that have multiple definitions in the browser 
database. For example, the window displays information about multiple versions of 
overridden functions in object-oriented code.

Figure 15.4 on page 182 shows the Symbols window. Table 15.5 on page 181 explains 
the items in the window.

Table 15.5  Opening the Browser Contents window

On this host… Do this…

Windows Select View > Browser Contents.

Macintosh Select Window > Browser Contents.

Solaris Select Window > Browser Contents.

Linux Select Window > Browser Contents.
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Figure 15.4  Symbols window

Opening the Symbols Window

Use the Symbols window to list all implementations, whether overridden or not, of 
any symbol that has multiple definitions. You can access the Symbols window by 
using a contextual menu.

1. Open a contextual menu, as explained in Table 15.7.

Table 15.6  Symbols window—items

Item Explanation

Symbols toolbar Provides one-click access to common browser commands and 
class-filtering commands.

Symbols pane Displays a list of all symbols with multiple declarations.

Source pane Displays the source code for the currently selected item.
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2. Select Find all implementations of from the contextual menu that appears.

3. The Symbols window opens.

Symbols toolbar
Most of the Symbol toolbar items are identical to those in the Class Browser window.

Symbols pane
The Symbols pane lists symbols with multiple definitions in the browser database. 
Select a symbol from the list to view its definition in the Source pane.

Source pane
The Source pane used in the Symbols window is identical to the one used by the Class 
Browser window. See “Source pane” on page 172 for more details.

Table 15.7  Opening the Symbols window

On this host… Do this…

Windows Right-click the symbol name.

Macintosh Control-click the symbol name.

Solaris Click and hold on the symbol name.

Linux Click and hold on the symbol name.
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Using Browser Wizards

When you create a new class, member function, or data member in the IDE, you use 
browser wizards. These wizards provide the steps to help you complete the process.

This chapter provides information on these wizards:

• “The New Class Wizard” on page 185

• “The New Member Function Wizard” on page 190

• “The New Data Member Wizard” on page 193

NOTE Most wizard pages contain default settings. To accept all current 
settings in the wizard, click Finish in any screen. The wizard 
displays a summary of all the current settings for the new project. 
Click Generate to accept the current settings and create the new 
item, or click Cancel to return to the wizard to modify settings.

The New Class Wizard
Use the New Class wizard to specify the name, declaration, and location for a new 
class. Click Finish in any screen to apply default values to remaining parameters to 
complete the process. The New Class wizard creates the files that define the class.
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Figure 16.1  New Class wizard—Name and Location

Using the New Class Wizard

To use the New Class Wizard, follow these steps:

1. Open the Class Browser window, as explained in Table 16.1.

2. Select Browser > New Class.

Table 16.1  Opening the Class Browser window

On this host... Do this...

Windows Select View > Class Browser.

Macintosh Select Window > Class Browser.

Solaris Select Window > Class Browser.

Linux Select Window > Class Browser.
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NOTE You can also click the New Item icon  in the Class Browser 
window to create a new class.

3. In the New C++ Class wizard, enter Name and Location information:

a. Class Name—Enter a name for the class in this field.

b. Declaration File—This menu lets you specify whether the file is a New File, 
which is a new declaration file, or Relative to class, which is a declaration 
that depends on an existing file in the project.

If you choose the New File option, type in the enabled field the path where 
you want to save the file. Alternatively, click Set next to the field to choose 
the path in which to save the file.

If you choose the Relative to class option, select Before or After to establish 
the order of the new class in relation to existing classes. In the field next to the 
Before and After drop-down selection, type the name of the class you want to 
relate to the new class. Alternatively, click Set next to this field, type the name 
of a class in the window that opens, and then click Select.

NOTE If you want to use a separate file to define the members of the new 
class, type the path to the separate file in the field below the Use 
separate file for member definitions checkbox. Alternatively, click 
Existing to use a standard dialog box to select the file. To create a 
new, separate file, click New and save the new file to a location on 
your hard disk.

4. Click Next.
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Figure 16.2  New Class wizard—Base Class and Methods

5. Enter Base Classes and Methods information.

Enter a list of base classes for the new class:

a. Access—Choose an access type, Public, Protected, or Private, for the 
constructor and destructor from this drop-down menu.

b. Constructor parameters—Enter a list of parameters for the constructor.

c. Virtual destructor—Click this checkbox to create a virtual destructor for the 
new class.

d. As an option, you can enter in the Namespaces required for the base classes 
and constructor parameters field the required namespaces for the base 
classes from the Base Classes field, and the constructor parameters in the 
Generate Constructor and Destructor section of the wizard.

Or,

If needed, you can specify the base classes and constructor parameters.

6. Click Next.
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Figure 16.3  New Class wizard—Include Files

7. Enter Include Files information.

Specify additional header #include files for the new class:

a. Include files that will automatically be added for base classes—This field 
shows you a list of #include files that the IDE automatically adds to find the 
base classes.

b. Additional header include files—Enter in this field a list of other include 
files for the new class in addition to those in the previous field. Separate each 
file in the list with a comma.

8. Click Next.
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Figure 16.4  New Class wizard—Targets

9. Enter Targets information:

Select the checkbox next to the build target’s name in the list to add the class files 
to a specific build target.

10. Click Finish.

Review the settings summary.

11. Click Generate.

The New Member Function Wizard
Use the New Member Function wizard to specify the name, return type, and 
parameters for a new member function. Enter additional information in the wizard 
fields to refine the function definition.
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Figure 16.5  New Member Function wizard

Using the New Member Function Wizard

To use the New Member Function wizard, follow these steps:

1. Open the Class Browser window, as explained in Table 16.2 on page 191.

2. Select Browser > New Member Function.

Table 16.2  Opening the Class Browser window

On this host... Do this...

Windows Select View > Class Browser.

Macintosh Select Window > Class Browser.

Solaris Select Window > Class Browser.

Linux Select Window > Class Browser.
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3. In the New C++ Member Function window, enter the Member Function 
Declaration.

a. Name—Type a name for the member function.

b. Return Type—Enter an appropriate function return type.

c. Parameters—Type a list of function parameters.

d. Namespaces required for parameters (optional)—Type a list of 
namespaces required for parameters.

4. Click Next.

Figure 16.6  New Member Function wizard—File Locations

5. Enter Member Function File Locations and Include Files information.

6. Click Finish.

7. Review settings summary, then click Generate.
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The New Data Member Wizard
Use the New Data Member wizard to define the new data-member declaration, and to 
specify new data member file locations. The wizard offers additional options to further 
define the function.

Figure 16.7  New Data Member wizard

Using the New Data Member Wizard

To use the New Data Member wizard, follow these steps:

1. Open the Class Browser window, as explained in Table 16.3 on page 193.

Table 16.3  Opening the Class Browser window

On this host... Do this...

Windows Select View > Class Browser.

Macintosh Select Window > Class Browser.
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2. Select Browser > New Data Member.

3. In the New C++ Data Member window, enter the Name, Type, Namespaces 
required for type (optional), Initializer, and Modifiers.

a. Name—Type a name for the data member in this field.

b. Type—Enter an appropriate data-member type in this field.

c. Namespaces required for type (optional)—(Optional) Enter a list of 
namespaces required for the type in the Type field. A sample namespace
is std.

d. Initializer—(Optional) Enter an initial value for the data member in this field. 
Sample initializers are 100 and inConstructorParameterName.

e. Modifiers—Select the access level and type for the new data member.

4. Click Next.

5. Specify Data Member File Locations.

This section lets you specify file locations associated with the new member 
functions, including these fields: Declaration, Definition (not available in this 
wizard), Include file automatically added for member type, and Additional 
header include files.

a. Declaration—This field shows you the data member’s declaration file 
location.

b. Definition—This field is not available in this wizard.

c. Include file automatically added for member type—This field shows you if 
an include file will be automatically added for the data-member type.

d. Additional header include files—Enter in this field a list of other include 
files for the new data member, in addition to the file listed in the previous 
field. Example files are <string> and YourHeader.h.

6. Click Finish.

Solaris Select Window > Class Browser.

Linux Select Window > Class Browser.

Table 16.3  Opening the Class Browser window (continued)

On this host... Do this...
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7. Review settings summary, then click Generate.
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Debugger

This section contains these chapters:

• Working with the Debugger

• Manipulating Program Execution

• Working with Variables

• Working with Memory

• Working with Debugger Data

• Working with Hardware Tools
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Working with the Debugger

This chapter explains how to work with the debugger in the CodeWarrior™ IDE to 
control program execution. The main component of the debugger is the Thread 
window, which shows these items:

• Common debugging controls—step, kill, start, and stop program execution

• Variable information—see the variables in the executing code, their values, and 
their addresses

• Source code—see the source code under debugger control

This chapter contains these sections:

• “About the CodeWarrior Debugger” on page 199

• “About Symbolics Files” on page 200

• “Thread Window” on page 200

• “Common Debugging Actions” on page 204

• “Symbol Hint” on page 207

• “Contextual Menus” on page 209

• “Multi-core Debugging” on page 210

About the CodeWarrior Debugger
A debugger controls program execution and shows the internal operation of a 
computer program. Use the debugger to find problems while the program executes. 
Also use the debugger to observe how a program uses memory to complete tasks.

The CodeWarrior debugger provides these levels of control over a computer program:

• Execution of one statement at a time

• Suspension of execution after reaching a specific point in the program

• Suspension of execution after changing a specified memory value

After the debugger suspends program execution, use various windows to perform 
these tasks:
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• View the function-call chain

• Manipulate variable values

• View register values in the computer processor

About Symbolics Files
A symbolics file contains debugging information that the IDE generates for a computer 
program. The debugger uses this information to control program execution. For 
example, the debugger uses the symbolics file to find the source code that corresponds 
to the executing object code of the computer program.

Symbolics files contain this information:

• Routine names

• Variables names

• Variable locations in source code

• Variable locations in object code

The IDE supports several types of symbolics files. Some programs generate separate 
symbolic files, while others do not. For example, when you use CodeView on 
Windows, the IDE places the symbolics file inside the generated binary file.

Thread Window
The debugger suspends the execution of processes in a computer program. The Thread 
window displays information about a suspended process during a debugging session.

Use the Thread window to perform these tasks:

• View the call chain for a routine

• View routine variables, both local and global

• View a routine in terms of its source code, assembly code, or a mix of both types 
of code

Figure 17.1 shows the Thread window. Table 17.1 explains the items in the window.
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Figure 17.1  Thread window

Table 17.1  Thread window—items

Item Icon Explanation

Debug / Run / Resume 
button

Click to perform these tasks:

• Continue execution up to the 
next breakpoint, watchpoint, or 
eventpoint

• Run the program until it exits

• Continue execution of a 
currently stopped program

Stop button Click to stop (pause) program 
execution.

Kill button Click to terminate program execution 
and close the Thread window.
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Step Over button Click to execute the current line, 
including any routines, and proceed to 
the next statement.

Step Into button Click to execute the current line, 
following execution inside a routine.

Step Out button Click to continue execution to the end of 
the current routine, then follow 
execution to the routine’s caller.

Breakpoints button Click to open the Breakpoints window.

Expressions button Click to open the Expressions window.

Symbolics button Click to open the Symbolics window.

Pane Expand box Click to enlarge the pane to fill
the window.

Pane Collapse box Click to reduce an expanded pane to its 
original size.

Pane resize bar Drag to resize the panes on either side 
of the bar.

Stack pane Shows the current routine calling chain, 
with the most current routine name at 
the bottom

Variables pane Shows the local and global variables 
that the current routine uses.

Table 17.1  Thread window—items (continued)

Item Icon Explanation
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Variables Pane Listing 
button

Click this icon to switch among these 
display states:

• All—show all local and global 
variables in the code

• Auto—show only the local 
variables of the routine to which 
the current-statement
arrow points

• None—show no variables. Use 
this display state to improve 
stepping performance for slow 
remote connections

Source pane
disclosure triangle

Click to show or hide the Source pane.

Source pane Shows the executing source code. This 
pane operates the same way as an 
editor window, however, you cannot edit 
the contents of the pane or use pane-
splitter controls.

Source File button Click to edit the contents of the Source 
pane in an editor window. 

Current-statement arrow Points to the statement that the 
debugger will execute next.

Dash Appears to the left of each line at which 
you can set a breakpoint or eventpoint. 
Click the dash to set a breakpoint on 
that line.

Functions list box Click to show a list of functions declared 
in the file. Select a function to highlight it 
in the Source pane.

Table 17.1  Thread window—items (continued)

Item Icon Explanation
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Common Debugging Actions
This section explains how to perform common debugging actions that correct source-
code errors, control program execution, and observe memory behavior:

• Start the debugger

• Step into, out of, or over routines

• Stop, resume, or kill program execution

• Run the program

• Restart the debugger

Starting the Debugger

Use the Debug command to begin a debugging session. The debugger takes control of 
program execution, starting at the main entry point of the program.

Select Project > Debug or click the Debug button shown at left to
start the debugger.

After you start the debugging session, the IDE opens a new Thread window.

Line and Column button Shows the current line and column 
number of the text-insertion cursor. 
Click to specify a line to show in the 
Source pane.

Source list box Click to specify how to display source 
code in the Source pane:

• Source—programming-
language statements appear 
exclusively in the pane

• Assembler—assembly-
language instructions appear 
exclusively in the pane

• Mixed—each programming-
language statement shows its 
corresponding assembly-
language instructions

Table 17.1  Thread window—items (continued)

Item Icon Explanation
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NOTE Some projects require additional configuration before the debugging 
session can begin. The IDE might prompt you for permission to 
perform this configuration automatically.

Stepping Into a Routine

Use the Step Into command to execute one source-code statement at a time and follow 
execution into a routine call.

Select Debug > Step Into or click the Step Into button shown at left to
step into a routine.

After the debugger executes the source-code statement, the current-statement arrow 
moves to the next statement determined by these rules:

• If the executed statement did not call a routine, the current-statement arrow 
moves to the next statement in the source code.

• If the executed statement called a routine, the current-statement arrow moves to 
the first statement in the called routine.

• If the executed statement is the last statement in a called routine, the current-
statement arrow moves to the statement that follows the calling routine.

Stepping Out of a Routine

Use the Step Out command to execute the rest of the current routine and stop program 
execution after the routine returns to its caller. This command causes execution to 
return up the calling chain.

Select Debug > Step Out or click the Step Out button shown at left to
step out of a routine.

The current routine executes and returns to its caller, then program execution stops.

Stepping Over a Routine

Use the Step Over command to execute the current statement and advance to the next 
statement in the source code. If the current statement is a routine call, program 
execution continues until reaching one of these points:
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• the end of the called routine

• a breakpoint

• a watchpoint

• an eventpoint that stops execution

Select Debug > Step Over or click the Step Over button shown at left to
step over a routine.

The current statement or routine executes, then program execution stops.

Stopping Program Execution

Use the Break or Stop command to suspend program execution during a
debugging session.

Select Debug > Break, Debug > Stop, or click the Stop button shown at left 
to
stop program execution.

The operating system surrenders control to the debugger, which stops
program execution.

Resuming Program Execution

Use the Resume command to continue executing a suspended debugging session. If 
the debugging session is already active, use this command to switch view from the 
Thread window to the executing program.

Select Project > Resume or click the Debug button shown at left to
resume program execution.

The suspended session resumes, or the view changes to the running program.

NOTE The Resume command appears only for those platforms that
support it. If your platform does not support this command, you
must stop the current debugging session and start a new session.
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Killing Program Execution

Use the Kill command to completely terminate program execution and end the 
debugging session. This behavior differs from stopping a program, as stopping 
temporarily suspends execution.

Select Debug > Kill or click the Kill button shown at left to
kill program execution.

The debugger terminates program execution and ends the debugging session.

Running a Program

Use the Run command to execute a program normally, without debugger control.

Select Project > Run or click the Run button shown at left to
begin program execution.

The debugger does not control program execution as the program runs.

Restarting the Debugger

Use the Restart command after stopping program execution. The debugger goes back 
to the beginning of the program and begins execution again. This behavior is 
equivalent to killing execution, then starting a new debugging session.

Select Debug > Restart to restart the debugger.

Symbol Hint
The symbol hint shows information about variable values. This information appears 
automatically while the debugger is active.

Select the Show variable values in source code option in the Display Settings 
preference panel to use the symbol hint.
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Figure 17.2  Symbol hint

Toggling the Symbol Hint

Turn on the symbol hint to view information about program variables in source views.

1. Click Edit > Preferences.

The IDE Preferences window appears.

2. Select Display Settings in the IDE Preference Panels list.

The Display Settings preference panel appears.

3. Check or clear the Show variable values in source code checkbox.

Check the checkbox to use the symbol hint. Clear the checkbox to stop using the 
symbol hint.

4. Click Apply or Save to confirm your changes to the preference panel.

5. Close the IDE Preferences window.

Using the Symbol Hint

During a debugging session, use the symbol hint to view information about
program variables.

To use the symbol hint, rest the cursor over a variable in a source view. After a brief 
pause, the symbol hint appears and shows the current variable value.

The symbol hint shows the current variable value.
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Contextual Menus
The contextual menu provides a shortcut to frequently used menu commands. The 
available menu commands change, based on the context of the selected item.

Sample uses of the contextual menu for debugging tasks include:

• changing the format of variables displayed in variable panes

• manipulating breakpoints and the program counter in source panes

• viewing memory in separate windows

TIP Experiment using the contextual menu in various IDE windows to 
discover additional features.

Figure 17.3 shows a sample contextual menu in a source view.

Figure 17.3  Contextual menus
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Using Contextual Menus

Use contextual menus to more conveniently apply context-specific menu commands 
to selected items.

Right-click, Control-click, or click and hold on an item to open a contextual menu for 
that item.

The contextual menu appears, displaying menu commands applicable to the selected 
item.

Multi-core Debugging
The IDE allows simultaneous debugging of multiple projects. This feature provides 
multi-core debugging capability for some embedded processors. By configuring each 
project to operate on a single core, the IDE can debug multiple cores by debugging 
multiple projects.

Configuring multi-core debugging involves these tasks:

• configuring specific target settings for each project

• for some cores, specifying a configuration file for initializing multi-core 
debugging

For more information, see the Targeting documentation.
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Manipulating Program 
Execution

This chapter explains how to use breakpoints, watchpoints, and eventpoints to 
manipulate execution of your program in the CodeWarrior™ IDE:

• Breakpoints—halt program execution on a line of source code that you specify. 
You can set a breakpoint that always halts program execution, or you can set a 
breakpoint that halt program execution if a condition that you specify is true.

• Eventpoints—perform a task during program execution on a line of source code 
that you specify. Eventpoints can play sounds, run scripts, log data, and perform 
other operations.

• Watchpoints—halt program execution after a location in memory changes value

• Special breakpoints—these internal breakpoints halt program execution in special 
cases, such as halting program execution at the main() function or for a C++ 
exception.

After you set these items in your source code, you start a debugging session to use 
them. As program execution arrives at each of these items, the debugger can halt 
execution, perform a task, or update data.

This chapter contains these sections:

• “Breakpoints” on page 212

• “Eventpoints” on page 223

• “Watchpoints” on page 233

• “Special Breakpoints” on page 237
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Breakpoints
You use breakpoints to halt program execution on a specific line of source code. After 
you set a breakpoint at a key point in the program, you can halt its execution, examine 
its current state, and check register and variable values. You can also change values 
and alter the flow of normal program execution. Setting breakpoints helps you debug 
your program and verify its efficiency.

You can use these types of breakpoints:

• regular breakpoints—halt program execution

• conditional breakpoints—halt program execution after meeting a condition that 
you specify

• temporary breakpoints—halt program execution and then remove the breakpoint 
that caused the halt

You can also create breakpoint templates to simplify the process of setting complex 
breakpoints. A breakpoint template has all the properties of a breakpoint, except for a 
its location in source code. After you define a breakpoint template, you can have the 
debugger use the template as the basis for each breakpoint you set in your source code.

Breakpoints have enabled and disabled states. Table 18.1 explains these states.

Breakpoints Window
You use the Breakpoints window to set breakpoints. Figure 18.1 on page 213 shows 
this window. Table 18.2 on page 213 explains the items in the window.

You can change the sort order of the items in the Breakpoints window by clicking the 
column titles. Click the sort order button next to the rightmost column title to toggle 
between ascending and descending sort order.

Table 18.1  Breakpoints—states

State Icon Explanation

Enabled Indicates that the breakpoint is currently enabled. The debugger 
halts program execution at an enabled breakpoint. Click the icon 
to disable the breakpoint.

Disabled Indicates that the breakpoint is currently disabled. The debugger 
does not halt program execution at a disabled breakpoint. Click 
the icon to enable the breakpoint. 
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Figure 18.1  Breakpoints window

Table 18.2  Breakpoints window—items

Item Icon Explanation

Create Breakpoint 
Template button

Click to create a new breakpoint 
template in the Templates page.

You can complex breakpoints based on 
the properties you define in the 
breakpoint template.

Create Breakpoint Group 
button

Click to create a new group in the 
Groups page of the Breakpoints 
window.

Clicking this button is equivalent to 
clicking Breakpoints > Create 
Breakpoint Group with the 
Breakpoints window frontmost.

Click an icon in this column to
disable or enable the Condition
associated with the item.

Click an icon in this column
to disable or enable a group
of items.

Shows the projects that the
item affects (when it affects
more than one project).
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Set Default Breakpoint 
Template button

Click to designate the selected item in 
the Templates page as the default 
breakpoint template. The debugger 
uses this template as the basis for 
creating new breakpoints.

Clicking this button is equivalent to 
clicking Breakpoints > Set Default 
Breakpoint Template with the 
Breakpoints window frontmost.

Rename Breakpoint 
button

Click to rename the selected item in the 
Breakpoints window.

Clicking this button is equivalent to 
clicking Breakpoints > Rename 
Breakpoint with the Breakpoints 
window frontmost.

Breakpoint Properties 
button

Click to view more information about the 
selected breakpoint, such as name, 
associated condition, and number of 
hits during execution.

Clicking this button is equivalent to 
clicking Breakpoints > Breakpoint 
Properties with the Breakpoints 
window frontmost.

Groups tab Click to display the Groups page. This 
page lets you work with breakpoints, 
eventpoints, watchpoints, and internal 
breakpoints.

Instances tab Click to display the Instances page. 
This page lets you set breakpoints, 
eventpoints, and watchpoints on a per-
thread or per-process basis.

Templates tab Click to display the Templates page. 
This page lets you define breakpoint 
templates and specify a default 
breakpoint template.

Table 18.2  Breakpoints window—items (continued)

Item Icon Explanation
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Opening the Breakpoints Window

Use the Breakpoints window to view a list of breakpoints currently set in
your projects.

To open the Breakpoints window, click View > Breakpoints or Window > 
Breakpoints Window.

NOTE Double-click a breakpoint in the Breakpoints window to display its 
associated source-code line in an editor window.

Saving the Contents of the Breakpoints Window

You can save the contents of the Breakpoints window. This features is useful for 
saving sets of breakpoint data, then later re-opening those sets to reuse them.

To save the contents of the Breakpoints window, click File > Save or File > Save 
As. Clicking File > Save As lets you specify the name and path to save the file that 
stores the contents.

Working with Breakpoints
This section explains how to work with breakpoints in your source code and in the 
Breakpoints window.

Active These items affect program execution. 
Click the icon to make inactive.

Inactive These items do not affect program 
execution. Click the icon to make active.

Table 18.2  Breakpoints window—items (continued)

Item Icon Explanation
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Setting a Breakpoint

Use the Set Breakpoint command to set a breakpoint. A regular breakpoint suspends 
program execution. The debugger does not execute the line of source code that 
contains the regular breakpoint.

The default breakpoint template in the Templates page of the Breakpoints window 
determines the type of breakpoint that the debugger sets. The Auto Breakpoint 
default breakpoint template defines a breakpoint that halts program execution at a line 
of source code. You can change the default breakpoint template to a breakpoint 
template that you specify.

Figure 18.2 shows some source code and the Breakpoints column to the left of the 
source code. Breakpoint icons appear in this column.

Figure 18.2  Setting Breakpoints

To set a breakpoint at a line of source code, click the Breakpoints column next to that 
line. The active breakpoint icon appears in the column. After you debug the project, 
the debugger halts program execution at the line that has the active breakpoint icon.

TIP You can also set a breakpoint for selected results in the Search 
Results window and for selected items in the Symbolics window.

If you debug your project first, dash icons appear in the Breakpoints column next to 
source-code lines at which you can set breakpoints. Click a dash icon to set a 
breakpoint at that line. The dash icon changes to an active breakpoint icon.

This icon indicates an
active breakpoint.
This icon indicates an
active breakpoint.

Click the dash icon to
set an active break-
point at this line.

Breakpoints column
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NOTE Setting a breakpoint in a file affects execution of all build targets that 
include that file.

Viewing Breakpoint Properties

After you set a breakpoint, you can view and modify its properties. Table 18.3 
explains breakpoint properties.

To view properties for a breakpoint, select its name in the Breakpoints window and 
click Breakpoints > Breakpoint Properties.

Table 18.3  Breakpoint properties

Property Explanation

Breakpoint Type The type of item, such as Auto Breakpoint.

Serial number The non-persistent serial number that uniquely identifies the
item in the IDE. Use this number to identify the item in scripting 
languages. This number is not the same number that the debugger 
plug-ins use to identify the item.

Condition The conditional expression associated with the item. This conditional 
expression must evaluate to true in order for the item to perform its 
specified action.

Hit Count The number of times that program execution arrives at this item 
before the item performs its specified action. For example, enter >5 
to have program execution arrive at this item 5 times before the item 
performs an action.

File-Info The path to the file that contains the item.

Name The name of the item, which appears in the Breakpoints window. 
The IDE creates a default name based on the item properties, but 
you can change this name to a more meaningful one. Use this name 
to identify the item in scripting languages.

Original Process The persistent identifier for the active process at the time you set the 
item. If information about the active process was not available at the 
time you set the item, this identifier shows the process at the time the 
item affected program execution.

Original-Target The path to the build target that contains the item.

Times Hit The number of times that this item affected program execution.
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Disabling a Breakpoint

Disable a breakpoint to prevent it from affecting program execution. The disabled 
breakpoint remains at the source-code line at which you set it, so that you can enable it 
later. Disabling the breakpoint is easier than clearing it and re-creating it from scratch.

To disable a breakpoint, select its name in the Breakpoints window, or click the 
cursor on the source-code line that contains the breakpoint, and click Debug > 
Disable Breakpoint.

The enabled breakpoint icon changes to a disabled breakpoint icon (shown at 
left). The disabled breakpoint icon indicates that the breakpoint does not halt 
program execution.

Enabling a Breakpoint

Enable a breakpoint to have it halt program execution. Enabling a breakpoint that you 
previously disabled is easier than clearing it and re-creating it from scratch.

To enable a breakpoint, select its name in the Breakpoints window, or click the cursor 
on the source-code line that contains the breakpoint, and click Debug > 
Enable Breakpoint.

The disabled breakpoint icon changes to an enabled breakpoint icon (shown at 
left). The enabled breakpoint icon indicates that the breakpoint halts
program execution.

Times Left The number of times remaining for this item to affect
program execution.

Thread The thread in which the item takes effect.

Hardware The hardware on which to use the item. For example, set this 
property to Prefer Hardware to specify that the breakpoint is a 
hardware breakpoint.

Table 18.3  Breakpoint properties (continued)

Property Explanation
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Clearing a Breakpoint

Use the Clear Breakpoint command to clear a breakpoint.

To clear a breakpoint in source code, click the cursor on the source-code line that 
contains the breakpoint and click Debug > Clear Breakpoint. You can also click 
the active breakpoint icon in the Breakpoints column to clear the breakpoint.

To clear a breakpoint in the Breakpoints window, select its name from the list in the 
Groups, Instances, or Templates pages and press Delete.

Clearing All Breakpoints

Use the Clear All Breakpoints command to clear all breakpoints from your projects.

To clear all breakpoints, click Debug > Clear All Breakpoints. The Breakpoints 
window reflects your changes.

Setting a Temporary Breakpoint

Use the Temporary Breakpoint command to set temporary breakpoints. Unlike a 
regular breakpoint that halts execution each time you debug a project, a temporary 
breakpoint halts execution only once. The debugger removes the temporary 
breakpoint after halting program execution. Setting a temporary breakpoint is 
equivalent to using the Run To Cursor command.

To set a temporary breakpoint at a line of source code, Alt-click or Option-click the 
dash icon next to that line. The dash icon changes to an active breakpoint icon. After 
you debug the project, the debugger halts program execution at the line that has the 
active breakpoint icon. After execution halts, the active breakpoint icon reverts to a 
dash icon.

Setting a Conditional Breakpoint

Use the Condition column of the Breakpoints window to set a conditional 
breakpoint. A conditional breakpoint has an associated conditional expression.
The debugger evaluates the expression to determine whether to halt program 
execution at that breakpoint.
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A conditional breakpoint behaves in two different ways:

• If the expression evaluates to true (a non-zero value), the debugger halts
program execution.

• If the expression evaluates to false (a zero value), program execution continues 
without stopping.

Follow these steps to set a conditional breakpoint:

1. Set a breakpoint that you want to associate with a conditional expression.

2. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

3. In the Groups, Instances, or Templates pages of the Breakpoints window, find 
the breakpoint that you want to associate with a conditional expression.

4. Double-click the Condition column of the breakpoint.

5. Enter an expression in the Condition text box.

During subsequent debugging sessions, the debugger evaluates the expression to 
determine whether to halt program execution at the conditional breakpoint.

NOTE Alternatively, drag-and-drop an expression from a source view or 
from the Expression window into the Breakpoints window.

Working with Breakpoint Templates
This section explains how to define breakpoint templates, specify one of these 
breakpoint templates as the default breakpoint template, and delete breakpoint 
templates.

A breakpoint template defines all properties of a breakpoint except for its location in 
source code. For example, you can define a breakpoint template that stops execution 
only 10 times, and only if an associated conditional expression evaluates to false.

The default breakpoint template is the breakpoint template that the debugger uses as 
the basis for new breakpoints that you set. For example, if you define a breakpoint 
template named Thread Break, you can specify it as the default breakpoint template. 
After you do this, the Thread Break template properties apply to all new breakpoints 
that you set in your source code.

The initial default breakpoint template is Auto Breakpoint, which defines the regular 
breakpoint that halts program execution at a line of source code. You can change the 
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default breakpoint template from Auto Breakpoint to any of your breakpoint 
templates. You can also change the default breakpoint template back to
Auto Breakpoint.

Creating a Breakpoint Template

Use the Templates page of the Breakpoints window to define breakpoint templates. 
You define a breakpoint template by using an existing breakpoint as a starting point.

To define a breakpoint template, follow these steps:

1. Set a breakpoint in your source code.

2. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

3. Click the Groups tab.

The Groups page of the Breakpoints window comes forward.

4. Select the name of the breakpoint that you just set.

The debugger gives the breakpoint a default name that includes the name of the 
file in which you set the breakpoint and the line at which you set the breakpoint.

5. Click the Create Breakpoint Template button in the toolbar of the
Breakpoints window.

6. Click the Templates tab of the Breakpoints window.

The Templates page of the Breakpoints window comes forward. The new 
breakpoint template appears in this page with the name New Template.

You can rename the breakpoint template by selecting it and clicking Breakpoints > 
Rename Breakpoint with the Breakpoints window frontmost, or clicking the 
Rename Breakpoint button in the Breakpoints window toolbar.

NOTE You cannot rename the Auto Breakpoint template.
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Deleting a Breakpoint Template

Use the Templates page of the Breakpoints window to delete breakpoint templates 
that you no longer need.

To delete a breakpoint template, follow these steps:

1. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

2. Click the Templates tab of the Breakpoints window.

The Templates page of the Breakpoints window comes forward.

3. Select the breakpoint template that you want to delete.

4. Click Edit > Delete or Edit > Clear.

NOTE You cannot delete the Auto Breakpoint template, because it defines 
the regular breakpoint.

Specifying the Default Breakpoint Template

Use the Templates page of the Breakpoints window to specify the default breakpoint 
template. The debugger uses this template as the basis for creating new breakpoints in 
your source code.

The initial default breakpoint template is Auto Breakpoint, which defines the regular 
breakpoint. You can specify any one of your breakpoint templates, or Auto 
Breakpoint, as the default breakpoint template.

To specify the default breakpoint template, follow these steps:

1. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

2. Click the Templates tab of the Breakpoints window.

The Templates page of the Breakpoints window comes forward.

3. Select the breakpoint template that you want to specify as the default
breakpoint template.
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4. Click Breakpoints > Set Default Breakpoint Template or click the Set 
Default Breakpoint Template button in the Breakpoints window toolbar.

The debugger now uses the breakpoint template that you specified as the basis for 
creating new breakpoints in your source code.

Eventpoints
You use eventpoints to perform a task when program execution arrives at a specific 
line of source code or when an associated conditional expression evaluates to true. 
You can set an eventpoint that performs a task such as running a script, playing a 
sound, or collecting trace data. An eventpoint is equivalent to a breakpoint that 
performs a task other than halting program execution.

You can use several kinds of eventpoints. The Breakpoints column represents these 
eventpoints with various icons. You can set more than one eventpoint on the same line 
of source code. The Breakpoints column shows all eventpoints that you set for each 
line. Table 18.4 explains the eventpoints and shows their corresponding icons.

You can also create breakpoint templates to simplify the process of setting complex 
eventpoints. Creating a breakpoint template for an eventpoint is nearly identical to 
creating a breakpoint template for a breakpoint. The difference is using an eventpoint 
instead of a breakpoint as the starting point for creating the breakpoint template.

Table 18.4  Eventpoints

Eventpoint Icon Explanation

Log Point Logs or speaks a string or expression and records 
messages to the Log window

Pause Point Pauses execution just long enough to refresh
debugger data

Script Point Runs a script, application, or other item

Skip Point Skips execution of a line of source code

Sound Point Plays a sound

Trace Collection Off Stops collecting trace data for the Trace window

Trace Collection On Starts collecting trace data for the Trace window
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Eventpoints have enabled and disabled states. Table 18.5 explains these states.

TIP You can set an eventpoint in the Thread window and for selected 
variables in the Symbolics window.

Log Point
A Log Point logs or speaks a string or expression. A Log Point can also record 
messages to the Log window. You can configure the message that appears in the log 
window.

Setting a Log Point

To set a Log Point, follow these steps:

1. Click the cursor on the line of source code at which you want to set the Log Point.

2. Click Debug > Set Eventpoint > Set Log Point.

The Log Point Settings window appears (Figure 18.3).

3. Enter the text of your log message in the Message text box.

Table 18.5  Eventpoints—states

State Icon Explanation

Enabled See
Table 
18.4

Indicates that the eventpoint is currently enabled. The debugger 
performs the specified task at an enabled eventpoint. Click the 
icon to disable the eventpoint.

Disabled Indicates that the eventpoint is currently disabled. The debugger 
does not perform the specified task at a disabled eventpoint. 
Click the icon to enable the eventpoint. 
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Figure 18.3  Log Point Settings window

4. Check at least one of these checkboxes:

• Log Message—check to have the IDE display the message that you enter in
the Message text box in a Message window when program execution reaches the 
Log Point

• Speak Message—check to have the IDE use the sound capabilities of the host 
operating system to speak the message that you enter in the Message text box

NOTE (Windows) Install the Speech software development kit (SDK) in 
order to have the Speak Message feature work correctly.

• Treat as Expression—check to have the IDE evaluate the text you enter in the 
Message text box as an expression. For example, if you enter "n = 100" in the 
Message text, the debugger parses that text as an expression.

TIP Include quotation marks around your expression, like this:
"n = 100"

• Stop in Debugger—check to stop program execution in the debugger

5. Click the OK button to confirm your settings.

Clearing a Log Point

To clear a Log Point, follow these steps:

1. Select the Log Point that you want to clear.

Click the cursor on the line of source code that has the Log Point, or select the Log 
Point by name in the Breakpoints window.
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2. Click Debug > Clear Eventpoint > Clear Log Point.

Pause Point
A Pause Point suspends program execution just long enough to refresh debugger data. 
For example, without setting a pause point, you must wait for the debugger to halt 
program execution before it can refresh data. Setting a Pause Point, however, lets you 
pause the debugging session to give the debugger time to refresh the data.

Setting a Pause Point

To set a Pause Point, follow these steps:

1. Click the cursor on the line of source code at which you want to set the
Pause Point.

2. Click Debug > Set Eventpoint > Set Pause Point.

Clearing a Pause Point

To clear a Pause Point, follow these steps:

1. Select the Pause Point that you want to clear.

Click the cursor on the line of source code that has the Pause Point, or select the 
Pause Point by name in the Breakpoints window.

2. Click Debug > Clear Eventpoint > Clear Pause Point.

Script Point
A Script Point runs a script, application, or other item. After you set a Script Point at a 
line of source code, its associated action occurs when program execution arrives at that 
line. For example, you can set a Script Point that performs these actions:

• (Windows) execute a file as if you had used a Windows command line

• (Mac OS) launch an AppleScript or application
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Setting a Script Point

To set a Script Point, follow these steps:

1. Click the cursor on the line of source code at which you want to set the
Script Point.

2. Click Debug > Set Eventpoint > Set Script Point.

The Script Point Settings window appears (Figure 18.4 on page 227).

Figure 18.4  Script Point Settings window

3. Use the list box to specify Commands or Script File.

Specify Commands if you intend to enter a command line that executes a file. 
Specify Script File if you intend to enter a path to a script file.

4. Enter the text of your Script Point in the text box.

Enter a command line or a path to a script file.

5. Check Stop in Debugger if you want to stop program execution in the debugger.

6. Click the OK button to confirm your settings.

Clearing a Script Point

To clear a Script Point, follow these steps:

1. Select the Script Point that you want to clear.

Click the cursor on the line of source code that has the Script Point, or select the 
Script Point by name in the Breakpoints window.
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2. Click Debug > Clear Eventpoint > Clear Script Point.

Skip Point
A Skip Point prevents the debugger from executing a line of source code. This 
eventpoint is useful when you are aware of a line that you need to fix, but would like to 
go ahead and debug the rest of the program. You can set a Skip Point at that line and 
have the debugger execute the rest of the project without executing that particular line.

NOTE Skip Points do not work with the Java programming language.

Setting a Skip Point

To set a Skip Point, follow these steps:

1. Click the cursor on the line of source code at which you want to set the Skip Point.

2. Click Debug > Set Eventpoint > Set Skip Point.

Clearing a Skip Point

To clear a Skip Point, follow these steps:

1. Select the Skip Point that you want to clear.

Click the cursor on the line of source code that has the Skip Point, or select the 
Skip Point by name in the Breakpoints window.

2. Click Debug > Clear Eventpoint > Clear Skip Point.

Sound Point
A Sound Point is an audible alert. You can set a Sound Point so that when you step or 
run through code, the IDE plays a sound when program execution arrives at the line 
that has a Sound Point. Unlike a Log Point set to Speak Message, which speaks the 
message you specify, the Sound Point plays a simple notification sound.
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Setting a Sound Point

To set a Sound Point, follow these steps:

1. Click the cursor on the line of source code at which you want to set the
Sound Point.

2. Click Debug > Set Eventpoint > Set Sound Point.

The Sound Point Settings window appears (Figure 18.5 on page 229).

Figure 18.5  Sound point settings

3. Use the Sound to Play list box to specify the notification sound that you want the 
IDE to play when program execution arrives at the Sound Point.

4. Check Stop in Debugger if you want to stop program execution in the debugger.

5. Click the OK button to confirm your settings.

Clearing a Sound Point

To clear a Sound Point, follow these steps:

1. Select the Sound Point that you want to clear.

Click the cursor on the line of source code that has the Sound Point, or select the 
Sound Point by name in the Breakpoints window.

2. Click Debug > Clear Eventpoint > Clear Sound Point.
229IDE 5.5 User’s Guide 



Manipulating Program Execution
Eventpoints
Trace Collection Off
A Trace Collection Off eventpoint stops the collection of trace data. This eventpoint is 
useful when you want trace collection to stop when program execution reaches a line 
of source code that you specify.

Setting a Trace Collection Off Eventpoint

To set a Trace Collection Off eventpoint, follow these steps:

1. Click the cursor on the line of source code at which you want to set the
Trace Collection Off eventpoint.

2. Click Debug > Set Eventpoint > Set Trace Collection Off.

Clearing a Trace Collection Off Eventpoint

To clear a Trace Collection Off eventpoint, follow these steps:

1. Select the Trace Collection Off eventpoint that you want to clear.

Click the cursor on the line of source code that has the Trace Collection Off 
eventpoint, or select the Trace Collection Off eventpoint by name in the 
Breakpoints window.

2. Click Debug > Clear Eventpoint > Clear Trace Collection Off.

Trace Collection On
A Trace Collection On eventpoint starts the collection of trace data. This eventpoint is 
useful when you want trace collection to start when program execution reaches a line 
of source code that you specify.

Setting a Trace Collection On Eventpoint

To set a Trace Collection On eventpoint, follow these steps:

1. Click the cursor on the line of source code at which you want to set the
Trace Collection On eventpoint.
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2. Click Debug > Set Eventpoint > Set Trace Collection On.

Clearing a Trace Collection On Eventpoint

To clear a Trace Collection On eventpoint, follow these steps:

1. Select the Trace Collection On eventpoint that you want to clear.

Click the cursor on the line of source code that has the Trace Collection On 
eventpoint, or select the Trace Collection On eventpoint by name in the 
Breakpoints window.

2. Click Debug > Clear Eventpoint > Clear Trace Collection On.

Working with Eventpoints
This section explains how to work with eventpoints in your source code and in the 
Breakpoints window.

Viewing Eventpoint Properties

After you set an eventpoint, you can view and modify its properties.

To view properties for an eventpoint, select its name in the Breakpoints window and 
click Breakpoints > Breakpoint Properties.

Disabling an Eventpoint

Disable an eventpoint to prevent it from performing its specified action. The disabled 
eventpoint remains at the source-code line at which you set it, so that you can enable it 
later. Disabling the eventpoint is easier than clearing it and re-creating it from scratch.

To disable an eventpoint, follow these steps:

1. Select the eventpoint that you want to disable.

Select the eventpoint by name in the in the Breakpoints window, or click the 
cursor on the source-code line that contains the eventpoint.
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2. Click Debug > Disable Eventpoint.

The Disable Eventpoint menu appears.

3. From the Disable Breakpoint menu, click the Disable Eventpoint command, 
where Eventpoint is the type of eventpoint that you want to disable.

The enabled eventpoint icon changes to a disabled eventpoint icon (shown at 
left). The disabled eventpoint icon indicates that the eventpoint does not perform 
its specified action.

Enabling an Eventpoint

Enable an eventpoint to have it perform its specified action during program execution. 
Enabling a eventpoint that you previously disabled is easier than clearing it and re-
creating it from scratch.

To enable an eventpoint, follow these steps:

1. Select the eventpoint that you want to enable.

Select the eventpoint by name in the in the Breakpoints window, or click the 
cursor on the source-code line that contains the eventpoint.

2. Click Debug > Enable Eventpoint.

The Enable Eventpoint menu appears.

3. From the Enable Eventpoint menu, click the Enable Eventpoint command, where 
Eventpoint is the type of eventpoint that you want to enable.

The disabled eventpoint icon changes to its original eventpoint icon (Table 18.4 on 
page 223). The enabled eventpoint icon indicates that the eventpoint performs its 
specified action.

Setting a Conditional Eventpoint

Use the Condition column of the Breakpoints window to set a conditional 
eventpoint. A conditional eventpoint has an associated conditional expression.
The debugger evaluates the expression to determine whether the eventpoint performs 
its specified action.

A conditional eventpoint behaves in two different ways:
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• If the expression evaluates to true (a non-zero value), the eventpoint performs its 
specified action.

• If the expression evaluates to false (a zero value), the eventpoint does not perform 
its specified action.

Follow these steps to set a conditional eventpoint:

1. Set an eventpoint that you want to associate with a conditional expression.

2. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

3. In the Groups, Instances, or Templates pages of the Breakpoints window, find 
the eventpoint that you want to associate with a conditional expression.

4. Double-click the Condition column of the eventpoint.

5. Enter an expression in the Condition text box.

During subsequent debugging sessions, the debugger evaluates the expression to 
determine whether the eventpoint performs its specified action.

NOTE Alternatively, drag-and-drop an expression from a source view or 
from the Expression window into the Breakpoints window.

Watchpoints
You use watchpoints to halt program execution when a specific location in memory 
changes value. After you set a watchpoint at a key point in memory, you can halt 
program execution when that point in memory changes value, examine the call chain, 
check register and variable values, and step through your code. You can also change 
values and alter the flow of normal program execution. A watchpoint is equivalent to a 
memory breakpoint.

Unlike a breakpoint, a watchpoint can detect when any part of your program affects 
memory. When the program writes a new value to the address or area of memory that 
has the watchpoint, the debugger suspends program execution.

NOTE You cannot set a watchpoint on a local variable, because the 
debugger cannot detect watchpoints for variables stored on the stack 
or in registers.
233IDE 5.5 User’s Guide 



Manipulating Program Execution
Watchpoints
You can also create breakpoint templates to simplify the process of setting complex 
watchpoints. Creating a breakpoint template for a watchpoint is nearly identical to 
creating a breakpoint template for a breakpoint. The difference is using a watchpoint 
instead of a breakpoint as the starting point for creating the breakpoint template.

Watchpoints have enabled and disabled states. Table 18.6 explains these states.

TIP You can set an eventpoint in the Thread window and for selected 
variables in the Symbolics window.

A project can have a different maximum number of watchpoints, depending on the 
build target. The IDE generally limits the acceptable range for watchpoints to memory 
that it can write-protect. This range also depends on the host and on the application. 
For more information, see the Targeting documentation.

Setting a Watchpoint

Use the Set Watchpoint command to set a watchpoint. A watchpoint suspends 
program execution when the memory location that you specify changes value.
The debugger does not execute the line of source code that contains the watchpoint.

To set a watchpoint, follow these steps:

1. Click Project > Debug.

A debugging session starts.

2. Click Data > View Memory.

A Memory window appears.

Table 18.6  Watchpoints—states

State Icon Explanation

Enabled Indicates that the watchpoint is currently enabled. The debugger 
halts program execution at an enabled watchpoint. Click the icon 
to disable the watchpoint.

Disabled Indicates that the watchpoint is currently disabled. The debugger 
does not halt program execution at a disabled watchpoint. Click 
the icon to enable the watchpoint. 
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3. Select a range of bytes in the Memory window.

Do not double-click the range of bytes.

4. Click Debug > Set Watchpoint.

An underline appears beneath the selected range of bytes, indicating that you set a 
watchpoint in that range.

TIP You can change the color of the watchpoint underline in the Display 
Settings panel of the IDE Preferences window

After you debug the project, the debugger halts program execution if the specified 
memory location changes value.

TIP You can also set a watchpoint for selected variables in the Thread, 
Variable, and Symbolics windows.

Viewing Watchpoint Properties

After you set a watchpoint, you can view and modify its properties.

To view properties for a watchpoint, select its name in the Breakpoints window and 
click Breakpoints > Breakpoint Properties.

Disabling a Watchpoint

Disable a watchpoint to prevent it from affecting program execution. The disabled 
watchpoint remains at the memory location at which you set it, so that you can enable 
it later. Disabling the watchpoint is easier than clearing it and re-creating it
from scratch.

To disable a watchpoint, select its name in the Breakpoints window, or select the 
range of bytes in the Memory window at which you set the watchpoint, and click 
Debug > Disable Watchpoint.

The enabled watchpoint icon disappears, which indicates a disabled watchpoint.
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Enabling a Watchpoint

Enable a watchpoint to have it halt program execution when its associated memory 
location changes value. Enabling a watchpoint that you previously disabled is easier 
than clearing it and re-creating it from scratch.

To enable a watchpoint, select its name in the Breakpoints window, or select the 
range of bytes in the Memory window at which you set the watchpoint, and click 
Debug > Enable Watchpoint.

The enabled watchpoint icon appears (shown at left), which indicates an
enabled watchpoint.

Clearing a Watchpoint

Use the Clear Watchpoint command to clear a watchpoint.

To clear a watchpoint in the Memory window, select range of bytes at which you set 
the watchpoint and click Debug > Clear Watchpoint.

To clear a watchpoint in the Breakpoints window, select its name from the list in the 
Groups, Instances, or Templates pages and press Delete.

Clearing All Watchpoints

Use the Clear All Watchpoints command to clear all watchpoints from your projects.

To clear all watchpoints, click Debug > Clear All Watchpoints. The Breakpoints 
window reflects your changes.

NOTE All watchpoints clear automatically when the target program 
terminates or when the debugger terminates the program.
The watchpoints reset the next time the program runs.
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Setting a Conditional Watchpoint

Use the Condition column of the Breakpoints window to set a conditional 
watchpoint. A conditional watchpoint has an associated conditional expression.
The debugger evaluates the expression to determine whether to halt program 
execution at that watchpoint.

A conditional watchpoint behaves in two different ways:

• If the expression evaluates to true (a non-zero value), the debugger halts
program execution when the memory location associated with the watchpoint 
changes value.

• If the expression evaluates to false (a zero value), program execution continues 
without stopping.

Follow these steps to set a conditional watchpoint:

1. Set a watchpoint that you want to associate with a conditional expression.

2. Click View > Breakpoints or Window > Breakpoints Window.

The Breakpoints window appears.

3. In the Groups, Instances, or Templates pages of the Breakpoints window, find 
the watchpoint that you want to associate with a conditional expression.

4. Double-click the Condition column of the watchpoint.

5. Enter an expression in the Condition text box.

During subsequent debugging sessions, the debugger evaluates the expression to 
determine whether to halt program execution at the conditional watchpoint.

NOTE Alternatively, drag-and-drop an expression from a source view or 
from the Expression window into the Breakpoints window.

Special Breakpoints
Special breakpoints halt program execution for very specific reasons:

• program execution arrives at the beginning of the function main()

• a C++ or Java exception occurs
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• an event occurs that the debugger plug-in defines as a break event

You cannot change or delete special breakpoints, but you can enable and disable them.

Disabling Special Breakpoints

Disable special breakpoints to prevent them from affecting program execution.

To disable special breakpoints, click the Active icon (shown at left) to the left of 
the Special group in the Groups page of the Breakpoints window.

The active icon changes to an inactive icon, which indicates that the special 
breakpoints are disabled.

Enabling Special Breakpoints

Enable special breakpoints to have them halt program execution.

To enable special breakpoints, click the Inactive icon (shown at left) to the left of 
the Special group in the Groups page of the Breakpoints window.

The inactive icon changes to an active icon, which indicates that the special 
breakpoints are enabled.
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This chapter explains how to work with variables in a CodeWarrior™ IDE debugging 
session. These windows show various types of information about variables:

• Global Variables window—shows information about global variables and static 
variables in your project

• Variable window—shows information for an individual variable in your project

• Expressions window—shows variable values and lets you form calculation 
expressions based on those values

This chapter contains these sections:

• “Global Variables Window” on page 239

• “Variable Window” on page 241

• “Expressions Window” on page 244

Global Variables Window
The Global Variables window shows all global and static variables for each process 
that you debug. You can open separate Global Variables windows for each process in 
the same build target. Use the window to observe changes in variable values as the 
program executes.

Figure 19.1 on page 240 shows the Global Variables window. Table 19.1 on page 240 
explains the items in the window.
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Figure 19.1  Global Variables window

Opening the Global Variables Window

Use the Global Variables window to display global variables declared in a program or 
static variables declared in the source files that comprise the program.

To open the Global Variables window, select View > Global Variables or Window 
> Global Variables Window.

Viewing Global Variables for Different Processes

You can open a separate Global Variables window for each process that the same 
parent application creates.

To open the Global Variables window for a particular process, follow these steps:

Table 19.1  Global Variables window—items

Item Explanation

File Lists source files that declare global or static variables. Click a 
source file to view its static variables. Click Global Variables 
to view all global variables declared in the program.

Variables Lists variables according to the file selected in the File pane. 
Double-click a variable to display it in a separate
Variable window.
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1. Click Project > Debug.

A debugging session starts.

2. In the Thread window toolbar, use the Process list box to specify the process that 
has the global variables that you want to examine.

3. Click View > Global Variables or Window > Global Variables Window.

Repeat these steps for each process that has global variables that you want to examine.

Variable Window
A Variable window allows manipulation of a single variable used in source code. For a 
local variable, the window closes after program execution exits the routine that defines 
the variable.

Figure 19.2 shows the Variable window.

Figure 19.2  Variable window

Opening a Variable Window

A Variable window manipulates a single variable or variable hierarchy. A Variable 
window containing a local variable closes after program execution exits the routine 
that defines that variable.

1. Select a variable in any window pane that lists variables.

2. Open a Variable window:

• Select Data > View Variable, or

• Double-click the variable.

A Variable window appears. Double-click a value to change it.
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TIP Use Variable windows to monitor individual variables independently 
of other windows. For example, use a Variable window to continue 
monitoring a variable that leaves the current scope of program 
execution in the Thread window.

Alternatively, use a contextual menu to open a variable window, as explained in Table 
19.2.

Manipulating Variable Formats

You can change the way the Variables window displays data. For example, you can 
add labels to variable data so that those labels appear in the Variables window and 
clarify the displayed data.

For example, suppose you have the structure defined in Listing 19.1.

Listing 19.1  Sample structure definition

struct Rect {
  short               top;
  short               left;
  short               bottom;
  short               right;
};

The Variables window might show an instance myRect of the Rect structure like this:

myRect     0x000DCEA8

You can create an Extensible Markup Language (XML) file that defines a new way to 
display the structure, as shown in Listing 19.2.

Table 19.2  Opening a Variable window by using a contextual menu

On this host… Do this…

Windows Right-click the variable and select View Variable.

Macintosh Control-click the variable and select View Variable.

Solaris Click and hold on the variable, then select View Variable.

Linux Click and hold on the variable, then select View Variable.
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Listing 19.2  Sample variable format definition

<variableformats>
  <variableformat>
    <osname>osWin32</osname>
    <runtimename>runtimeWin32</runtimename>
    <typename>Rect</typename>
    <expression>
      "{T: " + ^var.top + 
      " L: " + ^var.left + 
      " B: " + ^var.bottom + 
      " R: " + ^var.right +
      "}{H: " + (^var.bottom - ^var.top) + 
      " W: " + (^var.right - ^var.left) + "}"
    </expression>
  </variableformat>
</variableformats>

Given this new variable format definition, the Variables window now shows the same 
myRect instance like this:

myRect  {T: 30 L: 30 B: 120 R: 120}{H: 90 W: 90}

To manipulate variable formats, you place an XML file that defines the new format 
inside the VariableFormats directory at

CodeWarrior/Bin/Plugins/Support/VariableFormats/

where CodeWarrior is the path to your CodeWarrior installation.

The IDE reads the XML files in this directory to determine how to display variable 
data. Table 19.3 explains the main XML tags that the IDE recognizes.

Table 19.3  Variable formats—XML tags

Tag Explanation

variableformats A group of variable format records.

variableformat An individual variable format record.

osname The operating system that defines the scope of this record.

runtimename The runtime that defines the scope of this record.
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Expressions Window
The Expressions window helps you monitor and manipulate these kinds of items:

• global and local variables

• structure members

• array elements

Figure 19.3 shows the Expressions window. Table 19.4 explains the items in
the window.

Figure 19.3  Expressions window

typename The name of the Type that this record will format.

expression The expression that reformats the variable display. The IDE 
evaluates this expression to determine the format that it 
applies to the variable. The IDE replaces all occurrences of the 
^var placeholder with the name of the variable.

Table 19.4  Expressions window—items

Item Explanation

Expression column Lists expressions and expression hierarchies. Click the 
hierarchical controls to expand or collapse the
expression view.

Value column Shows the current value of each corresponding expression in 
the Expression column. Double-click a value to change it.

Table 19.3  Variable formats—XML tags (continued)

Tag Explanation
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Opening the Expressions Window

Use the Expressions window to inspect frequently used variables as their values 
change during a debugging session.

To open the Expressions window, select View > Expressions or Window > 
Expressions Window.

Alternatively, click the Expressions button in the Thread window toolbar to 
open the Expressions window.

Adding Expressions

The Expressions window handles various ways of adding expressions for inspection.

To add an expression to the Expressions window, do this:

• Select the desired expression and choose Data > Copy to Expression, or

• Use the contextual menu with a selected expression, or

• Drag and drop an expression from another window into the Expressions window.

The Expressions window reflects the added expression. Drag expressions within the 
window to reorder them.

Adding a Constant Value to a Variable

You can enter an expression in the Expressions window that adds a constant value to a 
variable. Suppose x is a short integer type in the variable context of some function 
scope in C++ code. You can enter the expression x+1 and the IDE computes the 
resulting value just as you would compute it on a calculator.

1. Select the variable to which you want to add a constant value.

For example, select x.

2. Enter an expression that adds a constant value to the variable.

For example, append +1 to x so that the resulting expression is x+1.

The IDE adds the constant value to the variable and displays the result in the 
Expressions window.
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Making a Summation of Two Variables

You can enter an expression in the Expressions window that computes the sum of two 
variables. Suppose x is a short integer type in the variable context of some function 
scope in C++ code. You can enter the expression x+y and the IDE computes the 
resulting value just as you would compute it on a calculator.

1. Select the variable to which you want to add another variable.

For example, select x.

2. Enter an expression that adds a second variable to the first variable.

For example, append +y to x so that the resulting expression is x+y.

The IDE computes the sum of the two variables and displays the result in the 
Expressions window.

Removing Expressions

The Expressions window handles various ways of removing expressions that no 
longer require inspection.

To remove an expression from the Expressions window, do this:

• Select the expression to remove and choose Edit > Delete or Edit > Clear, or

• Select the expression to remove and press the Backspace or Delete key.

The Expressions window updates to reflect the removed expression.

NOTE Unlike the Variable window, the Expressions window does not 
remove a local variable after program execution exits the routine that 
defines the variable.
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This chapter explains how to work with variables in a CodeWarrior™ IDE debugging 
session. These windows show various types of information about variables:

• Memory window—shows the memory that your project manipulates as
it executes

• Array window—shows the contents of arrays that your project manipulates as
it executes

• Registers window—shows the register contents of a processor

• Register Details window—shows a graphical representation of processor 
registers and explains register contents

• Cache window—shows processor or instructor cache data

• Trace window—shows collected trace information

This chapter contains these sections:

• “Memory Window” on page 247

• “Array Window” on page 252

• “Registers Window” on page 254

• “Register Details Window” on page 258

Memory Window
The Memory window manipulates program memory contents in various data types. 
Use this resizable window to perform these tasks:

• View memory

• Change individual memory bytes

• Set watchpoints
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CAUTION Arbitrarily changing memory contents could degrade the stability of 
the IDE, another program, or the operating system itself. Understand 
the consequences of manipulating memory.

Figure 20.1 shows the Memory window. Table 20.1 on page 248 explains the items in 
the window.

Figure 20.1  Memory window

Table 20.1  Memory window—items

Item Icon Explanation

Display Enter a symbol representing the starting 
address of memory to display. Valid 
symbols include addresses and non-
evaluating expressions, such as main or x.

View Select the data format in which to view 
memory contents.

Memory Space
(for processors that 
support multiple 
memory spaces)

Choose the memory space in which to view 
selected variables or
source code.

Previous Memory 
Block

Click to view the preceding block
of memory.

Next Memory Block Click to view the succeeding block of 
memory.
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Viewing and Changing Raw Memory

Use the View Memory command to view and change the raw contents of memory.

1. Select an item or expression that resides at the memory address to be examined.

2. Choose Data > View Memory.

A new Memory window appears.

Address Displays a contiguous range of memory 
addresses, beginning with the address 
entered in the Display field.

Hex Displays a hexadecimal representation of 
the memory addresses shown in the 
Address pane.

Ascii Displays an ASCII representation of the 
memory addresses shown in the Address 
pane.

Word Size Select the bit size of displayed words.

Page
(for processors that 
support multiple 
pages)

Select the memory-space page in which to 
view source code.

Table 20.1  Memory window—items (continued)

Item Icon Explanation
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3. Select Raw data from the View list pop-up.

The contents of memory at the selected location appears in both hexadecimal and 
ASCII.

Scroll through memory by selecting the Address, Hex, or ASCII pane of the 
Memory window and then using the up and down arrow keys. Display a different 
memory location by changing the expression in the Display field.

Change the word size displayed in the Memory window by using the Word Size 
list pop-up. The choices are 8, 16, and 32 bits.

Change the contents of a particular memory location by double-clicking on that 
location in either the hexadecimal or ASCII pane of the Memory window. Replace 
the current value by entering a hexadecimal value in the Hex pane or a string of 
ASCII characters in the ASCII pane.

Alternatively, use a contextual menu to view and change memory, as explained in 
Table 20.2.

Viewing Memory Referenced by a Pointer

Use the View Memory command to inspect the memory referenced by a pointer—
including an address stored in a register.

1. Select a pointer in a source window.

2. Choose Data > View Memory.

A new Memory window appears.

Table 20.2  Opening a Memory window by using a contextual menu

On this host… Do this…

Windows Right-click the item and select View Memory.

Macintosh Control-click the item and select View Memory.

Solaris Click and hold on the item, then select View Memory.

Linux Click and hold on the item, then select View Memory.
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3. Select Raw data from the View list pop-up.

The contents of memory referenced by the pointer appears in both hexadecimal 
and ASCII.

Viewing Different Memory Spaces

Use the Page list pop-up to view a particular memory space.

NOTE This feature is available only for processors that support multiple 
memory spaces.

1. Select the name of a variable or a function in a source window.

2. Choose Data > View Memory.

A Memory window appears.

3. Select a memory space from the Page list pop-up.

4. Select Raw data from the View list pop-up if inspecting a variable. Select 
Disassembly, Source, or Mixed from the View list pop-up if inspecting source 
code.

The Memory window displays the selected memory-space page.

Setting a Watchpoint in the Memory Window

To set a Watchpoint using the Memory window, follow these steps:

1. Run/Debug your program.

2. From the Main Toolbar, choose Data > View Memory.

This opens the Memory window.

3. Select a range of bytes in the Memory window.

Do not double-click the range of bytes.

4. From the Main Toolbar, choose Debug > Set Watchpoint.
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NOTE A red line appears under the selected variable in the Variable 
window, indicating that you have set a Watchpoint. You can change 
the color of this line in the Display Settings panel of the IDE 
Preferences window (Edit > IDE Preferences).

Clearing Watchpoints from the Memory window

To clear a Watchpoint from the Memory window, follow these steps:

1. Select a range of bytes in the Memory window.

2. Choose Debug > Clear Watchpoint.

To clear all Watchpoints from the Memory window:

1. Open the Memory window.

You do not have to select a range of bytes.

2. Choose Debug > Clear All Watchpoints.

NOTE All Watchpoints clear automatically when the target program 
terminates or the debugger terminates the program, and reset next 
time the program runs.

Array Window
An Array window allows manipulation of a contiguous block of memory, displayed as 
an array of elements. The window lists array contents sequentially, starting at
element 0.

The Array window title shows the base address bound to the array. The base address 
can bind to an address, a variable, or a register. An array bound to a local variable 
closes after the routine that defines the variable returns to the calling routine.

For array elements cast as structured types, a hierarchical control appears to the left of 
each element. Use these hierarchical controls to expand or collapse the display of each 
element’s contents.

Figure 20.2 shows an Array window. Table 20.3 explains the items in the window.
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Figure 20.2  Array window

Table 20.3  Array window—items

Item Icon Explanation

Hierarchical control Click to collapse the view of the information 
pane.

Bind To Select the base address of the array: 
Address, Variable, or Register.

Array size Enter the number of elements to display in 
the
Array window.

Struct Member Select a specific member to show in each 
element, or show all members.

Element Shows the array elements in a hierarchical 
list.

Value Shows the value of each array element.

Location Shows the address in memory of each array 
element.
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Opening an Array Window

Use the View Array command to manipulate a contiguous memory block as an array 
of elements in an Array window.

1. Select the array that you want to view.

2. Select Data > View Array.

A new Array window appears.

TIP Drag and drop a register name or variable name to an Array window 
to set the base address. Use the View Memory As command to 
interpret memory displayed in an Array window as a different type.

Alternatively, use a contextual menu to open an Array window, as explained in Table 
20.4 on page 254.

Registers Window
The Registers window gives you a hierarchical view of these register types:

• general registers—contents of the central processing unit (CPU) of the host 
computer

• floating-point unit (FPU) registers—contents of the FPU registers

• registers specific to the host computer

You can use the Register window to perform these tasks:

• expand the hierarchical items in the window and view their contents

Table 20.4  Opening an Array window by using a contextual menu

On this host… Do this…

Windows Right-click the array and select View Array.

Macintosh Control-click the array and select View Array.

Solaris Click and hold on the array, then select View Array.

Linux Click and hold on the array, then select View Array.
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• select and modify register values

• view documentation for individual registers (depending on the register)

Figure 20.3 shows a sample Registers window.

Figure 20.3  Registers Window

General Registers
The General Registers are the register contents of the central processing unit (CPU) 
of the host computer. The exact listing of these registers depends on the host CPU and 
on the current build target. See the Targeting documentation for additional 
information.

FPU Registers
The FPU Registers are the register contents of the floating-point unit (FPU) of the 
host computer. The exact listing of these registers depends on the host FPU and on the 
current build target. See the Targeting documentation for additional information.

Host-specific Registers
The Registers window also lists additional register contents for registers specific to the 
host computer. The exact listing of these registers depends on the host computer and 
on the current build target. See the Targeting documentation for additional 
information.
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Opening the Registers Window

Open the Registers window to inspect and modify various register contents.

Figure 20.3 explains how to open the Registers window.

Viewing Registers

View registers to inspect and modify their contents.

1. Open the Registers window.

2. Expand the hierarchical list to view register groups.

Expanding the list shows the register groups that you can view or change.

3. Expand a register group.

Expanding a group shows its contents, by register name and corresponding value.

Changing Register Values

Change register values during program execution in order to examine program 
behavior.

1. Open the Registers window.

2. Expand the hierarchical list to view the names and corresponding values of the 
register that you want to modify.

Table 20.5  Opening the Registers window

On this host… Do this…

Windows Select View > Registers.

Macintosh Select Window > Registers Window.

Solaris Select Window > Registers Window.

Linux Select Window > Registers Window.
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3. Double-click the register value that you want to change.

The value highlights.

4. Enter a new register value.

5. Press Enter or Return.

The register value changes.

Changing Register Data Views

Change register data views to see register contents in a different format. For example, 
you can change the view of a register from binary format to hexadecimal format.

1. Open the Registers window.

2. Expand the hierarchical list to view the names and corresponding values of the 
register that you want to view in a different format.

3. Select the register value that you want to view in a different format.

The value highlights.

4. Select Data > View as format, where format is the data format in which you 
want to view the register value.

The available formats depend on the selected register value.

5. The register value changes format.

6. Select Data > View as Default to restore the original data format.

Alternatively, you can use a contextual menu to change the data format, as explained 
in Table 20.6 on page 257.

Table 20.6  Changing the data format by using a contextual menu

On this host… Do this…

Windows Right-click the register value and select View as format.

Macintosh Control-click the register value and select View as format.
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Opening Registers in a Separate Registers Window

Open registers in a separate Register Window to narrow the scope of registers that 
appear in a single window.

1. Open the Registers window.

2. Expand the hierarchical list to view the register or register group that you want to 
view in a separate Registers window.

3. Double-click the register or register group.

4. A new Registers window opens.

The new Registers window lists the name and value of the register that you double-
clicked, or the names and values of the register group that you double-clicked.

Register Details Window
The Register Details window lets you view detailed information about individual bits 
of registers from 2 bits to 32 bits in size. This window shows information for both 
system registers and memory-mapped registers. To open the Register Details window, 
click View > Register Details or Window > Register Details Window.

The Register Details window has fields that describe the register, its bitfields, and the 
values of those bitfields. Extensible Markup Language (XML) files in the Registers 
folder of your CodeWarrior installation provide the information that appears in the 
window. The Registers folder is inside the Support folder. The Support folder is 
inside the Plugins folder of your CodeWarrior installation.

Figure 20.4 on page 259 shows the Register Details window. Table 20.7 on page 259 
explains the items in the window.

Solaris Click and hold on the register value and select
View as format.

Linux Click and hold on the register value and select
View as format.

Table 20.6  Changing the data format by using a contextual menu (continued)

On this host… Do this…
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Figure 20.4  Register Details window

Table 20.7  Register Details window—items

Item Icon Explanation

Description File text box Enter the name or full path to the XML 
file for the register you want to view, or 
click the Browse button to open a 
dialog box that you can use to specify 
the file.

Register Name Shows the name of the register 
depicted in the window.

Address text box Enter the starting address of the register 
values that you want to see in the 
Register Display.

An error message appears if you enter 
an invalid starting address.
259IDE 5.5 User’s Guide 



Working with Memory
Register Details Window
Format list box Use to specify the data format for bit 
values in the Register Display:

• Binary

• Character

• Decimal

• Unsigned Decimal

• Hexadeccimal

• Default—have the IDE 
determine the best format

Register Display Shows a depiction of the register that 
you specify in the Description File text 
box, including individual register bits 
and their values.

Bitfield Name list box Use to specify a bitfield to highlight in 
the Register Display. The Description 
portion of the window reflects available 
information for the bitfield.

Select None to have the Description 
portion of the window reflect information 
for the entire register and not a bitfield in 
that register.

Bit Value text box Shows the current value of the bits in 
the Bitfield Name list box, according to 
the format that you specify in the 
Format list box.

Click the spin buttons to increment or 
decrement the current value, or enter a 
new value in the text box.

Changing the value changes only the 
Register Display. You must click the 
Write button to write the new value to 
the register itself.

Table 20.7  Register Details window—items (continued)

Item Icon Explanation
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Bit Value Modifier list box Use to specify a change in the value of 
the selected bitfield, or to see a brief 
explanation of specific bitfield values.

Changing the value changes only the 
Register Display. You must click the 
Write button to write the new value to 
the register itself.

Description Shows a description of the register or a 
selected bitfield in the register.

Use the Description File text box to 
specify the register.

Use the Text View list box to view 
specific register information, such as 
register descriptions, bitfield 
descriptions, and register details.

Revert button Click to change a modified value in the 
Register Display to its original value.

If you clicked the Write button to write a 
new value to the register itself, you 
cannot revert that value.

Read button Click to have the Register Display 
reflect current bit values from the 
register itself.

Write button Click to write the bit values in the 
Register Display to the register itself.

After you write new values to the 
register itself, you cannot revert them.

Reset Value button Click to restore the default value for the 
selected bitfield.

The IDE disables this button if the 
selected bitfield does not have a
default value.

Text View list box Use to specify the information that 
appears in the Description portion of the 
window.

Table 20.7  Register Details window—items (continued)

Item Icon Explanation
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Description File
Enter in this text box the name of the register that you want to see in the Register 
Display of the Register Details window. Alternatively, enter the full path to the 
register description file on your computer, or click the Browse button to open a dialog 
box that lets you specify the register description file. The text box is not case sensitive.

After you enter a name or path, the debugger searches for a matching register 
description file in the Registers folder of your CodeWarrior installation and the 
project access paths. If the debugger finds a matching file, the Register Display 
updates the information in the Register Details window. If the debugger does not find 
a matching name, an error message appears.

For example, to view the contents of the Opcode register, you can:

• type Opcode in the Description File text box and press Enter or Return, or

• type the full path to the opcode.xml file in the Registers folder and press
Enter or Return.

The debugger matches your entry with the opcode.xml file in the Registers folder. 
The Register Display in the Register Details window updates its information to show 
Opcode register details.

The debugger also updates the Register Display to show the current values in the 
register. If the debugger fails to update the display, an error message appears.

Register Display
This display shows the current contents of 32 bits of register data, starting at the 
address that you specify in the Address text box. The data appears according to the 
format that you specify in the Format list box.

The Register Display groups the 32 bits of data into register bitfields. Clicking one of 
the bits selects its associated bitfield. Additional information about the bitfield, such as 
its name and permissions, appears in the Description portion of the Register Details 
window.

Text View
Use this list box to change the information that appears in the Description portion of 
the Register Details window:

• Auto—select to have the IDE determine which information to display in
the window
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• Register Description—select to show information about the entire register, such 
as the name of the register itself and the meaning of its contents

• Bitfield Description—select to show information about the selected bitfield in 
the Register Display, such as the name of the bitfield and its access permissions

• Register Details—select to show in-depth information about the current register, 
such as its name, its bit values, and bit-value explanations
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Working with Debugger 
Data

This chapter explains how to work with data that debugger of the CodeWarrior™ IDE 
generates. These windows show various types of debugger data:

• Symbolics window—shows information that the debugger generates for
a program

• Processes window—shows individual processes and tasks that the debugger
can control

• Log window—shows messages that the debugger generates during the
debugging session

This chapter contains these sections:

• “Symbolics Window” on page 265

• “Processes Window” on page 268

• “Log Window” on page 271

Symbolics Window
The Symbolics window displays information that the debugger generates for the 
active file. Symbolics information includes data about program variables, functions, 
data structures, and source files.

Select the Activate Browser option in the Build Extras target settings panel in order 
to generate the symbolics information during the next build or debugging session.

Figure 21.1 on page 266 shows the Symbolics window. Table 21.1 on page 266 
explains the items in the window.
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Figure 21.1  Symbolics window

Table 21.1  Symbolics window—items

Item Icon Explanation

Debugger toolbar Contains buttons that represent common 
debugging commands, such as stopping the 
program and stepping through code.

Executables pane Lists recently used executable files that 
contain symbolics information.

Files pane Lists source files in the build target being 
debugged, for the selected executable file.

Functions pane Lists the functions declared in the file 
selected in the Files pane.

Source pane Displays the source code in the file selected 
in the
Files pane.
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Opening the Symbolics Window

The Symbolics window displays information generated by the IDE for a file.

To open the Symbolics window, do one of these tasks:

• Select View > Symbolics or Window > Symbolics window.

• Open a symbolics file. The IDE typically appends .xSYM or .iSYM, to the names 
of these files.

• Open an executable file for which the IDE previously generated symbolics 
information. The IDE typically appends .exe or .app to the names of the files.

Alternatively, click the Symbolics button in the Thread window toolbar to 
open the Symbolics window.

Using the Executables Pane

The Executables pane lists recently opened executable files for which the IDE 
generated symbolics information.

To use the pane, select an executable file in the list. The Files pane updates to display 
information for the selected executable file.

Using the Files Pane

The Files pane lists the source files in the build target being debugged, for the selected 
executable file in the Executables pane.

To use the pane, select a file in the list. The Functions pane and Source pane update to 
display information for the selected file.

Using the Functions Pane

The Functions pane lists functions declared in the selected file in the Files pane.

TIP The Sort functions by method name in symbolics window option 
changes the order in which the Functions pane lists functions.
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To use the pane, select a function in the list. The Source pane updates to display source 
code for the selected function.

Using the Source Pane

The Source pane displays source code for the selected function in the Functions pane, 
using the fonts and colors specified in the IDE Preferences window.

To use the pane, select a function in the Functions pane. The corresponding source 
code appears in the Source pane.

If the selected function does not contain source code, the Source pane displays the 
message Source text or disassembly not available.

NOTE Use the Source pane in the Symbolics window to view source code, 
copy source code, and set breakpoints. Use an editor window to 
modify the source code. Use a Thread window to view the currently 
executing statement.

Processes Window
The Processes window shows information about processes executing on various 
machines, like the host computer or the hardware under debugger control. The 
window shows this information:

• running processes

• tasks for selected processes

• some hidden processes

The debugger also controls processes that you add manually.

Figure 21.2 shows the Processes window. Table 21.2 on page 269 explains the items in 
the window.

NOTE If the Processes window does not show processes for a sepcific 
machine, you might need to start a debugging session for that 
machine. For example, you might need to debug a project that runs 
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on external hardware in order to see executing processes for
that hardware.

Figure 21.2  Processes window

Table 21.2  Processes window—items

Item Icon Explanation

Target Machine Select a machine for which to display active 
processes.

Debugger toolbar Toolbar buttons represent common 
debugging commands, such as debugging 
the program and killing program execution.

Attach to Process Click to have the debugger control the 
process that you select in the Process pane.

Stack Crawl window Click to open a Thread window for the 
process that you select in the Process pane.

Process pane Lists active processes for the selected 
machine.

Task pane Lists the status of tasks for a selected 
process in the Process pane.
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Opening the Process Window

Use the Process Window command to view and manipulate active processes on a 
selected machine.

NOTE The Processes window appears only for those platforms that
support it.

Table 21.3 explains how to open the Processes window.

Using the Process Pane

Use the Process pane to view active processes on a selected machine. Processes under 
debugger control appear in bold or with a check mark.

1. Use the Processes selector to select the item for which to view active processes.

2. Select a process in the Process pane.

The Task pane displays all tasks assigned to the selected process.

Using the Task Pane

Use the Task pane to view tasks under debugger control. Select a process in the 
Process pane to display its tasks under debugger control in the Task pane. Double-
click a task to open it in a new Thread window, or choose the task name and click the 
Stack Crawl Window button.

Table 21.3  Opening the Processes window

On this host… Do this…

Windows Select View > Processes.

Macintosh Select Window > Processes Window.

Solaris Select Window > Processes Window.

Linux Select Window > Processes Window.
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Attaching the Debugger to a Process

Click the Attach to Process button to assign a selected process to a new debugging 
session. This assignment allows the debugger to control processes that it does not 
otherwise recognize. For example, you can click the Attach to Process button to assign 
dynamic link libraries or shared libraries to the debugger.

1. Use the Processes selector to select the item for which to view active processes.

2. Select a process to attach to the debugger.

3. Click Attach to Process .

The debugger assumes control of the selected process. Processes under debugger 
control appear in bold or with a check mark.

Log Window
The Log window displays messages during program execution. Select the Log System 
Messages option in the Debugger Settings panel to activate the Log window.

The IDE allows saving Log window contents to a .txt (text) file and copying text 
from the Log window to the system clipboard.

Windows-hosted Log window messages include:

• Dynamic Link Library (DLL) loading and unloading

• debugging printf() messages

Macintosh-hosted Log window messages include:

• PowerPC™ code fragments

• DebugStr() messages

Figure 21.3 shows the Log window.
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Figure 21.3  Log window

Opening the Log Window

Use the Debugger Settings preference panel to enable message logging. The Log 
window records these types of messages for a program during a debugging session:

• the start of new tasks

• routine entry and exit

• Windows: DLL loading and unloading, and debug printf() messages

• Macintosh: PowerPC code-fragment loading and DebugStr() messages

1. Select the Log System Messages option in the Debugger Settings preference 
panel.

2. Select Project > Debug.

The Log window appears. It allows selecting, copying, and saving logged text to a 
file for later analysis. See the Targeting documentation for additional information.
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Working with Hardware 
Tools

This chapter explains the CodeWarrior™ IDE hardware tools. Use these tools for 
board bring-up, test, and analysis.

This chapter contains these sections:

• “Flash Programmer Window” on page 273

• “Hardware Diagnostics Window” on page 284

• “Working with a Logic Analyzer” on page 297

• “Trace Window” on page 301

• “Cache window” on page 302

• “Profile window” on page 303

• “Command Window” on page 303

Flash Programmer Window
The Flash Programmer window lists global options for the flash programmer 
hardware tool. These preferences apply to every open project file.

Figure 22.1 on page 274 shows the Flash Programmer window. Table 22.1 on page 
274 explains the items in the window.

To open the Flash Programmer window, click Tools > Flash Programmer.

The Flash Programmer window has these panels:

• Target Configuration

• Flash Configuration

• Program / Verify

• Erase / Blank Check
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• Checksum

Figure 22.1  Flash Programmer window

Table 22.1  Flash Programmer window—items

Item Explanation

Flash Programmer pane Shows a tree structure of panels. Click a panel name to display 
that panel in the Flash Programmer window.

Show Log button Click to display a text file that logs flash programmer actions. 
Check the Enable Logging checkbox in the Target 
Configuration panel to enable this button.

Load Settings button Click to restore previously saved settings for the current panel.

Save Settings button Click to save to a file the settings for the current panel.

OK button Click to save your changes to all panels and close the window.

Cancel button Click to discard your changes to all panels and close
the window.
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Target Configuration
The Target Configuration panel configures general flash programmer settings. 
Figure 22.2 on page 275 shows the Target Configuration panel. Table 22.2 on page 
275 explains the items in the panel.

Figure 22.2  Target Configuration panel

Table 22.2  Target Configuration panel—items

Item Explanation

Default Project Shows the current default project in the IDE.

Default Target Shows the default build target in the IDE. Clear the Use 
Custom Settings checkbox to have the IDE use the 
connection settings from the build target for connecting to
the hardware.
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Use Custom Settings 
checkbox.

Check to specify the connection information that you want to 
use for connecting to the hardware. In this case, the IDE can 
connect to the hardware without using settings from a project.

Clear to use the connection information stored in the default 
project for connecting to the hardware. You cannot clear the 
checkbox if you do not have an active default project or
default target.

Connection information includes the information that you 
specify in the Target Processor list box, the Connection list 
box, and the Use Target Initialization text box.

Target Processor
text/list box

Use to specify the hardware processor.

Connection list box Use to specify the method that the IDE uses to connect to
the hardware.

Use Target Initialization 
checkbox and text box

Check to specify an initialization file for the hardware 
connection. Enter the initialization file path in the text box, or 
click the Browse button to open a dialog box that you can use 
to specify the initialization file path.

Clear if you do not want to use an initialization file for the 
hardware connection.

Target Memory Buffer 
Address text box

Specify the starting address of an area in RAM that the flash 
programmer can use as a scratch area. The flash programmer 
must be able to access this starting address through the 
remote connection (after the hardware initializes).

The flash programmer should not modify any memory location 
other than the target memory buffer and flash memory.

For example, the flash programmer uses the target memory 
buffer to download and execute the flash device driver.

Target Memory Buffer 
Size text box

Specify the size of an area in RAM that the flash programmer 
can use as a scratch area, starting at the address you specify 
in the Target Memory Buffer Address text box.

The flash programmer should not modify any memory location 
other than the target memory buffer and flash memory.

Table 22.2  Target Configuration panel—items (continued)

Item Explanation
276 IDE 5.5 User’s Guide



Working with Hardware Tools
Flash Programmer Window
Flash Configuration
The Flash Configuration panel configures settings for the flash device on the 
hardware device. Figure 22.3 shows the Flash Configuration panel. Table 22.3 on page 
278 explains the items in the panel.

Figure 22.3  Flash Configuration panel

Enable Logging checkbox Check to have the IDE generate detailed status information 
during flash operations. Checking this checkbox enables the 
Show Log button.

Clear to disable logging of detailed status information
during flash operations. Clearing this checkbox disables the 
Show Log button.

Click the Show Log button to view the status information.

Verify Target Memory 
Writes checkbox

Check to have the IDE verify all write operations to the 
hardware RAM by reading the result of each write operation.

Clear to have the IDE perform write operations without 
verifying them.

Table 22.2  Target Configuration panel—items (continued)

Item Explanation
277IDE 5.5 User’s Guide 



Working with Hardware Tools
Flash Programmer Window
Program / Verify
The Program / Verify panel lets you program an image into flash memory and verify 
the programming operation. Figure 22.4 on page 279 shows the Program / Verify 
panel. Table 22.4 on page 279 explains the items in the panel.

Table 22.3  Flash Configuration panel—items

Item Explanation

Flash Memory Base 
Address text box

Enter the base address of the beginning of flash memory
on the hardware device. Enter the address based on the 
perspective of the hardware device.

Device pane Shows an alphabetical list of supported flash device types. 
Select a device type from this pane. Your selection determines 
the contents of the Organization and Sector Address Map 
panes.

Organization pane Shows a list of supported layouts of flash memory in the 
hardware design, based on your selection in the Device pane. 
Each list item is of the form 
ChipCapacityxDataBusWidthxNumberOfChipsInLayout. Select 
an organization from this pane. Your selection determines the 
contents of the Sector Address Map pane.

For example, 2048Kx8x2 indicates a chip capacity of 2048 
kilobytes, a byte-wide interface to the data bus, and a 2-chip 
hardware layout.

For hardware layouts of 2 or more chips, assume an 
interleaved organization. For example, for a 2048Kx16x2 
organization, there are 2 chips on a 32-bit bus, and each chip 
provides 16 bits of data.

Sector Address Map 
pane

Shows a map of sector addresses that reflects your selections 
in the Device and Organization panes and your entry in the 
Flash Memory Base Address text box. This map is for 
informational purposes only.
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Figure 22.4  Program / Verify panel

Table 22.4  Program / Verify panel—items

Item Explanation

Use Selected File 
checkbox and text box

Check to specify a file to program into flash memory. Enter the 
file path in the text box, or click the Browse button to open a 
dialog box that you can use to specify the file path.

Clear to have the IDE program flash memory with the file that 
the default build target determines.

The file determines the address to which the IDE programs 
flash memory. If you specify a file that does not contain 
address information, such as a binary file, the IDE programs 
flash memory at address zero. Check the Apply Address 
Offset checkbox to specify an address offset fro m zero.

Restrict Address Range 
checkbox

Check to use the Start and End text boxes to specify the 
address range in which you want the IDE to program flash 
data. If you use a binary file to program flash data, the flash 
programmer ignores data outside the address range that
you specify.

Clear to have the IDE determine the address range in which to 
program flash data.
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Start text box Enter the starting address of the range that you want the flash 
programmer to use for programming flash data.

Check the Restrict Address Range checkbox to enable this 
text box.

End text box Enter the ending address of the range that you want the flash 
programmer to use for programming flash data.

Check the Restrict Address Range checkbox to enable this 
text box.

Apply Address Offset 
checkbox

Check to specify an offset at which to program flash data. The 
IDE adds this offset to the starting address that the file 
specifies. The flash programmer begins programming flash 
data at the starting address plus the offset.

Clear to have the flash programmer begin programming flash 
data at the starting address that the file specifies. In this case, 
the IDE does not add an offset to the starting address.

Offset text box Enter the offset to add to the starting address that the file 
specifies. The flash programmer begins programming flash 
data at the resulting address.

Check the Apply Address Offset checkbox to enable this
text box.

Flash Base Address Shows the base address of the beginning of flash memory
on the hardware device. This address is the same address that 
you specify in the Flash Memory Base Address text box of 
the Flash Configuration panel.

Flash Base + Offset Shows the resulting address of adding the offset value that you 
specify in the Offset text box to the Flash Base Address 
value. The flash programmer begins programming flash data 
at this resulting address.

Status Shows flash programmer progress information. Click the 
Details button to show more thorough progress information.

Table 22.4  Program / Verify panel—items (continued)

Item Explanation
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Erase / Blank Check
The Erase / Blank Check panel lets you erase an image from flash memory and check 
for blank memory. Figure 22.5 shows the Erase / Blank Check panel. Table 22.5 on 
page 282 explains the items in the panel.

Figure 22.5  Erase / Blank Check panel

Program button Click to have the flash programmer program flash data into the 
hardware device. The Status reflects flash programmer 
progress.

The flash programmer does not check for blank flash memory 
before it begins programming the flash data.

Verify button Click to have the IDE verify the data that the flash programmer 
programmed into the hardware device. The verify operation 
reads the flash data from the hardware device and compares 
that data against the image file on disk. The Status reflects 
flash programmer progress.

Table 22.4  Program / Verify panel—items (continued)

Item Explanation
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Checksum
The Checksum panel lets you calculate checksum values. Figure 22.6 on page 283 
shows the Checksum panel. Table 22.6 on page 283 explains the items in the panel.

Table 22.5  Erase / Blank Check panel—items

Item Explanation

All Sectors
checkbox and list

Check to apply the erase or blank check operation to the entire 
flash memory.

Clear to specify the sectors that you want to erase or check
for blanks. Select the sectors in the list below the checkbox.

Erase Sectors 
Individually checkbox

Check to have the flash programmer ignore chip erase 
commands and erase each individual sector instead.

Clear to have the flash programmer obey chip erase 
commands and erase all sectors at once.

Check the All Sectors checkbox to enable this checkbox.

Status Shows flash programmer progress information. Click the 
Details button to show more thorough progress information.

Erase button Click to have the flash programmer erase the sectors that you 
specified. The Status reflects flash programmer progress.

Blank Check button Click to have the flash programmer perform these tasks:

• upload the sectors that you specified to the
hardware device

• compare the uploaded sectors against 0xff

• report the values that do not match 0xff.

The Status reflects flash programmer progress.
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Figure 22.6  Checksum panel

Table 22.6  Checksum panel—items

Item Explanation

File on Target
option button

Select to have the flash programmer read the file that you 
specified in the Use Selected File text box of the Program / 
Verify panel. The flash programmer reads this file to 
determine the required memory regions of the flash device for 
the checksum operation.

The Restrict Address Range and Apply Address Offset 
information that you specify in the Program / Verify panel also 
apply to this option button.

File on Host
option button

Select to have the flash programmer read the file on the host 
computer. The flash programmer reads this file to determine 
the required memory regions of the flash device for the 
checksum operation.

The Restrict Address Range and Apply Address Offset 
information that you specify in the Program / Verify panel also 
apply to this option button.
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Hardware Diagnostics Window
The Hardware Diagnostics window lists global options for the hardware diagnostic 
tools. These preferences apply to every open project file.

Figure 22.7 on page 285 shows the Hardware Diagnostics window. Table 22.7 on page 
285 explains the items in the window.

To open the Hardware Diagnostics window, click Tools > Hardware Diagnostics.

The Hardware Diagnostics window has these panels:

• Configuration

• Memory Read / Write

Memory Range on Target
option button

Select to have the flash programmer read the range that you 
specify in the Start and Size values in the Address Range 
group. The flash programmer uses this memory range for the 
checksum operation.

Entire Flash
option button

Select to have the flash programmer read the entire contents 
of flash memory. The flash programmer reads uses this data 
for the checksum operation.

Start text box Enter the starting address of the range that you want the flash 
programmer to use for the checksum operation.

Select the Memory Range on Target option button to enable 
this text box.

Size text box Enter the size of the address range that you want the flash 
programmer to use for the checksum operation. This size is 
relative to the starting address that you specify in the Start
text box.

Select the Memory Range on Target option button to enable 
this text box.

Status Shows flash programmer progress information. Click the 
Details button to show more thorough progress information.

Calculate Checksum 
button

Click to have the flash programmer calculate the checksum 
according to your specifications. At the end of the checksum 
operation, the Status shows the calculated checksum.

Table 22.6  Checksum panel—items (continued)

Item Explanation
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• Scope Loop

• Memory Tests

Figure 22.7  Hardware Diagnostics window

Table 22.7  Hardware Diagnostics window—items

Item Explanation

Hardware Diagnostics 
pane

Shows a tree structure of panels. Click a panel name to display 
that panel in the Hardware Diagnostics window.

Load Settings button Click to restore previously saved settings for the current panel.

Save Settings button Click to save to a file the settings for the current panel.

OK button Click to save your changes to all panels and close the window.

Cancel button Click to discard your changes to all panels and close
the window.
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Configuration
The Configuration panel configures general flash programmer settings. Figure 22.8 
shows the Configuration panel. Table 22.8 explains the items in the panel.

Figure 22.8  Configuration panel

Table 22.8  Configuration panel—items

Item Explanation

Default Project Shows the current default project in the IDE.

Default Target Shows the default build target in the IDE. Clear the Use 
Custom Settings checkbox to have the IDE use the 
connection settings from the build target for diagnosing
the hardware.
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Memory Read / Write
The Memory Read / Write panel configures diagnostic tests for performing memory 
reads and writes over the remote connection interface. Figure 22.9 on page 288 shows 
the Memory Read / Write panel. Table 22.9 on page 288 explains the items in
the panel.

Use Custom Settings 
checkbox.

Check to specify the connection information that you want to 
use for diagnosing the hardware. In this case, the IDE can 
connect to the hardware without using settings from a project.

Clear to use the connection information stored in the default 
project for connecting to the hardware. You cannot clear the 
checkbox if you do not have an active default project or
default target.

Connection information includes the information that you 
specify in the Target Processor list box, the Connection list 
box, and the Use Target Initialization text box.

Target Processor
text/list box

Use to specify the hardware processor.

Connection list box Use to specify the method that the IDE uses to connect to
the hardware.

Use Target Initialization 
checkbox and text box

Check to specify an initialization file for the hardware 
connection. Enter the initialization file path in the text box, or 
click the Browse button to open a dialog box that you can use 
to specify the initialization file path.

Clear if you do not want to use an initialization file for the 
hardware connection.

Table 22.8  Configuration panel—items (continued)

Item Explanation
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Figure 22.9  Memory Read / Write panel

Table 22.9  Memory Read / Write panel—items

Item Explanation

Read option button Select to have the hardware diagnostic tools perform
read tests.

Write option button Select to have the hardware diagnostic tools perform
write tests.

Byte option button Select to have the hardware diagnostic tools perform byte-
size operations.

Word option button Select to have the hardware diagnostic tools perform word-
size operations.

Long Word option button Select to have the hardware diagnostic tools perform long-
word-size operations.

Target Address text box Specify the address of an area in RAM that the hardware 
diagnostic tools should analyze. The tools must be able to 
access this starting address through the remote connection 
(after the hardware initializes).
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Scope Loop
The Scope Loop panel configures diagnostic tests for performing repeated memory 
reads and writes over the remote connection interface. The tests repeat until you stop 
them. By performing repeated read and write operations, you can use a scope analyzer 
or logic analyzer to debug the hardware device.

Figure 22.10 on page 290 shows the Scope Loop panel. Table 22.10 on page 290 
explains the items in the panel.

After the first 1000 operations, the Status shows the estimated time
between operations.

NOTE For all values of Speed, the time between operations depends heavily 
on the processing speed of the host computer.

For Read operations, the Scope Loop test has an additional feature. During the first 
read operation, the hardware diagnostic tools store the value read from the hardware. 
For all successive read operations, the hardware diagnostic tools compare the read 
value to the stored value from the first read operation. If the Scope Loop test 
determines that the value read from the hardware is not stable, the diagnostic tools 
report the number of times that the read value differs from the first read value.

Value to Write text box Specify the value that the hardware diagnostic tools write 
during testing.

Select the Write option button to enable this text box.

Status Shows hardware diagnostic progress information. Click the 
Details button to show more thorough progress information.

Access Target button Click to have the have the hardware diagnostic tools 
performed your specified tests. The Status shows test results.

Table 22.9  Memory Read / Write panel—items (continued)

Item Explanation
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Figure 22.10  Scope Loop panel

Table 22.10  Scope Loop panel—items

Item Explanation

Read option button Select to have the hardware diagnostic tools perform
read tests.

Write option button Select to have the hardware diagnostic tools perform
write tests.

Byte option button Select to have the hardware diagnostic tools perform byte-
size operations.

Word option button Select to have the hardware diagnostic tools perform word-
size operations.

Long Word option button Select to have the hardware diagnostic tools perform long-
word-size operations.

Target Address text box Specify the address of an area in RAM that the hardware 
diagnostic tools should analyze. The tools must be able to 
access this starting address through the remote connection 
(after the hardware initializes).
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Memory Tests
The Memory Tests panel lets you perform three different tests on the hardware:

• Walking Ones

• Address

• Bus Noise

Figure 22.11 on page 292 shows the Memory Tests panel. Table 22.11 on page 292 
explains the items in the panel.

You can specify any combination of the tests and the number of passes to perform 
them. For each pass, the hardware diagnostic tools perform the tests in turn, until all 
passes are complete. The tools tally memory test failures and display them in a log 
window after all passes are complete. Errors resulting from memory test failures do 
not stop the testing process, however, fatal errors immediately stop the testing process.

Value to Write text box Specify the value that the hardware diagnostic tools write 
during testing.

Select the Write option button to enable this text box.

Speed slider Move to adjust the speed at which the hardware diagnostic 
tools repeat successive read and write operations. Lower 
speeds increase the delay between successive operations. 
Higher speeds decrease the delay between
successive operations.

Status Shows hardware diagnostic progress information. Click the 
Details button to show more thorough progress information.

Begin Scope Loop button Click to have the have the hardware diagnostic tools 
performed your specified tests. The Status shows test results.

Table 22.10  Scope Loop panel—items (continued)

Item Explanation
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Figure 22.11  Memory Tests panel

Table 22.11  Memory Tests panel—items

Item Explanation

Walking 1’s checkbox Check to have the hardware diagnostic tools perform the 
Walking Ones test.

Clear to have the diagnostic tools skip the Walking Ones test.

Address checkbox Check to have the hardware diagnostic tools perform the 
Address test.

Clear to have the diagnostic tools skip the Address test.

Bus Noise checkbox Check to have the hardware diagnostic tools perform the Bus 
Noise test.

Clear to have the diagnostic tools skip the Bus Noise test.

Start text box Enter the starting address of the range that you want to test.

End text box Enter the ending address of the range that you want to test.

Byte option button Select to have the hardware diagnostic tools perform byte-
size operations.
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Word option button Select to have the hardware diagnostic tools perform word-
size operations.

Long Word option button Select to have the hardware diagnostic tools perform long-
word-size operations.

Passes text box Enter the number of times that you want to repeat the
specified tests.

Show Log button Click to display a text file that logs memory test actions.

Use Target CPU 
checkbox

Check to have the hardware diagnostic tools download the test 
code to the hardware device. Enter in the Target Scratch 
Memory Start and Target Scratch Memory End text boxes 
the memory range that you want to use on the hardware 
device. The CPU on the hardware device executes the test 
code in this memory range.

Clear to have the hardware diagnostic tools execute the test 
code through the remote connection interface.

Execution performance improves greatly if you execute the 
test code on the hardware CPU, but requires that the hardware 
has enough stability and robustness to execute the test code.

Target Scratch Memory 
Start text box

Specify the starting address of an area in RAM that the 
hardware diagnostic tools can use as a scratch area. The tools 
must be able to access this starting address through the 
remote connection (after the hardware initializes).

Target Scratch Memory 
End text box

Specify the ending address of an area in RAM that the 
hardware diagnostic tools can use as a scratch area. The tools 
must be able to access this starting address through the 
remote connection (after the hardware initializes).

Status Shows memory test progress information. Click the Details 
button to show more thorough progress information.

Begin Test button Click to have the hardware diagnostic tools perform the 
memory tests that you specified. The Status reflects memory 
test progress.

Table 22.11  Memory Tests panel—items (continued)

Item Explanation
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Walking Ones
This test detects these memory faults:

• Address Line—The board or chip address lines are shorting or stuck at 0 or 1. 
Either condition could result in errors when the hardware reads and writes to the 
memory location. Because this error occurs on an address line, the data may end 
up in the wrong location on a write operation, or the hardware may access the 
wrong data on a read operation.

• Data Line—The board or chip data lines are shorting or stuck at 0 or 1. Either 
condition could result in corrupted values as the hardware transfers data to or 
from memory.

• Retention—The contents of a memory location change over time. The effect is 
that the memory fails to retain its contents over time.

The Walking Ones test includes four subtests:

• Walking Ones—This subtest first initializes memory to all zeros. Then the 
subtest writes, reads, and verifies bits, with each bit successively set from the 
least significant bit (LSB) to the most significant bit (MSB). The subtest 
configures bits such that by the time it sets the MSB, all bits set to a value of 1. 
This pattern repeats for each location within the memory range that you specify. 
For example, the values for a byte-based Walking Ones subtest occur in
this order:

0x01, 0x03, 0x07, 0x0F, 0x1F, 0x3F, 0x7F, 0xFF

• Ones Retention—This subtest immediately follows the Walking Ones subtest. 
The Walking Ones subtest should leave each memory location with all bits set
to 1. The Ones Retention subtest verifies that each location has all bits set to 1.

• Walking Zeros—This subtest first initializes memory to all ones. Then the subtest 
writes, reads, and verifies bits, with each bit successively set from the LSB to the 
MSB. The subtest configures bits such that by the time it sets the MSB, all bits set 
to a value of 0. This pattern repeats for each location within the memory range 
that you specify. For example, the values for a byte-based Walking Zeros subtest 
occur in this order:

0xFE, 0xFC, 0xF8, 0xF0, 0xE0, 0xC0, 0x80, 0x00

• Zeros Retention—This subtest immediately follows the Walking Zeros subtest. 
The Walking Zeros subtest should leave each memory location with all bits set
to 0. The Zeros Retention subtest verifies that each location has all bits set to 0.
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Address
This test detects memory aliasing. Memory aliasing exists when a physical memory 
block repeats one or more times in a logical memory space. Without knowing about 
this condition, you might conclude that there is much more physical memory than 
what actually exists.

The address test uses a simplistic technique to detect memory aliasing. The test writes 
sequentially increasing data values (starting at one and increasing by one) to each 
successive memory location. The maximum data value is a prime number and its 
specific value depends on the addressing mode so as to not overflow the memory 
location.

The test uses a prime number of elements to avoid coinciding with binary
math boundaries:

• For byte mode, the maximum prime number is 28-5 or 251.

• For word mode, the maximum prime number is 216-15 or 65521.

• For long word mode, the maximum prime number is 232-5 or 4294967291.

If the test reaches the maximum value, the value rolls over to 1 and starts incrementing 
again. This sequential pattern repeats throughout the memory under test. Then the test 
reads back the resulting memory and verifies it against the written patterns. Any 
deviation from the written order could indicate a memory aliasing condition.

Bus Noise
This test stresses the memory system by causing many bits to flip from one memory 
access to the next (both addresses and data values). Bus noise occurs when many bits 
change consecutively from one memory access to another. This condition can occur on 
both address and data lines.

Address lines
To force bit flips in address lines, the test uses three approaches:

• Sequential—This approach works sequentially through all of the memory under 
test, from lowest address to highest address. This sequential approach results in 
an average number of bit flips from one access to the next.

• Full Range Converging—This approach works from the fringes of the memory 
range toward the middle of the memory range. Memory access proceeds in this 
pattern, where + number and - number refer to the next item location (the specific 
increment or decrement depends on byte, word, or long word address mode):
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– the lowest address

– the highest address

– (the lowest address) + 1

– (the highest address) - 1

– (the lowest address) + 2

– (the highest address) - 2

• Maximum Invert Convergence—This approach uses calculated end point 
addresses to maximize the number of bits flipping from one access to the next. 
This approach involves identifying address end points such that the values have 
the maximum inverted bits relative to one another. Specifically, the test identifies 
the lowest address with all 0x5 values in the least significant nibbles and the 
highest address with all 0xA values in the least significant nibbles. After the test 
identifies these end points, memory access alternates between low address and 
high address, working towards the center of the memory under test. Accessing 
memory in this manner, the test achieves the maximum number of bits flips from 
one access to the next.

Data lines
To force bit flips in data lines, the test uses two sets of static data, a pseudo-random set 
and a fixed-pattern set. Each set contains 31 elements—a prime number. The test uses 
a prime number of elements to avoid coinciding with binary math boundaries. The sets 
are unique to each addressing mode so as to occupy the full range of bits.

• The test uses the pseudo-random data set to stress the data lines in a repeatable 
but pattern-less fashion.

• The test uses the fixed-pattern set to force significant numbers of data bits to flip 
from one access to the next.

The subtests execute similarly in that each subtest iterates through static data, writing 
values to memory. The test combines the three address line approaches with the two 
data sets to produce six unique subtests:

• Sequential with Random Data

• Sequential with Fixed Pattern Data

• Full Range Converging with Random Data

• Full Range Converging with Fixed Pattern Data

• Maximum Invert Convergence with Random Data

• Maximum Invert Convergence with Fixed Pattern Data
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Working with a Logic Analyzer
This section explains how to set up your project to connect to a logic analyzer and how 
to use the IDE to issue commands to the logic analyzer. For more information about 
setting up the logic analyzer to transmit information to the IDE, refer to the
Targeting documentation.

Configuring the Project
Use the Analyzer Connections target settings panel (Figure 22.12) to configure your 
project to connect to a logic analyzer.

Use the Connection list box to specify the logic analyzer connection that you want to 
use. Click the Edit Connection button to configure the parameters of the connection. 
Figure 22.13 on page 298 shows the window that appears when you click the Edit 
Connection button. Table 22.12 on page 298 explains the options in this window.

NOTE Each build target supports only one connection to a logic analyzer. If 
you want your project to have more logic analyzer connections, 
create a build target for each additional connection.

Figure 22.12  Analyzer Connections settings panel
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Figure 22.13  Editing a logic analyzer connection

Table 22.12  Logic analyzer connection options

Option Explanation

Name text box Enter the name that you want to assign to this collection
of options.

Debugger list box Use to specify the debugger to use with the logic analyzer.

Connection Type list box Use to specify the connection method to the logic analyzer.

Analyzer Type list box Use to specify the type of logic analyzer.

Host Name text box Enter the Internet Protocol (IP) address of the logic analyzer.

Analyzer Configuration 
File text box

Enter the name of the configuration file that the logic
analyzer requires.

Analyzer Slot text box Enter the slot name that identifies the logic analyzer location.
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Using the Logic Analyzer
The IDE can work with a logic analyzer in these ways:

• Connect—establish a connection to the logic analyzer

• Arm—enable the logic analyzer to collect trace data

• Disarm—disable the logic analyzer from collecting trace data

• Update Data—retrieve the latest data from the logic analyzer

• Disconnect—close the connection to the logic analyzer

Before you can use the IDE to work with a logic analyzer, you must use the Analyzer 
Settings target settings panel to configure a connection to the logic analyzer.
The IDE requires this information in order to correlate collected trace data with 
currently running source code.

Connect
This command uses the connection options that you specified in the Analyzer 
Settings target settings panel to perform these tasks:

1. Establish a connection to the logic analyzer.

2. Load the configuration file that you specified in the Analyzer Configuration File 
text box (the load process might take several minutes).

Trace Support File text 
box

Enter the name of the file that the logic analyzer requires to 
support the collection of trace data.

Analyzer Can Cause 
Target Breakpoint 
checkbox

Check to allow that the logic analyzer to cause a
hardware breakpoint.

Clear to prevent the logic analyzer from causing a
hardware breakpoint.

Target Breakpoint Can 
Cause Analyzer Trigger 
checkbox

Check to allow a hardware breakpoint to trigger the
logic analyzer.

Clear to prevent a hardware breakpoint from triggering the 
logic analyzer. 

Table 22.12  Logic analyzer connection options (continued)

Option Explanation
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3. Requests additional information from you as required (for example, for an Agilent 
connection, the IDE asks you to select the machine that you want to use).

4. Retrieves all data that will appear in the Trace window.

Click Tools > Logic Analyzer > Connect to use this command. You cannot use this 
command if you are already connected to a logic analyzer.

Arm
This command instructs the logic analyzer to perform a Run All operation. This 
operation prepares the logic analyzer to collect trace data. Click Tools > Logic 
Analyzer > Arm to use this command. You cannot use this command if the IDE has 
not established a connection to the logic analyzer, or if you already armed the logic 
analyzer.

Disarm
This command instructs the logic analyzer to perform a Stop All operation, if it is still 
running. This operation stops the logic analyzer from collecting trace data. Click 
Tools > Logic Analyzer > Disarm to use this command. You cannot use this 
command if the IDE has not established a connection to the logic analyzer.

NOTE You must use the Disarm command in order to update trace data in 
the IDE.

Update Data
This command retrieves the most recent trace data from the logic analyzer in order to 
display that data in the Trace window of the IDE. Click Tools > Logic Analyzer > 
Update Data to use this command. The Trace window flushes its previous data and 
updates its display with the newly retrieved trace data. You cannot use this command 
until you first Disarm the logic analyzer.

NOTE The Update Data command does not update the column labels in the 
Trace window. If you change the labels in the logic analyzer, you 
must disconnect from it in the IDE and then reconnect to it. After you 
disconnect and reconnect, the Trace window reflects your changes to 
the column labels.
300 IDE 5.5 User’s Guide



Working with Hardware Tools
Trace Window
Disconnect
This command disconnects the IDE from the logic analyzer, it the connection still 
exists. Click Tools > Logic Analyzer > Disconnect to use this command. After you 
disconnect the IDE from the logic analyzer, the Trace window flushes its data. You 
cannot use this command if you are not currently connected to a logic analyzer.

Trace Window
After you configure your project to use a logic analyzer and collect trace data, you use 
the Trace window (Figure 22.14) to view the collected data.The trace window shows 
up to 100,000 states or trace frames, beginning with the most recent frame.

The IDE determines the column labels that appear in the Trace window at the time it 
connects to the logic analyzer. If you update these labels in the logic analyzer, your 
changes do not appear in the Trace window if you update data. In the IDE, you must 
disconnect from the logic analyzer and reconnect to it in order to update the column 
labels in the Trace window.

After you use a logic analyzer to collect trace data, open the Trace window by clicking 
Data > View Trace.

Figure 22.14  Trace window
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Cache Window
Use the Cache window (Figure 22.14) to view cache information for the target 
processor. Click Data > View Cache to open the Cache window.

NOTE The View Cache menu might have additional supported commands, 
depending on the target processor. For example, you might be able to 
click Data > View Cache > Instruction Cache or Data > View 
Cache > Data Cache to view these two types of cache concurrently.

Figure 22.15  Cache window

Profile Window
Use the Profile window (Figure 22.16 on page 303) to examine profile data that you 
collect from executing code. Examining this data helps you improve the performance 
of your project. You use profiler Application Programming Interface (API) calls or 
#pragma directives in your source code to turn on the profiler, collect profiling data, 
and turn off the profiler. For more information, refer to the Profiler User Guide.

To open the Profile window, add the appropriate API calls or #pragma directives to 
your source code, then debug your project. The Profile window opens automatically.
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Figure 22.16  Profile window

Command Window
The IDE supports a command-line interface to some of its features. You can use the 
command-line interface together with various scripting engines, such as the 
Microsoft® Visual Basic® script engine, the Java™ script engine, TCL, Python, and 
Perl. You can also issue a command line that saves a log file of command-line activity.

The Command window in the IDE shows the standard output and standard error 
streams of command-line activity. Figure 22.17 on page 303 shows the Command 
window.

Figure 22.17  Command window
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Opening the Command Window

Use the Command window to view the standard output and standard error streams of 
command-line activity.

To open the Command window, click View > Command Window.

Issuing Command Lines

Use the Command window to issue command lines to the IDE. For example, enter 
debug to start a debugging session.

To issue a command line, bring forward the Command window, type the command 
line, and press Enter or Return. The IDE executes the command line that you entered.

If you work with hardware as part of your project, you can use the Command window 
to issue command lines to the IDE while the hardware is running.

NOTE Enter help to see a list of available commands and a brief 
explanation of each command. Enter help command to see a 
detailed explanation of the command.
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Compilers and Linkers

This section contains these chapters:

• Compilers

• Linkers
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Compilers

This chapter explains how to work with compilers in the CodeWarrior™ IDE. The IDE 
uses compilers to complete these tasks:

• Generate object code—the compiler translates source code into object code. 
Sample source code includes C++ files and Java files. Object code represents the 
same source instructions in a language that the computer directly understands.

• Flag syntax errors—the compiler highlights source code with syntax errors. 
Syntax errors result from failing to follow valid structure in a programming 
language. In C++, a common syntax error is to forget to conclude a statement 
with a semicolon.

Read this chapter to learn more about typical tasks for working with compilers.

This chapter contains these sections:

• Choosing a Compiler

• Compiling Projects

Choosing a Compiler
Choose a compiler to determine how the IDE interprets source code. The IDE uses a 
plug-in compiler architecture. This architecture provides these features:

• Modularity—the IDE associates a specific compiler plug-in with a particular 
programming language or environment. For example, a compiler plug-in exists 
for C++ source code, and another compiler plug-in exists for Java source code.

• Flexibility—as new programming languages develop, the IDE can use new 
compiler plug-ins.

The IDE associates common file-name extensions with various plug-in compilers. For 
example, most Java files have the file-name extension .java. The IDE associates 
these files with the Java compiler. The File Mappings panel provides control over 
such associations.
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Compiling Projects
Compile projects to process the source files that comprise a computer program and 
generate object code. The compiler flags syntax errors in the source files.

Use these tasks to compile projects:

• Compile source files.

• Set the build order or link order.

• Update a project or its files.

• Create an executable file from a project.

• Run an application created from the project.

• Remove object code.

This section explains how to perform each task.

Compiling Source Files

Use the Compile commands to compile source files into binary files. The IDE can 
compile a single file, multiple files, or all files in an open project.

1. Enable the Project window that contains the desired files to be compiled.

2. Select one or more files.

3. Choose Project > Compile.

The IDE compiles the selected files.

NOTE The Project menu contains most commands for compiling and 
linking projects. However, depending on the project type, some 
commands might be disabled or renamed.

Setting the Build and Link Order of Files

Use the Link Order view in the Project window to specify the order in which the 
compiler and linker process files. Establishing the proper link order prevents link 
errors caused by file dependencies. The Link Order view is sometimes called the 
Segments view or Overlays view, depending on the target.
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1. Click the Link Order tab in a Project window.

2. Click and drag files into the desired link order.

The IDE changes the link order. The build begins at the top of the link order, processes 
each file, and concludes at the bottom of the link order.

NOTE The IDE uses the new link order during subsequent Update, Make, 
Run, and Debug operations.

Updating Projects

Use the Bring Up To Date command to compile, but not link, the newly added, 
modified, and touched files in a project. Unlike the Make and Run commands, the 
Bring Up To Date command does not produce a binary file.

1. Select the project to update.

2. Choose Project > Bring Up To Date.

The IDE compiles all uncompiled project files.

Making Executable Files

Use the Make command to compile the newly-added, modified, and touched files in a 
project, then link them into a binary file. Unlike the Run command, the Make 
command does not execute the binary file. The Make command is useful for creating 
dynamic link libraries (DLLs), shared libraries, code resources, or tools.

1. Select the project to make.

2. Choose Project > Make.

The IDE processes the project and creates a binary file.

Running Application Projects

Use the Run command to perform these tasks:

• Compile and link a project (if necessary).
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• Create a standalone application.

• Change project settings (if required).

• Save the application.

• Run the application.

Note, the Run command is not available if the project creates a non-executable file 
like a dynamic linked library (DLL), shared library, library, code resource, or tool.

1. Select the project to run.

2. Choose Project > Run.

Synchronizing File Modification Dates

Use the Synchronize Modification Dates command to update the modification dates 
of all files stored in a project. This command is useful for handling files from a third-
party editor that does not share file-status information with the IDE.

1. Select the project window.

2. Choose Project > Synchronize Modification Dates.

The IDE checks the file-modification dates and marks modified files for re-
compilation.

Removing Object Code

Use the Remove Object Code command to remove binary object code stored in the 
project file and reduce project size.

1. Open the desired project to remove object code.

2. Choose Project > Remove Object Code.

3. Set compaction options as desired.

• Select Recurse subprojects to remove object code from all subprojects in the 
project file.

• Select Compact targets to remove these items:

– Target data files with the .tdt extension.

– Browser data.
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– Dependency information.

– Additional data cached by the IDE.

4. Select the method by which the IDE removes the object code.

• Click All Targets to remove object code from all build targets.

• Click Current Target to remove object code only from the active build target.

The IDE removes the specified object code from the project.
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Linkers

This chapter explains how to work with linkers in the CodeWarrior™ IDE. The IDE 
uses linkers to complete these tasks:

• Combine code—the linker combines source-file object code with object code 
from library files and other related files. The combined code represents a 
complete computer program.

• Create a binary file—the linker processes the complete computer program and 
generates a binary file. Sample binary files include applications and shared 
libraries.

Read this chapter to learn more about typical tasks for working with linkers.

This chapter contains these sections:

• Choosing Linkers

• Linking Projects

Choosing Linkers
Choose a linker to determine the binary file type produced by the IDE. This list 
describes common binary files:

• Applications—applications, or executable files, represent a wide body of 
computer programs. Common applications include word processors, web 
browsers, and multimedia players.

• Libraries—libraries contain code for use in developing new computer programs. 
Libraries simplify programming tasks and enhance re-usability.

• Specialized files—files designed for highly efficient operation in a specific 
context. Such files usually support a particular combination of hardware and 
software to perform tasks.

The IDE provides various linkers for software development. The Target Settings 
panel contains an option for selecting a linker. The IDE maps to each linker a group of 
recognized file-name extensions. These mappings determine how the IDE interprets 
each file.
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Linking Projects
Link projects to process object code and generate a binary file. Refer to the 
CodeWarrior Targeting documentation for more information about linkers for specific 
computer systems. This section explains general-purpose linker tasks.

Generating Project Link Maps

Use the Generate Link Map command to create a link-map file that contains function 
and cross-section information about the generated object code. The link map reveals 
the files, libraries, and functions ignored by the IDE while producing the binary 
output.

The IDE stores the link-map file in the project folder. The file uses the same name as 
the build target, with a .MAP or .xMAP extension.

1. Select the project window.

2. Choose Edit > target_name Settings.

3. Select the linker panel in the Target Settings Panels list.

4. Select the Generate Link Map option.

5. Click Save.

6. Choose Project > Make.

The IDE generates the link-map file.
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Preferences and Target 
Settings

This section contains these chapters:

• Customizing the IDE

• Working with IDE Preferences

• Working with Target Settings

• Preference and Target Settings Options
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Customizing the IDE

The CodeWarrior™ IDE enables you to customize menus, toolbars, and key bindings 
to suit your programming preferences. Use the Customize IDE Commands 
window—which consists of the Commands, Toolbar Items, and Key Bindings tabs—
to build your customizations.

This chapter contains these sections:

• “Customizing IDE Commands” on page 317

• “Customize Toolbars” on page 328

• “Customize Key Bindings” on page 334

Customizing IDE Commands
You can customize the menu commands in the IDE’s menu bar, as well as control the 
appearance of specific menu commands, create new command groups to distinguish 
menu commands, and associate a command line (Windows, Solaris, and Linux) or a 
script or application (Mac OS) with a new menu command. The customized menu 
commands you create have access to IDE information, such as the current editor 
selection, the frontmost window, and the current project and its output file.

Figure 25.1 on page 318 shows the Customize IDE Commands window. Table 25.1 on 
page 318 has a high-level explanation of each button in the window. See the tasks in 
this chapter for more detailed information.
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Figure 25.1  Customize IDE Commands window

Table 25.1  Customize IDE Commands window—button overview

Button name Explanation

New Group Click to add a new command group to the Commands list.

New Command Click to add a new command setting within a group.

Factory Settings Click to restore the default options for the current Customize IDE Commands 
(Commands and Toolbar Items) lists.

Revert Click to restore the most recently saved options for the current Customize IDE 
Commands (Commands and Toolbar Items) lists.

Export Click to save a file that contains commands and key bindings to use later in the 
Customize IDE Commands lists.

Import Click to open a file that contains commands and key bindings to use in the 
current Customize IDE Commands lists.

Save Click to save customizations to the Customize IDE Commands list.
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Commands Tab
Click the Commands tab at the top of the Customize IDE Commands window to 
display the commands view. Use this view to modify existing menu commands, and to 
create and remove command groups and menu commands.

Modifying Existing Commands

You can use the Commands tab of the Customize IDE Commands window to 
examine and modify existing command groups and menu commands. This view 
includes a Commands list. This hierarchical list organizes individual menu commands 
into command groups. Click the hierarchical control next to a command group to 
expand that group and view its contents.

To examine a particular item, select it in the Commands list. The information for the 
selected item appears on the right-hand side of the Customize IDE Commands 
window. This window provides this information for each selected item:

• Name—This field shows the name of the selected item. If the IDE does not 
permit you to change the name of the selected items, this field is grayed out.

• Appears in Menus—Enable this checkbox to display the selected item in the 
specified position in the CodeWarrior menu bar. For example, enabling this 
checkbox for the RunApp menu command allows that menu command to appear 
under the MyMenu command group in the menu bar. Disabling the checkbox 
prevents the RunApp menu command from appearing in the menu bar under the 
MyMenu command group.

• Action—This section shows information about the action the selected item 
performs. For default menu commands, this section shows the command type, 
such as Command or Hierarchical Menu. For customized menu commands 
that you create, this section lets you specify a command line (Windows, Solaris, 
and Linux) or a script (Mac OS) that runs after you choose the customized menu 
command.

• Key Bindings—This area consists of the Key Bindings list, the New Binding 
button, and the Auto Repeat checkbox.

Creating a New Command Group

To create a new command group for menu commands, follow these steps:
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1. Click the New Group button.

The IDE creates a new command group called New Group, adds it to the Commands 
list, and displays its information in the Customize IDE Commands window.

2. Rename the new command group in the Name field.

Change the default name of New Group to describe your new command group.

3. Use the Appears in Menus checkbox to toggle the appearance of the new 
command group in the IDE menu bar.

Select the Appears in Menus checkbox to display the new command group in the 
menu bar. Clear the checkbox if you do not want the command group to appear in 
the menu bar.

4. Click Save.

The IDE saves your new command group. If you selected the Appears in Menus 
checkbox, your new command group appears in the menu bar.

Figure 25.2  New Command group
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Creating a New Menu Command

To create a new menu command, follow these steps:

1. Select the command group you want to contain the new menu command.

You must select an existing command group in the Commands list.

2. Click the New Command button.

The IDE creates a new menu command named New Command and places it within 
the selected command group. The information for the new menu command appears in 
the Customize IDE Commands window.

3. Enter a name for the new menu command.

You can change the default name of New Command. Enter a new name in the Name 
field of the Customize IDE Commands window.

4. Use the Appears in Menus checkbox to toggle the appearance of the new 
command within its command group.

5. Define the desired Action for the new menu command.

6. Click Save.

The IDE saves your new menu command. If you enabled the Appears in Menus 
checkbox, the new menu command appears within the selected command group.
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Figure 25.3  Command action fields

Defining Command Actions (Windows)

These fields help you associate an action with the new menu command:

• Execute—Enter in this field a command to run an application. Alternatively, 
click the ellipsis button next to the field to select the application using a standard 
dialog box.

• Arguments—Enter in this field the arguments that the IDE must pass to the 
application specified in the Execute field. Alternatively, choose the desired 
arguments from the pop-up menu next to the field.

• Directory—Enter in this field the working directory the IDE should use when it 
executes the application specified in the Execute field. Alternatively, choose the 
desired directory from the pop-up menu next to the field.
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Pre-defined Variables in Command 
Definitions
The IDE provides pre-defined variables for Windows, Solaris, and Linux (not Mac 
OS) to associate actions with commands. When you create a new command, you can 
use these pre-defined variables in command definitions to provide additional 
arguments that the IDE passes to the application (which is specified in the Execute 
field).

NOTE You can use variables that end with Dir as both argument and 
directory names.

Figure 25.4  Pre-defined Arguments variables
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Figure 25.5  Pre-defined Directory variables

Table 25.2 explains the pre-defined variables for command-line arguments.

Table 25.2  Pre-defined variables in command definitions

Variable Command-line output

%sourceFilePath sourceFilePath is the frontmost editor window's full path.

%sourceFileDir sourceFileDir is the frontmost editor window's directory.

%sourceFileName sourceFileName is the frontmost editor window's filename.

%sourceLineNumber sourceLineNumber is the line number of the insertion point in the front 
window.

%sourceSelection sourceSelection is the path to a temporary file containing the currently 
selected text.

%sourceSelUpdate sourceSelUpdate is like sourceSelection, except the IDE waits for the 
command to finish and updates the selected text with the contents of the file.
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Using a Pre-defined Variable

To use a pre-defined variable, follow these steps:

1. Create a new menu command.

The IDE creates a new menu command named New Command and places it 
within your selected command group. The information for the new menu 
command appears in the Customize IDE Commands window.

2. Enter a name for the new menu command.

You can change the default name of New Command. Enter a new name in the 
Name field of the Customize IDE Commands window.

3. Use the Appears in Menus checkbox to toggle the appearance of the new 
command within its command group.

%projectFilePath projectFilePath is the full path of the front project window.

%projectFileDir projectFileDir is the directory of the front project window.

%projectFileName projectFileName is the filename of the front project window.

%projectSelectedFiles %projectSelectedFiles passes the selected filenames in the project 
window.

%targetFilePath targetFilePath is the full path of the output file of the front project.

%targetFileDir targetFileDir is the directory of the output file of the front project.

%targetFileName targetFileName is the filename of the output file of the front project.

%currentTargetName %currentTargetName passes the name of the current target of the 
frontmost window.

%symFilePath symFilePath is the full path to the symbolics file of the front project (can be 
the same as targetFile, such as CodeView).

%symFileDir symFileDir is the full directory to the symbolics file of the front project (can 
be the same as targetFile, such as CodeView)

%symFileName symFileName is the full filename to the symbolics file of the front project 
(can be the same as targetFile, such as CodeView)

Table 25.2  Pre-defined variables in command definitions (continued)

Variable Command-line output
325IDE 5.5 User’s Guide 



Customizing the IDE
Customizing IDE Commands
4. Define the Action for the new menu command.

a. Enter in the Execute field a command line to run an application.

b. Next to the Arguments field, click on the arrow icon and select an 
argument listed in the pop-up menu.

c. Next to the Directory field, click on the arrow icon and select a directory 
listed in the pop-up menu.

5. Click Save.

The IDE saves your new menu command with the pre-defined variables. If you 
enabled the Appears in Menus checkbox, the new menu command appears within the 
selected command group.

Defining Command Actions (Mac OS)

After you create a new menu command the Customize IDE Commands window 
shows the Run App/Script field. This field appears in the Action section of the 
window. 

1. Click the Choose button next to the field to display a standard Open dialog box.

2. Use the dialog box to select an application or script.

The IDE launches this application or script each time you choose the menu 
command. The path to the selected application or script appears in the Run App/
Script field.

Deleting Command Groups and Menu Commands

You can delete the command groups and menu commands that you create for the IDE. 
Once removed, the command groups no longer appear in the IDE’s menu bar, and the 
menu commands no longer activate their associated command lines (Windows) or 
applications or scripts (Mac OS).

NOTE If you need to temporarily remove your customized command groups 
and menu commands, consider exporting your settings. If you export 
your settings, you do not need to reconstruct them if you want them 
in the future.
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Figure 25.6  Delete Command group

To delete a command group or menu command, follow these steps:

1. Select the command group or menu command you wish to delete.

If necessary, click the hierarchical control next to a group to expand and view its 
contents.

2. Click Delete.

After clicking the Delete button, the selected command group or menu command 
disappears from the Commands list.

3. Click Save.

Clicking the Save button confirms the deletion. The IDE removes deleted command 
groups from its menu bar. Deleted menu commands disappear from their respective 
command groups.
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Customize Toolbars
You can customize your IDE toolbars to contain frequently used commands.

The IDE toolbars contain a series of elements. Each element typically represents a 
menu command. After you click the element, the IDE executes the associated menu 
command. The toolbar can also contain elements that execute actions other than menu 
commands.

Figure 25.7  Toolbar Items tab

This section explains these topics:

• “Kinds of Toolbars” on page 329

• “Toolbar Elements” on page 329

• “Modify a Toolbar” on page 330
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Kinds of Toolbars
The CodeWarrior IDE uses two toolbar types:

• Main toolbar—This toolbar, also known as the floating toolbar, is always 
available.

• Window toolbars—These toolbars appear in particular windows, such as the 
Project window toolbar and the Browser window toolbar.

This distinction is important because you show, hide, clear, and reset the different 
toolbar types by using different sets of menu commands. These commands distinguish 
between the floating toolbar and the other window toolbars.

When you change one of these toolbar types, that change applies to every instance of 
that toolbar type you subsequently create. For example, if you modify the toolbar in an 
editor window, your changes appear in all editor windows opened thereafter.

Figure 25.8  Main toolbar

Figure 25.9  Project window toolbar

Toolbar Elements
A toolbar can contain these elements:

• Commands—buttons that you click to execute IDE menu commands

• Controls—menus, such as Document Settings, Functions, Header Files, Markers, 
Version Control, and Current Target

• Miscellaneous—other elements, such as the File Dirty Indicator and File Path 
field

• Scripts (Mac OS)—buttons that you click to execute one of the scripts available 
through the Scripts menu
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Click the Toolbar Items tab at the top of the Customize IDE Commands window to 
display the Toolbar view. Use this view to add new elements to a toolbar.

Modify a Toolbar
You can modify a toolbar in these ways:

• Add a toolbar element

• Remove a toolbar element

• Clear all elements on a toolbar

• Reset a toolbar

In certain circumstances there are restrictions on which elements you can add or 
remove from a toolbar. For example, you cannot add a second instance of an element 
to the toolbar.

After you modify a toolbar, the changes apply to every instance of that toolbar. For 
example, if you customize the Project window toolbar, those changes will affect every 
Project window that you open, not just the toolbar in the active Project window. Your 
changes do not affect windows that are already open.

TIP To display a ToolTip that names a toolbar element, rest the cursor 
over the element. On the Mac OS 9-hosted IDE, activate Balloon 
Help and rest the cursor over the element.

Adding a Toolbar Element

You add an element to a toolbar by dragging and dropping it from the Toolbar Items 
list onto a toolbar. This list is in the Toolbar Items view in the Customize IDE 
Commands window.

To add an element to a toolbar, follow these steps:

1. From the Toolbar Items list, select the icon next to the element that you want to 
add to a toolbar.

Make sure that the destination toolbar is visible.
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2. Drag the element’s icon from the Toolbar Items list to the destination toolbar.

On the Windows-hosted IDE, if the destination toolbar accepts the element, a 
framing bracket appears in the toolbar. This framing bracket shows you where the 
new element will appear after you release the cursor. If the destination toolbar 
does not accept the element, the framing bracket does not appear.

3. Release the element at the desired position.

After you release the element, the IDE inserts the element into the
destination toolbar.

The toolbar might not accept an element for these reasons:

• The toolbar is full.

• The element already exists in the toolbar.

• You cannot use the element in the toolbar because the window does not support 
that element.

• You cannot add these elements to any toolbar except the editor window toolbar: 
Document Settings, Functions, Header Files, Markers, and Version Control 
menus; File Dirty Indicator; and File Path field.

• You cannot add the Current Target menu element to any toolbar except the 
Project window toolbar.

Removing a Toolbar element

You remove a toolbar element by selecting it and using a contextual menu command 
to remove it from the toolbar.

To remove an element from a toolbar, follow these steps:

1. Display a contextual menu for the button that you want to remove, as explained in 
Table 25.3 on page 331.

Table 25.3  Displaying a contextual menu for a toolbar button

On this host... Do this...

Windows Right-click the button.

Macintosh Control-click the button.

Solaris Control-click the button.

Linux Ctrl-click the button.
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2. Select the Remove Toolbar Item command from the contextual menu.

The IDE removes the button from the toolbar.

Clearing All Buttons on Toolbars

You can clear all elements from a toolbar and build your own toolbar from scratch. 
Table 25.4 explains how to clear the main (floating) toolbar and window toolbars.

Reset Toolbars

Reset a toolbar to restore its default button set.explains how to reset the main (floating) 
toolbar and window toolbar by using menu commands.

Table 25.4  Clearing toolbars

On this host… Do this to clear the
main toolbar…

Do this to clear the
window toolbar…

Windows Select View > Toolbars >
Clear Main Toolbar.

Select View > Toolbars >
Clear Window Toolbar.

Macintosh Select Window > Toolbar 
> Clear Floating Toolbar.

Select Window > Toolbar 
> Clear Window Toolbar.

Solaris Select Window > Toolbar 
> Clear Floating Toolbar.

Select Window > Toolbar 
> Clear Window Toolbar.

Linux Select Window > Toolbar 
> Clear Floating Toolbar.

Select Window > Toolbar 
> Clear Window Toolbar.
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Alternatively, you can use a contextual menu to reset the main toolbar or a window 
toolbar. Once you reset the toolbar, the IDE restores the default toolbar button set. 
explains how to reset the main (floating) toolbar and window toolbar by using a 
contextual menu.

Table 25.5  Resetting a toolbar by using menu commands

On this host… Do this to reset the
main toolbar…

Do this to reset the
window toolbar…

Windows Select View > Toolbars >
Reset Main Toolbar.

Select View > Toolbars >
Reset Window Toolbar.

Macintosh Select Window > Toolbar 
> Reset Floating Toolbar.

Select Window > Toolbar 
> Reset Window 
Toolbar.

Solaris Select Window > Toolbar 
> Reset Floating Toolbar.

Select Window > Toolbar 
> Reset Window 
Toolbar.

Linux Select Window > Toolbar 
> Reset Floating Toolbar.

Select Window > Toolbar 
> Reset Window 
Toolbar.

Table 25.6  Resetting a toolbar by using a contextual menu

On this host… Do this to reset the
main toolbar…

Do this to reset the
window toolbar…

Windows Right-click the toolbar and 
select Reset Toolbar.

Right-click the toolbar and 
select Reset Toolbar.

Macintosh Control-click the toolbar and 
select Reset Toolbar.

Control-click the toolbar and 
select Reset Toolbar.

Solaris Click and hold on the toolbar, 
then select Reset Toolbar.

Click and hold on the toolbar, 
then select Reset Toolbar.

Linux Click and hold on the toolbar, 
then select Reset Toolbar.

Click and hold on the toolbar, 
then select Reset Toolbar.
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Customize Key Bindings
You can customize the keyboard shortcuts, known as key bindings, for various 
commands in the CodeWarrior IDE. You can bind a set of keystrokes to virtually any 
command. To activate the command, type its associated key binding. Use the 
Customize IDE Commands window to change IDE key bindings.

You can also use the Customize IDE Commands window to look up default key 
bindings for specific commands, as well as change existing key bindings to better suit 
your needs.

Click the Commands tab at the top of the Customize IDE Commands window to 
display the Commands view. Use this view to configure the key bindings for menu 
commands, editor actions, and other actions. You can also specify prefix keys.

This section has these topics:

• Modifying key bindings

• Adding key bindings

• Deleting key bindings

• Setting Auto Repeat for key bindings

• Exporting commands and key bindings

• Importing commands and key bindings
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Figure 25.10  Customize IDE Commands—Key Bindings

Adding Key Bindings

Use the Customize IDE Commands window to specify additional key bindings for a 
particular command.

To add a key binding, follow these steps:

1. From the Commands list, select the command to which you want to add a new key 
binding.

Click the hierarchical controls next to the command categories to expand them as 
necessary so that you can see individual commands. Select the individual 
command you wish to modify.
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NOTE If you want to use your keyboard’s numeric keypad as part of the 
new key binding, enable the Numeric Keypad Bindings checkbox 
in the Customize IDE Commands window.

2. Click New Binding.

After clicking this button, the Edit Key Binding dialog box appears.

Figure 25.11  Edit Key Bindings

3. Create the key combination you would like to use for the selected command.

For example, to add the key combination Ctrl-8, hold down the Ctrl key and press 
the 8 key, then release both keys at the same time.

If you decide against the key combination that you just entered, or if you make a 
mistake, click Cancel in the Edit Key Binding dialog box. The IDE discards 
changes and returns you to the Customize IDE Commands window.

4. Click OK in the Edit Key Binding dialog box.

The new key binding appears in the Key Bindings list in the Customize IDE 
Commands window.

5. Click Save in the Customize IDE Commands window to save your changes.

The new key binding is now available for use in the IDE.

Exporting Commands and Key Bindings

You can export to a file the custom commands and key bindings that you use with the 
IDE. You can then import the file into another IDE running on a different computer in 
order to transfer all of your custom commands and key bindings. This process 
simplifies your setup on the other computer because you do not have to recreate your 
custom commands and key bindings manually.
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NOTE After you import your custom commands and key bindings into 
another computer, the IDE running on that computer first sets all its 
commands and key bindings to their default values, then imports 
your custom commands and key bindings.

To export your custom commands and key bindings, follow these steps:

1. Click Export in the Customize IDE Commands window.

After you click this button, a standard Save dialog box appears.

2. Select a location in which to save the Commands&KeyBindings.mkb file.

This file contains information about your custom commands and key bindings.

3. Click Save.

The IDE saves the Commands&KeyBindings.mkb file at the selected location.

TIP You can rename the Commands&KeyBindings.mkb file, but 
remember to preserve the .mkb extension. This extension identifies 
the file as a Metrowerks Key Bindings file. Furthermore, the 
Windows-hosted version of the CodeWarrior IDE uses this extension 
to properly recognize the commands and key bindings file.

Importing Commands and Key Bindings

You can import custom commands and key bindings from a previously exported file. 
Commands&KeyBindings.mkb is the default name of an exported file for custom 
commands and key bindings.

NOTE After you import your custom commands and key bindings into 
another computer, the IDE running on that computer first sets all its 
commands and key bindings to their default values, then imports 
your custom commands and key bindings.

To import commands and key bindings, follow these steps:
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1. Click Import in the Customize IDE Commands window.

After you click this button, a standard Open dialog box appears.

2. Use the dialog box to find and open the Commands&KeyBindings.mkb file that 
you want to import.

The IDE adds the custom commands and key bindings to the Customize IDE 
Commands window.
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Preferences

This chapter explains core CodeWarrior™ IDE preference panels and provides basic 
information on global- and project-level preference options. Consult the Targeting 
documentation for information on platform-specific preference panels.

This chapter contains these sections:

• “IDE Preferences Window” on page 339

• “General Panels” on page 341

• “Editor Panels” on page 355

• “Debugger Panels” on page 366

Abbreviated descriptions appear in this chapter. See “Preference and Target Settings 
Options” on page 399 for more information on preference-panel options.

IDE Preferences Window
The IDE Preferences window lists global IDE preference options. These preferences, 
unless superseded by a Target Settings option, apply to every open project file.

The IDE Preferences window lists preferences by group:

• General—configures overall IDE preferences, such as project builds, recent 
items, and third-party tools

• Editor—configures editor preferences, such as fonts, tabs, and syntax coloring

• Debugger—configures debugger preferences, such as window hiding during 
debugging sessions, low-level interactions, and variable highlighting
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Figure 26.1  IDE Preferences window

Table 26.1  IDE Preferences window—items

Item Explanation

IDE Preference Panels list Lists preference panels, organized by group. Click the hierarchical 
control next to a group name to show or hide individual
preference panels.

Preference panel Shows the options for the selected item in the IDE Preference 
Panels list.

Factory Settings Click to restore the default options for the current preference panel.

Revert Panel Click to restore the most recently saved options for the current 
preference panel.

Export Panel Click to save an XML file that contains options for the current 
preference panel.

Import Panel Click to open an XML file that contains options for the current 
preference panel.
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Opening the IDE Preferences Window

Use the IDE Preferences window to modify global general, editor, and
debugger options.

To open the IDE Preferences window, select Edit > Preferences.

General Panels
The General section of the IDE Preference Panels list defines the basic options 
assigned to a new project.

The General preference panels available on most IDE hosts include:

• “Build Settings” on page 341

• “Concurrent Compiles” on page 343

• “IDE Extras” on page 344

• “Help Preferences” on page 348

• “Plugin Settings” on page 348

• “Shielded Folders” on page 349

• “Source Trees” on page 351

Build Settings
The Build Settings preference panel provides options for customizing various aspects 
of project builds, including:

OK (Windows) Click to save modifications to all preference panels and close
the window.

Cancel (Windows) Click to discard modifications to all preference panels and close
the window.

Apply (Windows) Click to confirm modifications to all preference panels.

Save (Macintosh, Solaris, and 
Linux)

Click to save modifications to all preference panels.

Table 26.1  IDE Preferences window—items (continued)

Item Explanation
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• file actions during project builds

• memory usage to accelerate builds

• local data storage of projects stored on read-only volumes

Figure 26.2  Build Settings preference panel (Windows)

Figure 26.3  Build Settings preference panel (Macintosh)
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Concurrent Compiles
The Concurrent Compiles preference panel controls execution of simultaneous IDE 
compilation processes. The IDE lists this panel in the IDE Preference Panels list when 
the active compiler supports concurrency.

The IDE uses concurrent compiles to compile code more efficiently. The IDE 
improves its use of available processor capacity by spawning multiple compile 
processes, which allow the operating system to perform these tasks as needed:

• optimize resource use

• use overlapped input/output

For those compilers that support concurrency, concurrent compiles improve compile 
time on both single- and multiple-processor systems.

Table 26.2  Build Settings preference panel—items

Item Explanation

Play sound after ‘Bring Up To 
Date’ & ‘Make’ (Macintosh, 
Solaris, and Linux)

Select to have the IDE play an alert sound after completing a
Bring Up To Date or Make command.

Success (Macintosh, Solaris, 
and Linux)

Choose the sound the IDE plays after successfully completing a 
Bring Up To Date or Make command.

Failure (Macintosh, Solaris, and 
Linux)

Choose the sound the IDE plays after failing to complete a
Bring Up To Date or Make command.

Build before running Choose to always build the project before running it, never build the 
project before running it, or ask for the desired action.

Save open files before build Select to automatically save the contents of all editor windows before 
starting a build.

Show message after building 
up-to-date project

Select to have the IDE display a message after successfully building 
a project.

Include file cache (Macintosh) Enter the kilobytes of memory to allocate to the file cache used for 
#include files during a project build.

Compiler thread stack 
(Windows and Macintosh)

Enter the kilobytes of memory to allocate to the stack for execution of 
the IDE compiler thread. Increase the size when compiling heavily 
optimized code.

Use Local Project Data Storage Select to specify a location to save project data if the project is on a 
read-only volume. Click Choose to select the location.
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Figure 26.4  Concurrent Compiles preference panel

IDE Extras
The IDE Extras preference panel provides options for customizing various aspects of 
the IDE, including:

• menu-bar layout

• the number of recent projects, document files, and symbolics files to remember

• use of a third-party editor

Table 26.3  Concurrent Compiles preference panel—items

Item Explanation

Use Concurrent Compiles Select to have the IDE run multiple compilation processes 
simultaneously.

Recommended Select to allow the number of concurrent compiles suggested by
the IDE.

User Specified Select to stipulate the number of concurrent compiles.
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Figure 26.5  IDE Extras preference panel (Windows)

Figure 26.6  IDE Extras preference panel (Macintosh)
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Table 26.4  IDE Extras preference panel—items

Item Explanation

Menu bar layout Choose a layout that organizes IDE menus into a typical host-
platform menu bar. Restart the IDE in order for menu-bar layout 
changes to take effect.

Projects Enter the number of recently opened projects for the IDE to display in 
the Open Recent submenu. Enter zero to disable this feature.

Documents Enter the number of recently opened documents for the IDE to 
display in the Open Recent submenu. Enter zero to disable
this feature.

Symbolics Enter the number of recently opened symbolics files for the IDE to 
display in the Open Recent submenu. Enter zero to disable
this feature.

Workspaces Enter the number of recently opened workspaces for the IDE to 
display in the Open Recent submenu. Enter zero to disable this 
feature.

Context popup delay 
(Macintosh, Solaris, and Linux)

Enter the number of ticks to wait before displaying contextual menus. 
A tick is 1/60 of a second.

Use Third Party Editor 
(Windows)

Select to use a third-party text editor to edit source files.

Launch Editor (Windows) Enter a command-line expression that runs the desired third-party 
text editor.

Launch Editor w/ Line # 
(Windows)

Enter a command-line expression that runs the desired third-party 
text editor and passes to that editor an initial line of text to display.

Use Multiple Document 
Interface (Windows)

Select to have the IDE use the Multiple Document Interface (MDI). 
Clear to have the IDE use the Floating Document Interface (FDI). 
Restart the IDE in order for interface changes to take effect.

Zoom windows to full screen 
(Macintosh, Solaris, and Linux)

Select to have zoomed windows fill the entire screen. Clear to have 
zoomed windows in a default size.

Use Script menu (Macintosh, 
Solaris, and Linux)

Select to display the Scripts menu in the menu bar. Clear to remove 
the Scripts menu from the menu bar.

Use External Editor (Macintosh, 
Solaris, and Linux)

Select to use a third-party text editor to edit text files in the current 
project. Clear to use the editor included with the IDE.

Use ToolServer menu
(Classic Macintosh)

Select to display the ToolServer menu in the menu bar. Clear to 
remove the ToolServer menu from the menu bar.
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Using an External Editor on the Macintosh

To use an external editor on the Macintosh, the IDE sends AppleEvents to an alias file 
that points to the editor application. Manually configure the IDE to use an external 
editor.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the IDE Extras panel from the IDE Preference Panels list.

3. Select the Use External Editor option.

4. Click Save.

The IDE is now prepared to use an external editor application. To specify the external 
editor to use:

1. Find and open the CodeWarrior folder.

2. Create a folder named (Helper Apps) inside the CodeWarrior folder (if it does 
not already exist).

3. Make an alias of the desired editor application.

4. Place the alias file inside the (Helper Apps) folder.

5. Rename the alias file External Editor.

6. Restart the IDE in order for changes to take effect.

The IDE now uses the aliased external editor.

Enable automatic Toolbar help 
(Classic Macintosh)

Select to display Balloon Help after resting the cursor over a toolbar 
icon. Clear to prevent Balloon Help from appearing.

Use default workspace Select this option to have the IDE use the default workspace to save 
and restore state information. Clear this option to have the IDE 
always start in the same state.

Find Reference using 
(Macintosh)

Choose an online browser application to view reference information 
and definitions.

Table 26.4  IDE Extras preference panel—items (continued)

Item Explanation
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Help Preferences
The Help Preferences panel, available on the Solaris and Linux IDE hosts, specifies 
the browser used for viewing IDE online help.

Figure 26.7  Help Preferences panel

Plugin Settings
The Plugin Settings preference panel contains options for troubleshooting third-party 
IDE plug-ins.

Table 26.5  Help Preferences panel—items

Item Explanation

Browser Path Enter a path to the browser to use for viewing IDE online help. 
Alternatively, use the Set button.

Set Click to select the path to the browser to use for viewing IDE
online help.
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Figure 26.8  Plugin Settings preference panel

Shielded Folders
The Shielded Folder preference panel enables the IDE to ignore specified folders 
during project operations and find-and-compare operations. The IDE ignores folders 
based on matching names with regular expressions defined in the preference panel.

NOTE If the Access Paths settings panel in the Target Settings window 
contains a path to a shielded folder, the IDE overrides the shielding 
and includes the folder in project operations and find-and-compare 
operations.

Table 26.6  Plugin Settings preference panel—items

Item Explanation

Level Choose the plug-in diagnostics level the IDE generates the next time 
it loads plug-ins. Restart the IDE in order for diagnostic-level 
changes to take effect.

Disable third party COM plugins Select to prevent the IDE from loading third-party Common Object 
Model (COM) plug-ins.
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Figure 26.9  Shielded Folders preference panel

Table 26.7  Shielded Folders preference panel—items

Item Icon Explanation

Shielded folder list Lists folders that match the specified regular expression. 
The IDE skips these folders during project operations, find-
and-compare operations, or both operations.

Regular Expression Enter the regular expression used to shield folders from 
selected operations.

Project operations Select to have the IDE skip folders during project 
operations. A bullet appears in the corresponding column 
of the shielded folder list.

Find and compare operations Select to have the IDE skip folders during find-and-
compare operations. A bullet appears in the corresponding 
column of the shielded folder list.

Add Click to add the current Regular Expression field entry to 
the shielded folder list.
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Source Trees
Use the Source Trees panel to add, modify, and remove source trees (root paths) used 
in projects. Use source trees to define common access paths and build-target outputs to 
promote sharing of projects across different hosts. Source trees have these scopes:

• Global source trees, defined in the IDE Preferences window, apply to all 
projects.

• Project source trees, defined in the Target Settings window for a particular 
project, apply only to files in that project. Project source trees always take 
precedence over global source trees.

Except for the difference in scope, global and project source trees operate identically.

Change Click to replace the selected regular expression in the 
shielded folder list with the current Regular Expression 
field entry.

Remove Click to delete the selected regular expression from the 
shielded folder list.

Table 26.8  Default regular expressions in Shielded Folders panel

Regular Expression Explanation

\(.*\) Matches folders with names that begin and end with parentheses, 
such as the (Project Stationery) folder.

CVS Matches folders named CVS. With this regular expression, the IDE 
skips Concurrent Versions System (CVS) data files.

.*[_]Data Matches the names of folders generated by the IDE that store target 
data information, such as a folder named MyProject_Data.

Table 26.7  Shielded Folders preference panel—items (continued)

Item Icon Explanation
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Figure 26.10  Source Trees panel

Table 26.9  Source Trees panel—items

Item Explanation

Source Tree list Contains the Name and Path of currently defined source trees.

Name Enter in this field a name for a new source tree or modify the name of 
a selected source tree.

Type Choose the source-tree path type.

Choose Click to select or modify a source-tree path.

Add Click to add a new source-tree path to the Source Tree list.

Change Click to modify the selected source-tree name or path.

Remove Click to delete the selected source tree from the Source Tree list.
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Adding Source Trees

Add source trees that define root paths for access paths and build-target output.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Source Trees panel from the IDE Preference Panels list.

3. Enter in the Name field a name for the new source tree.

4. Choose the source tree Type:

• Absolute Path—defines a path from the root level of the hard drive to a desired 
folder, including all intermediate folders

• Environment Variable—(Windows, Solaris, and Linux) defines an environment 
variable in the operating environment

• Registry Key—(Windows) defines a key entry in the operating-environment 
registry

5. Enter the source-tree definition:

• For Absolute Path—Click Choose to display a subordinate dialog box. Use the 
dialog box to select the desired folder. The absolute path to the selected folder 
appears in the Source Trees preference panel.

• For Environment Variable—Enter the path to the desired environment variable.

• For Registry Key—Enter the path to the desired key entry in the registry.

6. Click Add.

The IDE adds the new source tree to the Source Trees list.

7. Click OK, Apply, or Save.

The IDE saves the source-tree changes.

Changing Source Trees

Change a source tree to update path information for a project. The IDE must be able to 
resolve source trees before building the project.
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1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Source Trees panel from the IDE Preference Panels list.

3. Select the desired source tree in the Source Trees list.

4. If needed, enter in the Name field a new name for the selected source tree.

5. If needed, choose from the Type options a new path type for the selected source 
tree.

6. Click Change.

The IDE updates the source tree and displays changes in the Source Trees list. A 
reminder message to update source-tree references in the project appears.

7. Click OK, Apply, or Save.

The IDE saves the source-tree changes.

Removing Source Trees

Remove source trees that the project no longer uses. The IDE must be able to find the 
remaining source trees before building the project.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Source Trees panel from the IDE Preference Panels list.

3. Select the obsolete source tree from the Source Trees list.

4. Click Remove.

The IDE updates the Source Trees list. A reminder message to update source-tree 
references in the project appears.

5. Click OK, Apply, or Save.

The IDE saves the source-tree changes.

Removing Remote Connections

Remove a remote connection that the project no longer uses.
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1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Remote Connections panel from the IDE Preference Panels list.

3. Select from the Remote Connections list the obsolete remote connection.

4. Click Remove.

The IDE updates the Remote Connections list.

5. Click OK, Apply, or Save.

The IDE saves the remote-connection changes.

Editor Panels
The Editor section of the IDE Preference Panels list defines the editor settings 
assigned to a new project.

The Editor preference panels available on most IDE hosts include:

• “Code Completion” on page 355

• “Code Formatting” on page 356

• “Editor Settings” on page 358

• “Font & Tabs” on page 360

• “Text Colors” on page 362

Code Completion
The Code Completion preference panel provides options for customizing the IDE 
code-completion behavior, including:

• automatic invocation and indexing

• window positioning and appearance delay

• case sensitivity
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Figure 26.11  Code Completion preference panel

Code Formatting
The Code Formatting preference panel provides options for customizing editor code-
formatting behavior, including:

• indenting

• syntax placement

• brace handling

Table 26.10  Code Completion preference panel—items

Item Explanation

Automatic Invocation Select to automatically open the Code Completion window to 
complete programming-language symbols. Clear to manually open 
the window.

Window follows insertion point Select to have the Code Completion window follow the insertion 
point as you edit text. Clear to leave the window in place.

Display deprecated items Select to have the Code Completion window display obsolete items 
in gray text. Clear to have the window hide obsolete items.

Case sensitive Select to have the IDE consider case when completing code. Clear 
to have the IDE ignore case.

Code Completion Delay (ticks) Enter the number of ticks to wait before opening the Code 
Completion window. A tick is 1/60 of a second.
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Figure 26.12  Code Formatting preference panel

Table 26.11  Code Completion preference panel—items

Item Explanation

Use Automatic Code 
Formatting

Check to have the editor automatically format your source code 
according to the settings in this panel.

Clear to prevent the editor from automatically formatting your code.

Language Settings Use to specify the language type that you want to format. Your 
selection changes the other options in this panel to their default 
states for the selected language. 

Format braces Check to have the editor automatically insert a closing brace when 
you type an opening brace. The editor places the cursor between the 
opening brace that you typed and the closing brace that it inserts.

Clear to prevent the editor from automatically inserting a closing 
brace when you type an opening brace.
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Editor Settings
The Editor Settings preference panel provides options for customizing the editor, 
including:

• fonts, window locations, and insertion-point positions

Place opening brace on 
separate line

Check to have the editor place on the next line an opening brace that 
you type.

Clear to prevent the editor from placing on the next line an opening 
brace that you type.

Indent braces Check to have the editor indent braces by one tab stop from the 
previous line.

Clear to prevent the editor from indenting braces by one tab stop 
from the previous line.

Place “else” on same line as 
closing brace

Check to have the editor place else and else if text on the 
same line as the closing brace of the if or else if statement.

Clear to prevent the editor from placing else and else if text on 
the same line as the closing brace of the if or else if statement.

Indent code within braces Check to have the editor indent code by one tab stop from
the braces.

Clear to prevent the editor from indenting code by one tab stop from 
the braces.

Indent “case” within “switch” 
statement

Check to have the editor indent case statements by one tab stop 
inside a switch statement.

Clear to prevent the editor from indenting case statements by one 
tab stop inside a switch statement.

Close braces, brackets, and 
parentheses

Check to have the editor automatically insert the corresponding 
closing character when you type an opening brace, bracket, or 
parenthesis. The editor places the cursor between the opening 
character and the closing character.

Clear to prevent the editor from automatically inserting the 
corresponding closing character when you type an opening brace, 
bracket, or parenthesis.

Table 26.11  Code Completion preference panel—items (continued)

Item Explanation
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• contextual menus

• additional editor-window features

Figure 26.13  Editor Settings preference panel

Table 26.12  Editor Settings preference panel—items

Item Explanation

Font preferences Select to retain font settings for each source file. Clear to apply 
default font settings each time the IDE displays the source file.

Selection position Select to retain the text-insertion position in each source file.

Window position and size Select to retain the location and dimensions of each editor window.

Edit Commands Select to add Edit menu commands to contextual menus.

Browser Commands Select to add Browser menu commands to contextual menus. Also 
select in order to use the Insert Template Commands option.

Insert Template Commands
(Macintosh)

Select to add the Insert Template submenu to contextual menus. 
The submenu displays source-defined function templates.
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Font & Tabs
The Font & Tabs preference panel provides options for customizing settings used by 
the editor, including:

• font and font size used in editor windows

• auto indentation and tab size

• tabs on selections and replacing tabs with spaces

Project Commands Select to add Project menu commands to contextual menus.

VCS Commands Select to add VCS (Version Control System) menu commands to 
contextual menus.

Debugger Commands Select to add Debug menu commands to contextual menus.

Balance while typing Select to flash the matching (, [, or { after typing ), ], or } in an 
editor window.

Use multiple undo Select to allow multiple undo and redo operations while editing text.

Relaxed C popup parsing Select to allow the C parser to recognize some non-standard 
function formats and avoid skipping or misinterpreting some 
definition styles.

Drag and drop editing Select to allow drag-and-drop text editing.

Left margin click selects line Select to allow selection of an entire line of text by clicking in the left 
margin of the editor window.

Sort function popup Select to sort function names by alphabetical order in menus. Clear 
to sort function names by order of appearance in the source file.

Enable Virtual Space (Windows 
and Macintosh)

Select to allow moving the text-insertion point beyond the end of a 
source-code line. Entering new text automatically inserts spaces 
between the former end of the line and the newly entered text.

Balance Flash Delay Enter the number of ticks to flash a balancing punctuation character. 
A tick is1/60 of a second.

Default file format Choose the default end-of-line format used to save files.

Table 26.12  Editor Settings preference panel—items (continued)

Item Explanation
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Figure 26.14  Font & Tabs preference panel

Table 26.13  Font & Tabs preference panel—items

Item Explanation

Font Choose the typeface displayed in editor windows.

Size Choose the font size displayed in editor windows.

Script (Windows) Choose the IDE script system. The script system maps keyboard 
keys to characters of an alphabet.

Tab indents selection Select to indent each line of selected text after pressing Tab. Clear to 
replace selected text with a tab character after pressing Tab.

Tab Size Enter the number of spaces to substitute in place of a tab character. 
This number applies to the Tab Inserts Spaces option.

Auto Indent Select to automatically apply the indentation level from the previous 
line of text to each new line created by pressing Enter or Return.

Tab Inserts Spaces Select to insert spaces instead of a tab character into text after 
pressing Tab. The Tab Size option determines the number of 
inserted spaces.
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Setting the Text Font

To set the text font, follow these steps:

1. Choose Edit > Preferences.

2. Select the Font & Tabs panel in the Editor selection in the IDE Preference 
Panels list.

3. In the Font Settings area of the IDE Preferences window, select a font type in the 
drop-down menu in the Font field.

4. Save your font in the IDE Preferences window.

– Windows: Click OK.

– Macintosh: Click Save.

The foreground text changes to the new font.

Setting the Text Size

To set the text size, follow these steps:

1. Choose Edit > Preferences.

2. Select the Font & Tabs panel in the Editor selection in the IDE Preference 
Panels list.

3. In the Font Settings area of the IDE Preferences window, select the Size drop-
down menu and choose a text point size (from 2 points to 24 points).

4. Save your text size in the IDE Preferences window.

– Windows: Click OK.

– Macintosh: Click Save.

The foreground text changes to the new size.

Text Colors
The Text Colors preference panel customizes colors applied to elements of source 
code displayed in editor windows:

• default foreground and background in editor windows
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• standard comments, keywords, and strings in source code

• custom-defined keywords

• browser symbols

Default settings provide a simple scheme of at least four source-code colors. If four 
colors do not provide sufficient detail, modify this preference panel to create more 
sophisticated color schemes.

Figure 26.15  Text Colors preference panel

Table 26.14  Text Colors preference panel—items

Item Explanation

Foreground Click the color swatch to display a subordinate dialog box. Use the 
dialog box to set the foreground color used in editor windows for text.

Background Click the color swatch to set the background color used in
editor windows.

Activate Syntax Coloring Select to apply customized colors to comments, keywords, strings, 
and custom keywords in text. Clear to use the Foreground color for 
all text.
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Setting the Foreground Text Color

Use the Foreground Color option to configure the foreground text color displayed in 
editor windows.

Comments Click the color swatch to set the color used for source-code 
comments.

Keywords Click the color swatch to set the color used for source-code language 
keywords.

Strings Click the color swatch to set the color used for source-code string 
literals.

Set 1, Set 2, Set 3, Set 4 Click a color swatch to set the color used for the corresponding 
custom-keyword set.

Edit Click to add, modify, or remove keywords from the corresponding 
custom-keyword set.

Activate Browser Coloring Select to apply customized colors to browser symbols in text. Clear 
to use the Foreground color for all text.

Classes Click the color swatch to set the color used for source-code classes.

Constants Click the color swatch to set the color used for source-code 
constants.

Enums Click the color swatch to set the color used for source-code 
enumerations.

Functions Click the color swatch to set the color used for source-code 
functions.

Globals Click the color swatch to set the color used for source-code global 
variables.

Macros Click the color swatch to set the color used for source-code macros.

Templates Click the color swatch to set the color used for source-code 
templates.

TypeDefs Click the color swatch to set the color used for source-code type 
definitions.

Other Click the color swatch to set the color used for other symbols not 
specified in the Activate Browser Coloring section.

Table 26.14  Text Colors preference panel—items (continued)

Item Explanation
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1. Choose Edit > Preferences.

2. Select the Text Colors panel in the Editor selection in the IDE Preference 
Panels list.

3. Click the Foreground color box to set the editor’s foreground color.

4. Pick color.

5. Click OK in the Color Picker window.

6. Save your colors in the IDE Preferences window.

– Windows: Click OK.

– Macintosh: Click Save.

The foreground text color changes to the new color.

Setting the Background Text Color

Use the Background Color option to configure the background color displayed by all 
editor windows.

1. Choose Edit > Preferences.

2. Select the Text Colors panel in the Editor selection in the IDE Preference 
Panels list.

3. Click the Background color box to set the editor’s background color.

4. Pick color.

5. Click OK in the Color Picker window.

6. Save your colors in the IDE Preferences window.

– Windows: Click OK.

– Macintosh: Click Save.

The background text color changes to the new color.

Activate Syntax and Browser Coloring

Use the Activate Syntax Coloring and Activate Browser Coloring options to 
configure the syntax and browser colors that all your editor windows display.
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1. Choose Edit > Preferences.

2. Select the Text Colors panel in the Editor selection in the IDE Preference 
Panels list.

3. Select the checkbox next to the Activate Syntax Coloring or the Activate 
Browser Coloring option.

4. Click on the colored box next to the item for which you want to configure color.

5. Pick color.

6. Click OK in the Color Picker window.

7. Save your colors in the IDE Preferences window.

– Windows: Click OK.

– Macintosh: Click Save.

The colors change to the new colors.

Debugger Panels
The Debugger section of the IDE Preference Panels list defines the basic debugger 
settings assigned to a new project.

The Debugger preference panels available on most IDE hosts include:

• “Display Settings” on page 366

• “Window Settings” on page 368

• “Global Settings” on page 369

• “Remote Connections” on page 371

Display Settings
The Display Settings preference panel provides options for customizing various 
aspects of the IDE Debugger, including:

• assignment of colors to changed variables and watchpoints

• view of variable types

• display of local variables

• use of decimal values

• sorting of functions
366 IDE 5.5 User’s Guide



Working with IDE Preferences
Debugger Panels
• use of dynamic objects

Figure 26.16 on page 367 shows the Display Settings preference panel. Table 26.15 on 
page 367 explains the items in the preference panel.

Figure 26.16  Display Settings preference panel

Table 26.15  Display Settings preference panel—items

Item Explanation

Variable values change Click the color swatch to set the color that indicates a changed 
variable value.

Watchpoint indicator Click the color swatch to set the color that indicates a changed 
watchpoint value.

Show variable types Select to always show the type associated with each variable.

Show variable location Select to display the Location column in the Variables pane of the 
Thread window.
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Window Settings
The Window Settings preference panel provides options for customizing how the 
debugger displays windows during debugging sessions, including non-debugging and 
project windows.

Figure 26.17  Window Settings preference panel

Show all locals Select to always show all local variables. Clear to have the debugger 
show only variables near the program counter.

Show values as decimal 
instead of hex

Select to always show decimal values instead of
hexadecimal values.

Sort functions by method name 
in symbolics window

Select to sort functions of the form className::methodName in 
the Symbolics window by methodName. Clear to sort
by className.

Attempt to use dynamic type of 
C++, Object Pascal and SOM 
objects

Select to attempt to display the runtime type of the specified 
language objects. Clear to display the static type.

Show tasks in separate 
windows

Select to display tasks in separate Thread windows. Clear to shows 
all tasks in one window, with a list pop-up to choose a task to display. 
Restart active debugging sessions in order for changes to
take effect.

Show variable values in source 
code

Select to show variable values in contextual menus in the
source code.

Default size for unbounded 
arrays

Enter the default number of unbounded array elements to display in 
a View Array window.

Table 26.15  Display Settings preference panel—items (continued)

Item Explanation
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Global Settings
The Global Settings preference panel provides options for customizing various global 
options for the debugger, including:

• file caching to accelerate debugger sessions

• automatic launch of applications and libraries

• confirmation of attempts to close or quit debugging sessions

Table 26.16  Window Settings preference panel—items

Item Explanation

Do nothing Select to leave all windows in place when starting a
debugging session.

Minimize non-debugging 
windows (Windows)

Select to minimize all non-debugging windows when starting a 
debugging session.

Collapse non-debugging 
windows (Macintosh, Solaris, 
and Linux)

Select to collapse all non-debugging windows when starting a 
debugging session.

Hide non-debugging windows Select to hide, but not close, all non-debugging windows when 
starting a debugging session.

Close non-debugging windows Select to close all non-debugging windows, except for the active 
project window, when starting a debugging session.

Do nothing to project windows Select to prevent the IDE from hiding project windows when starting 
a debugging session.

Use Debugging Monitor 
(Classic Macintosh)

Select to use a second monitor during debugging sessions.

Monitor for debugging
(Classic Macintosh)

Choose the monitor to display debugging windows. The coordinates 

in parentheses identify the selected monitor in the QuickDraw® 
coordinate space.

Move open windows to 
debugging monitor when 
debugging starts
(Classic Macintosh)

Select to move all open windows to the selected debugging monitor 
when a debugging session starts.

Open windows on debugging 
monitor during debugging 
(Classic Macintosh)

Select to display on the debugging monitor any window opened 
during a debugging session.
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Figure 26.18  Global Settings preference panel

Table 26.17  Global Settings preference panel—items

Item Explanation

Cache Edited Files Between 
Debug Sessions

Select to maintain a cache of modified files between debugging 
sessions. Use this option to debug through the original source code 
for files modified since the last build.

Maintain files in cache Enter the number of days that the IDE maintains its file cache.

Purge Cache Click to delete the file cache maintained by the IDE, freeing memory 
and disk space.

Confirm invalid file modification 
dates when debugging

Select to have the IDE display a warning message when debugging 
a project with mis-matched file modification dates.

Automatically launch 
applications when SYM file 
opened

Select to automatically launch the application program associated 
with an opened symbolics file.

Confirm “Kill Process” when 
closing or quitting

Select to prompt for confirmation before killing processes upon 
quitting a debugging session.

Select stack crawl window 
when task is stopped

Select to bring forward the Stack Crawl window (also known as the 
Thread window) after the debugger stops tasks.
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Remote Connections
The Remote Connections preference panel configures general network settings for 
remote-debugging connections between the host computer and other computers. Use 
these general settings as the basis for defining more specific connections for individual 
projects in conjunction with the Remote Debugging settings panel. The Target 
Settings window contains the Remote Debugging settings panel.

Figure 26.19  Remote Connections preference panel

Don’t step into runtime support 
code

Select to have the IDE skip stepping into Metrowerks Standard 
Library (MSL) runtime support code and instead directly step into 
your own code.

Auto Target Libraries Select to have the IDE attempt to debug dynamically linked libraries 
(DLLs) loaded by the target application.

Table 26.17  Global Settings preference panel—items (continued)

Item Explanation
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Adding Remote Connections

Add a remote connection that defines a general network connection between the host 
computer and a remote computer.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Remote Connections panel from the IDE Preference Panels list.

3. Click Add.

The New Connection dialog box appears.

4. Enter in the Name field the name for the general remote connection.

5. Choose from the Debugger pop-up menu the desired debugger for use with the 
remote connection. 

6. Configure the Browse in processes window option as desired:

• selected—the IDE filters the Processes window list and the list of available 
debuggers for an opened symbolics file. The filter prevents an unavailable remote 
connection from appearing in either list.

• cleared—the IDE does not filter the Processes window list or the list of available 
debuggers for an opened symbolics file. Both available and unavailable remote 
connections appear in the lists.

7. Choose from the Connection Type pop-up menu the desired network protocol for 
the remote connection.

Table 26.18  Remote Connections preference panel—items

Item Explanation

Remote Connection list Displays the name and connection type of all remote connections 
currently defined.

Add Click to add a new remote connection to the Remote Connection list.

Change Click to change the settings of the selected remote connection.

Remove Click to remove the selected remote connection from the Remote 
Connection list.
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8. Enter in the IP Address field the Internet Protocol address of the remote 
computer.

9. Click OK.

The IDE adds the new remote connection to the Remote Connections list.

10. Click OK, Apply, or Save.

The IDE saves the remote-connection changes.

Changing Remote Connections

Change a remote connection to update network-connection information between the 
host computer and a remote computer.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Remote Connections panel from the IDE Preference Panels list.

3. Select from the Remote Connections list the remote connection that requires 
modification.

4. Click Change.

A dialog box appears with the current network settings for the selected remote 
connection.

5. If needed, enter in the Name field a new name for the general remote connection.

6. If needed, choose from the Debugger pop-up menu a new debugger for use with 
the remote connection. 

7. If needed, toggle the Browse in processes window option.

8. If needed, choose from the Connection Type pop-up menu a new network 
protocol for the remote connection.

9. If needed, enter in the IP Address field a new Internet Protocol address for the 
remote computer.

10. Click OK.

The IDE updates the remote connection and displays changes in the Remote 
Connections list.
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11. Click OK, Apply, or Save.

The IDE saves the remote-connection changes.

Removing Remote Connections

Remove a remote connection that the project no longer uses.

1. Choose Edit > Preferences.

The IDE Preferences window appears.

2. Select the Remote Connections panel from the IDE Preference Panels list.

3. Select from the Remote Connections list the obsolete remote connection.

4. Click Remove.

The IDE updates the Remote Connections list.

5. Click OK, Apply, or Save.

The IDE saves the remote-connection changes.
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Working with Target 
Settings

This chapter explains core CodeWarrior™ IDE target-settings panels and provides 
basic information on target-settings options for the current project’s build targets. 
Consult the Targeting documentation for information on platform-specific target-
settings panels.

This chapter contains these sections:

• “Target Settings Window” on page 375

• “Target Panels” on page 377

• “Code Generation Panels” on page 388

• “Editor Panels” on page 391

• “Debugger Panels” on page 393

Abbreviated descriptions appear in this chapter. See “Preference and Target Settings 
Options” on page 399 for more information on target-settings-panel options.

Target Settings Window
The Target Settings window lists settings for the current project’s build targets. These 
target settings supersede global IDE preferences defined in the IDE Preferences 
window.

The Target Settings window lists settings by group:

• Target—configures overall build-target settings, such as names, browser 
caching, file mappings, and access paths

• Language Settings—configures programming-language settings. Consult the 
Targeting documentation for more information about these settings panels.

• Code Generation—configures processor, disassembler, and optimization 
settings for generating code
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• Linker—configures linker settings for transforming object code into a final 
executable file. Consult the Targeting documentation for more information about 
these settings panels.

• Editor—configures custom keyword sets and colors

• Debugger—configures settings for executable files, program suspension, and 
remote debugging

Figure 27.1  Target Settings window

Table 27.1  Target Settings window—items

Item Explanation

Target Settings Panels list Lists settings panels, organized by group. Click the hierarchical 
control next to a group name to show or hide individual
settings panels.

Settings panel Shows the options for the selected item in the Target Settings 
Panels list.

Factory Settings Click to restore the default options for the current settings panel.
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Opening the Target Settings Window

Use the Target Settings window to modify build-target options for the current 
project.

• Choose Edit > targetname Settings.

The Target Settings window appears.

Target Panels
The Target section of the Target Settings Panels list defines the general target settings 
assigned to a new project.

The Target settings panels available on most IDE hosts include:

• “Target Settings” on page 378

• “Access Paths” on page 379

• “Build Extras” on page 382

• “Runtime Settings” on page 384

Revert Panel Click to restore the most recently saved options for the current 
settings panel.

Export Panel Click to save an XML file that contains options for the current
settings panel.

Import Panel Click to open an XML file that contains options for the current 
settings panel.

OK (Windows) Click to save modifications to all settings panels and close
the window.

Cancel (Windows) Click to discard modifications to all settings panels and close
the window.

Apply (Windows) Click to confirm modifications to all settings panels.

Save (Macintosh, Solaris, and 
Linux)

Click to save modifications to all settings panels.

Table 27.1  Target Settings window—items (continued)

Item Explanation
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• “File Mappings” on page 386

• “Source Trees” on page 388

Target Settings
The Target Settings panel provides options for:

• setting the name of the current build target

• setting the linker, pre-linker, and post-linker for the build target

• specifying the project output directory for the final output file

Figure 27.2  Target Settings panel

Table 27.2  Target Settings panel—items

Item Explanation

Target Name Enter a name (26 or fewer characters) for the selected build target as 
it will appear in the project window.

Linker Select the linker to use on the current build target.

Pre-linker Select the pre-linker to use on the current build target.

Post-linker Select the post- linker to use on the current build target.
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Access Paths
The Access Paths settings panel defines the search paths for locating and accessing a 
build target’s system files and header files.

NOTE The Windows version of the Access Paths settings panel displays 
either User Paths or System Paths, depending on the selected radio 
button. The Macintosh, Solaris, and Linux versions of the Access 
Paths settings panel display both User Paths and System Paths.

Output Directory Shows the location where IDE creates the output binary file. Click 
Choose to change this location.

Choose Click to select the directory in which the IDE saves the output
binary file.

Clear Click to delete the current Output Directory path.

Save project entries using 
relative paths

Select to save project file entries using a relative path from a defined 
access path. This option is helpful if the project has multiple files with 
the same name.

Table 27.2  Target Settings panel—items (continued)

Item Explanation
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Figure 27.3  Access Paths settings panel (Windows)

Figure 27.4  Access Paths settings panel (Macintosh)
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The User Paths and System Paths lists display columns with status icons for each 
access path. Furthermore, there are different types of access paths. Table 27.4 explains 
these items.

Table 27.3  Access Paths settings panel—items

Item Explanation

User Paths Click the radio button to display the User Paths list (those paths 
searched by #include "..." statements).

System Paths Click the radio button to display the System Paths list (those paths 
searched by #include <...> statements).

Always Search User Paths Select to treat #include <...> statements the same as 
#include "..." statements.

Interpret DOS and Unix Paths
(Macintosh)

Select to treat / and \ as subfolder separator characters. Clear to 
treat / and \ as ordinary text.

Require Framework Style 
Includes (Mac OS X)

Select to require #include statements of the form 
LibraryName/HeaderFile.h. Clear to allow statements of the 
form HeaderFile.h.

User Paths list Displays a list of currently defined user-level access paths.

System Paths list Displays a list of currently defined system-level access paths.

Add Default Click to restore the default user- and system-level access paths.

Host Flags list pop-up Choose the host platforms that can use the selected access path.

Add Click to add a user- or system-level access path.

Change Click to modify the selected user- or system-level access path.

Remove Click to remove the selected user- or system-level access path.

Table 27.4  User Paths and System Paths list columns

Name Icon Explanation

Search status A checkmark icon indicates an active access path that the
IDE searches.

No checkmark icon indicates an inactive access path that the IDE 
does not search.
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Build Extras
The Build Extras settings panel contains options that define how the CodeWarrior 
IDE builds a project.

Recursive search A folder icon indicates that the IDE recursively searches the 
subdirectories of the access path.

No folder icon indicates that the IDE does not recursively search the 
access path.

Framework
(Mac OS X 
development)

An ƒ icon indicates that the access path points to a framework. 
Framework paths are implicitly recursive.

No ƒ icon indicates that the access path does not point to a 
framework.

Access path Shows the full access path to the selected directory. Access paths 
have these types:

• Absolute—the complete path, from the root level of the hard 
drive to the directory, including all intermediate directories

• Project—the path from the project file relative to the 
designated directory

• CodeWarrior—the path from the CodeWarrior IDE relative to 
the designated directory

• System—the path from the operating system’s base 
directory relative to the designated directory

• Source tree—the path from a user-defined source tree 
relative to the designated directory

Table 27.4  User Paths and System Paths list columns (continued)

Name Icon Explanation
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Figure 27.5  Build Extras settings panel

Table 27.5  Build Extras settings panel—items

Item Explanation

Use modification date caching Select to have the IDE cache modification-date information and use 
that information each time it builds a target.

Cache Subprojects Select to improve multi-project updating and linking speed.

Generate Browser Data From Choose whether the IDE generates browser data for the project, and 
the method by which the IDE generates that data.

Dump internal browse 
information after compile

Select to have the IDE dump raw browser information for viewing. 
This option appears after selecting Compiler from the Generate 
Browser Data From pop-up menu.

Prefix file Enter the path to your project’s prefix file. This options appears after 
selecting Language Parser from the Generate Browser Data From 
pop-up menu.
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Runtime Settings
The Runtime Settings panel specifies a debugging application for non-executable 
files. Dynamic linked libraries (DLLs), shared libraries, and code resources are sample 
non-executable files. For example, use this panel to specify a debugging application 
for Adobe® Photoshop® plug-ins.

Macro file Enter the path to your project’s macro file. This options appears after 
selecting Language Parser from the Generate Browser Data From 
pop-up menu.

Use External Debugger
(Windows)

Select to use an external debugger instead of the CodeWarrior 
debugger.

Application (Windows) Click Browse to select the external debugger application. 
Alternatively, enter in the field the path to the external debugger.

Arguments (Windows) Enter in this field any program arguments to pass to the external 
debugger when the IDE transfers control.

Initial directory (Windows) Click Browse to select an initial directory for the external debugger. 
Alternatively, enter in the field the path to the initial directory.

Table 27.5  Build Extras settings panel—items (continued)

Item Explanation
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Figure 27.6  Runtime Settings panel

Table 27.6  Runtime Settings panel—items

Item Explanation

Host Application for Libraries & 
Code Resources

Click Choose to select the application program for debugging non-
executable files. Alternatively, enter in the field the path to the 
application program. Click Clear to delete the current field entry.

Working Directory Enter the path to a directory used for debugging the non-executable 
files. Leave this field blank to use the same directory that contains 
the non-executable files.

Program Arguments Enter a command line of program arguments to pass to the host 
application when the IDE transfers control.

Environment Settings Lists the environment variables that have been added to the
build target.

Add Click to add the current Variable and Value pair to the Environment 
Settings list.
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File Mappings
The File Mappings settings panel associates file-name extensions with a CodeWarrior 
plug-in compiler. These associations determine whether the IDE recognizes a source 
file by its filename extension or file type. Use the settings panel to add, change, and 
remove file mappings.

Figure 27.7  File Mappings settings panel

Change Click to replace the selected entry in the Environment Settings list 
with the current Variable and Value pair.

Remove Click to delete the selected environment variable from the 
Environment Settings list.

Variable Enter a name for the environment variable. This name pairs with the 
information in the Value field.

Value Enter a value for the environment variable. This value pairs with the 
information in the Variable field.

Table 27.6  Runtime Settings panel—items (continued)

Item Explanation
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Table 27.7  File Mappings settings panel—items

Item Icon Explanation

File Mappings list Displays a list of currently defined mappings between file-
name extensions and plug-in compilers.

File Type Enter in this field a file type (such as TEXT) for the file 
mapping. Alternatively, click Choose to set the file type by 
selecting an example file. This file type also appears in the 
corresponding column of the File Mappings list.

Extension Enter in this field the file-name extension (such as .cpp) 
for the file mapping. This file-name extension also appears 
in the corresponding column of the File Mappings list.

Resource File flag A bullet in this column denotes a resource file. The IDE 
includes these resource files when building the final output 
file. Use the Flags pop-up menu to toggle this flag.

Launchable flag A bullet in this column denotes a launchable file. The IDE 
opens launchable files with the application that created 
them. Double-click launchable files from the Project 
window. Use the Flags pop-up menu to toggle this flag.

Precompiled File flag A bullet in this column denotes a precompiled file. The IDE 
builds precompiled files before building other files. Use the 
Flags pop-up menu to toggle this flag.

Ignored By Make flag A bullet in this column denotes a file ignored by the 
compiler during builds. For example, use this option to 
ignore text (.txt) files or document (.doc) files. Use the 
Flags pop-up menu to toggle this flag.

Compiler Choose from this list pop-up the plug-in compiler to 
associate with the selected file mapping. This compiler 
selection also appears in the corresponding column of the 
File Mappings list.

Flags Choose from this pop-up menu the desired flags for the 
selected file mapping. A checkmark indicates an active 
flag. Bullets appear in the corresponding columns of the 
File Mappings list to reflect flag states.

Edit Language Choose from this list pop-up the desired language to 
associate with the selected file mapping. The IDE applies 
the appropriate syntax coloring for the selected language.

Add Click to add the current File Type, Extension, Flags, 
Compiler, and Edit Language entries to the File 
Mappings list.
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Source Trees
The Source Trees settings panel in the Target Settings window defines project-
specific root paths. These project-specific paths supersede the global root paths 
defined in the Source Trees preference panel of the IDE Preferences window.

Code Generation Panels
The Code Generation section of the Target Settings Panels list provides a single core 
panel for configuring optimization routines. Consult the Targeting documentation for 
more information about platform-specific settings panels.

Global Optimizations
The Global Optimizations settings panel configures how the compiler optimizes 
object code. All optimization routines rearrange object code without affecting its 
logical execution sequence.

NOTE Always debug programs with optimization routines disabled. The 
IDE does not provide source views of optimized code.

Change Click to change the selected item in the File Mappings list 
to reflect the current File Type, Extension, Flags, 
Compiler, and Edit Language entries.

Remove Click to remove the selected item in the File Mappings list.

Table 27.7  File Mappings settings panel—items (continued)

Item Icon Explanation
388 IDE 5.5 User’s Guide



Working with Target Settings
Code Generation Panels
Figure 27.8  Global Optimizations settings panel

The Details field lists individual optimization routines applied at the selected 
optimization level. Table 27.9 on page 390 explains these optimizations and their 
availability at certain optimization levels.

Table 27.8  Global Optimizations settings panel—items

Item Explanation

Faster Execution Speed Select to favor optimization routines that increase the execution 
speed of the final object code, at the expense of larger code size.

Smaller Code Size Select to favor optimization routines that reduce the size of the final 
object code, at the expense of slower execution speed.

Optimization Level slider Move to the desired optimization level. The IDE applies more 
optimization routines at higher optimization levels. The Details field 
lists the active optimization routines.
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Table 27.9  Optimization routines

Optimization Routine Explanation Optimization 
Level

Global Register Allocation
or
Global Register Allocation Only 
for Temporary Values

Stores working values of heavily used variables 
in registers instead of memory.

1, 2, 3, 4

Dead Code Elimination Removes statements never logically executed 
or referred to by other statements.

1, 2, 3, 4

Branch Optimizations Merges and restructures portions of the 
intermediate code translation in order to reduce 
branch instructions.

1, 2, 3, 4

Arithmetic Operations Replaces intensive computational instructions 
with faster equivalent instructions that produce 
the same result.

1, 2, 3, 4

Expression Simplification Replaces complex arithmetic expressions with 
simplified equivalent expressions.

1, 2, 3, 4

Common Subexpression 
Elimination

Replaces redundant expressions with a
single expression.

2, 3, 4

Copy Propagation
or
Copy and Expression 
Propagation

Replaces multiple occurrences of one variable 
with a single occurrence.

2, 3, 4

Peephole Optimization Applies local optimization routines to small 
sections of code.

2, 3, 4

Dead Store Elimination Removes assignments to a variable that goes 
unused before being reassigned again.

3, 4

Live Range Splitting Reduces variable lifetimes to achieve optimal 
allocation. Shorter variable lifetimes reduce 
register spilling.

3, 4

Loop-Invariant Code Motion Moves static computations outside of a loop 3, 4

Strength Reduction Inside loops, replaces multiplication instructions 
with addition instructions.

3, 4

Loop Transformations Reorganizes loop object code in order to reduce 
setup and completion-test overhead.

3, 4
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Editor Panels
The Editor section of the Target Settings Panels list provides a single core panel for 
configuring custom keywords within a project.

Custom Keywords
The Custom Keywords settings panel configures as many as four keyword sets, each 
with a list of keywords, and syntax coloring for a project. These project-specific 
settings supersede the global settings defined in the Text Colors preference panel of 
the IDE Preferences window.

Loop Unrolling
or
Loop Unrolling (Opt for Speed 
Only)

Duplicates code inside a loop in order to spread 
over more operations branch and completion-
test overhead.

3, 4

Vectorization For processors that support vector 
optimizations, translates computations with 
code-loop arrays into equivalent vector 
instructions.

3, 4

Lifetime Based Register 
Allocation
or
Register Coloring

In a particular routine, uses the same processor 
register to store different variables, as long as 
no statement uses those variables 
simultaneously.

3, 4

Instruction Scheduling Rearranges the instruction sequence to reduce 
conflicts among registers and processor 
resources.

3, 4

Repeated Iterates the optimization routines listed between 
{* and *}.

4

Table 27.9  Optimization routines (continued)

Optimization Routine Explanation Optimization 
Level
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Figure 27.9  Custom Keywords settings panel

Adding a Keyword to a Keyword Set

To add a keyword to a keyword set, follow these steps:

1. Click Edit next to the desired keyword set.

A dialog box appears. This dialog box lists the current collection of keywords in 
the keyword set.

2. Enter the new keyword into the field at the top of the dialog box.

3. Click Add.

The new keyword appears in the keyword list.

4. Select Case Sensitive as desired.

When selected, the IDE treats the case of each keyword in the keyword set as 
significant. When cleared, the IDE ignores the case of each keyword in the 
keyword set.

5. Click Done.

The IDE saves the modified keyword set.

Table 27.10  Custom Keywords settings panel—items

Item Explanation

Keyword set 1, Keyword set 2, 
Keyword set 3, Keyword set 4

Click a color swatch to set the color used for the corresponding 
custom-keyword set.

Edit Click to add, modify, or remove keywords from the corresponding 
custom-keyword set.
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Removing a Keyword from a Keyword Set

To remove a keyword from a keyword set, follow these steps:

1. Click Edit next to the desired keyword set.

A dialog box appears. This dialog box lists the current collection of keywords in 
the keyword set.

2. Select the obsolete keyword in the Custom Keywords list.

3. Press the delete key for your platform.

• Windows, Solaris, and Linux: Backspace

• Macintosh: Delete

4. Click Done.

The IDE saves the modified keyword set.

Debugger Panels
The Debugger section of the Target Settings Panels list defines general debugger 
settings for the project. Consult the Targeting documentation for more information 
about platform-specific settings panels.

The Debugger settings panels available on most IDE hosts include:

• “Other Executables” on page 393

• “Debugger Settings” on page 396

• “Remote Debugging” on page 397

Other Executables
The Other Executables settings panel configures additional executable files for the 
IDE to debug together with the current build target.
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Figure 27.10  Other Executables settings panel

Table 27.11  Other Executables settings panel—items

Item Icon Explanation

File list Lists the executable files that the IDE can debug together 
with the current build target.

Debug column Click in this column to toggle debugging of the 
corresponding executable file.

Add Click to select an executable file to add to the File list.

Change Click to change the selected entry in the File list.

Remove Click to remove the selected entry in the File list.
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Adding an Executable File to the File List

To add an executable file to the File list, follow these steps:

1. Click Add.

The Debug Additional Executable dialog box appears.

2. Enter in the File Location field the path to the executable file.

Alternatively, click Choose to display a dialog box. Use the dialog box to select 
the executable file. The path to the selected executable file appears in the File 
Location field.

3. Select Download file during remote debugging as desired.

When selected, the IDE downloads the executable file from a remote computer 
during the debugging session. Enter in the corresponding field the path to the 
remote file. Alternatively, click Choose to select the file. Click Clear to delete the 
current entry.

4. Select Debug merged executable as desired.

When selected, the IDE debugs an executable file that merged with the project 
output. Enter in the corresponding field the path to the original executable file 
(prior to merging). Alternatively, click Choose to select the file. Click Clear to 
delete the current entry.

5. Click Done.

The IDE adds the executable file to the File list.

Changing an Executable File in the File List

To change an executable file in the File list, follow these steps:

1. Select the desired path.

2. Click Change.

The Debug Additional Executable dialog box appears.

3. Modify the File Location field as desired.

4. Modify the Download file during remote debugging option as desired.
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5. Modify the Debug merged executable option as desired.

6. Click Done.

The IDE modifies the executable file.

Removing an Executable File from the File List

To remove an executable file from the File list, follow these steps:

1. Select the obsolete path.

2. Click Remove.

The IDE removes the executable file from the File list.

Debugger Settings
The Debugger Settings panel configures activity logs, data-update intervals, and 
other debugger-related options.

Figure 27.11  Debugger Settings panel
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Remote Debugging
The Remote Debugging settings panel configures target-specific network settings for 
remote-debugging connections between the host computer and other computers. Use 
this target-specific panel to build on the general connections defined in the Remote 
Connections preference panel of the IDE Preferences window.

Table 27.12  Debugger Settings panel—items

Item Explanation

Location of Relocated Libraries 
and Code Resources

Enter in this field the path to code resources or relocated libraries 
required for debugging the project. Alternatively, click Choose to 
select the required files.

Stop on application launch Select to halt program execution at the beginning of a debugging 
session. Select the desired stop point: Program entry point, 
Default language entry point, or User specified.

Program entry point Select to halt program execution upon entering the program.

Default language entry point Select to halt program execution upon entering a default point 
defined by the programming language.

User specified Select to halt program execution at a specified function. Enter the 
desired function name in the corresponding field.

Auto-target Libraries Select to debug dynamically linked libraries (DLLs) loaded by the 
target application, at the expense of slower performance.

Cache symbolics between runs Select to have the IDE cache the symbolics information it generates 
for a project. Clear to have the IDE discard the information after each 
debugging session ends.

Log System Messages Select to log all system messages to a Log window.

Stop at Watchpoints Select to halt program execution at every watchpoint. Clear to halt 
program execution at watchpoints with changed values.

Update data every n seconds Enter the number of seconds n to wait before updating the data 
displayed in debugging-session windows.
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Figure 27.12  Remote Debugging settings panel

Table 27.13  Remote Debugging settings panel—items

Item Explanation

Enable remote debugging Select to define for the current build target a remote-debugging 
connection in terms of a general connection. Choose from the 
Connection pop-up menu the desired general connection.

Remote download path Enter the path to the directory in which to store downloaded files.

Launch remote host application Select to launch an application on the remote computer to serve as a 
host application. Enter in the corresponding field the path to the 
remote application.
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Preference and Target 
Settings Options

Use this chapter to look up CodeWarrior™ IDE preference-panel or target-setting 
options and learn more about their capabilities. Option names are arranged in 
alphabetical order.

NOTE This chapter covers options for the core IDE preference or target-
setting panels described in this manual. See the Targeting 
documentation for additional panel information.

A

Activate Browser Coloring
Select this option to activate coloring of browser symbols in editor windows. Clear the 
option to apply the default text color to all symbols. Click the color swatch next to a 
symbol to modify its color.

Activate Syntax Coloring
Select this option to activate coloring of Comments, Keywords, Strings, and Custom 
Keyword Sets symbols in editor windows. Clear the option to apply the default text 
color to all the symbols. Click the color swatch next to a symbol to modify its color.

Add Default
Click this button to restore the default user path or system path to the Access Paths 
panel.
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Always Search User Paths
This option controls the search criteria the IDE uses to find system and user files. 
When

• selected—the IDE treats searching for system files (such as #include <...>) 
the same as user files (#include "...").

• disabled—the IDE treats system paths differently from user paths.

Application
Enter in this field the path to the external debugger that the IDE uses in place of the 
CodeWarrior debugger. Alternatively, click Browse to open a dialog box. Use the 
dialog box to select the external debugger.

Arguments
Enter in this field command-line arguments to pass to the external debugger at the 
beginning of a debugging session.

Attempt to use dynamic type of C++, Object Pascal 
and SOM objects
Select this option to display runtime types for C++, Object Pascal, and SOM objects. 
Clear the option to display static types.

Auto Indent
Select this option to apply automatically the same indentation as the previous line for 
each new line of text created by pressing Enter or Return. Clear the option to always 
return to the left margin for each new line of text.

Auto-target Libraries

Auto Target Libraries
Select this option to have the IDE attempt to debug dynamically linked libraries 
(DLLs) loaded by the target application. The IDE debugs the DLLs that have 
symbolics information.
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This option applies to non-project debugging sessions, such as debugging an attached 
process.

NOTE Selecting this option may slow IDE performance. Clear the option to 
improve speed.

Automatic Invocation
Select this option to have the Code Completion window automatically open after 
typing specific programming-language characters in the active editor window. Clear 
the option to manually open the Code Completion window.

The specific characters that trigger opening of the Code Completion window depend 
on the programming language that you use. For example, typing a period after a Java 
class triggers opening of the Code Completion window, allowing you to complete the 
class invocation.

You can change the time it takes for the Code Completion window to appear after you 
type a trigger character. If you perform any activity during this delay time, you cancel 
opening the Code Completion window.

See also:

• “Code Completion Delay” on page 404

Automatically launch applications when SYM file 
opened
Select this option to launch the application associated with an opened symbolics file. 
The IDE sets an implicit breakpoint at the main entry point of the application. Clear 
the option to open the symbolics file without launching the associated application.

Table 28.1 explains how to skip launching the target program

Table 28.1  Bypass launching the target program

On this host… Do this…

Windows Press Alt while the IDE opens the symbolics file.

Macintosh Press Option while the IDE opens the symbolics file.

Solaris Press Alt while the IDE opens the symbolics file.

Linux Press Alt while the IDE opens the symbolics file.
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B

Background
Click this color swatch to configure the background color of editor windows.

Balance Flash Delay
Enter in this field the time, in ticks, to highlight a matching punctuation character 
during a Balance while typing check. Each tick represents 1/60th of a second (16.67 
milliseconds).

Sample tick values include:

• 0 (zero)—disables balance flashing

• 30—the default flash value (1/2 of a second)

• 999—the maximum-flash delay value

Balance while typing
Select this option to have the editor check for balanced parentheses, brackets, and 
braces in editor windows. For each closing parenthesis, bracket, or brace, the editor 
attempts to find the opening counterpart.

The IDE behaves differently, depending on whether it finds the counterpart:

• Found—the editor window scrolls to display the matching character, then returns 
to the insertion point. The Balance Flash Delay option determines how long the 
editor displays the matching character.

• Not found—the IDE beeps.

Browser Commands
Select this option to add Browser menu commands to contextual menus. Clear the 
option to remove the commands from the contextual menus.
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Browser Path
Enter in this field a path to the browser to use for viewing IDE online help. The 
Netscape Navigator® browser is the default application. The PATH environment 
variable specifies the path to the browser.

To change the default setting, or if the IDE cannot find Netscape Navigator, enter in 
the Browser Path field a path to an alternate browser. Alternatively, click Set to select 
the path.

Build before running
Choose from this pop-up menu the way in which the IDE handles project builds before 
running the compiled application:

• Always—always build projects before running them.

• Never—never build projects before running them.

• Ask—ask each time how to proceed.

C

Cache Edited Files Between Debug Sessions
Select this option to maintain a cache of edited files between debugging sessions. Use 
this option to debug through the original source code for files modified since the last 
build. 

Enter in the Maintain files in cache field the number of days to keep the cached files. 
Click Purge Cache to delete the current cache.

See also:

• “Maintain files in cache” on page 419

• “Purge Cache” on page 422

Cache Subprojects
Use this option to improve multi-project updating and linking. When
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• selected—the IDE increases its memory requirements in order to generate 
symbolics information for both the build targets and the subprojects within each 
build target.

• cleared—the IDE does not increase its memory requirements and does not 
generate symbolics information.

Cache symbolics between runs
Select this option to have the IDE maintain a cache of symbolics information 
generated for the project. The IDE refers to this cached symbolics information during 
subsequent debugging sessions. The cache improves IDE performance. Clear the 
option to force the IDE to discard the symbolics information at the end of each 
debugging session.

Case sensitive
Select this option to have the IDE consider case when completing code. Clear the 
option to have the IDE ignore case.

The IDE can determine possible symbol matches according to case. For example, if 
you clear the Case sensitive option and type str in the active editor window, the IDE 
displays both string and String as possible matches. Selecting the option causes 
the IDE to display only string as a possible match.

Close non-debugging windows
Select this option to close non-debugging windows, except for the active project 
window, when starting a debugging session. At the end of the debugging session, the 
IDE automatically re-opens the closed windows.

Code Completion Delay
Enter in this field the number of ticks to have the IDE wait from the time you type a 
trigger character to the time the Code Completion window opens. A tick is 1/60 of a 
second.

Performing any activity during this delay time cancels opening of the Code 
Completion window.

See also:

• “Automatic Invocation” on page 401
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Collapse non-debugging windows
Select this option to collapse non-debugging windows when starting a debugging 
session. At the end of the debugging session, the IDE automatically restores the 
collapsed windows.

Comments
Select the Activate Syntax Coloring option in order to configure this option. Use this 
option to configure the color of C, C++, and Java comments displayed in editor 
windows. The IDE then uses the chosen color for comments placed between /* and 
*/ or from // to the end of a line.

Click the color swatch next to Comments to set the color.

Compiler
Choose from this list pop-up the desired compiler for the selected File Type in the File 
Mappings list. Select None to not associate the selected file type with any compiler.

Compiler thread stack
Enter in this field the maximum kilobytes of stack size for the IDE to allocate to 
compiling and linking thread support.

The IDE threads all build processes, with compiling and linking occurring on a thread 
separate from the main application thread. This setting controls the compiler-thread 
stack size.

To avoid frequent compiler crashes, such as when building very large or complex 
projects, increase the default compiler-thread-stack size.

Confirm invalid file modification dates when 
debugging
Select this option to keep track of source-file modification dates in a project. The IDE 
displays a warning message if the modification dates do not match. The message 
warns of possible discrepancies between object code and source code. Clear the option 
to prevent the IDE from displaying the warning message.
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Confirm “Kill Process” when closing or quitting
Select the Confirm “Kill Process” when closing or quitting option to have the IDE 
prompt for confirmation before killing processes upon closing the Thread window or 
quitting the IDE. Clear the option to kill processes without prompting.

Context popup delay
Enter in this field the minimum time, in ticks, to hold down the mouse button before 
IDE contextual menus appear. Each tick represents 1/60 of a second (16.67 
milliseconds).

Sample tick values include:

• 0 (zero)—disables appearance of contextual menus

• 40—default popup delay value (2/3 of a second)

• 240—maximum popup delay value

D

Debugger Commands
Select this option to add Debug menu commands to IDE contextual menus. Clear the 
option to remove the commands from the contextual menus.

Default file format
Choose from this list pop-up the default end-of-line (EOL) conventions used by the 
IDE to save files:

• Macintosh: <CR>

• DOS: <LF><CR>

• UNIX: <LF>
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Default language entry point
Select this option to halt program execution upon entering a default point defined by 
the programming language. For example, C++ defines the main() function as the 
default point.

Default size for unbounded arrays
Enter in this field the default number of elements to display in View Array windows 
for unbounded arrays.

Disable third party COM plugins
Select this option to prevent the IDE from loading third-party Component Object 
Model (COM) plugins. Clear the option to have the IDE load the plugins at start-up 
time.

Use this option to help troubleshoot problems with the IDE. If the problem goes away 
after disabling the plug-ins, then a conflict exists between the third-party plugins and 
the IDE plugins.

Display deprecated items
Select this option to have the Code Completion window display obsolete 
programming-language items. Clear the option to have the window hide the obsolete 
items.

Deprecated items appear in gray text in the Code Completion window.

Do nothing
Select this option to leave all windows in place during a debugging session.

Do nothing to project windows
Select this option to prevent the IDE from manipulating project windows when 
starting a debugging session. Use this option to help debug multiple build targets or 
multiple projects.
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Documents
Enter in this field the number of recent documents to display in the Open Recent 
submenu.

Don’t step into runtime support code
Select this option to have the IDE bypass stepping into the Metrowerks Standard 
Library (MSL) runtime support code and instead directly step into your own code. 
Clear the option to have the IDE step into the MSL runtime setup code, then step into 
your own code.

Drag and drop editing
Select this option to allow dragging and dropping of text in editor windows. Clear the 
option to disable drag-and-drop text editing.

Dump internal browse information after compile
Select this option to view the raw browser information that a plug-in compiler or 
linker provides for the IDE. Use this option to help develop plug-ins for use with the 
IDE.

NOTE After enabling the Dump internal browse information after 
compile option, compile only single files or small files. Compiling 
an entire project can create huge internal browser information for the 
IDE to display.

E

Edit Commands
Select this option to add Edit menu commands to IDE contextual menus. Clear the 
option to remove the commands from the contextual menus.
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Edit Language
Choose from this pop-up menu the programming language to associate with the 
selected file mapping. The selected language determines the syntax-color scheme. For 
example, choose C/C++ to apply the appropriate syntax-color scheme for C or C++ 
programming-language components.

Enable automatic Toolbar help
Select this option to display Balloon Help after resting the cursor over a toolbar button. 
Clear the option to prevent Balloon Help from appearing.

Enable remote debugging
Select this option to define a remote-debugging connection specific to the current 
build target. Choose from the Connection pop-up menu the general connection to use 
as the basis for the target-specific connection.

Enable Virtual Space
Use this option to configure the editor for handling spaces in different ways. When

• selected—the editor allows moving the text-insertion point past the end of a line 
of text, using either the arrow keys or the mouse. After moving to the desired 
position, begin entering text. The editor automatically inserts spaces between the 
former end of the line and the newly entered text.

• cleared—the editor requires manual insertion of spaces to move past the end of a 
line of text.

Environment Settings
Use this section to specify environment variables to pass to your program as part of the 
environment parameter in your program’s main() function, or as part of environment 
calls. These environment variables are only available to the target program. When 
your program terminates, the settings are no longer available.

NOTE The Environment Settings section appears only when you develop 
code for a Windows build target. The section does not appear for any 
other build target.
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Export Panel
Click this button to save to an Extensible Markup Language (XML) file the current 
state of the active preference or settings panel.

Extension
Enter in this field a file-name extension, such as the .c or .h , for a selected File Type 
in the File Mappings list. Table 28.2 on page 410 lists default file-name extensions.

Table 28.2  Default file-name extensions

Type Extension Explanation

Minimum 
CodeWarrior 
Installation

.iSYM CodeWarrior Intel® Symbols

.mch CodeWarrior Precompiled Header

.mcp CodeWarrior Project File

.SYM CodeWarrior Mac OS 68K Debug Symbols

.xSYM CodeWarrior Mac OS PPC Debug Symbols

.dbg CodeWarrior Debug Preferences

.exp Exported Symbol File

.iMAP CodeWarrior Link Map

.MAP CodeWarrior Link Map

Assembly .a Assembly Source File (Windows and Macintosh)

.asm Assembly Source File

.dump CodeWarrior Disassembled File
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C and C++ .c++ C++ Source File

.cc C++ Source File

.hh C++ Header File

.hpp C++ Header File

.i C Inline Source File

.icc C++ Inline Source File

.m Object C Source File

.mm Object C++ Source File

Default C and C++ .c C Source File

.cp C++ Source File

.cpp C++ Source File

.h C and C++ Header File

Default Java .class Java Class File

.jar Java Archive File

.jav Java Source File

.java Java Source File

Java .JMAP Java Import
Mapping Dump

.jpob Java Constructor File

.mf Java Manifest File

Table 28.2  Default file-name extensions (continued)

Type Extension Explanation
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F

Factory Settings
Click this button to change all modified options to their default values in the current 
preference or settings panel.

Library .a (Static) Archive Library (Solaris and Linux)

.lib Library File

.o Object File
(Windows and Macintosh)

.o Object (Relocatable) Library or Kernel Module
(Solaris and Linux)

.obj Object File

.pch Precompiled Header Source File

.pch++ Precompiled Header Source File

.so Shared Library (Linux)

Script .sh Shell Script (Linux)

.psh Precompile Shell Script (Linux)

.pl Perl Script (Linux)

Mac OS X .dylib Mach-O Dynamic Library

.a Mach-O Static Library

.o Mach-O Object File

.plist Property List

Table 28.2  Default file-name extensions (continued)

Type Extension Explanation
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Failure
Choose from this pop-up menu a sound to play after a Bring Up To Date or Make 
operation fails.

File Type
Enter in this field the four-character file type for the selected file mapping in the File 
Mappings list.

Find and compare operations
A bullet in the Find and compare operations column, whose label appears at 
left, indicates that the IDE ignores matching folders for find-and-compare 
operations. Such operations include dragging a folder into fields in the Find 
window, or comparing folder contents.

Find Reference using
Choose from the Find Reference using options an online browser application to look 
up references and definitions.

For example, use this option to look up documentation for language keywords:

1. Select an online browser application, such as THINK Reference, with the Find 
Reference using option.

2. Select a language keyword, such as boolean, in the source code.

3. Choose the Find Reference menu command. The IDE looks up reference 
information for the boolean keyword in the THINK Reference documentation.

Although they are not included with the CodeWarrior product, the IDE supports these 
online browser formats:

• Apple Help Viewer (CW manuals)

• Apple Help Viewer (Mac OS X API Ref)

• PalmQuest Reference (Palm Pilot)

• QuickView–such as Macintosh Programmer’s Toolbox Assistant (MPTA)

• THINK Reference
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Font
Choose from the Font options the typeface to use for displaying text in editor 
windows. This setting behaves in two different ways, depending on the current IDE 
state:

• No editor windows open—the setting modifies the default font. All editor 
windows take on the default font.

• Editor windows open—the setting modifies the font displayed in the frontmost 
editor window only. Other editor windows remain unaffected. The default font 
remains unchanged.

Font preferences
Select the Font preferences option to remember font settings for each file in a project. 
Clear the option to use the default font settings every time the IDE opens each file. The 
Font & Tabs preference panel defines the default settings.

Foreground
Use the Foreground option to configure the color of any text not affected by the 
Activate Syntax Coloring or Activate Browser Coloring options. 

Click the color swatch to change the current color.

G-I

Generate Browser Data From
Choose from this pop-up menu whether the IDE generates browser data, and from 
what source it generates that data.

Choose from these possibilities:

• None—Disable browser-data generation. Certain IDE features that use browser 
data will be unable to work with the project, but the project’s size will be smaller.

• Compiler—Have the IDE use the compiler to generate the browser data. If you 
choose this option, you must Make the project in order to generate the browser 
data. The IDE uses the compiler assigned to the project to generate the browser 
data during the build process.
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• Language Parser—Have the IDE use the language parser to generate the 
browser data. Certain IDE features, such as C/C++ Code Completion, function 
more effectively if you choose this option. The IDE uses the language parser 
assigned to the project to generate the browser data.

NOTE If you choose the Language Parser option, you can also have the 
IDE take into account your custom macro definitions. To do so, enter 
the path to your prefix file in the Prefix file field and the path to your 
macro file in the Macro file field.

Grid Size X
Enter in the Grid Size X field the number of pixels to space between markings on the 
x-axis of the Layout Editor grid.

Grid Size Y
Enter in the Grid Size Y field the number of pixels to space between markings on the 
y-axis of the Layout Editor grid.

Hide non-debugging windows
Select the Hide non-debugging windows option to hide, but not close, non-
debugging windows when starting a debugging session.

To reveal the hidden windows, do one of these tasks:

• Use the Window menu, or

• Double-click the names of the hidden files in the Project window, or

• Perform lookups for symbols within the hidden windows.

At the end of the debugging session, the IDE automatically reveals the hidden 
windows.

Host Application for Libraries & Code Resources
The Host Application for Libraries & Code Resources field lets you specify a host 
application to use when debugging a non-executable file, such as a shared library, 
dynamic link library (DLL), or code resource. The application that you specify in this 
field is not the debugger application, but rather the application with which the non-
executable file interacts.
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Host Flags
The Host Flags list pop-up defines the host platforms which can use the selected 
access path. The settings include:

• None–no host can use this access path.

• All–all hosts can use this access path.

• Windows–only use this path for Windows build targets.

• Mac OS–only use this path for Mac OS build targets.

NOTE Multiple hosts can be selected.

Import Panel
Click Import Panel to load the contents of a previously saved Extensible Markup 
Language (XML) file into the active preference or settings panel.

Include file cache
Use the Include file cache option to specify the upper limit of kilobytes of memory 
used by the IDE for caching #include files and precompiled headers. The larger the 
value entered, the more memory the IDE uses to accelerate builds.

Initial directory
Enter in this field the initial directory for use with the external debugger. 
Alternatively, click Browse to open a dialog box. Use the dialog box to select the 
initial directory.

Insert Template Commands
Select the Insert Template Commands option to display the Insert Template 
submenu in contextual menus. The submenu displays source-defined function 
templates. Clear to remove the submenu from the contextual menus.

NOTE Select the Browser Commands option in order to select the Insert 
Template Commands option. Otherwise, the Insert Template 
Commands state has no effect.
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Interpret DOS and Unix Paths
This option determines how the IDE treats filenames for interface files:

• Selected—the IDE treats the backslash (\) and the forward slash (/) characters as 
subfolder separator characters. In the example

#include "sys/socks.h"

the IDE searches for a subfolder called sys that contains a socks.h file.

• Cleared—the IDE treats both the backslash and forward slash characters as part 
of the filename. Using the same example, the IDE now searches for a sys/
socks.h filename.

K-L

Keywords
Use the Keywords option to configure the color of C, C++, and Java programming 
language’s keywords displayed in editor windows when the Activate Syntax 
Coloring option is enabled. Coloring does not include macros, types, variables 
defined by system interface files, or variables defined in source code. Click the color 
swatch next to Keywords to set the color.

Launch Editor
Enter in the Launch Editor field a command-line expression that specifies the third-
party text editor that the CodeWarrior IDE runs to edit text files.

The IDE expands the %file variable of the command-line expression into the full file 
path. For example, to run the Emacs text editor to edit text files, enter this command-
line expression:

runemacs %file

Consult the documentation provided with the third-party text editor for more 
information about using command lines.
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Launch Editor w/ Line #
Enter in the Launch Editor w/ Line # field a command-line expression that specifies 
the third-party text editor that the IDE runs to edit text files, and an initial line of text 
that the third-party editor displays upon running.

The IDE expands the %line variable of the command-line expression into an initial 
line of text for the third-party text editor to display. For example, to run the Emacs text 
editor to edit a text file, and to have the Emacs editor display the line provided to it by 
the IDE, enter this command-line expression:

runemacs %file %line

Consult the documentation provided with the third-party text editor for more 
information about using command lines.

Launch remote host application
Select this option to launch an application on the remote computer to serve as a host 
application. Enter in the corresponding field the path to the remote host application.

Left margin click selects line
Select the Left margin click selects line option to use a right-pointing cursor, 
shown at left, to select entire lines of text from the left margin. Clear the option 
to disable use of the right-pointing cursor.

With the right-pointing cursor active, click in the left margin to select the current line, 
or click and drag along the left margin to select multiple lines.

Level
Choose from the Level options the amount of information reported for IDE plug-ins in 
development. This information is useful for diagnosing plug-in behavior or for 
viewing information about the properties of installed plug-ins.

Choose one of these levels of plug-in diagnostic information:

• None (default)—The IDE does not activate plug-in diagnostics or produce 
output.

• Errors Only—The IDE reports problems encountered while loading plug-ins. 
These problems appear in a new text file after the IDE starts up

• All Info—The IDE reports information for each installed plug-in, such as 
problems with plug-in loading, optional plug-in information, and plug-in 
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properties. This information appears in a new text file after the IDE starts up. The 
text file also contains a complete list of installed plug-ins and their associated 
preference panels, compilers, and linkers.

The IDE allows saving and printing the text file. Use the file as an error reference for 
troubleshooting plug-ins. The text file also provides suggestions for correcting general 
plug-in errors.

Linker
Use the Linker option menu to select the linker to use with the project. The choices 
available are always dependent on the plug-in linkers that available to the 
CodeWarrior IDE.

To learn more about the linkers, see the appropriate Targeting manual.

Location of Relocated Libraries and Code Resources
Enter in this field the path to the relocated libraries and code-resource files required 
for debugging the project. Alternatively, click Choose to display a dialog box. Use the 
dialog box to select the required files.

Log System Messages
Select this option to have the IDE maintain a log of all system messages generated 
during the debugging session. The Log window displays this platform-specific 
information. Clear the option to disable the log.

M

Maintain files in cache
Enter in the Maintain files in cache text box the number of days that the IDE 
maintains files in the file cache.

Menu bar layout
Choose from the Menu bar layout options the desired configuration of menus listed 
in the IDE:
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• Windows—organizes the menu bar according to a typical Microsoft® Windows® 
arrangement

• Macintosh—organizes the menu bar according to a typical Apple® Mac® OS 
arrangement

Minimize non-debugging windows
Select the Minimize non-debugging windows option to minimize non-debugging 
windows to a reduced size when a debugging session starts. At the end of the 
debugging session, the IDE automatically restores the minimized windows.

NOTE The Minimize non-debugging windows option is only available in 
MDI mode.

See also:

• “Use Multiple Document Interface” on page 431

Monitor for debugging
Choose from the Monitor for debugging options the specific monitor to use during 
debugging sessions. The IDE displays debugging windows in the selected monitor. 
The coordinates in parentheses identify the selected monitor in QuickDraw space.

Move open windows to debugging monitor when 
debugging starts
Select the Move open windows to debugging monitor when debugging starts 
option to move all open windows to the selected debugging monitor after a debugging 
session starts. At the end of the debugging session, the IDE restores the moved 
windows to their original positions.
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O

Open windows on debugging monitor during 
debugging
Select the Open windows on debugging monitor during debugging option to 
display on the debugging monitor any window that opens during the debugging 
session.

The IDE does not save the positions of windows closed on the debugging monitor 
during the debugging session. This behavior prevents window positions from 
gravitating to the debugging monitor.

Output Directory
Use the Output Directory caption to show the location the IDE places a final linked 
output file. The default location is the directory that contains your project file. Use the 
Choose control to specify the location path.

P

Play sound after ‘Bring Up To Date’ & ‘Make’
Select the Play sound after ‘Bring Up To Date’ & ‘Make’ option to play a sound 
after a build operation completes. Choose different sounds for successful and 
unsuccessful builds using the Success and Failure pop-up options, respectively.

See also:

• “Failure” on page 413

• “Success” on page 428

Post-linker
Use the Post-linker option to select a post-linker that performs additional work (such 
as format conversion) on the final executable file. 
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For more information see the appropriate Targeting manual.

Pre-linker
Use the Pre-linker option to select a pre-linker that performs additional work on the 
object code in a project. This work takes place before the IDE links the object code 
into the final executable file. 

For more information about the pre-linkers available, see the build targets Targeting 
manual.

Program Arguments
Use the Program Arguments field to enter command-line arguments to pass to the 
project at the beginning of a debugging session. Your program receives these 
arguments after you choose Project > Run.

Program entry point
Select this option to halt program execution upon entering the program.

Projects
Enter in this field the number of recent projects to display in the Open Recent 
submenu.

Project Commands
Select the Project Commands option to add Project menu commands to contextual 
menus. Clear the option to remove the commands from the contextual menus.

Project operations
A bullet in the Project operations column, whose label appears at left, indicates 
that the IDE ignores matching folders for project operations. Such operations 
include dragging a folder into the Project window, building a project, or 
searching access paths after choosing File > Open.

Purge Cache
Click Purge Cache to delete the contents of the current file cache.
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R

Recommended
Select the Recommended option to allow the number of concurrent compiles 
suggested by the IDE. This suggestion takes into account the number of active Central 
Processing Units (CPUs) on the host computer.

Regular Expression
Enter in the Regular Expression field a text pattern to match against folder names. 
The IDE excludes matching folders and their contents from selected project operations 
or find-and-compare operations.

Relaxed C popup parsing
Use the Relaxed C popup parsing option to control the strictness of C coding 
conventions:

• Select the option to have the IDE recognize some non-standard functions that 
interfere with Kernighan-and-Ritchie conventions. The IDE displays the non-
standard functions in the Routine list pop-up.

• Clear the option to have the IDE recognize only functions that conform to 
Kernighan-and-Ritchie conventions. The IDE displays only the standard 
functions in the Routine list pop-up.

For more information, refer to “Reference Manual,” of The C Programming 
Language, Second Edition, by Kernighan and Ritchie, published by Prentice Hall.

NOTE Toggle the Relaxed C popup parsing option to maximize 
recognition of functions, macros, and routine names in the source 
code.

Remote download path
Enter in this field the path to the directory in which to store files downloaded from the 
remote host application.
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Require Framework Style Includes
This option determines the strictness with which the IDE treats #include statements 
for frameworks:

• selected—the IDE requires the framework in addition to the referenced header 
file. In the example

#include <Cocoa/CocoaHeaders.h>

the IDE requires the presence of Cocoa/ in order to find the CocoaHeaders.h 
file.

• cleared—the IDE requires only the referenced header file. Using the same 
example, Cocoa/ becomes optional.

Revert Panel
Click Revert Panel to revert all modified options in the current preference or 
settings panel to the values present when the panel was originally opened.

S

Save open files before build
Select the Save open files before build option to automatically save files during 
project operations:

• Preprocess

• Precompile

• Compile

• Disassemble

• Bring Up To Date

• Make

• Run

Save project entries using relative paths
Use the Save project entries using relative paths option to store the location of a file 
using a relative path from one of the access paths. The settings include:
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• enabled–the IDE stores extra location information to distinctly identify different 
source files with the same name. The IDE remembers the location information 
even if it needs to re-search for files in the access paths.

• disabled–the IDE remembers project entries only by name. This setting can 
cause unexpected results if two or more files share the same name. In this case, 
re-searching for files could cause the IDE to find the project entry in a different 
access path.

Script
Choose from the Scripts options the script system (language) used to display text in 
editor windows. This setting behaves in two different ways, depending on the current 
IDE state:

• No editor windows open—the setting modifies the default script system. All 
editor windows take on the default script system.

• Editor windows open—the setting modifies the script system displayed in the 
frontmost editor window only. Other editor windows remain unaffected. The 
default script system remains unchanged.

Select stack crawl window when task is stopped
Select the Select stack crawl window when task is stopped option to automatically 
bring the Thread window to the foreground after the debugger stops a task. Clear the 
option to leave the Thread window in its previous position.

This option is useful for watching variable values change in multiple Variable 
windows as the debugger steps through code.

Selection position
Select the Selection position option to remember these items for each editor window:

• visible text

• insertion-point location

• selected text

Clear the option to open each editor window according to default settings and place 
the insertion point at the first line of text.

NOTE The IDE must be able to write to the file in order to remember 
selection position.
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Show all locals
Select the Show all locals option to display all local variables in Variable windows. 
Clear the option to show only variables near the program counter.

The Variables pane uses these display settings:

• Variables: All—shows all local variables in the code.

• Variables: Auto—only shows the local variables of the routine to which the 
current-statement arrow currently points.

• Variables: None—does not show variables. Use this setting to improve stepping 
performance for slow remote connections.

Show message after building up-to-date project
Select the Show message after building up-to-date project option to have the IDE 
display a message after building an up-to-date project.

Show tasks in separate windows
Select the Show tasks in separate windows option to open a separate Thread window 
for each task. Clear the option to use one Thread window to display multiple tasks. 
When cleared, use the Task list pop-up at the top of the Thread window to choose a 
task to display.

Show the component palette when opening a form
Select the Show the component palette when opening a form option to 
automatically display the Component Palette after opening a form in the Layout 
Editor. Clear the option to require manual opening of the Component Palette.

Show the object inspector when opening a form
Select the Show the object inspector when opening a form option to automatically 
open an Object Inspector window when opening a layout in the Layout Editor. Clear 
the option to require manual opening of the Object Inspector.

Show values as decimal instead of hex
Select the Show values as decimal instead of hex option to display variable values in 
decimal form. Clear the option to display the values in hexadecimal form.
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Show variable location
Select the Show variable location option to display the Location column in the 
Variables pane of the Thread window. Clear the option to hide the Location column.

Show variable types
Select the Show variable types option to display the type associated with each 
variable in Variable windows. Clear the option to hide the variable types.

Show variable values in source code
Select the Show variable values in source code option to show current values for 
variable names displayed in contextual menus. Clear the option to show variable 
names only.

Size
Choose from the Size options the font size used to display text in editor windows. This 
setting behaves in two different ways, depending on the current IDE state:

• No editor windows open—the setting modifies the default font size. All editor 
windows take on the default font size.

• Editor windows open—the setting modifies the font size displayed in the 
frontmost editor window only. Other editor windows remain unaffected. The 
default font size remains unchanged.

Sort functions by method name in symbolics window
Select the Sort functions by method name in symbolics window option to 
alphabetically sort functions by method name. Clear the option to alphabetically sort 
by class name. The sorting affects functions of the form className::methodName 
that appear in the Symbolics window.

Since most C++ and Java source files contain methods that belong to the same class, 
select the option to simplify selection of functions by typing method names.

Stop at Watchpoints
Select this option to halt program execution at every watchpoint, regardless of whether 
the watchpoint value changed. Clear the option to halt execution at watchpoints with 
changed values.
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Stop on application launch
Select this option to halt program execution at a specified point each time a debugging 
session begins.

Strings
Use the Strings option to configure the color of anything that is not a comment, 
keyword, or custom keyword and displayed in editor windows when the Activate 
Syntax Coloring option is enabled. Sample strings include literal values, variable 
names, routine names, and type names.

Click the color swatch next to Strings to set the color.

Sort function popup
Select the Sort function popup option to sort function names by alphabetical order in 
list pop-ups. Clear the option to sort function names by order of appearance in the 
source file.

Success
Choose from the Success options a sound to play after a Bring Up To Date or Make 
operation succeeds.

Symbolics
Enter in this field the number of recent symbolics files to display in the Open Recent 
submenu.

System Paths
Click the System Paths radio button to display the System Paths pane in the Access 
Paths preference panel.

Supported hosts:

• Windows: available.

• Macintosh: not available.
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T

Tab indents selection
Use the Tab indents selection option to control how the editor inserts tabs into the 
currently selected lines of text:

• Select the option so that pressing Tab causes the editor to insert tab characters in 
front of each selected line of text. The editor thereby indents the selected text.

• Clear the option so that pressing Tab causes the editor to replace selected text 
with a tab character. The editor thereby overwrites the selected text.

Tab Inserts Spaces
Select the Tab Inserts Spaces option to have the editor insert spaces instead of tab 
characters into text. Clear the option to have the editor use tab characters.

The Tab Size option determines the number of spaces inserted by the editor.

Tab Size
Enter in the Tab Size field the number of spaces to substitute in place of a tab 
character in text. This number applies to the Tab Inserts Spaces option.

Target Name
Use the Target Name text box to set or modify the name of the current build target. 
This name appears in the Targets view in the Project window. This name is not the 
name assigned to the final output file, that is set in the Linker panel for the build target.

Type
Choose from the Type options the desired source-tree path type:

• Absolute Path—This source-tree type is based on a file path.

• Environment Variable—This source-tree type is based on an existing 
environment-variable definition. The Macintosh-hosted IDE cannot create or 
modify this source-tree type.

• Registry Key—This source-tree type is based on an existing Windows registry 
key entry.
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U

Update data every n seconds
Select this option to update the information displayed in debugging-session windows 
after a specified time interval. Enter in the field the number of seconds n to elapse 
before the next update. Clear this option to prevent data updates and keep the same 
window information throughout the debugging session.

Use Concurrent Compiles
Select the Use Concurrent Compiles option to run more than one compiling 
processes at a time. Concurrent compiling makes better use of available processor 
capacity by allowing the operating system to optimize resource utilization, such as 
taking advantage of over-lapped input/output.

Both single- and multi-processor systems benefit from enabling concurrent compiles. 
On multiprocessor systems, the speed-up is significant.

Use Debugging Monitor
Select the Use Debugging Monitor option to view debugging windows on a second 
monitor after a debugging session starts. This option only appears when the second 
monitor is connected to the computer.

Use default workspace
Select this option to have the IDE use the default workspace. The IDE uses the default 
workspace to save and restore window and debugging states from one session to the 
next.

For example, if you select this option and close the IDE with a project window visible 
onscreen, that project window reappears the next time you start the IDE.

Clear this option to have the IDE start with the same default state for each new 
session: no windows visible onscreen.

For example, if you clear this option and close the IDE with a project window visible 
onscreen, that project window does not appear the next time you start the IDE. Instead, 
the IDE always starts without opening any windows.
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Use External Debugger
Select this option to have the IDE use an external debugger application in place of the 
CodeWarrior debugger.

Use External Editor
Select the Use External Editor option to use an external text editor to modify text 
files in the current project. Clear the option to use the text editor included with the 
IDE.

Use Local Project Data Storage
Select the Use Local Project Data Storage option to store on the host computer data 
associated with a project file on a read-only volume. Clear the option to store project 
data inside the same folder as the project file itself.

After loading a project file, the IDE creates or updates an associated project data 
folder. The IDE stores intermediate project data in this folder. When building or 
closing a project, the IDE uses the information in the project data folder to update the 
project file.

By default, the IDE places the project data folder within the same folder as the project 
file. However, the IDE cannot create or update a project data folder in a location that 
grants read-only privileges. 

Use modification date caching
Use the Use modification date caching option to determine whether the IDE checks 
the modification date of each project file prior to making the project. The settings 
include:

• enabled–the IDE caches the modification dates of the files in a project. At 
compilation time, the IDE refers to this cache to determine whether a specific file 
should be recompiled. This can shorten compilation time significantly for large 
projects.

• disabled–the IDE checks every file at each recompile of the project. Use this 
setting if using third-party editors to ensure that the IDE checks every file at 
compilation time.

Use Multiple Document Interface
Toggle this option to change the IDE interface:
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• Selected—The IDE uses MDI (Multiple Document Interface). In this interface, 
the IDE uses a main application window with a gray background. IDE windows 
appear inside the main application window. The gray background obscures your 
view of the desktop.

• Cleared—The IDE uses FDI (Floating Document Interface). In this interface, 
the IDE does not use a main application window. You can see through the IDE 
user interface to your desktop. IDE windows appear above the desktop.

Use multiple undo
Select the Use multiple undo option to remember several undo and redo operations in 
editor windows. Clear the option to remember only the most recent undo or redo 
action.

The IDE stores undo and redo actions on a stack in first-in last-out (FILO) order, 
however, the stack size and capability are limited. For example, assume there are five 
undo actions on the stack (ABCDE). If the IDE redoes two actions (ABC), then performs 
a new action (ABCF), the undo events (DE) are no longer available.

Use Script menu
Select the Use Script menu option to display the Scripts menu in the IDE menu bar. 
Clear the option to remove the Scripts menu from the menu bar. The Scripts menu 
provides convenient access to IDE scripts.

For more information about scripting the IDE, refer to the CodeWarrior Scripting 
Reference.

Use Third Party Editor
Select the Use Third Party Editor option to use a third-party text editor to modify 
text files. Clear the option to use the text editor included with the IDE.

Enter in the Launch Editor and Launch Editor w/ Line # fields command-line 
expressions that specify information that the IDE passes to the third-party editor.

Consult the documentation provided with the third-party text editor for more 
information about using command lines.

See also:

• “Launch Editor” on page 417

• “Launch Editor w/ Line #” on page 418
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Use ToolServer menu
Select the Use ToolServer menu option to display the ToolServer menu in the IDE 
menu bar. Clear the option to remove the ToolServer menu from the menu bar.

User Paths
Click this radio button to display the User Paths pane in the Access Paths preference 
panel.

User Specified
Select the User Specified option to stipulate the number of concurrent compiles to 
allow in the IDE. Enter the desired number in the text box beside the option.

NOTE The IDE accommodates a maximum of 1024 concurrent compiles. 
However, there is a point where the host system becomes compute-
bound, and allowing more processes only adds overhead. For a 
single-processor system, the practical limit is approximately 12 
concurrent compiles.

V

Value
The Value text box defines the value of the variable defined in the Variable text box 
that will be passed to a host application when control is transferred to it by the IDE.

Variable
The Variable text box defines the name of a variable to be passed to a host application 
when control is transferred to it by the IDE.
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Variable values change
Use the Variable values change option to configure the color of changed variables 
that appear in debugger windows. Click the color swatch to change the current color.

VCS Commands
Select the VCS Commands option to add VCS menu commands to contextual menus. 
Clear the option to remove the commands from the contextual menus.

Refer to the documentation that came with the version control system to learn about 
using it with the CodeWarrior IDE.

W-Z

Watchpoint indicator
Use the Watchpoint indicator option to configure the color of watchpoints that 
appear in debugger windows. Click the color swatch to change the current color.

Window follows insertion point
Select this option to have the Code Completion window follow the insertion point as 
you edit text in the active editor window. Clear the option to leave the Code 
Completion window in place.

Window position and size
Select the Window position and size option to remember the location and dimensions 
of each editor window. Clear the option to open each editor window according to 
default settings.

NOTE The IDE must be able to write to the file in order to remember 
window position and size.
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Working Directory
Enter in this field the path to the default directory to which the current project has 
access. Debugging occurs in this location. If this field is blank, debugging occurs in 
the same directory as the executable file.

Workspaces
Enter in this field the number of recent workspace files to display in the Open Recent 
submenu.

Zoom windows to full screen
Use the Zoom windows to full screen option to configure the behavior of the zoom 
box in the upper right-hand corner of all editor windows:

• Select the option to have the IDE resize a zoomed window to fill the entire 
screen.

• Clear the option to have the IDE resize a zoomed window to its default size.
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VIII

Menus

This section contains these chapters:

• IDE Menus

• Menu Commands
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IDE Menus

This chapter provides an overview of CodeWarrior™ IDE menus and their commands. 
The IDE provides two different arrangements of IDE menus, configurable in the IDE 
Extras preference panel:

• Windows menu layout

• Macintosh menu layout

This chapter lists the IDE menus under each menu layout. For each menu, a table 
shows this information:

• Menu command—the name of each command in the menu.

• Description—a short description of each command.

This chapter has these sections:

• “Windows Menu Layout” on page 439

• “Macintosh Menu Layout” on page 452

Windows Menu Layout
This section provides an overview of the menus and menu commands available in the 
Windows menu layout. 

File Menu
The File menu contains commands for opening, creating, saving, closing, and printing 
source files and projects. The File menu also provides different methods for saving 
edited files.
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Table 29.1  File menu commands

Menu command Explanation

New Creates new projects using the New Project wizard or from project 
stationery files.

Open Opens source and project files for editing and project
modification operations.

Find and Open File Opens the file specified in the Find and Open File dialog or from the 
selected text in the active window.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to change this command to Find.

Close Closes the active window.

Save Saves the active file using the editor window’s filename.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to change this command to Save All.

Save All Saves all open editor windows.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to substitute this command for the Save 
command.

Save As Saves a copy of the active file under a new name and closes the 
original file.

Save A Copy As Saves a copy of the active file without closing the file.

Revert Discards all changes made to the active file since the last
save operation.

Open Workspace Opens a workspace that you previously saved.

Close Workspace Closes the current workspace. (You cannot close the
default workspace.)

Save Workspace Saves the current state of onscreen windows, recent items,
and debugging.

Save Workspace As Saves an existing workspace under a different name.

Import Components Imports the components from another catalog into the
current catalog.

Close Catalog Closes the current catalog and its associated Catalog Components 
window and Component Palette.
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Edit Menu
The Edit menu contains all the customary editing commands, along with some 
CodeWarrior additions. This menu also includes the commands that open the 
Preferences and Target Settings windows.

Import Project Imports a project file previously saved in extensible markup 
language format (XML) and converts it into project file format.

Export Project Exports the active project file to disk in extensible markup language 
(XML) format.

Page Setup Displays the Page Setup dialog for setting paper size, orientation, 
and other printer options.

Print Displays the Print dialog for printing active files, and the contents of 
Project, Message, and Errors & Warning window contents.

Open Recent Displays a submenu of recently opened files and projects that can be 
chosen to open in the IDE.

Exit Quits the CodeWarrior IDE.

When using the Windows menu layout on a Macintosh host, this 
command does not appear. Instead, use the Quit command in the 
File menu or the Quit CodeWarrior command in the CodeWarrior 
menu.

Table 29.2  Edit menu commands

Menu command Explanation

Undo Undoes the action of the last cut, paste, clear, or typing operation.

If you cannot undo the action, this command changes to
Can’t Undo.

Redo Redoes the action of the last Undo operation.

If you cannot redo the action, this command changes to
Can’t Redo.

Cut Removes the selected text and places a copy of it on the Clipboard.

Copy Copies the selected text and places a copy of it on the Clipboard.

Table 29.1  File menu commands (continued)

Menu command Explanation
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View Menu
The View menu contains commands for viewing toolbars, the class browser, the 
Message window, and debugging windows.

Paste Places the contents of the Clipboard at current insertion point or 
replaces the selected text.

Delete Removes the selected text without placing a copy on the Clipboard.

When using the Windows menu layout on a Macintosh host, this 
command does not appear. Instead, use the Clear command.

This command saves a copy of 
an existing workspace. Use this 
command to save the 
workspace under a different 
name.Select All

Selects all the text in the current editor window or text box for cut, 
copy, paste, clear, or typing operations.

Balance Selects the text between the nearest set of parenthesis, braces, or 
brackets.

Shift Left Moves the selected text one tab stop to the left.

Shift Right Moves the selected text one tab stop to the right.

Get Previous Completion Shortcut for selecting the previous item that appears in the Code 
Completion window.

Get Next Completion Shortcut for selecting the next item that appears in the Code 
Completion window.

Complete Code Opens the Code Completion window.

Preferences Opens the IDE Preferences window where you can set general IDE, 
editor, debugger, and layout options.

Target Settings
(the name changes, based on 
the name of the active build 
target)

Opens the project’s Target Settings window where you can set 
target, language, code generation, linker, editor, and debugger 
options.

Version Control Settings Opens the VCS Settings window to enable the activation of a version 
control system and its relevant settings.

Commands & Key Bindings Opens the Customize IDE Commands window where you can 
create, modify, remove menus, menu commands, and key bindings.

Table 29.2  Edit menu commands (continued)

Menu command Explanation
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Search Menu
The Search menu contains commands for finding text, replacing text, comparing files, 
and navigating code.

Table 29.3  View menu commands

Menu command Explanation

Toolbars Use the Toolbars menu to show, hide, reset, and clear window and 
main toolbars.

Project Inspector Opens or brings to the front a Project Inspector window.

Browser Contents Opens or brings to the front a Browser Contents window.

Class Browser Opens or brings to the front a New Class Browser window.

Class Hierarchy Opens or brings to the front a Class Hierarchy window.

Build Progress Opens the Build Progress window.

Errors & Warnings Opens or brings to the front an Errors & Warnings window.

Symbolics Opens the Symbolics window.

Processes Opens or brings to the front a Processes window. 

Breakpoints Opens or brings to the front the Breakpoints window. Use this 
window to view, create, modify, and remove breakpoints.

Registers Opens or brings to the front a Register window.

Expressions Opens or brings to the front an Expressions window. Use to view, 
create, modify, and remove expressions.

Global Variables Opens or brings to the front a Global Variables window. 

Table 29.4  Search menu commands

Menu command Explanation

Find Opens the Find and Replace window for performing searches in the 
active editor window.

Replace Opens the Find and Replace window for replacing text in the active 
editor window.

Find in Files Opens the Find in Files window for performing searches in the active 
editor window.
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Find Next Finds the next occurrence of the find string in the active
editor window.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find Previous.

Find In Next File Finds the next occurrence of the find string in the next file listed in the 
Find window’s File Set.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find In Previous 
File.

Enter Find String Replaces the Find text box string with the selected text.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Enter Replace 
String.

Find Selection Finds the next occurrence of the selected text in the active
editor window.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find Previous 
Selection.

Replace Selection Replaces the replace string in the Replace text box with the
selected text.

Replace and Find Next Replaces the selected text with the Replace text box string, then 
performs a Find Next operation.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Replace and Find 
Previous.

Replace All Finds all matches of the Find text box string and replaces them with 
the Replace text box string.

Find Definition Searches for the definition of the routine name selected in the active 
editor window using the project’s source files.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to change this command to Find Reference.

Go Back Returns to the previous CodeWarrior browser view.

Table 29.4  Search menu commands (continued)

Menu command Explanation
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Project Menu
The Project menu contains commands for manipulating files, handling libraries, 
compiling projects, building projects, and linking projects.

Go Forward Moves to the next CodeWarrior browser view.

Go to Line Opens the Go To Line dialog where you can specify by line number 
where to position the text insertion point.

Compare Files Opens the Compare Files Setup window where you can choose to 
compare folders or files and merge their contents.

Apply Difference Adds, removes, or changes the selected text in the destination file to 
match the selected text in the source file.

Unapply Difference Reverses the modifications made to the destination file by the Apply 
Difference command.

Table 29.5  Project menu commands

Menu command Explanation

Add Window Adds the active window to the project.

Add Files Opens a dialog box that you can use to add multiple files to the 
active project.

Create Group Opens the Create Group dialog box that you can use to add a new 
file group to the active project. The new file group appears below the 
selected file or group.

Create Target Opens the Create Target dialog box that you can use to add a new 
build target to the active project. The new build target appears below 
the selected build target.

Create Segment
or
Create Overlay

Opens the Create Segment/Overlay dialog box that you can use to 
add a new segment or overlay to the active project. The new 
segment or overlay appears below the selected one.

Create Design Opens the Create New Design dialog box that you can use to add a 
design to the active project. The new design appears in the Design 
tab of the project window.

Table 29.4  Search menu commands (continued)

Menu command Explanation
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Export Project as GNU Makefile Exports the current project to a GNU makefile.

When using the Windows menu layout on a Macintosh host, this 
command does not appear.

Check Syntax Checks the active editor window or selected files in the project 
window for compilation errors.

Preprocess Preprocesses the active editor window or selected files in the project 
window and displays the results in a new editor window.

Precompile Precompiles the active editor window or selected files in the project 
window and stores the results in a new header file.

Compile Compiles the active editor window or selected files in the project 
window.

Disassemble Disassembles the active editor window or selected files in the project 
window and displays the results in a new editor window.

Bring Up To Date Compiles all marked or modified files in the current build target of the 
active project.

Make Compiles and links all marked or modified files in the current build 
target of the active project, saving the executable file.

Stop Build Stops the current compile and linking operation and cancels the 
remainder of the build process.

Remove Object Code Removes the object code from one or more build targets in the 
project.

When using the Windows menu layout on a Macintosh host, hold 
down the Shift key to change this command to Remove Object 
Code & Compact.

Re-search for Files Resets the cached locations of source files using the project access 
paths, and storing them for faster builds and project operations.

Reset Project Entry Paths Resets the location of all source files in the active project using the 
project access paths.

Synchronize Modification Dates Updates the modification dates of all source files in the active 
project.

Table 29.5  Project menu commands (continued)

Menu command Explanation
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Debug Menu
The Debug menu contains commands for managing program execution.

Debug

or

Resume

Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Run Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Set Default Project Uses the Set Default Project menu to choose the default project 
when more than one project is open in the IDE.

Set Default Target Uses the Set Default Target menu to choose the default build target 
when more than one build target is present in the project file.

Table 29.6  Debug menu commands

Menu command Explanation

Break Pauses execution of the program in a debugging session to enable 
examination of register and variable contents

Kill Terminates the current debugging session returning control to
the IDE.

Restart Terminates the current debugging session, then restarts the program 
from the beginning.

Step Over Executes each source line in the program, treating routine calls as a 
single statement and stopping the program at the next line of code.

Step Into Executes each source line in the program, following any
subroutine calls.

Step Out Executes each source line in the subroutine and stops the program 
when the routine returns to its caller.

Run to Cursor Sets a temporary breakpoint on the source line containing the 
insertion point.

Change Program Counter Opens the Change Program Counter dialog box that you can use to 
move the current statement arrow to an address or symbol.

Table 29.5  Project menu commands (continued)

Menu command Explanation
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Set Breakpoint

or

Clear Breakpoint

Sets a breakpoint on the source line containing the insertion point.

Clears the breakpoint on the source line containing the insertion 
point.

Set Eventpoint Sets an eventpoint on the source line containing the insertion point.

Clear Eventpoint Clears the breakpoint on the source line containing the insertion 
point.

Set/Clear Breakpoint Opens the Set/Clear Breakpoint dialog box that you can use for 
setting or clearing breakpoints by address or symbol.

Enable Breakpoint

or

Disable Breakpoint

Activates the disabled breakpoint on the source line containing the 
insertion point.

De-activates the breakpoint on the source line containing the 
insertion point.

Clear All Breakpoints Clears all breakpoints currently set in the default build target of the 
active project.

Show Breakpoints

or

Hide Breakpoints

Adds a Breakpoint Column to all project editor windows where you 
can set, view, or clear breakpoints.

Removes the Breakpoint Column from all project editor windows.

Set Watchpoint

or

Clear Watchpoint

Sets a watchpoint on the source line containing the insertion point.

Clears the watchpoint on the source line containing the insertion 
point.

Enable Watchpoint

or

Disable Watchpoint

Activates the disabled watchpoint on the source line containing the 
insertion point.

De-activates the watchpoint on the source line containing the 
insertion point.

Clear All Watchpoints Clears all watchpoints currently set in the default build target of the 
active project.

Table 29.6  Debug menu commands (continued)

Menu command Explanation
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Data Menu
The Data menu contains commands that control how the CodeWarrior debugger 
displays data values. This menu appears only during a debugging session.

Break on C++ Exception Configures the debugger to break at __throw() each time a C++ 
exception occurs.

Break on Java Exceptions Use this menu to select the Java exceptions on which the debugger 
breaks.

Connect Establishes communication with an embedded device to start a 
debugging session.

When using the Windows menu layout on a Macintosh host, this 
command does not appear.

Table 29.7  Data menu commands

Menu command Explanation

Show Types Toggles the appearance of the data type on local and global 
variables displayed in Variable panes and Variable windows.

Refresh All Data Updates data displays.

New Expression Creates a new expression entry in the Expressions window.

Copy to Expression Copies the selected variable to the Expressions window.

View As Displays the View As dialog where the data type of the selected 
variable can be specified.

View Variable Displays the selected variable in a new Variables window.

View Array Displays the selected array variable in a new Arrays window.

View Memory Displays the selected variable in a new Memory window.

View Memory As Displays the View As dialog where the data type of the selected 
variable can be specified, then shown in a new Memory window.

Cycle View Toggles the data view among View Source, View Disassembly, 
View Mixed, and View Raw Data.

View Source View data as source code.

Table 29.6  Debug menu commands (continued)

Menu command Explanation
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Window Menu
The Window menu contains commands that manipulate IDE windows.

The menu lists the names of all open file and project windows. A checkmark appears 
beside the active window, and an underline indicates a modified and unsaved file.

View Disassembly View data as language disassembly.

View Mixed View data as source code and its disassembly.

View Raw Data View data without applied formatting.

View As Default Views the selected variable in the default value format.

View As Binary Views the selected variable as a binary value.

View As Signed Decimal Views the selected variable as a signed decimal value.

View As Unsigned Decimal Views the selected variable as an unsigned decimal value.

View As Hexadecimal Views the selected variable as a hexadecimal value.

View As Character Views the selected variable as a character value.

View As C String Views the selected variable as a C string.

View As Pascal String Views the selected variable as a Pascal string.

View As Unicode String Views the selected variable as a Unicode string.

View As Floating Point Views the selected variable as a floating point value.

View As Enumeration Views the selected variable as an enumerated value.

View As Fixed Views the selected variable as a 32-bit fixed value.

Table 29.7  Data menu commands (continued)

Menu command Explanation
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Help Menu
The Help menu contains commands for accessing the IDE’s online help.

Table 29.8  Window menu commands

Menu command Explanation

Close Closes the active window.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to change this command to Close All.

Close All Closes all non-project windows.

When using the Windows menu layout on a Macintosh host, hold 
down the Option key to substitute this command for the
Close command.

Cascade Arranges all editor windows so that only the title bar is visible.

Tile Horizontally Tiles all editor windows horizontally on the screen so none overlap.

Tile Vertically Tiles all editor windows vertically on the screen so none overlap.

Save Default Window Saves the active browser windows settings and applies it to other 
browser windows as they are opened.

Table 29.9  Help menu commands

Menu command Explanation

CodeWarrior Help Launches a help viewer to display the CodeWarrior IDE online help. 
Click on a link to view a specific IDE topic.

Index Launches a help viewer to display a glossary of common terms used 
in the CodeWarrior help and manuals.

Search Launches a help viewer to a page for searching the CodeWarrior 
help and manuals.

Online Manuals Launches a help viewer to display a list of CodeWarrior manuals. 
Click on a link to view a specific manuals contents.

Metrowerks Website Launches a browser and automatically points you to the Metrowerks 
web site.

About Metrowerks CodeWarrior Displays the CodeWarrior IDE version and build number information.
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Macintosh Menu Layout
This section provides an overview of the menus and menu commands available in the 
Macintosh menu layout. 

Apple Menu
The Apple menu (Mac OS 9.x.x and earlier) provides access to the CodeWarrior 
About box, shows system applications, and lists additional items.

Select About Metrowerks CodeWarrior to display the IDE version and build-number 
information.

When using the Macintosh menu layout on a Windows host, this menu does not 
appear.

CodeWarrior Menu
The CodeWarrior Menu (visible in Mac OS X only) provides access to the 
CodeWarrior About box, IDE preferences, and the command that quits the IDE.

When using the Macintosh menu layout on a Windows host, this menu does not 
appear.

File Menu
The File menu contains commands for opening, creating, saving, closing, and printing 
source files and projects. The File menu also provides different methods for saving 
edited files.

Table 29.10  Apple menu commands

Menu command Explanation

About Metrowerks CodeWarrior Displays the CodeWarrior IDE version and build number information.

Preferences Opens the IDE Preferences window where you can set general IDE, 
editor, debugger, and layout options.

Quit Quits the CodeWarrior IDE.
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Table 29.11  File menu commands

Menu command Explanation

New Text File Creates a new text file and displays it in a new editor window.

New Creates new projects using the New Project wizard or from project 
stationery files.

Open Opens source and project files for editing and project
modification operations.

Open Recent Displays a submenu of recently opened files and projects that can be 
chosen to open in the IDE.

Find and Open File Opens the file specified in the Find and Open File dialog or from the 
selected text in the active window.

Close Closes the active window.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Option key to change this command to Close All.

Save Saves the active file using the editor window’s filename.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Option key to change this command to Save All.

Save As Saves a copy of the active file under a new name and closes the 
original file.

Save A Copy As Saves a copy of the active file without closing the file.

Revert Discards all changes made to the active file since the last save 
operation.

Open Workspace Opens a workspace that you previously saved.

Close Workspace Closes the current workspace. (You cannot close the default 
workspace.)

Save Workspace Saves the current state of onscreen windows, recent items, and 
debugging.

Save Workspace As Saves an existing workspace under a different name.

Import Components Imports the components from another catalog into the current 
catalog.

Close Catalog Closes the current catalog and its associated Catalog Components 
window and Component Palette.
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Edit Menu
The Edit menu contains all of the customary editing commands, along with some 
CodeWarrior additions. This menu also includes the commands that open the 
Preferences and Target Settings windows.

Import Project Imports a project file previously saved in extensible markup 
language format (XML) and converts it into project file format.

Export Project Exports the active project file to disk in extensible markup language 
(XML) format.

Page Setup Displays the Page Setup dialog for setting paper size, orientation, 
and other printer options.

Print Displays the Print dialog for printing active files, and the contents of 
Project, Message, and Errors & Warning window contents.

Quit (Classic Mac OS) Quits the CodeWarrior IDE.

Table 29.12  Edit menu commands

Menu command Explanation

Undo Undoes the action of the last cut, paste, clear or typing operation.

If you cannot undo the action, this command changes to
Can’t Undo.

Redo Redoes the action of the last Undo operation.

If you cannot redo the action, this command changes to
Can’t Redo.

Cut Removes the selected text and places a copy of it on the Clipboard.

Copy Copies the selected text and places a copy of it on the Clipboard.

Paste Places the contents of the Clipboard at current insertion point or 
replaces the selected text.

Clear Removes the selected text without placing a copy on the Clipboard.

When using the Macintosh menu layout on a Windows host, this 
command does not appear. Instead, use the Delete command.

Table 29.11  File menu commands (continued)

Menu command Explanation
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Search Menu
The Search menu contains commands for finding text, replacing text, comparing files, 
navigating code, and finding routine definitions.

This command saves a copy of 
an existing workspace. Use this 
command to save the 
workspace under a different 
name.Select All

Selects all the text in the current editor window or text box for cut, 
copy, paste, clear, or typing operations.

Balance Selects the text between the nearest set of parenthesis, braces,
or brackets.

Shift Left Moves the selected text one tab stop to the left.

Shift Right Moves the selected text one tab stop to the right.

Get Previous Completion Shortcut for selecting the previous item that appears in the Code 
Completion window.

Get Next Completion Shortcut for selecting the next item that appears in the Code 
Completion window.

Complete Code Opens the Code Completion window.

Insert Reference Template Inserts a routine template corresponding to the selected Mac OS 
Toolbox call in the active window.

When using the Macintosh menu layout on a Windows host, this 
command does not appear.

Preferences Opens the IDE Preferences window where you can set general IDE, 
editor, debugger, and layout options.

Target Settings
(the name changes, based on 
the name of the active build 
target)

Opens the project’s Target Settings window where you can set 
target, language, code generation, linker, editor, and debugger 
options.

Version Control Settings Opens the VCS Settings window to enable the activation of a version 
control system and its relevant settings

Commands & Key Bindings Opens the Customize IDE Commands window where you can 
create, modify, remove menus, menu commands, and key bindings.

Table 29.12  Edit menu commands (continued)

Menu command Explanation
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Table 29.13  Search menu commands

Menu command Explanation

Find and Replace Opens the Find and Replace window for performing find and replace 
operations on the active editor window.

Find in Files Opens the Find in Files window for performing searches in the active 
editor window.

Find Next Finds the next occurrence of the find string in the active editor 
window.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find Previous.

Find In Next File Finds the next occurrence of the find string in the next file listed in the 
Find window’s File Set.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find In Previous 
File.

Enter Find String Replaces the Find text box string with the selected text.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Enter Replace 
String.

Find Selection Finds the next occurrence of the selected text in the active editor 
window.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find Previous 
Selection.

Replace Selection Replaces the replace string in the Replace text box with the selected 
text.

Replace and Find Next Replaces the selected text with the Replace text box string, then 
performs a Find Next operation.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Replace and Find 
Previous.

Replace All Finds all matches of the Find text box string and replaces them with 
the Replace text box string.
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Project Menu
The Project menu contains commands for manipulating files, handling libraries, 
compiling projects, building projects, and linking projects.

Find Definition Searches for the definition of the routine name selected in the active 
editor window using the project’s source files.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Shift key to change this command to Find Definition & 
Reference.

Find Reference Searches for the definition of the routine name selected in the active 
editor window using the specified online help system.

When using the Macintosh menu layout on a Windows host, this 
command does not appear.

Go Back Returns to the previous CodeWarrior browser view.

Go Forward Moves to the next CodeWarrior browser view.

Go to Line Opens the Go To Line dialog where you can specify by line number 
where to position the text insertion point.

Compare Files Opens the Compare Files Setup window where you can choose to 
compare folders or files and merge their contents.

Apply Difference Adds, removes, or changes the selected text in the destination file to 
match the selected text in the source file.

Unapply Difference Reverses the modifications made to the destination file by the Apply 
Difference command.

Table 29.14  Project menu commands

Menu command Explanation

Add Window
(the name changes, based on 
the name of the selected item)

Adds the active window to the project.

Add Files Opens a dialog that you can use to add multiple files to the
active project.

Table 29.13  Search menu commands (continued)

Menu command Explanation
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Create Group

or

Create Target

or

Create Overlay

or

Create Segment

Displays the Create Group dialog where you can add a new file 
group to the active project immediately after the selected file or 
group.

Displays the Create Target dialog where you can add a new build 
target to the active project immediately after the selected build target.

Displays the Create Overlay dialog where you can add a new 
memory overlay to the active project immediately after the selected 
overlay.

Displays the Create Segment dialog where you can add a new 
segment to the active project immediately after the selected 
segment.

Create Design Opens the Create New Design dialog box that you can use to add a 
design to the active project. The new design appears in the Design 
tab of the project window.

Check Syntax Checks the active editor window or selected files in the project 
window for compilation errors.

Preprocess Preprocesses the active editor window or selected files in the project 
window and displays the results in a new editor window.

Precompile Precompiles the active editor window or selected files in the project 
window and stores the results in a new header file.

Compile Compiles the active editor window or selected files in the project 
window.

Disassemble Disassembles the active editor window or selected files in the project 
window and displays the results in a new editor window.

Bring Up To Date Compiles all marked or modified files in the current build target of the 
active project.

Make Compiles and links all marked or modified files in the current build 
target of the active project, saving the executable. file

Stop Build Stops the current compile and linking operation and cancels the 
remainder of the build process.

Table 29.14  Project menu commands (continued)

Menu command Explanation
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Debug Menu
The Debug menu contains commands for managing program execution.

Remove Object Code Removes the object code from one or more build targets in the 
project.

When using the Macintosh menu layout on a Macintosh host, hold 
down the Option key to change this command to Remove Object 
Code & Compact.

Re-search for Files Resets the cached locations of source files using the project access 
paths, and storing them for faster builds and project operations.

Reset Project Entry Paths Resets the location of all source files in the active project using the 
project access paths.

Synchronize Modification Dates Updates the modification dates of all source files in the active 
project.

Debug

or

Resume

Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Run Compiles and links all marked or modified files in the current build 
target of the active window, then runs the built executable file.

Set Default Project Uses the Set Default Project menu to choose the default project 
when more than one project is open in the IDE.

Set Default Target Uses the Set Default Target menu to choose the default build target 
when more than one build target is present in the project file.

Table 29.15  Debug menu commands

Menu command Explanation

Kill Terminates the current debugging session returning control to 
he IDE.

Restart Terminates the current debugging session, then restarts the program 
from the beginning.

Table 29.14  Project menu commands (continued)

Menu command Explanation
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Step Over Executes each source line in the program, treating routine calls as a 
single statement and stopping the program at the next line of code.

Step Into Executes each source line in the program, following any subroutine 
calls.

Step Out Executes each source line in the subroutine and stops the program 
when the routine returns to its caller.

Stop Pauses execution of the program in a debugging session to enable 
examination of register and variable contents.

Set Breakpoint

or

Clear Breakpoint

Sets a breakpoint on the source line containing the insertion point.

Clears the breakpoint on the source line containing the insertion 
point.

Set Eventpoint Sets an eventpoint on the source line containing the insertion point.

Clear Eventpoint Clears the breakpoint on the source line containing the insertion 
point.

Set/Clear Breakpoint Displays the Set/Clear Breakpoint dialog for setting or clearing 
breakpoints by address or symbol.

Enable Breakpoint

or

Disable Breakpoint

Activates the disabled breakpoint on the source line containing the 
insertion point.

De-activates the breakpoint on the source line containing the 
insertion point.

Clear All Breakpoints Clears all breakpoints currently set in the default build target of the 
active project.

Show Breakpoints

or

Hide Breakpoints

Adds a Breakpoint Column to all project editor windows where 
breakpoints can be set, viewed, and cleared.

Removes the Breakpoint Column from all project editor windows.

Set Watchpoint

or

Clear Watchpoint

Sets a watchpoint on the source line containing the insertion point.

Clears the watchpoint on the source line containing the insertion 
point.

Table 29.15  Debug menu commands (continued)

Menu command Explanation
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Data Menu
The Data menu contains commands that control how the CodeWarrior debugger 
displays data values. This menu only appears during a debugging session.

Enable Watchpoint

or

Disable Watchpoint

Activates the disabled watchpoint on the source line containing the 
insertion point.

De-activates the watchpoint on the source line containing the 
insertion point.

Clear All Watchpoints Clears all watchpoints currently set in the default build target of the 
active project.

Run to Cursor Sets a temporary breakpoint on the source line containing the 
insertion point.

Change Program Counter Displays the Change Program Counter dialog where you can move 
the current statement arrow to an address or symbol.

Break on C++ Exception Configures the debugger to break at __throw() each time a C++ 
exception occurs.

Break on Java Exceptions Use this menu to select which Java exceptions the debugger should 
break on.

Switch to Monitor Configures the IDE to use an external debugger instead of the 
CodeWarrior debugger.

When using the Macintosh menu layout on a Windows host, this 
command does not appear.

Table 29.16  Data menu commands

Menu command Description

Show Types Toggles the appearance of the data type on local and global 
variables displayed in Variable panes and Variable windows.

Refresh All Data Updates data displays.

New Expression Creates a new expression entry in the Expressions window.

Copy to Expression Copies the selected variable to the Expressions window.

Table 29.15  Debug menu commands (continued)

Menu command Explanation
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View As Displays the View As dialog where the data type of the selected 
variable can be specified.

View Variable Displays the selected variable in a new Variables window.

View Array Displays the selected array variable in a new Arrays window.

View Memory Displays the selected variable in a new Memory window.

View Memory As Displays the View As dialog where the data type of the selected 
variable can be specified, then shown in a new Memory window.

Cycle View Toggles the data view among View Source, View Disassembly, 
View Mixed, and View Raw Data.

View Source View data as source code.

View Disassembly View data as language disassembly.

View Mixed View data as source code and its disassembly.

View Raw Data View data without applied formatting.

View As Default Views the selected variable in the default value format.

View As Binary Views the selected variable as a binary value.

View As Signed Decimal Views the selected variable as a signed decimal value.

View As Unsigned Decimal Views the selected variable as an unsigned decimal value.

View As Hexadecimal Views the selected variable as a hexadecimal value.

View As Character Views the selected variable as a character value.

View As C String Views the selected variable as a C string.

View As Pascal String Views the selected variable as a Pascal string.

View As Unicode String Views the selected variable as a Unicode string.

View As Floating Point Views the selected variable as a floating point value.

View As Enumeration Views the selected variable as an enumerated value.

View As Fixed Views the selected variable as a 32-bit fixed value.

View As Fract Views the selected variable as a fract value.

When using the Macintosh menu layout on a Windows host, this 
command does not appear.

Table 29.16  Data menu commands (continued)

Menu command Description
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Window Menu
The Window menu contains commands that manipulate IDE windows. The Window 
menu is divided into several sections:

• window commands to stack, tile, zoom, collapse, and save window positions.

• toolbar submenu for showing, hiding, resetting, and clearing window and floating 
toolbars.

• commands to open specific browser, IDE, and debugger windows.

• names of all open file and project windows.

A check mark appears beside the active window, and an underline denotes a modified 
and unsaved file.

Table 29.17  Window menu commands

Menu command Description

Stack Editor Windows Arranges all editor windows so that only the title bar is visible.

Tile Editor Windows Tiles all editor windows horizontally on the screen so none overlap.

Tile Editor Windows Vertically Tiles all editor windows vertically on the screen so none overlap.

Zoom Window Restores the active editor window to its previous size and position.

Collapse Window
(Minimize Window)

or

Expand Window
(Maximize Window)

Collapses the active editor window so that only its title bar is visible.

Expands the collapsed editor window to its previous size and 
position.

Save Default Window Saves the current browser-window settings for later re-use.

Toolbars Use the Toolbars submenu to show, hide, reset, and clear window, 
main, and floating toolbars.

Browser Contents Opens or brings to the front a Browser Contents window.

Class Hierarchy Window Opens or brings to the front a Class Hierarchy window.

New Class Browser Opens or brings to the front a New Class Browser window.

Build Progress Window Opens or brings to the front a Build Progress window.

Errors & Warnings Window Opens or brings to the front an Errors & Warnings window.

Project Inspector Opens or brings to the front a Project Inspector window.
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VCS Menu
The VCS (Version Control System) menu appears in the IDE’s menu bar when the 
Use Version Control option is enabled. The CodeWarrior IDE can operate with many 
difference version control systems including CVS, Visual SourceSafe, and others.

This icon represents the VCS menu in the Macintosh-hosted IDE
menu bar.

Refer to the documentation that came with the version control system to learn about 
using it with the CodeWarrior IDE.

Tools Menu
The Tools menu appears in the IDE’s menu bar after you enable the Use ToolServer 
menu checkbox in the IDE Extras preference panel. The Tools menu contains 
commands for controlling Apple® ToolServer™ and Macintosh Programmer’s 
Workbench (MPW).

Macintosh: This icon represents the Tools menu in the Macintosh-hosted IDE 
menu bar.

Refer to Targeting Mac OS to learn about using ToolServer and MPW
with projects.

ToolServer Worksheet Opens or brings to the front a ToolServer Worksheet window.

When using the Macintosh menu layout on a Windows host, this 
command does not appear.

Symbolics Window Opens or brings to the front a Symbolics window. 

Processes Window Opens or brings to the front a Processes window. 

Expressions Window Opens or brings to the front an Expressions window. Use to view, 
create, modify, and remove expressions.

Global Variables Window Opens or brings to the front a Global Variables window. 

Breakpoints Window Opens or brings to the front a Breakpoints window. Use to view, 
create, modify, and remove breakpoints.

Register Window Opens or brings to the front a Register window.

Table 29.17  Window menu commands (continued)

Menu command Description
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Scripts Menu
The Scripts menu appears in the IDE’s menu bar after you enable the Use Scripts 
menu checkbox in the IDE Extras preference panel and creates a (Scripts) folder 
in the Metrowerks CodeWarrior folder of your CodeWarrior installation.

The Scripts menu uses the directory structure of the (Scripts) folder to create a 
hierarchical menu. This hierarchical menu lists all of the scripts in the (Scripts) 
folder. Open a script-editing utility or a text editor to learn more about the scripts that 
might already exist in the (Scripts) folder.

Refer to the CodeWarrior Scripting Reference to learn more about scripting the 
CodeWarrior IDE.

Help Menu
The Help menu contains commands for accessing the IDE’s online help.

NOTE Classic Macintosh: The Help menu contains additional menu 
commands for working with Balloon Help and accessing Apple’s 
online help.

Table 29.18  Help menu commands

Menu command Description

CodeWarrior Help Launches a help viewer to display the CodeWarrior IDE online help. 
Click on a link to view a specific IDE topic.

Index (Windows) Opens the online help to the Index tab.

Search (Windows) Opens the online help to the Search tab.

Online Manuals Launches a help viewer to display a list of CodeWarrior manuals. 
Click on a link to view a specific manuals contents.

Metrowerks Website Launches a browser and automatically points you to the Metrowerks 
website.

About Metrowerks CodeWarrior 
(Windows)

Displays the CodeWarrior IDE version and build number information.
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Menu Commands

This section presents an alphabetical listing of all available menu commands in the 
CodeWarrior™ IDE. Menu commands that appear only on certain host platforms are 
documented. A menu command that has no host information is available on all hosts. 

Use this listing as a reference to find information about a specific menu command.

A

About Metrowerks CodeWarrior
This command displays the CodeWarrior IDE version and build number information.

TIP Click the Installed Products button in this window to view and save 
information about installed products and plug-ins for the 
CodeWarrior IDE. You can also use this window to enable or disable 
plug-in diagnostics.

Add Files
The Add Files command opens a dialog which allows one or more files to be added to 
the project. 

Add Window
The Add Window command adds the file in the active Editor window to the open 
project. The name of the menu command changes, based on the name of the active 
window. For example, if the name of the active window is MyFile, the name of the 
menu command changes to Add MyFile to Project.
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Align
Reveals the Align submenu with component alignment commands like Right Edges, 
Vertical Centers, and others.

See also:

• “Bottom Edges” on page 469

• “Horizontal Center” on page 484

• “Left Edges” on page 485

• “Right Edges” on page 494

• “To Grid” on page 500

• “Top Edges” on page 501

• “Vertical Center” on page 503

All Exceptions
The All Exceptions command of the Java submenu to tell the debugger to break every 
time an exception occurs. This behavior includes exceptions thrown by the virtual 
machine, your own classes, the debugger, classes in classes.zip, and so on. Java 
programs throw many exceptions in the normal course of execution, so catching all 
exceptions causes the debugger to break often.

Anchor Floating Toolbar
The Anchor Floating Toolbar command attaches the floating toolbar beneath the 
menu bar. Once attached, the anchored toolbar can not be moved again until it is 
unanchored.

See also:

• “Unanchor Floating Toolbar” on page 502

Apply Difference
The Apply Difference command applies the selected difference from the source file 
into the destination file.
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B

Balance
The Balance command selects all the text starting at the current insertion point and 
enclosed in parentheses (), brackets [], or braces {},

Bottom Edges
The Bottom Edges command of the Align submenu aligns the bottom edges of the 
selected components.

Break
The Break command temporarily suspends execution of the target program and 
returns control to the debugger.

See also “Stop” on page 498.

Break on C++ Exception
The Break on C++ Exception command tells the debugger to break at __throw() 
each time a C++ exception occurs.

Break on Java Exceptions
The Break on Java Exceptions command reveals the Java Exceptions submenu. 

See also:

• “Exceptions in Targeted Classes” on page 478

• “Uncaught Exceptions Only” on page 502.

Breakpoints

Breakpoints Window
These commands open the Breakpoints window.
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Bring To Front
The Bring To Front command moves the selected objects so that they are displayed 
in front of all other objects.

Bring Up To Date
The Bring Up To Date command updates the current build target in the active project 
by compiling all of the build target’s modified and touched files.

Browser Contents
The Browser Contents command opens the Browser Contents window. This 
command is not available if the Enable Browser option is not activated.

Build Progress

Build Progress Window
These commands open the Build Progress window. Use it to monitor the IDE’s status 
as it compiles a project.

C

Cascade
The Cascade command arranges open editor windows one on top of another, with 
their window titles visible. 

Change Program Counter
The Change Program Counter command opens a window that lets you move the 
current-statement arrow to a particular address or symbol.
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Check Syntax
The Check Syntax command checks the syntax of the source file in the active Editor 
window or the selected files in the open project window. If the IDE detects one or 
more errors, a Message window appears and shows information about the errors.

The Check Syntax command is not available if:

• the active Editor window is empty.

• no project file is open.

Check Syntax does not generate object code.

Table 30.1 explains how to abort the syntax-checking process:

Class Browser
The Class Browser command opens a Class Browser window. This command is 
unavailable if the Enable Browser option is not enabled.

Class Hierarchy

Class Hierarchy Window
These commands open a Multi-Class Browser window. This command is unavailable 
if the Enable Browser option is not enabled.

Clear
The Clear command removes the selected text. This menu command is equivalent to 
pressing the Backspace or Delete key.

Table 30.1  Aborting the syntax-checking process

On this host… Do this…

Windows Press Esc.

Macintosh Press Command-. (Command-Period).

Solaris Press Esc.

Linux Press Esc.
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Clear All Breakpoints
The Clear All Breakpoints command clears all breakpoints in all source files 
belonging to the target program.

Clear All Watchpoints
The Clear All Watchpoints command clears all watchpoints in the current program.

Clear Breakpoint
The Clear Breakpoint command clears the breakpoint at the currently selected line. If 
the Show Breakpoints option is enabled, the marker in the Breakpoints column of the 
Editor window disappears.

Clear Eventpoint
This command opens a submenu that lets you remove an eventpoint from the currently 
selected line. If the Show Breakpoints option is active, the Breakpoints column in the 
editor windows shows a marker next to each line with an eventpoint. The marker 
represents the eventpoint type.

Clear Floating Toolbar
The Clear Floating Toolbar command removes all the shortcut icons from the 
floating toolbar. Once the toolbar is cleared, drag shortcut icons from the Commands 
and Key Bindings window to the toolbar to create a custom floating toolbar.

Clear Main Toolbar
The Clear Main Toolbar command removes all the shortcut icons from the main 
toolbar. Once the toolbar is cleared, drag shortcut icons from the Commands and Key 
Bindings window to the toolbar to create a custom main toolbar.

Clear Watchpoint
The Clear Watchpoint command removes a watchpoint from the selected variable or 
memory range.
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Clear Window Toolbar
The Clear Window Toolbar command removes all the shortcut icons from the 
window toolbar. Once the toolbar is cleared, drag shortcut icons from the Commands 
and Key Bindings window to the toolbar to create a custom window toolbar.

Close
The Close command closes the active window. 

Close All
The Close All command closes all open windows of a certain type. The name of this 
menu command changes, based on the type of item selected. For example, select one 
of several open editor windows, the menu command changes its name to Close All 
Editor Documents.

NOTE Macintosh: Press the Option key to change Close to Close All.

Close Catalog
The Close Catalog command closes the current catalog and remove the catalog from 
the Component Catalog window and the Component Palette.

Close Workspace
This command closes the current workspace.

You cannot close the default workspace, but you can choose whether to use it by 
toggling the Use default workspace option in the IDE Extras preference panel.

Commands & Key Bindings
The Commands and Key Bindings command opens the Customize IDE Commands 
window.
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Complete Code
The Complete Code command opens the Code Completion window. Use this window 
to help you automatically complete programming-language symbols as you type them 
in the active editor window.

CodeWarrior Glossary
The CodeWarrior Glossary command opens and display a list of vocabulary terms 
used by the CodeWarrior manuals and online help.

CodeWarrior Help
This command opens the online help for the CodeWarrior IDE.

Collapse Window
The Collapse Window command collapses the active window so that only its title is 
visible.

Compare Files
The Compare Files command opens the Compare Files Setup window. Use it to 
choose two files or folders for comparison and merging. After choosing the items, a 
comparison window appears that shows the differences between the items.

Compile
The Compile command compiles selected source files into binary files. The IDE 
compiles source files that are:

• part of the current project and open in the active Editor window, or

• selected files, segments, or groups in a project window.

Connect
The Connect command establishes communications between the IDE and embedded 
hardware to begin a debugging session.
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Copy
The Copy command copies selected text to the system Clipboard. If the Message 
Window is active, the Copy command copies all the text in the Message Window to 
the Clipboard.

Copy to Expression
The Copy to Expression command copies the variable selected in the active pane to 
the Expressions window.

Create Design
This command creates a new design in the current project. The new design appears in 
the Design tab of the project window. You cannot create a design if each build target 
in the project already belongs to a design.

Create Group
The Create Group command creates a new group in the current project. This 
command is only active when the Files view is visible in the project window.

Create Overlay

Create Segment
These commands create a new segment or overlay in the current project. This 
command is only active when the Segments view or Overlays view is visible in the 
project window.

Create Target
The Create Target command creates a new build target in the current project. This 
command is only active when the Targets view is visible in the project window.

Cut
The Cut command copies the selected text to the system Clipboard, replacing the 
previous Clipboard contents, and removes it from the current document or text box.
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Cycle View
Toggles view among various data formats.

See also:

• “View Disassembly” on page 505

• “View Mixed” on page 505

• “View Raw Data” on page 505

• “View Source” on page 505

D

Debug
This command compiles and links a project, then run the CodeWarrior debugger with 
the project’s code. If debugging is active, The Threads window to examine program 
information and step through the code as it executes. If debugging is not active, the 
Threads window appears, but the program executes without stopping in the debugger.

Delete
The Delete command removes the selected text without placing it on the system 
clipboard. This menu command is equivalent to pressing the Backspace or Delete key.

Disable Breakpoint
The Disable Breakpoint command de-activates the breakpoint at the currently 
selected line.

Disable Watchpoint
The Disable Watchpoint command de-activates a watchpoint for the selected variable 
or memory range.
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Disassemble
The Disassemble command disassembles the compiled source files selected in the 
project window. After disassembling a file, the IDE creates a .dump file that contains 
the file’s object code. The .dump file appears in a new window after the IDE 
completes the disassembly process.

Display Grid
The Display Grid command toggles the visibility of grid lines in the layout window. 
When checked, the grid lines appear, otherwise, no grid is visible.

E

Enable Breakpoint
The Enable Breakpoint command activates a breakpoint at the currently selected 
line. The breakpoint appears in the left side of the editor window if the Breakpoint 
column is visible. The states of the breakpoint marker include:

•  enabled breakpoint.

•  disabled breakpoint.

•  no breakpoint in line.

Enable Watchpoint
The Enable Watchpoint command activates a watchpoint for the selected variable or 
memory range.

Enabled watchpoints are indicated by an underline of the selected variable or range of 
memory. Disabled watchpoints do not have the underline. The underline’s color can 
be configured in the Display Settings preference panel of the IDE Preference window. 

Enter Find String
The Enter Find String command copies the selected text in the active window 
directly into the target search string. It will then appear in the Find text box of both the 
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Find and Replace and Find in Files windows. Once done, use any of the find 
commands to search for matches without opening any Find-related windows.

Enter Replace String
The Enter Replace String command copies the selected text in the active window 
directly into the target search string. It will then appear in the Replace with text box of 
both the Find and Replace and Find in Files windows. Once done, use any of the find 
commands to search for matches without opening any Find-related windows.

NOTE Macintosh: Press the Shift key to change the Enter Find String 
command to the Enter Replace String menu command.

Errors & Warnings

Errors & Warnings Window
These commands open the Errors and Warnings window.

Exceptions in Targeted Classes
The Exceptions in Targeted Classes command of the Java submenu to tell the 
debugger to break only on exceptions thrown by your own classes in the project. 
Choose this command to break on the exceptions thrown by your classes, rather than 
on the exceptions that Java programs throw in the normal course of execution.

Exit
The Exit command exits the CodeWarrior IDE immediately, provided that:

• All changes to the open editor files are already saved, or

• The open editor files are not changed.

If a Project window is open, the IDE saves all changes to the project file before 
exiting. If an Editor window is open and changes are not saved, the CodeWarrior IDE 
asks if you want to save your changes before exiting.
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Expand Window
The Expand Window command expands a collapsed window (a window with only its 
title visible). Only available when a collapsed window is currently active.

Export Project
The Export Project command exports a CodeWarrior project to a file in extensible 
markup language (XML) format. The IDE prompts for a name and location to save the 
new XML file.

Export Project as GNU Makefile
This command exports a CodeWarrior project to a GNU makefile. The IDE displays a 
message that tells you the name of the makefile and its location on the hard disk.

Expressions

Expressions Window
These commands open an Expressions window.

F

Find
The Find command opens the Find and Replace window to perform find operations 
within the active file.

Find Definition & Reference
The Find Definition & Reference command searches for the definition of the 
selected routine name in the active Editor window. Searching starts within the source 
files belonging to the open project. If the IDE does not find a definition, a system beep 
sounds. 
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If the IDE does not find the routine definition within the project files, searching 
continues using the online help system specified in the IDE Extras preference panel.

NOTE Macintosh: Press the Option key to change the Find Definition menu 
command to the Find Definition & Reference menu command.

Find Definition
The Find Definition command searches for the definition of the selected routine name 
in the active window. Searching occurs in the source files belonging to the open 
project. If the IDE finds the definition, the source file that contains the definition 
appears in an Editor window, and the routine name appears highlighted.

If the IDE finds more than one definition, a Message window appears warning of 
multiple definitions. If the IDE does not find a definition, a system beep sounds.

NOTE Select the Activate Browser option in the Build Extras target 
settings panel and re-compile the project in order to use the Find 
Definition command.

Find in Files
The Find in Files command opens the Find in Files window. Once open, The Find in 
Files window to perform find-and-replace operations across multiple files using 
specified search criteria.

Find In Next File
The Find in Next File command searches for the next occurrence of the Find text box 
string in the next file listed in the Find in Files window. The menu command as an 
alternative to using the Find in Files window itself.

Find In Previous File
This command searches for the next occurrence of the Find text box string in the 
previous file listed in the Find in Files window. The menu command as an alternative 
to using the Find in Files window itself.
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NOTE (Macintosh) Press the Shift key to change the Find In Next File menu 
command to the Find In Previous File menu command.

Find Next
The Find Next command searches for the next occurrence of the Find text box string 
in the active window.

Find and Open File
Uses the Find and Open File command opens the Find and Open File dialog. Enter a 
filename, click OK, and the IDE searches the current project access paths as specified 
in the Access Paths panel of the Target Settings window.

Find and Open ‘Filename’
The Find and Open ‘Filename’ command opens an existing text file, using the 
currently selected text in the Editor window as the target filename.

Find Previous
The Find Previous command searches for the previous occurrence of the Find text 
box string in the active window.

NOTE Macintosh: Press the Shift key to change the Find Next menu 
command to the Find Previous menu command.

Find Previous Selection
The Find Previous Selection searches for the previous occurrence of the selected text 
in the active editor window.

NOTE Macintosh: Press the Shift key to change the Find Selection menu 
command to the Find Previous Selection menu command.
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Find Reference
The Find Reference command searches for the definition of the selected routine name 
in the active Editor window, using the online help system specified in the IDE Extras 
preference panel.

If the IDE does not find a definition, a system beep sounds.

Find and Replace
The Find and Replace command opens the Find and Replace window. Use this 
window to perform find-and-replace operations within the active file.

Find Selection
The Find Selection command searches for the next occurrence of the selected text in 
the active Editor window.

G

Get Next Completion
The Get Next Completion command acts as a shortcut that bypasses using the Code 
Completion window. Instead of scrolling through the Code Completion window to 
select the next symbol from the one currently selected, use this command to insert that 
next symbol directly into the active editor window.

Get Previous Completion
The Get Previous Completion command acts as a shortcut that bypasses using the 
Code Completion window. Instead of scrolling through the Code Completion window 
to select the previous symbol from the one currently selected, use this command to 
insert that previous symbol directly into the active editor window.
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Global Variables

Global Variables Window
These commands open the Global Variables window. Use this window to view global 
variables for an entire project or for a single file. Click a filename in the Files list 
displays the file’s global variables in the Variables list.

Go Back
The Go Back command returns to the previous view in the CodeWarrior browser.

Go Forward
The Go Forward command moves to the next view in the CodeWarrior Browser 
(after you The Go Back command to return to a previous view).

Go to Line
The Go to Line command opens the Line Number dialog box and enter a specific line 
number to move the text-insertion point to. If the line number specified exceeds the 
number of lines in the file, the text-insertion point moves to the last line in the file.

H

Hide Breakpoints
The Hide Breakpoints command conceals the Breakpoints column, which appears to 
the left of the source code shown in editor windows.

Hide Floating Toolbar
The Hide Floating Toolbar command conceals the IDE’s floating toolbar. After 
concealing the floating toolbar, the command changes to Show Floating Toolbar.
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Hide Main Toolbar
The Hide Main Toolbar command conceals the IDE’s main toolbar. After concealing 
the main toolbar, the command changes to Show Main Toolbar.

Hide Window Toolbar
The Hide Window Toolbar command conceals the toolbar in the active window. 
After concealing the window toolbar, the command changes to Show Window 
Toolbar.

Horizontal Center
The Horizontal Center command of the Align submenu aligns the horizontal centers 
of the selected components.

I

Import Components
The Import Components command imports components from another catalog for use 
with the current catalog.

Import Project
The Import Project command imports project files previously saved in extensible 
markup language (XML) file with the Export Project command into the IDE.

Insert Reference Template
This command inserts a routine template corresponding to the selected Mac OS 
Toolbox call in the active window. The IDE uses the online reference database 
application specified in the Find Reference Using list pop-up to search for the 
routine’s definition.
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K-L

Kill
The Kill command permanently terminates execution of the target program and 
returns control to the debugger.

Left Edges
The Left Edges command of the Align submenu aligns the left edges of the selected 
components.

M-N

Make
The Make command builds the selected project by compiling and linking its modified 
and touched files. The results of a successful build depend on the selected project type.

Maximize Window
Windows equivalent of Expand Window.

See also:

• “Expand Window” on page 479

Metrowerks Website
The Metrowerks Website command launches a web browser and display the 
Metrowerks web site.

Minimize Window
Windows equivalent of Collapse Window.

See also:
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• “Collapse Window” on page 474

New
The New command opens the New window. The New window to create new projects, 
files, components, and objects.

New Class
The New Class command opens the New Class wizard. Use this wizard to help create 
new classes in a project.

New Class Browser
The New Class Browser command opens a Browser window. The IDE grays out this 
menu command if the CodeWarrior browser is not activated. This menu command is 
equivalent to the Class Browser menu command.

New Data Member
The New Data Member command opens the New Data Member wizard. Use this 
wizard to help create new data members for a class.

New Event
The New Event command opens the New Event window. Use this window to help 
create new events for a selected class in a project.

New Event Set
The New Event Set command opens the New Event Set window to create a new event 
set for a selected class in a project.

New Expression
The New Expression command creates a new entry in the Expressions window, 
prompting entry of a new expression.
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New Member Function
The New Member Function command opens the New Member Function wizard. Use 
this wizard to help create new member functions for a class.

New Method
The New Method command opens the New Method window. Use this window to 
create a new method for a selected class in a project.

New Property
The New Property command opens the New Property. Use this window to create a 
new property for a selected class in a project.

New Text File
The New Text File command creates a new editable text file and open a Editor 
window.

No Exceptions
The No Exceptions command of the Java submenu sets the debugger to not break 
when exceptions occur.

O

Online Manuals
This command opens a list of online manuals about the CodeWarrior IDE, compilers, 
MSL, and target specific information.

Open
The Open command opens an existing project or source file.
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Open Recent
The Open Recent menu item reveals a submenu of recently opened projects and files. 
Choose a file from the submenu to open that item.

If two or more files in the submenu have identical names, the submenu shows the full 
paths to those files in order to distinguish between them.

Open Scripts Folder
This command opens the (Scripts) folder. This command is only available if the 
Use Scripts menu option is enabled.

Open Workspace
This command opens a workspace file that you previously saved.

P-Q

Page Setup
The Page Setup command sets the options used for printing CodeWarrior IDE files.

Paste
The Paste command replaces the selected text with the contents of the system 
clipboard into the active Editor window or text box. If no text is selected, the IDE 
places the clipboard contents at the text-insertion point.

The Paste command is unavailable if the Message window is active.

Precompile
The Precompile command precompiles the text file in the active Editor window into a 
precompiled header file.
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Preferences
The Preferences command opens the IDE Preferences window. Use this window to 
change the global preferences used by the CodeWarrior IDE. 

Preprocess
This command preprocesses selected source files in any language that has a 
preprocessor, such as C, C++, and Java.

Print
The Print command prints CodeWarrior IDE files, as well as Project, Message, and 
Errors and Warnings window contents.

Processes

Processes Window
These commands open the Processes window for those platforms that support it.

Project Inspector
Opens the Project Inspector window so that you can view information about your 
project. You can also use this window to manipulate file-specific information.

Quit

Quit CodeWarrior
Mac OS command equivalent of Exit: See “Exit” on page 478.
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R

Redo
After undoing an operation, you can redo it. For example, after choosing the Undo 
Typing command to remove some text that you typed, you can choose Redo Typing 
to override the undo and restore the text that you typed.

You can enable the Use multiple undo option in the Editor Settings preference panel 
to allow greater flexibility with regard to Undo and Redo operations. After enabling 
this option, you can choose Undo multiple times to undo multiple actions, and you 
can Redo multiple times to redo multiple actions.

Refresh All Data
This command updates the data that appears in all windows.

Register Details Window
The Register Details Window command opens the Register Details window, which 
allows you view descriptions of registers, bit fields, and bit values.

Registers

Register Window
These commands reveal the Registers submenu, which can be used to view general 
registers or FPU registers.

See also:

• “Register Details Window” on page 490

Remove Object Code
The Remove Object Code command shows the Remove Object Code dialog box. Use 
this dialog box to remove binary object code from the active project, or to mark the 
project’s files for re-compilation.
490 IDE 5.5 User’s Guide



Menu Commands
Remove Object Code & Compact
This command removes all binaries from the project and compacts it. Compacting the 
project removes all binary and debugging information and retains only the information 
regarding the files that belong to the project and project settings.

Remove Selected Items
The Remove Selected Items command removes the currently selected items from the 
Project window. 

CAUTION You cannot undo this command.

Replace
The Replace command opens the Find and Replace dialog box. Use this dialog box to 
perform find-and-replace operations within the active file. 

Replace All
The Replace All command finds all occurrences of the Find text box string and 
replaces them with the Replace text box string. If no text is selected in the active 
Editor window and there is no text in the Find text box, the IDE dims this menu 
command.

Replace and Find Next
This command substitutes selected text with the text in the Replace text box of the 
Find window, and then performs a Find Next operation. If no text is selected in the 
active Editor window and there is no text in the Find field of the Find window, the IDE 
grays out this menu command.

Replace and Find Previous
This command substitutes selected text with the text in the Replace text box of the 
Find window, and then performs a Find Previous operation. If no text is selected in 
the active Editor window and there is no text in the Find field of the Find window, the 
IDE grays out this menu command.
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NOTE (Mac OS) Press the Shift key to change the Replace and Find Next 
menu command to the Replace and Find Previous menu command.

Replace Selection
The Replace Selection command substitutes the selected text in the active window 
with the text in the Replace text box of the Find window. If no text is selected in the 
active Editor window, the IDE grays out the menu command.

The menu command to replace one instance of a text string without having to open the 
Find window. Suppose that you replaced all occurrences of the variable icount with 
jcount. While scrolling through your source code, you notice an instance of the 
variable icount misspelled as icont. To replace this misspelled variable with 
jcount, select icont and The Replace Selection menu command.

Re-search for Files
The Re-search for Files command speeds up builds and other project operations, the 
IDE caches the locations of project files after finding them in the access paths. Re-
search for Files forces the IDE to forget the cached locations of files and re-search for 
them in the access paths. This command is useful if you moved several files and you 
want the IDE to find the files in their new locations.

If the Save project entries using relative paths option is enabled, the IDE does not 
reset the relative-path information stored with each project entry, so re-searching for 
files finds the source files in the same location (the exception is if the file no longer 
exists in the old location). In this case, the IDE only re-searches for header files. To 
force the IDE to also re-search for source files, choose the Reset Project Entry Paths 
menu command.

If the Save project entries using relative paths option is disabled, the IDE re-
searches for both header files and source files.

Reset
The Reset command resets the program and return control to the IDE.

Reset Floating Toolbar
The Reset Floating Toolbar command restores the default state of the floating 
toolbar. Use this command to return the floating toolbar to its original default settings.
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Reset Main Toolbar
The Reset Main Toolbar command restores the default state of the main toolbar. Use 
this command to return the main toolbar to its original default settings.

Reset Project Entry Paths
The Reset Project Entry Paths command resets the location information stored with 
each project entry and forces the IDE to re-search for the project entries in the access 
paths. This command does nothing if the Save project entries using relative paths 
option is disabled.

Reset Window Toolbar
The Reset Window Toolbar command restores the default state of the toolbar in the 
active window. Use this command to return the toolbar to its original default settings.

Resize
Choose Resize reveals the Resize submenu. 

See also:

• “To Largest Height” on page 500

• “To Largest Width” on page 500

• “To Smallest Height” on page 501

• “To Smallest Width” on page 502

Restart
The Restart command terminates the current debugging session, then starts a new 
debugging session.

Restore Window
The Restore Window command restores a minimized window (a window reduced to 
an item in the task bar).
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Resume
The Resume command switches from the IDE to the running application. This menu 
command only appears after the IDE starts a debugging session and the application 
being debugged is currently running.

Revert
The Revert command restores the last saved version of the active Editor window.

Right Edges
The Right Edges command of the Align submenu aligns the right edges of the 
selected components.

Run
The Run command compiles, links, and creates a standalone application, and run that 
application. This command is unavailable if the project creates libraries, shared 
libraries, code resources, and other non-application binaries.

Run to Cursor
The Run to Cursor command sets a temporary breakpoint at the line of source code 
that has the text-insertion point, then runs the program.

S

Save
The Save command saves the contents of the active window to disk.

Save A Copy As
The Save A Copy As command saves the active window to a separate file. This 
command operates in different ways, depending on the active window.
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Save All
The Save All command saves all currently open editor files.

NOTE Mac OS: Press the Option key to change the Save command to the 
Save All menu command.

Save As
The Save As command saves the contents of the active window to disk under a 
different name.

Save Default Window
This command saves the window settings, such as position and size, of the active 
Browser or Search Results window. The IDE applies the saved settings to 
subsequently opened windows.

Save Workspace
This command saves to a file the current state current state of onscreen windows, 
recent items, and debugging. Use the dialog box that appears to name the workspace 
and navigate to a location in which to store the workspace.

Save Workspace As
This command saves a copy of an existing workspace. Use this command to save the 
workspace under a different name.Select All

The Select All command selects all text in the active window or text box. This 
command is usually used in conjunction with other Edit menu commands such as Cut, 
Copy, and Clear.

Send To Back
The Send To Back command moves the selected objects so that they are displayed 
behind all other objects.
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Set Breakpoint
The Set Breakpoint command sets a breakpoint at the currently selected line. If the 
Show Breakpoints option is active, the Breakpoints column in the editor windows 
will display a marker next to each line with a breakpoint.

Set/Clear Breakpoint
The Set/Clear Breakpoint command displays the Set/Clear Breakpoints dialog that 
lets you set or clear a breakpoint at a particular address or symbol.

Set Default Project
The Set Default Project command sets a particular project as the default project when 
more than one project is open. This is the project that all commands are directed.

Set Default Target
The Set Default Target command works with a different build target within the 
current project. Choose the build target to work with from the submenu. This menu 
command is useful for switching between multiple build targets in a project and 
performing a build for each target.

Set Eventpoint
This command opens a submenu that lets you set an eventpoint at the currently 
selected line. If the Show Breakpoints option is active, the Breakpoints column in the 
editor windows shows a marker next to each line with an eventpoint. The marker 
represents the eventpoint type.

Set Watchpoint
The Set Watchpoint command sets a watchpoint for the selected variable or memory 
range. Watchpoint variables are identified using an underline.

Shift Left
The Shift Left command shifts the selected source code one tab to the left. The 
amount of shift is controlled by the Tab Size option.
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Shift Right
The Shift Right command shifts the selected source code one tab to the right. The 
amount of shift is controlled by the Tab Size option.

Show Breakpoints
The Show Breakpoints command displays the Breakpoints column in editor 
windows. When active, the Breakpoints column appears along the left edge of all 
editor windows.

Show Floating Toolbar
The Show Floating Toolbar command displays the IDE’s floating toolbar. After 
displaying the floating toolbar, the command changes to Hide Floating Toolbar.

Show Main Toolbar
The Show Main Toolbar command displays the IDE’s main toolbar. After displaying 
the main toolbar, the command changes to Hide Main Toolbar.

Show Types
The Show Types command displays the data types of all local and global variables 
that appear in the active variable pane or variable window.

Show Window Toolbar
The Show Window Toolbar command displays the toolbar in the active window. 
After displaying the window toolbar, the command changes to Hide Window Toolbar.

Stack Editor Windows
The Stack Editor Windows command arranges open editor windows one on top of 
another, with their window titles visible.

Step Into
The Step Into command executes a single statement, stepping into function calls.
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Step Out
The Step Out command executes the remainder of the current function, then exit to 
that function’s caller.

Step Over
The Step Over command executes a single statement, stepping over function calls.

Stop
This command temporarily suspends execution of the target program and returns 
control to the debugger.

Stop Build
The Stop Build command halts the build currently in progress.

Switch to Monitor
This command transfers control from the CodeWarrior debugger to an external third-
party debugger.

Symbolics

Symbolics Window
These commands open the Symbolics window. Use this window to examine the 
executable files in a project.

Synchronize Modification Dates
The Synchronize Modification Dates command updates the modification dates 
stored in the project file. The IDE checks the modification date of each file in the 
project and marks for recompiling those files modified since the last successful 
compile process.
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Menu Commands
T-U

Target Settings
The Target Settings command displays the Target Settings window. This window 
contains settings panels used by the active build target. The name of the menu 
command changes, based on the name of the current build target. For example, if the 
name of the current build target is ReleaseTarget, the name of the menu command 
changes to ReleaseTarget Settings.

Tile Editor Windows
The Tile Editor Windows command arranges and resizes all open editor windows so 
that none overlap on the monitor. 

Figure 30.1  Tile Editor windows—example

Tile Editor Windows Vertically
The Tile Editor Windows Vertically command resizes all open editor windows to be 
vertically long, and arranged horizontally across the monitor so that all are viewable.

Tile Horizontally
This command arranges open editor windows horizontally so that none overlap. 
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Menu Commands
Figure 30.2  Tile horizontally—example

Tile Vertically
This command resizes open editor windows vertically and arrange them so that none 
overlap. 

Figure 30.3  Tile vertically—example

To Grid
The To Grid command of the Align submenu aligns selected components to a grid in 
the layout. You can display or hide the on screen grid.

To Largest Height
The To Largest Height command of the Resize submenu resizes the selected 
components to match the height of the component with the largest height.

To Largest Width
The To Largest Width command of the Resize submenu resizes the selected 
components to match the width of the component with the largest width.
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Toolbars
Choose Toolbars reveals the Toolbars submenu.

See also:

• “Show Window Toolbar” on page 497

• “Hide Window Toolbar” on page 484

• “Reset Window Toolbar” on page 493

• “Clear Window Toolbar” on page 473

• “Show Main Toolbar” on page 497

• “Hide Main Toolbar” on page 484

• “Reset Main Toolbar” on page 493

• “Clear Main Toolbar” on page 472

• “Hide Floating Toolbar” on page 483

• “Show Floating Toolbar” on page 497

• “Reset Floating Toolbar” on page 492

• “Clear Floating Toolbar” on page 472

ToolServer Worksheet
The ToolServer Worksheet command opens the ToolServer Worksheet window for 
use with the Apple® ToolServer™ application program.

The IDE can disable this command for these reasons:

• You did not install ToolServer on your computer.

• You installed ToolServer on your computer, but you did not yet start it.

Top Edges
The Top Edges command of the Align submenu aligns the top edges of the selected 
components.

To Smallest Height
The To Smallest Height command of the Resize submenu resizes the selected 
components to match the height of the component with the smallest height.
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To Smallest Width
The To Smallest Width command of the Resize submenu resizes the selected 
components to match the width of the component with the smallest width.

Unanchor Floating Toolbar
The Unanchor Floating Toolbar command detaches the floating toolbar from 
beneath the menu bar.

Unapply Difference
The Unapply Difference command reverses the action of the Apply Difference 
command in a file-comparison window.

Uncaught Exceptions Only
The Uncaught Exceptions Only command of the Java submenu tells the debugger to 
break only on unhandled exceptions.

Undo
The Undo command reverses the last action. The name of this menu command 
changes based upon the editor settings as well as the most recent action. For example, 
after typing text in an open Editor window, the Undo command changes its name to 
Undo Typing. Choose the Undo Typing command to remove the just typed text.

By default, only one undo or redo action is allowed. If the Use multiple undo option 
is enabled, undo and redo can act upon multiple actions. 

Ungroup
The Ungroup command separates a selected group so that you can move each 
component independently.
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Menu Commands
V-Z

Version Control Settings
The Version Control Settings command opens the VCS Settings window.

Vertical Center
The Vertical Center command of the Align submenu aligns the vertical centers of the 
selected components.

View Array
The View Array command to create a separate window displays a selected array.

View As
The View As command displays a selected variable as a value of a specified data type.

View As Binary
The View As Binary command displays the selected variable as a binary value.

View As Character
The View As Character command displays the selected variable as a character value.

View As C String
The View As C String command displays the selected variable as a C character string.

View As Default
The View As Default command displays the selected variable in its default format, 
based on the variable’s type.
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View As Enumeration
The View As Enumeration command displays the selected variable as an 
enumeration.

View As Fixed
The View As Fixed command displays the selected variable as a fixed-type numerical 
value.

View As Floating Point
The View As Floating Point command displays the selected variable as a floating-
point value.

View As Fract
This command displays the selected variable as a fractional data type.

NOTE The fractional data type is specific to the Mac OS.

View As Hexadecimal
The View As Hexadecimal command displays the selected variable as a hexadecimal 
value.

View As Pascal String
The View As Pascal String command displays the selected variable as a Pascal 
character string.

View As Signed Decimal
This command displays the selected variable as a signed decimal value.

View As Unicode String
The View As Unicode String command displays the selected variable as a Unicode 
character string.
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View As Unsigned Decimal
The View As Unsigned Decimal command displays the selected variable as an 
unsigned decimal value.

View Disassembly
This command changes the data view to show language disassembly.

View Memory
The View Memory command displays the contents of memory as a hexadecimal/
ASCII character dump.

View Memory As
The View Memory As command displays the memory that a selected variable 
occupies or the memory to which a selected register points.

View Mixed
This command changes the data view to show source code intermixed with assembly 
code.

View Raw Data
This command changes the data view to show raw data (instead of formatting that data 
as source code, disassembly, or another format).

View Source
This command changes the data view to show source code.

View Variable
The View Variable command creates a separate window displays a selected variable.
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Zoom Window
The Zoom Window command expands the active window to its previously set size. 
Choose Zoom Window a second time to return the window to its original size.
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Index

Symbols
#include files, caching 416
%file command-line string 417
%line command-line string 418
(Scripts) folder 465, 488
.*[_]Data 351
.mcp 33
\(.*\) 351
^var 244
__throw() 469

A
about

breakpoints 211
console applications 81
dockable windows 67
eventpoints 211
Files page in Project window 45
markers 115
projects 27
special breakpoints 211
watchpoints 211
workspaces 77

About Metrowerks CodeWarrior menu command 467
Absolute Path option

in Source Trees preference panel 429
in Type list box 429

abstract, icon for 171
Access Filter display 173
Access Paths settings panel 349, 379

columns
Framework 382
Recursive Search 382
Search Status 381

options
Add 381
Add Default 381
Always Search User Paths 381
Change 381
Host Flags 381
Interpret DOS and Unix Paths 381
Remove 381
Require Framework Style Includes 381
System Paths 381, 428

System Paths list 381
User Paths 381, 433
User Paths list 381

Access Target button 289
Action option 319
actions for debugging 204
Activate Browser Coloring option 399

in Text Colors panel 414
Activate Browser option

and relation to Symbolics window 265
in Build Extras panel 480

Activate Syntax Coloring option 399, 405
in Text Colors panel 414, 417, 428

activating automatic code completion 103
Active icon 215
Add button 381
Add Default button 399
Add Files button 136
Add Files menu command 467
Add Window menu command 467
adding

gray background behind IDE. See Use Multiple 
Document Interface, turning on.

remote connections 372
source trees 353

Address checkbox 292
Address Line fault 294
Address text box 259
advanced topics

for projects 38
advantages of using IDE 21
Align submenu 468, 469, 484, 485, 494, 500, 501, 503

Horizontal Center command 484
Left Edges command 485
Vertical Center command 494, 500, 501, 503

All Exceptions command 468
All Info option, in Plugin Diagnostics 418
All Sectors checkbox 282
All Sectors list 282
All Text option button 122, 125, 128
alphabetical sorting of Functions list pop-up 113
Always Search User Paths option 400
Analyzer Can Cause Target Breakpoint checkbox 299
Analyzer Configuration File text box 298
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Analyzer Connections target settings panel 297
Analyzer Slot text box 298
Analyzer Type list box 298
Ancestor pop-up 176
Anchor Floating Toolbar command 468
Appears in Menus 319, 320
Appears in Menus checkbox 140
Apple Help Viewer 413
Apple menu 452
Application field 400
applications

for the console, about 81
for the console, creating 82

Apply Address Offset checkbox 280
Apply button 150
Apply Difference command 151, 468, 502
Arguments field 400
Arithmetic Optimizations 390
Arm command 300
Array window 252

opening 254
arrays, setting default viewing size for unbounded 407
arrows

current statement 203
Attempt To Use Dynamic Type of C++, Object Pascal 

And SOM Objects option 400
Auto Indent option 400
Auto Repeat 319
Auto Target Libraries option 400
Auto, of Text View list box 262
auto-complete code. See code completion.
Automatic Invocation option 401
Automatically Launch Applications When SYM File 

Opened option 401
Auto-target Libraries option 400

B
Background option 402
background, desktop

removing from behind IDE. See Use Multiple 
Document Interface, turning on.

seeing behind IDE. See Use Multiple Document 
Interface, turning off.

Balance Flash Delay option 402
Editor Settings panel 402

Balance menu command 469

Balance While Typing option 402
balancing punctuation 101

toggling 101
Balloon Help 330, 409, 465
Base Classes field 188
Begin Scope Loop button 291
Begin Test button 293
Bit Value Modifier list box 261
Bit Value text box 260
Bitfield Description option

of Text View pop-up menu 263
Bitfield Name list box 260
Blank Check button 282
Bottom Edges command 469
boxes

Destination 146
Pane Collapse 153, 202
Pane Expand 153, 202
Source 146

Branch Optimizations 390
Break command 206
Break menu command 469
Break On C++ Exception menu command 469
Break on Java Exceptions command 469
Breakpoint Properties button 214
breakpoint template 220
breakpoint template, defined 212
breakpoint templates

creating 221
deleting 222
specifying the default 222
working with 220

Breakpoints 212
breakpoints

Breakpoint Type property 217
clearing all 219
Condition property 217
conditional 212
default template 220
defined 212
disabled 212, 234
enabled 212
File-Info property 217
Hardware property 218
Hit Count property 217
Name property 217
Original Process property 217
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Original-Target property 217
purpose of 211
regular 212
saving sets of 215
Serial Number property 217
setting conditional 219
setting temporary 219
template 220
temporary 212
Thread property 218
Times Hit property 217
Times Left property 218
viewing 215
working with 215

Breakpoints button 202
Breakpoints column, in editor window 94
Breakpoints menu command 469
Breakpoints window 212

Active icon 215
Breakpoint Properties button 214
Create Breakpoint Template button 213
Groups tab 214
Inactive icon 215
Instances tab 214
opening 215
Rename Breakpoint button 214
saving contents of 215
Set Default Breakpoint Template button 214
Templates tab 214

Breakpoints Window menu command 469
breakpoints, clearing 219
breakpoints, disabling 218
breakpoints, enabling 218, 232
breakpoints, setting 216
breakpoints, viewing properties for 217
Bring To Front menu command 470
Bring Up To Date

menu command 52, 53
Bring Up To Date menu command 413, 470
Browse button 129, 259, 262, 276, 279, 287
Browse In Processes Window option 372, 373
browser 160

Class Browser window 163
Classes pane 169
collapsing panes 168
creating new classes 170, 185, 186
creating new data members 193
creating new member functions 190, 191, 193

expanding panes 168
hierarchy windows 176
Member Functions pane 171
overview 23
printing class hierarchies 177
purpose of 157
setting options 157
Source pane 172
status area 173
using contextual menu 161
viewing data by contents 180
viewing data by inheritance 176
working with 157

Browser Access Filters 165
Browser Commands option 402

Editor Settings panel 416
Browser Contents 164
Browser Contents command 470
Browser Contents window 179

Symbols list 180
browser database

defined 157
Browser menu 402
Browser Path option 403
Browser Wizard 185
Build Before Running option 403
Build Extras panel

options
Initial Directory field 416
Use External Debugger 431
Use modification date caching 431

Build Extras settings panel 265, 382
options

Application 384
Arguments 384
Cache Subprojects 383
Dump internal browse information after 

compile 383
Generate Browser Data From 383
Initial directory 384
Use External Debugger 384
Use modification date caching 383

Build Extras target settings panel 480
Build Progress menu command 470
Build Progress Window menu command 470
Build Settings panel

options
Include file cache 416
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Play sound after ‘Bring Up To Date’ & 
‘Make’ 421

Save open files before build 424
Show message after building up-to-date 

project 426
Success 428
Use Local Project Data Storage 431

Build Settings preference panel 341
options

Build before running 343
Compiler thread stack 343
Failure 343
Include file cache 343
Play sound after ‘Bring Up To Date’ & 

‘Make’ 343
Save open files before build 343
Show message after building up-to-date 

project 343
Success 343
Use Local Project Data Storage 343

build system
overview 24

build targets 29
configuring 56
creating 54
management 49
managing 53
moving 50
removing 49, 54
renaming 51, 55
setting default 55
strategies for 40

Bus Noise checkbox 292
Bus Noise test

subtests
Full Range Converging 295
Maximum Invert Convergence 296
Sequential 295

bus noise, defined 295
Button

Choose 326
Delete 327
Export 337
Import 338
New Binding 336
Save 327

buttons
Access Target 289
Add 381

Add Default 399
Add Files 136
Apply 150
Begin Scope Loop 291
Begin Test 293
Blank Check 282
Breakpoint Properties 214
Breakpoints 202
Browse 129, 259, 262, 276, 279, 287
Calculate Checksum 284
Cancel 122, 124, 274, 285
Change 381
Clear List 136
Compare 147
Create Breakpoint Template 213
Debug 201
Details 280, 282, 284, 289, 291, 293
Edit 364
Erase 282
Export Panel 410
Expressions 202
Factory Settings 412
Find 122, 124, 127
Find All 122, 128
Installed Products 467
Kill 201
Line and Column 204
Load Settings 274, 285
Next Result 139
OK 274, 285
Previous Result 139
Program 281
Purge Cache 422
Read 261
Redo 151
Remove 381
Remove a Set 136
Rename Breakpoint 214
Replace 124, 128
Replace All 124, 128
Reset Value 261
resetting in toolbars 332
Resume 201
Revert 261
Run 201
Save Settings 274, 285
Save This Set 136
Set Default Breakpoint Template 214
Show Log 274, 293
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Source File 203
Step Into 202
Step Out 202
Step Over 202
Stop 128, 139, 201
Symbolics 202
Unapply 150
Undo 151
Variables Pane Listing 203
Verify 281
Warnings 139
Write 261

By Type text/list box 129
Byte option button 288, 290, 292

C
cache

purging 422
Cache Edited Files Between Debug Sessions 

option 403
Cache Subprojects option 403
Cache Symbolics Between Runs option 404
Cache window 302

opening 302
caching

#include files 416
precompiled headers 416

Calculate Checksum button 284
Can’t Redo menu command 441, 454
Can’t Undo menu command 441, 454
Cancel button 122, 124, 274, 285
Cancel button, in Remove Markers window 116
Cascade menu command 470
Case Sensitive checkbox 122, 125, 128, 146
Case Sensitive option 404
Change button 381
Change Program Counter menu command 470
changing

find strings 141
line views in a hierarchical window 178
register data views 257
register values 256
remote connections 373
source trees 353

Check Syntax command 471
Checkbox

Numeric Keypad Bindings 336

checkboxes
Address 292
All Sectors 282
Analyzer Can Cause Target Breakpoint 299
Appears in Menus 140
Apply Address Offset 280
Bus Noise 292
Case sensitive 122, 125, 128, 146
Compare text file contents 147
Enable Logging 277
Erase Sectors Individually 282
Ignore extra space 146
Log Message 225
Match whole word 122, 124, 128
Only show different files 147
Project headers 131
Project sources 131
Regular expression 122, 125, 128
Restrict Address Range 279
Search cached sub-targets 131
Search selection only 122, 125
Search sub-folders 129
Search up 122, 125
Speak Message 225
Stop at end of file 122, 125
Stop in Debugger 225, 227, 229
System headers 131
Target Breakpoint Can Cause Analyzer Trigger 

checkbox 299
Treat as Expression 225
Use Custom Settings 276, 287
Use Selected File 279
Use Target CPU 293
Use Target Initialization 276, 287
View Target Memory Writes 277
Walking 1’s 292

Checkout Status column
in Files view of Project window 46

Checksum panel 282
child windows, defined 67
choosing

a default project 36
linkers 313
one character from many in regular 

expressions 143
class browser

purpose of windows 163
working with windows 163

Class Browser menu command 471
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Class Browser window 163
Classes pane 165
Data Members pane 165
Member Functions pane 165
Source pane 165
Status area 165

class data
viewing from hierarchy windows 167

Class Declaration 173
Class Hierarchy 164
Class Hierarchy menu command 471
Class Hierarchy Window menu command 471
class hierarchy windows

purpose of 175
working with 175

classes
creating 170, 185, 186
hiding pane for 170
showing pane for 170
sorting list of 170

Classes option 364
Classes pane 169

in Class Browser window 165
classes.zip 468
Clear All Breakpoints menu command 472
Clear All Watchpoints menu command 472
Clear Breakpoint menu command 472
Clear Eventpoint menu command 472
Clear Floating Toolbar command in Toolbar 

submenu 472
Clear List button 136
Clear Main Toolbar menu command 472
Clear menu command 471
Clear Watchpoint menu command 472
Clear Window Toolbar command in Toolbar 

submenu 473
clearing

all breakpoints 219
all watchpoints 236
breakpoints 219
watchpoints 236

client area, defined 67
Clone Existing Target option 54
Close All command 63
Close All Editor Documents menu command 473
Close All menu command 473
Close Catalog menu command 473

Close command 37, 63
Close menu command 473
Close Non-debugging Windows option 404
Close Workspace menu command 473
closing

all files 63
dockable windows 75
files 63
projects 37
workspaces 80

Code 390
code

adding markers to 116
completing 102
disabling breakpoints 218
disabling eventpoints 231
disabling special breakpoints 238
disabling watchpoints 235
enabling breakpoints 218, 232
enabling special breakpoints 238
enabling watchpoints 236
locating 111
navigating 111
setting breakpoints in 216
setting watchpoints in 234
viewing breakpoint properties 217
viewing eventpoint properties 231
viewing watchpoint properties 235

Code column
in Files view of Project window 46

code completion
activating automatic behavior 103
configuration 103
deactivating automatic behavior 105
for data members 109
for parameter lists 109
navigating window 107
selecting items 108
triggering by keyboard 104
triggering from IDE menu bar 104

Code Completion Delay option 404
Code Completion preference panel 355

options
Automatic Invocation 356
Case sensitive 356
Code Completion Delay 356
Display deprecated items 356
Window follows insertion point 356
512 IDE 5.5 User’s Guide



Code Completion window 105
code completion, triggering from IDE menu bar 104
Code Formatting preference panel 356

options
Close Braces, Brackets, And Parentheses 358
Format Braces 357
Indent Braces 358
Indent Case Within Switch Statement 358
Indent Code Within Braces 358
Language Settings 357
Place Else On Same Line As Closing 

Brace 358
Place Opening Brace On Separate Line 358
Use Automatic Code Formatting 357

Code Generation section, of Target Settings panels 388
Code Only option button 123, 125, 128
CodeWarrior

menu reference 439
overview 19

CodeWarrior Glossary command 474
CodeWarrior Help menu command 474
CodeWarrior IDE

Apple menu 452
CodeWarrior menu 452
Data menu 449, 461
Debug menu 447, 459
Edit menu 441, 454
File menu 439, 452
Help menu 451, 465
Project menu 445, 457
Scripts menu 465
Search menu 443, 455
Tools menu 464
VCS menu 464
Window menu 442, 450, 463

CodeWarrior menu 452
CodeWarriorU.com 15
Collapse Non-debugging Windows option 405
Collapse Window menu command 474
collapsing

browser panes 168
dockable windows 74

COM 407
Command Actions

Arguments 322
Defining (Mac OS) 326
Defining (Windows) 322
Directory 322

Execute 322
Command Group

Delete 327
Command Groups 326

Delete 326
Command window 303

issuing command lines 304
opening 304

command-line window 303
Commands

Import 337
Modify 319

commands 170
About Metrowerks CodeWarrior 467
Add Files 467
Add Window 467
Apply Difference 151, 468
Arm 300
Balance 469
Bottom Edges 469
Break 206, 469
Break On C++ Exception 469
Break on Java Exceptions 469
Breakpoints 469
Breakpoints Window 469
Bring To Front 470
Bring Up To Date 470
Browser Contents 164, 470
Build Progress 470
Build Progress Window 470
Can’t Redo 441, 454
Can’t Undo 441, 454
Cascade 470
Change Program Counter 470
Check Syntax 471
Class Browser 471
Class Declaration 173
Class Hierarchy 164, 471
Class Hierarchy Window 471
Clear 471
Clear All Breakpoints 472
Clear All Watchpoints 472
Clear Breakpoint 472
Clear Eventpoint 472
Clear Main Toolbar 472
Clear Watchpoint 472
Close 37, 473
Close All 473
Close All Editor Documents 473
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Close Catalog 473
Close Workspace 473
CodeWarrior Glossary 474
CodeWarrior Help 474
Collapse Window 474
Commands & Key Bindings 473
Compare Files 147, 474
Compile 474
Complete Code 474
Connect 299, 474
Copy 475
Copy To Expression 475
Create Design 475
Create Group 475
Create Target 475
Cut 475
Cycle View 476
Debug 204, 476
Delete 476
Diagonal Line 178
Disable Breakpoint 476
Disable Watchpoint 476
Disarm 300
Disassemble 477
Disconnect 301
Display Grid 477
Enable Breakpoint 477
Enable Watchpoint 477
Enter Find String 141, 477
Enter Replace String 478
Errors And Warnings 478
Errors And Warnings Window 478
Exit 478
Expand Window 479
Export Project 36, 479, 484
Export Project as GNU Makefile 479
Expressions 479
Expressions Window 479
File Path 47
Find 123, 479
Find and Open ‘Filename’ 481
Find and Open File 481
Find And Replace 482
Find Definition 480
Find Definition & Reference 118, 479
Find In Files 480
Find In Next File 480
Find In Previous File 480, 481
Find Next 140, 481

Find Previous 140, 481
Find Previous Selection 481
Find Reference 118, 482
Find Selection 141, 482
Get Next Completion 482
Get Previous Completion 482
Global Variables 483
Global Variables Window 483
Go Back 164, 483
Go Forward 164, 483
Go To Line 483
Hide Breakpoints 483
Hide Classes 170
Hide Classes pane 173
Hide Window Toolbar 484
Import Components 484
Import Project 37, 484
Insert Reference Template 484
Kill 207, 485
Make 485
Maximize Window 485
Metrowerks Website 485
Minimize Window 485
New 486
New Class 486
New Class Browser 486
New Data 486
New Event 486
New Event Set 486
New Expression 486
New Item 169
New Member Function 487
New Method 487
New Property 487
New Text File 487
Online Manuals 487
Open 487
Open File 173
Open In Windows Explorer 47
Open Recent 488
Open Scripts Folder 488
Open Workspace 488
Page Setup 488
Pane Collapse 168
Pane Expand 168
Precompile 488
Preferences 489
Print 489
Processes 489
514 IDE 5.5 User’s Guide



Processes Window 489
Project Inspector 35
Redo 490
Refresh All Data 490
Register Details Window 258, 490
Register Windows 490
Registers 490
Remove Object Code 490
Remove Object Code & Compact 491
Remove Toolbar Item 332
Replace 126, 491, 492
Replace All 491
Replace and Find Next 491
Restart 207
Resume 206, 494
Revert 494
Run 207, 422, 494
Run To Cursor 494
Save Default Window 495
Save Workspace 495
Save Workspace As 495
Select All 495
Send To Back 495
Set Breakpoint 496
Set Default Project 36, 496
Set Default Target 496
Set Eventpoint 496
Set Watchpoint 496
Shift Right 496, 497
Show Breakpoints 472, 497
Show Classes 170
Show Classes pane 173
Show Inherited 165
Show private 166
Show protected 166
Show public 166
Show Types 497
Show Window Toolbar 484
Single Class Hierarchy Window 164
Sort Alphabetical 169, 170
Sort Hierarchical 169
Stack Editor Windows 497
Step Into 205
Step Out 205
Step Over 205, 498
Stop 206
Stop Build 498
Straight Line 178
Switch To Monitor 498

Symbolics 498
Symbolics Window 498
Synchronize Modification Dates 498
Toolbars 501
Unapply Difference 152
Update Data 300
View Array 503
View as implementor 166
View as subclass 166
View As Unsigned Decimal 503, 504, 505
View as user 166
View Disassembly 505
View Mixed 505
View Source 505
View Variable 505
Zoom Window 506

Commands & Key Bindings menu command 473
Commands tab 317, 319, 334
Commands&KeyBindings.mkb file 337
Comments Only option button 123, 125, 128
Comments option 405
common debugging actions 204
Common Subexpression Elimination 390
Compare button 147
Compare Files command 147
Compare Files menu command 474
Compare Files Setup window 145

Case Sensitive checkbox 146
Compare button 147
Compare Text File Contents checkbox 147
Destination box 146
Ignore Extra Space checkbox 146
Only Show Different Files checkbox 147
Source box 146

Compare Text File Contents checkbox 147
comparing files

differences, applying 151
differences, unapplying 152
overview 145
setup 145, 147

comparing files, explained 149
comparing folders

examining results 154
overview 145
setup 145, 148

comparing folders, explained 152
comparison

destination item 145
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source item 145
Compile menu command 474
compiler

avoiding crashes 405
Compiler option 405
Compiler option, in Generate Browser Data From 

menu 414
compiler thread stack

and avoiding compiler crashes 405
Compiler Thread Stack field 405
Complete Code menu command 474
completing code 102
Component Object Model. See COM.
Concurrent Compiles panel

options
Use Concurrent Compiles 423, 430
User Specified 433

Concurrent Compiles preference panel 343
options

Recommended 344
Use Concurrent Compiles 344
User Specified 344

condition, breakpoint property 217
conditional breakpoint, defined 219
conditional breakpoints 212

setting 219
conditional eventpoint, defined 232
conditional eventpoints

setting 232
conditional watchpoint, defined 237
conditional watchpoints

setting 237
Configuration panel 286
configuring

build targets 56
code completion 103
projects for a logic analyzer 297
targets 56

Confirm “Kill Process” When Closing Or Quitting 
option 406

Confirm Invalid File Modification Dates When 
Debugging option 405

Connect command 299
Connect menu command 474
Connection list box 276, 287
Connection pop-up menu, in Remote Debugging 

settings panel 398

Connection Type list box 298
Connection Type option 372, 373
console applications

creating 81, 82
applications

creating console applications 82
console applications, about 81
constant

adding to a variable 245
Constants option 364
contents

of register 258
Context Popup Delay option 406
contextual menu

using for browser 161
contextual menus 209

File Path command 47
Open In Windows Explorer command 47
using 210
using to dock a window 70

controlling program execution 199
conventions

figures 17
for manual 17
keyboard shortcuts 18

Copy And Expression Propagation 390
Copy menu command 475
Copy Propagation 390
Copy To Expression command 475
cores, debugging multiple 210
Create Breakpoint Template button 213
Create Design menu command 475
Create Group menu command 475
Create Target command 54
Create Target menu command 475
creating

a new data member 172
build targets 54
console application 82
console applications 81, 82
custom project stationery 38
empty projects 33
files (Macintosh) 60
files (Windows) 59
member functions 171
new classes 170, 185, 186
new data member 193
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new data members 193
new member function 190
new member functions 191
projects from makefiles 32
projects using stationery 31
subprojects 39
targets 54

cross-platform migration, and opening projects 34
Current Target list pop-up 44
Current Target menu 331
current-statement arrow 203
Custom Keywords settings panel 391
custom project stationery 38
Customize IDE Commands window 140, 317, 334, 336

Action 319
Appears in Menus 319, 320
Appears in Menus checkbox 140
Auto Repeat 319
Key Bindings 319
Name field 319
New Binding 319
New Group 320

Cut command 475
CVS 351
Cycle View menu command 476

D
dash 203
Data column

in Files view of Project window 46
Data Line fault 294
data members

completing code 109
creating 172, 193
identifier icons 171

Data Members pane 172
in Class Browser window 165

Data menu 449, 461
data, for debugger, working with 265
database

navigation for browser 160
deactivating automatic code completion 105
Dead Code Elimination 390
Dead Store Elimination 390
Debug button 201
Debug column

in Files view of Project window 46

Debug command 52, 53, 204
Debug menu 406, 447, 459

Clear All Breakpoints command 448, 460
Disable Watchpoint command 448, 461
Enable Breakpoint command 448, 460
Enable Watchpoint command 448, 460, 461
Hide Breakpoints command 448, 460

Debug menu command 476
debugger 422

attaching to a process 271
choosing for an opened symbolics file 372
overview 24
restarting 207
starting 204
working with data 265
working with memory 247
working with variables 239

Debugger Commands option 406
Debugger list box 298
Debugger section, of IDE preference panels 366
Debugger section, of Target Settings panels 393
Debugger Settings panel 271, 396

options
Auto-target Libraries 397
Cache symbolics between runs 397
Default language entry point 397, 407
Location of Relocated Libraries and Code 

Resources 397, 419
Log System Messages 397, 419
Program entry point 422
Stop at Watchpoints 397, 427
Stop on application launch 397, 428
Update data every n seconds 430
Update data every n seconds 397
User specified 397

debugger, defined 199
debugging

common actions 204
multiple cores 210
program execution 199
restarting a session 207
starting a session 204

Declaration File field 187
default breakpoint template 220
Default File Format option 406
default file-name extensions 410
Default Language Entry Point option

Debugger Settings panel 407
517IDE 5.5 User’s Guide 



Default Project 275, 286
default projects 36
default size and position of windows, setting 495
Default Size For Unbounded Arrays option 407
Default Target 275, 286
default target, setting 55
default workspace

definition of 77
using 78

definition
of breakpoint template 212
of breakpoints 212
of bus noise 295
of child windows 67
of client area 67
of conditional breakpoint 219
of conditional eventpoint 232
of conditional watchpoint 237
of debugger 199
of default workspace 77
of dock 67
of eventpoints 223
of IDE 15
of machines 268
of memory aliasing 295
of non-modal 69
of project 27
of regular expression 142
of special breakpoints 237
of symbolics file 200
of symbols 117, 118
of temporary breakpoint 219
of touch 46
of watchpoints 233
of workspace 77

Delete menu command 476
Description 261
Description File text box 259, 262
Design view 50
Designs view 35
desktop background

removing from behind IDE. See  Use Multiple 
Document Interface, turning on.

seeing behind IDE. See Use Multiple Document 
Interface, turning off.

Destination box 146
destination item, for comparison 145
Destination pane 150

details
viewing for registers 258

Details button 280, 282, 284, 289, 291, 293
development-process cycle for software 19
Device pane 278
diagnostics

disabling for plug-ins 467
enabling for plug-ins 467

Diagonal Line 178
dialog boxes

New Connection 372
difference from Single-Class Hierarchy window 178
Differences pane 151
Disable Breakpoint menu command 476
Disable Third Party COM Plugins option 407
Disable Watchpoint menu command 476
disabled breakpoint 212, 234
disabled eventpoint 224
disabling

plug-in diagnostics 467
Disarm command 300
Disassemble menu command 477
disclosure triangles

Source Code pane 139
Source pane 203

Disconnect command 301
Display Deprecated Items option 407
Display Grid menu command 477
Display Settings panel 235

options
Show all locals 426
Show tasks in separate windows 426
Show values as decimal instead of hex 426
Show variable location 427
Show variable types 427
Show variable values in source code 427
Sort functions by method name in symbolics 

window 427
Variable Values Change 434
Watchpoint Indicator 434

Display Settings preference panel 366
options

Attempt to use dynamic type of C++, Object 
Pascal and SOM objects 368

Default size for unbounded arrays 368
Show all locals 368
Show tasks in separate windows 368
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Show values as decimal instead of hex 368
Show variable location 367
Show variable types 367
Show variable values in source code 368
Sort functions by method name in symbolics 

window 368
Variable values change 367
Watchpoint indicator 367

DLL 371, 400
Do Nothing option 407
Do Nothing To Project Windows option 407
dock bars 74
dock, defined 67
dockable windows 67, 69

about 67
closing 75
collapsing 74
dock bars 74
docking windows of the same kind 71
expanding 75
moving 75
suppressing 74
turning off 74
types 68

Document Settings list pop-up 92
document settings pop-up

using 92
documentation

formats 16
structure 16
types 17

Documents option
IDE Extras panel 408

Don’t Step Into Runtime Support Code 408
Don’t Step Into Runtime Support Code option 408
Done button, in Remove Markers window 116
drag and drop

using to dock a window 70
Drag And Drop Editing option 408
Dump Internal Browse Information After Compile 

option 408
dump memory 505

E
Edit button 364
Edit Commands option 408
Edit Language option 409

Edit menu 408, 441, 454
editing

source code 97
symbols, shortcuts for 100

editor 87
overview 23
third-party support 432

Editor section, of IDE preference panels 355
Editor section, of Target Settings panels 391
Editor Settings panel

options
Balance Flash Delay 402
Browser Commands 416
Font Preferences 414
Insert Template Commands 416
Left margin click selects line 418
Project Commands 422
Relaxed C popup parsing 423
Selection position 425
Sort function popup 428
Use multiple undo 432
VCS Commands 434
Window position and size 434

Editor Settings preference panel 358
options

Balance Flash Delay 360
Balance while typing 360
Browser Commands 359
Debugger Commands 360
Default file format 360
Drag and drop editing 360
Edit Commands 359
Enable Virtual Space 360
Font preferences 359
Insert Template Commands 359
Left margin click selects line 360
Project Commands 360
Relaxed C popup parsing 360
Selection position 359
Sort function popup 360
Use multiple undo 360
VCS Commands 360
Window position and size 359

editor toolbar 89
editor window 87

adding panes to 94
Breakpoints column 94
collapsing toolbar in 90
expanding toolbar in 90
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line and column indicator 94
pane splitter controls 94
removing panes from 95
resizing panes 95
text editing area 94

editor windows
other 93
selecting text in 98

Emacs text editor 417, 418
empty projects

creating 33
Empty Target option 54
Enable Automatic Toolbar Help option 409
Enable Breakpoint menu command 477
Enable Browser option 470
Enable Logging checkbox 277
Enable Remote Debugging option 409
Enable Virtual Space option 409
Enable Watchpoint menu command 477
enabled breakpoint 212
enabled eventpoint 224
enabled watchpoint 234
enabling

plug-in diagnostics 467
End text box 280, 292
end-of-line format 406
enlarging panes, in browser 168
Enter Find String command 141
Enter Find String menu command 477
Enter Replace String menu command 478
Entire Flash option button 284
Enums option 364
Environment Settings option 409
Environment Variable option

of Source Trees preference panel 429
Environment Variable option, in Type pop-up 

menu 429
environment variables

Macintosh limitations 429
EOL format 406
Erase / Blank Check panel 281
Erase button 282
Erase Sectors Individually checkbox 282
Errors And Warnings menu command 478
Errors And Warnings Window menu command 478
Errors Only option

of Plugin Diagnostics 418
eventpoints

defined 223
disabled 224
enabled 224
Log Point 223, 224
Log Point, clearing 225
Log Point, setting 224
Pause Point 223, 226
Pause Point, clearing 226
Pause Point, setting 226
purpose of 211
Script Point 223, 226
Script Point, clearing 227
Script Point, setting 227
setting conditional 232
Skip Point 223, 228
Skip Point, clearing 228
Skip Point, setting 228
Sound Point 223, 228
Sound Point, clearing 229
Sound Point, setting 229
Sound Point, Speak Message 228
Trace Collection Off 223, 230
Trace Collection Off, clearing 230
Trace Collection Off, setting 230
Trace Collection On 223, 230
Trace Collection On, clearing 231
Trace Collection On, setting 230
working with 231

eventpoints, disabling 231
eventpoints, viewing properties for 231
examining debugger data 265
examining memory 247
examining variables 239
Exceptions In Targeted Classes command in Java 

Exceptions submenu 478
executable files

adding to the Other Executables list 395
changing in the Other Executables list 395
removing from the Other Executables list 396

execution
of program, controlling 199

execution, killing 207
execution, resuming 206
execution, stopping 206
Exit menu command 478
Expand Window menu command 479
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expanding
browser panes 168
dockable windows 75

Export 337
Export Panel button 318, 340, 410
Export Project as GNU Makefile menu command 479
Export Project command 36
Export Project menu command 479, 484
exporting

projects to XML files 36
Expression Simplification 390
Expressions button 202
Expressions menu command 479
Expressions window 244

adding expressions 245
opening 245

Expressions Window menu command 479
Extension field 410
external editor

using on the Macintosh 347
external editor support 432

F
Factory Settings button 412
Failure option 413
FDI 346, 432

and dockable windows 67
fields

Application 400
Arguments 400
Base Classes 188
Compiler thread stack 405
Declaration File 187
Extension 410
File Type 413
IP Address 373
Relative to class 187
Run App/Script 326

figure conventions 17
File

Commands&KeyBindings.mkb 337
File column

in Files view of Project window 46
%file command-line string 417
File Compare Results window 149

Apply button 150
Destination pane 150

Differences pane 151
pane resize bar 150
Redo button 151
Source pane 150
Unapply button 150
Undo button 151

File list 131
file management 49
File Mappings list 405
File Mappings settings panel 386

options
Add 387
Change 388
Compiler 387
Edit Language 387
Extension 387
File Mappings list 387
File Type 387
Flags 387
Ignored By Make flag 387
Launchable flag 387
Precompiled File flag 387
Remove 388
Resource File flag 387

File menu 439, 452
New Text File command 453

file modification icon 93
File On Host option button 283
File On Target option button 283
File Path command 47
file paths

viewing 47
File Set list 136
File Set list box 136
File Type field 413
File Type option 405
file-info, breakpoint property 217
file-name extensions

default settings 410
files

close all 63
closing 63
comparing 149
creating (Macintosh) 60
creating (Windows) 59
destination (for a comparison) 145
inspecting 35
moving 50
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opening 60
print selections 64
printing 64
renaming 51
replacing text in 126
reverting 65
save all 62
saving 61
saving copies 62
searching (multiple) 136
searching (single) 123
source (for a comparison) 145
touching 52
touching all 52
untouching 53
untouching all 53
working with 59

Files In Both Folders pane 154
Files Only In Destination pane 154
Files Only In Source pane 154
Files page, about 45
Files tab 49
Files view 35, 50, 53

Checkout Status column 46
Code column 46
Data column 46
Debug column 46
File column 46
Interfaces list pop-up 46
Sort Order button 46
Target column 46
Touch column 46

files, tasks for managing 59
Find

by text selection 140
single-file 121

Find All button 122, 128
Find and compare operations option

Shielded Folders panel 413
Find And Open ‘Filename’ menu command 481
Find and Open File command 481
Find and Replace

multiple-file 127
single-file 124

Find And Replace menu command 482
Find and Replace window

All Text option button 125
Cancel button 124

Case Sensitive checkbox 125
Code Only option button 125
Comments Only option button 125
Find button 124
Find text/list box 124
Match Whole Word checkbox 124
Regular Expression checkbox 125
Replace All button 124
Replace button 124
Replace With text/list box 124
Search Selection Only checkbox 125
Search Up checkbox 125
Stop At End Of File checkbox 125

Find button 122, 124, 127
Find command 123, 479
Find Definition & Reference command 118
Find Definition & Reference menu command 479
Find Definition menu command 480
Find In Files menu command 480
Find in Files window

All Text option button 128
Case Sensitive checkbox 128
Code Only option button 128
Comments Only option button 128
Find All button 128
Find button 127
Find text/list box 127
In Files page 135, 136

Add Files button 136
Clear List button 136
File Set list 136
File Set list box 136
Remove A Set button 136
Save This Set button 136

In Files tab 128
In Folders page 129, 130

Browse button 129
By Type text/list box 129
Search In text/list box 129
Search Sub-Folders checkbox 129

In Folders tab 128
In Projects page 131, 132

File list 131
Project Headers checkbox 131
Project list box 131
Project Sources checkbox 131
Search Cached Sub-Targets checkbox 131
System Headers checkbox 131
Target list box 131
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In Projects tab 128
In Symbolics page 133, 134

Symbolics list 133
Symbolics list box 133

In Symbolics tab 128
Match Whole Word checkbox 128
Regular Expression checkbox 128
Replace All button 128
Replace button 128
Replace With text/list box 127
Stop button 128

Find In Next File menu command 480
Find In Previous File menu command 480, 481
Find Next

using 140
Find Next command 140
Find Next menu command 481
Find Previous

using 140
Find Previous command 140

enabling in the Customize IDE Commands 
window 140

Find Previous menu command 481
Find Previous Selection menu command 481
Find Reference command 118
Find Reference menu command 482
Find Reference using option

IDE Extras panel 413
Find Selection command 141
Find Selection menu command 482
Find symbols with prefix 101
Find symbols with substring 101
Find text/list box 122, 124, 127
Find window

All Text option button 122
Cancel button 122
Case Sensitive checkbox 122
Code Only option button 123
Comments Only option button 123
Find All button 122
Find button 122
Find text/list box 122
Match Whole Word checkbox 122
Regular Expression checkbox 122
Search Selection Only checkbox 122
Search Up checkbox 122
Stop At End Of File checkbox 122

finding text

overview 121
Flags pop-up menu 387

Ignored By Make flag 387
Launchable flag 387
Precompiled File flag 387
Resource File flag 387

Flash Base + Offset 280
Flash Base Address 280
Flash Configuration panel 277
Flash Memory Base Address text box 278
Flash Programmer pane 274
flash programmer panels

Checksum 282
Erase / Blank Check 281
Flash Configuration 277
Program / Verify 278
Target Configuration 275

Flash Programmer window 273
Cancel button 274
Checksum panel

Calculate Checksum button 284
Details button 284
Entire Flash option button 284
File On Host option button 283
File On Target option button 283
Memory Range On Target option button 284
Size text box 284
Start text box 284
Status 284

Erase / Blank Check panel
All Sectors checkbox 282
All Sectors list 282
Blank Check button 282
Details button 282
Erase button 282
Erase Sectors individually checkbox 282
Status 282

Flash Configuration panel
Device pane 278
Flash Memory Base Address text box 278
Organization pane 278
Sector Address Map pane 278

Flash Programmer pane 274
Load Settings button 274
OK button 274
opening 273
Program / Verify panel

Apply Address Offset checkbox 280
Browse button 279
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Details button 280
End text box 280
Flash Base + Offset 280
Flash Base Address 280
Offset text box 280
Program button 281
Restrict Address Range checkbox 279
Start text box 280
Status 280
Use Selected File checkbox 279
Use Selected File text box 279
Verify button 281

Save Settings button 274
Show Log button 274
Target Configuration panel

Browse button 276
Connection list box 276
Default Project 275
Default Target 275
Enable Logging checkbox 277
Target Memory Buffer Address text box 276
Target Memory Buffer Size text box 276
Target Processor text/list box 276
Use Custom Settings checkbox 276
Use Target Initialization checkbox 276
Use Target Initialization text box 276
View Target Memory Writes checkbox 277

floating a window 72
Floating Document Interface. See FDI.
floating window type 68
focus bar 50
Folder Compare Results window 152

Files In Both Folders pane 154
Files Only In Destination pane 154
Files Only In Source pane 154
Pane Collapse box 153
Pane Expand box 153
pane resize bar 153
Selected Item group 154

folders
comparing 152
Registers 258
searching (multiple) 130

Font & Tabs panel 362
options

Font 414
Scripts 425
Size 427
Tab indents selection 429

Tab Inserts Spaces 429
Tab Size 429

Font & Tabs preference panel 360, 362
options

Auto Indent 361
Font 361
Script 361
Size 361
Tab indents selection 361
Tab Inserts Spaces 361
Tab Size 361

Font option
Font & Tabs panel 414

Font Preferences option
Editor Settings panel 414

Font Settings 362
Foreground option

Text Colors panel 414
Format list box 260
format, for end of line (EOL) 406
formats

for documentation 16
FPU Registers 255
Framework column, in Access Paths panel 382
Full Range Converging subtest 295
function

New Data Member 172
functions

creating new member 171
locating 111, 112

Functions list box 203
Functions list pop-up 91

sorting alphabetically 113
using 112

Functions option 364

G
General Registers 255
General section, of IDE preference panels 341
Generate Browser Data From option 414

Compiler 414
Language Parser 415
Language Parser, Macro file 415
Language Parser, Prefix file 415
None 414

Generate Constructor and Destructor 188
Get Next Completion menu command 482
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Get next symbol 101
Get Previous Completion menu command 482
Get previous symbol 101
Global Optimizations settings panel 388

options
Details 389
Faster Execution Speed 389
Optimization Level slider 389
Smaller Code Size 389

Global Register Allocation 390
Global Register Allocation Only For Temporary 

Values 390
Global Settings panel

options
Maintain Files in Cache 419
Select stack crawl window when task is 

stopped 425
Global Settings preference panel

options
Auto Target Libraries 371
Automatically launch applications when SYM 

file opened 370
Cache Edited Files Between Debug 

Sessions 370
Confirm "Kill Process" when closing or 

quitting 370
Confirm invalid file modification dates when 

debugging 370
Don’t step into runtime support code 371
Maintain files in cache 370
Purge Cache 370
Select stack crawl window when task is 

stopped 370
Global Variables menu command 483
Global Variables window 239

opening 240
viewing for different processes 240

Global Variables Window menu command 483
Globals option 364
Go Back 164
Go Back menu command 483
Go Forward 164
Go Forward menu command 483
Go To Line menu command 483
going back 114
going forward 114
going to a particular line 114

gray background, adding behind IDE. See Use Multiple 
Document Interface, turning on.

gray background, removing from behind IDE. See Use 
Multiple Document Interface, turning off.

Grid Size X option
Layout Editor panel 415

Grid Size Y option
Layout Editor panel 415

group management 49
grouping

regular expressions 143
groups

moving 50
removing 49
renaming 51
Selected Item 154
touching 52
touching all 52
untouching 53
untouching all 53

Groups tab 214

H
hardware diagnostic panels

Configuration 286
Memory Read / Write 287
Memory Tests 291

Address 295
Bus Noise 295
Bus Noise in address lines 295
Bus Noise in data lines 296
Walking Ones 294

Scope Loop 289
Hardware Diagnostics pane 285
Hardware Diagnostics window 284

Cancel button 285
Configuration panel

Browse button 287
Connection list box 287
Default Project 286
Default Target 286
Target Processor text/list box 287
Use Custom Settings checkbox 287
Use Target Initialization checkbox 287
Use Target Initialization text box 287

Hardware Diagnostics pane 285
Load Settings button 285
Memory Read / Write panel
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Access Target button 289
Byte option button 288
Details button 289
Long Word option button 288
Read option button 288
Status 289
Target Address text box 288
Value to write text box 289
Word option button 288
Write option button 288

Memory Tests panel
Address checkbox 292
Begin Test button 293
Bus Noise checkbox 292
Byte option button 292
Details button 293
End text box 292
Long Word option button 293
Passes text box 293
Show Log button 293
Start text box 292
Status 293
Target Scratch Memory End text box 293
Target Scratch Memory Start text box 293
Use Target CPU checkbox 293
Walking 1’s checkbox 292
Word option button 293

OK button 285
opening 284
Save Settings button 285
Scope Loop panel

Begin Scope Loop button 291
Byte option button 290
Details button 291
Long Word option button 290
Read option button 290
Speed slider 291
Status 291
Target Address text box 290
Value to write text box 291
Word option button 290
Write option button 290

hardware tools, working with 273
hardware, breakpoint property 218
headers

caching precompiled headers 416
Help menu 451, 465
Help Preferences panel 348

options

Browser Path 348
Set 348

Hide Breakpoints menu command 483
Hide Classes 170
Hide Classes pane 173
Hide Floating Toolbar command 483
Hide Main Toolbar command in Toolbar submenu 484
Hide non-debugging windows option

Windowing panel 415
Hide Window Toolbar command 484
hiding

classes pane 170
Hierarchy Control 176
hierarchy window 176
hierarchy windows

changing line views 178
using to view class data 167

hit count, breakpoint property 217
Horizontal Center command 484
Host Application for Libraries & Code Resources 

option
Runtime Settings panel 415

Host Application For Libraries And Code Resources 
field

of Runtime Settings panel 415
Host Name text box 298
host-specific registers 255
how to

activate automatic code completion 103
add a constant to a variable 245
add a keyword to a keyword set 392
add an executable file 395
add expressions (Expressions window) 245
add markers to a source file 116
add panes to an editor window 94
add remote connections 372
add source trees 353
adding subprojects to a project 39
alphabetize Functions list pop-up order 113
apply file differences 151
arm a logic analyzer 300
attach the debugger to a process 271
balance punctuation 101
change an executable file 395
change line views in a hierarchical window 178
change register data views 257
change register values 256
change remote connections 373
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change source trees 353
change the find string 141
choose a default project 36
choose files to compare 147
choose folders to compare 148
clear a breakpoint 219
clear a Log Point 225
clear a Pause Point 226
clear a Script Point 227
clear a Skip Point 228
clear a Sound Point 229
clear a Trace Collection Off eventpoint 230
clear a Trace Collection On eventpoint 231
clear a watchpoint 236
clear all breakpoints 219
clear all watchpoints 236
close a docked window 75
close a workspace 80
close projects 37
collapse a docked window 74
collapse browser panes 168
collapse the editor window toolbar 90
complete code for data members 109
complete code for parameter lists 109
connect to a logic analyzer 300
create a breakpoint template 221
create a console application 82
create a new class 170, 185, 186
create a new data member 193
create a new data members 172
create a new member function 171, 190, 191
create custom project stationery 38
create empty projects 33
create new projects from makefiles 32
create new projects using project stationery 31
deactivate automatic code completion 105
delete a breakpoint template 222
disable a breakpoint 218
disable a watchpoint 235
disable an eventpoint 231
disarm a logic analyzer 300
disconnect from a logic analyzer 301
dock a window by using a contextual menu 70
dock a window by using drag and drop 70
dock windows of the same kind 71
enable a breakpoint 218, 232
enable a watchpoint 236
examine items in the Folder Compare Results 

window 154

expand a docked window 75
expand browser panes 168
expand the editor window toolbar 90
export projects to XML files 36
float a window 72
generate project link maps 314
go to a particular line 114
hide the classes pane 170
import projects saved as XML files 37
indent text blocks 100
insert a reference template 119
issue command lines 304
kill program execution 207
look up symbol definitions 118
make a summation of two variables 246
make a window an MDI Child 73
manipulate variable formats 242
move a docked window 75
navigate browser data 160
navigate Code Completion window 107
navigate to a marker 116
open a recent workspace 80
open a single-class hierarchical window 179
open a workspace 79
open an Array window 254
open projects 33
open projects created on other hosts 34
open registers in a separate Registers window 258
open subprojects 40
open the Breakpoints window 215
open the Cache window 302
open the Command window 304
open the Expressions window 245
open the Flash Programmer window 273
open the Global Variables window 240
open the Hardware Diagnostics window 284
open the IDE Preferences window 341
open the Log window 272
open the Processes window 270
open the Profile window 302
open the Registers window 256
open the Symbolics window 267
open the symbols window 182
open the Target Settings window 377
open the Trace window 301
open the Variable window 241
overstrike text (Windows) 99
print class hierarchies 177
print projects 35
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remove a keyword from a keyword set 393
remove a marker from a source file 116
remove all markers from a source file 117
remove an executable file 396
remove panes from an editor window 95
remove remote connections 354, 374
remove source trees 354
replace text in a single file 126
resize panes in an editor window 95
restart the debugger 207
resume program execution 206
run a program 207
save a copy of a workspace 79
save a workspace 78
save projects 34
save the contents of the Breakpoints window 215
search a single file 123
search for text across multiple files 136
search for text across multiple folders 130
search for text across multiple projects 132
search for text across multiple symbolics files 134
search with a text selection 141
select entire routines 99
select item in Code Completion window 108
select lines 98
select multiple lines 98
select rectangular portions of lines 98
select text in editor windows 98
set a breakpoint 216
set a conditional breakpoint 219
set a conditional eventpoint 232
set a conditional watchpoint 237
set a Log Point 224
set a Pause Point 226
set a Script Point 227
set a Skip Point 228
set a Sound Point 229
set a temporary breakpoint 219
set a Trace Collection Off eventpoint 230
set a Trace Collection On eventpoint 230
set a watchpoint 234
show the classes pane 170
sort the classes list 170
specify the default breakpoint template 222
start the debugger 204
step into a routine 205
step out of a routine 205
step over a routine 205
stop program execution 206

suppress dockable windows 74
toggle automatic punctuation balancing 101
toggle the symbol hint 208
trigger code completion by keyboard 104
trigger code completion from IDE menu bar 104
unapply file differences 152
undock a window 72
unfloat a window 73
unindent text blocks 100
update data from a logic analyzer 300
use an external editor on the Macintosh 347
use contextual menus 210
use the browser contextual menu 161
use the default workspace 78
use the document settings pop-up 92
use the Executables pane in the Symbolics 

window 267, 268
use the Files pane in the Symbolics window 267
use the Find Next command 140
use the Find Previous command 140
use the Functions list pop-up 112
use the Functions pane in the Symbolics 

window 267
use the Interfaces list pop-up 112
use the Process pane 270
use the symbol hint 208
use the VCS pop-up 93
use virtual space 99
view a file path 47
view breakpoint properties 217
view browser data by contents 180
view browser data by inheritance 176
view class data from hierarchy window 167
view eventpoint properties 231
view global variables for different processes 240
view registers 256
view watchpoint properties 235

I
icon

for Tools menu 464
for VCS menu 464

icons
Active 215
file modification 93
for data members 171
for member functions 171
Inactive 215

IDE
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advantages 21
and threading 405
Apple menu 452
Code Completion window 105
CodeWarrior menu 452
Data menu 449, 461
Debug menu 447, 459
defined 15
Edit menu 441, 454
editing source code 97
editor 87
File menu 439, 452
Flash Programmer window 273
Hardware Diagnostics window 284
hardware tools 273
Help menu 451, 465
linkers 313
Mac-hosted 330
menu reference 439
preferences, working with 339
project manager and build targets 27
Project menu 445, 457
Scripts menu 465
Search menu 443, 455
target settings, working with 375
Tools menu 464
tools overview 22
User’s Guide overview 15
VCS menu 464
Window menu 442, 450, 463
Windows-hosted 331
workspaces 77

IDE Extras 464, 465
IDE Extras panel

options
Documents 408
Find Reference using 413
Launch Editor 417
Launch Editor w/ Line # 418
Menu bar layout 419
Projects 422
Symbolics 428
Use Default Workspace’ 430
Use External Editor 431
Use Multiple Document Interface 431
Use Script menu 432
Use ToolServer menu 433
Workspaces 435
Zoom windows to full screen 435

IDE Extras preference panel 344
options

Context popup delay 346
Documents 346
Enable automatic Toolbar help 347
Find Reference using 347
Launch Editor 346
Launch Editor w/ Line # 346
Menu bar layout 346
Projects 346
Recent symbolics 346
Use Default workspace 347
Use External Editor 346
Use Multiple Document Interface 346
Use Script menu 346
Use Third Party Editor 346
Use ToolServer menu 346
Zoom windows to full screen 346

Use Third Party Editor option 432
IDE Preference Panels list 340
IDE Preference Panels, Font & Tabs 362
IDE Preference Panels, Font Settings 362
IDE preferences

Activate Browser Coloring 364
Activate Syntax Coloring 363
Add 350, 352, 372
Attempt to use dynamic type of C++, Object Pascal 

and SOM objects 368
Auto Indent 361
Auto Target Libraries 371
Automatic Invocation 356
Automatically launch applications when SYM file 

opened 370
Background 363
Balance Flash Delay 360
Balance while typing 360
Browser Commands 359
Browser Path 348
Build before running 343
Cache Edited Files Between Debug Sessions 370
Case sensitive 356
Change 351, 352, 372
Choose 352
Classes 364
Close Braces, Brackets, And Parentheses 358
Close non-debugging windows 369
Code Completion Delay 356
Collapse non-debugging windows 369
Comments 364
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Compiler thread stack 343
Confirm "Kill Process" when closing or 

quitting 370
Confirm invalid file modification dates when 

debugging 370
Constants 364
Context popup delay 346
Debugger Commands 360
Default file format 360
Default size for unbounded arrays 368
Disable third party COM plugins 349
Display deprecated items 356
Do nothing 369
Do nothing to project windows 369
Documents 346
Don’t step into runtime support code 371
Drag and drop editing 360
Edit 364
Edit Commands 359
Enable automatic Toolbar help 347
Enable Virtual Space 360
Enums 364
Failure 343
Find and compare operations 350
Find Reference using 347
Font 361
Font preferences 359
Foreground 363
Format Braces 357
Functions 364
Globals 364
Hide non-debugging windows 369
Include file cache 343
Indent Braces 358
Indent Case Within Switch Statement 358
Indent Code Within Braces 358
Insert Template Commands 359
Keywords 364
Language Settings 357
Launch Editor 346
Launch Editor w/ Line # 346
Left margin click selects line 360
Level 349
Macros 364
Maintain files in cache 370
Menu bar layout 346
Minimize non-debugging windows 369
Monitor for debugging 369

Move open windows to debugging monitor when 
debugging starts 369

Name 352
Open windows on debugging monitor during 

debugging 369
Other 364
Place Else On Same Line As Closing Brace 358
Place Opening Brace On Separate Line 358
Play sound after ‘Bring Up To Date’ & ‘Make’ 343
Project Commands 360
Project operations 350
Projects 346
Purge Cache 370
Recent symbolics 346
Recommended 344
Regular Expression 350
Relaxed C popup parsing 360
Remote Connection list 372
Remove 351, 352, 372
Save open files before build 343
Script 361
Select stack crawl window when task is 

stopped 370
Selection position 359
SEt 348
Set 1, Set 2, Set 3, Set 4 364
Shielded folder list 350
Show all locals 368
Show message after building up-to-date 

project 343
Show tasks in separate windows 368
Show values as decimal instead of hex 368
Show variable location 367
Show variable types 367
Show variable values in source code 368
Size 361
Sort function popup 360
Sort functions by method name in symbolics 

window 368
Source Tree list 352
Strings 364
Success 343
Tab indents selection 361
Tab Inserts Spaces 361
Tab Size 361
Templates 364
Type 352
TypeDefs 364
Use Automatic Code Formatting 357
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Use Concurrent Compiles 344
Use Debugging Monitor 369
Use Default workspace 347
Use External Editor 346
Use Local Project Data Storage 343
Use Multiple Document Interface 346
Use multiple undo 360
Use Script menu 346
Use Third Party Editor 346
Use ToolServer menu 346
User Specified 344
Variable values change 367
VCS Commands 360
Watchpoint indicator 367
Window follows insertion point 356
Window position and size 359
Zoom windows to full screen 346

IDE Preferences window 235, 318, 339, 340
Apply button 341
Cancel button 341
Factory Settings button 318, 340
IDE Preference Panels list 340
Import Panel 416
Import Panel button 318, 340
OK button 341
opening 341
Revert Panel button 318, 340
Save button 318, 341

Ignore Extra Space checkbox 146
Ignored By Make File flag 387
Import button 338
Import Commands 337
Import Components menu command 484
Import Panel 416
Import Project command 37
Import Project menu command 484
importing

projects saved as XML files 37
In Files page 135, 136
In Files tab 128
In Folders page 129, 130
In Folders tab 128
In Projects page 131, 132
In Projects tab 128
In Symbolics page 133, 134
In Symbolics tab 128
Inactive icon 215
Include file cache option

Build Settings panel 416
Include Files 192
Include files 189
#include files, caching 416
indenting

text blocks 100
Initial Directory field

Build Extras panel 416
Initializer 194
Insert Reference Template 119
Insert Reference Template menu command 484
Insert Template Commands option

Editor Settings panel 416
inserting a reference template 119
inspecting

project files 35
Installed Products button 467
Instances tab 214
Instruction Scheduling 391
Integrated Development Environment. See IDE.
interface files

locating 111, 112
Interface menu 52
Interfaces list pop-up

in Files view of Project window 46
using 112

interfaces list pop-up 91
IP Address field 373

J
Java Exceptions Submenu

No Exceptions command 487
Java Exceptions submenu

All Exceptions command 468
Exceptions In Targeted Classes command 478
Uncaught Exceptions Only command 502

Java submenu 468, 478, 487, 502

K
Key Bindings 317, 319

Add 335
Customize 334

key bindings 118
keyboard conventions 18
keyboard shortcuts

Find symbols with prefix 101
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Find symbols with substring 101
Get next symbol 101
Get previous symbol 101

keywords
adding to a keyword set 392
removing from a keyword set 393

Keywords option
Text Colors panel 417

Kill button 201
Kill command 207
Kill menu command 485
killing program execution 207

L
Language Parser option, in Generate Browser Data 

From menu 415
Launch Editor option

IDE Extras panel 417
Launch Editor w/ Line # option

IDE Extras panel 418
Launch Remote Host Application option

Remote Debugging settings panel 418
Launchable flag 387
Layout Editor panel

options
Grid Size X 415
Grid Size Y 415
Show the component palette when opening a 

form 426
Show the object inspector when opening a 

form 426
layout management 49
layouts

moving 50
removing 49
renaming 51

least significant bit 294
Left Edges command 485
Left margin click selects line option

Editor Settings panel 418
Level option

Plugin Settings panel 418
Lifetime Based Register Allocation 391
line

going to in source code 114
Line And Column button 204
line and column indicator, in editor window 94

%line command-line string 418
Line Display 176
lines, selecting 98
lines, selecting multiple 98
lines, selecting rectangular portions of 98
link maps

generating for projects 314
Link Order page 47
Link Order tab 49
Link Order view 35, 50, 51
Linker option

Target Settings panel 419
linkers 313

choosing 313
linking projects 314
Linux

modifier key mappings 18
list

of symbols in Browser Contents window 180
list boxes

Analyzer Type 298
Bit Value Modifier 261
Bitfield Name 260
Connection 276, 287
Connection Type 298
Debugger 298
File Set 136
Format 260
Functions 203
Project 131
Source 204
Symbolics 133
Target 131
Text View 261, 262

list menus
document settings 92
functions 91
interfaces 91
markers 91
VCS 92

list pop-up menus
Current Target 44

list pop-ups
Ancestor 176
Browser Access Filters 165
document settings 92
functions 91
interfaces 91
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markers 91
Symbols 180
VCS 165

lists
All Sectors 282
File 131
File Mappings 405
File Set 136
Symbolics 133

Live Range Splitting 390
Load Settings button 274, 285
locating functions 111, 112
locating interface files 111, 112
locating source code 111
Location of Relocated Libraries and Code Resources 

option
Debugger Settings panel 419

Log Message checkbox 225
Log Point 223, 224
Log Point Settings window 225

Message text box 225
Speak Message checkbox 225
Stop in Debugger checkbox 225
Treat as Expression checkbox 225

Log Point, clearing 225
Log Point, setting 224
Log System Messages 271
Log System Messages option

Debugger Settings panel 419
Log Window

Log System Messages option 271
Log window 271

opening 272
logic analyzer 297

Arm command 300
arming 300
configuring a project 297
Connect command 299
connecting to 300
Disarm command 300
disarming 300
Disconnect command 301
disconnect from 301
Update Data command 300
updating data from 300
using 299

Logic Analyzer connection options

Analyzer Can Cause Target Breakpoint 
checkbox 299

Analyzer Configuration File text box 298
Analyzer Slot text box 298
Analyzer Type list box 298
Connection Type list box 298
Debugger list box 298
Host Name text box 298
Name text box 298
Target Breakpoint Can Cause Analyzer Trigger 

checkbox 299
Trace Support File text box 299

Long Word option button 288, 290, 293
looking up symbol definitions 118
Loop Transformations 390
Loop Unrolling 391
Loop Unrolling (Opt For Speed Only) 391
Loop-Invariant Code Motion 390
LSB 294

M
Mac OS

QuickHelp 117
QuickView 117, 119
THINK Reference 119

Mac OS X API 413
machines, defined 268
Macintosh

creating files 60
using an external editor 347

Macintosh menu layout 452
Macro file option, in Generate Browser Data From 

menu 415
Macros option 364
Maintain Files In Cache option 403
Maintain Files in Cache option

Global Settings panel 419
Make command 51, 52, 53
Make menu command 485
Make option 413
Make toolbar button 44
Makefile Importer wizard 32
makefiles

converting into projects 32
managing

build targets 53
projects 31
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targets 53
managing files, tasks 59
manipulating program execution 211

Breakpoints window 212
manipulating text 97
manual conventions 17
markers 115

adding to a source file 116
navigating to 116
removing all from source files 117
removing from source files 116

Markers list pop-up 91
Markers list, in Remove Markers window 115
Match Whole Word checkbox 122, 124, 128
matching

any character with regular expressions 143
replace strings to find strings with regular 

expressions 144
with simple regular expressions 143

Maximize Window menu command 485
Maximum Invert Convergence subtest 296
.mcp 33
MDI 346, 420, 432

and dockable windows 67
making a window an MDI child 73

Member Function Declaration 192
member functions

creating 171, 191
identifier icons 171

Member Functions pane 171
in Class Browser window 165

memory aliasing, defined 295
memory dump 505
Memory Range On Target option button 284
Memory Read / Write panel 287
memory tests

Address 295
Bus Noise 295

address lines 295
data lines 296

Bus Noise test
Full Range Converging subtest 295
Maximum Invert Convergence subtest 296
Sequential subtest 295

Walking Ones 294
Walking Ones test

Address Line fault 294

Data Line fault 294
Ones Retention subtest 294
Retention fault 294
Walking Ones subtest 294
Walking Zeros subtest 294
Zeros Retention subtest 294

Memory Tests panel 291
Address test 295
Bus Noise test 295

address lines 295
data lines 296

Walking Ones test 294
Memory window 247
memory, working with 247
Menu

Current Target 331
menu

Search 118
Menu bar layout option

IDE Extras panel 419
menu commands

About Metrowerks CodeWarrior 467
Add Files 467
Add Window 467
Apply Difference 151, 468
Arm 300
Balance 469
Bottom Edges 469
Break 469
Break On C++ Exception 469
Break on Java Exceptions 469
Breakpoints 469
Breakpoints Window 469
Bring To Front 470
Bring Up To Date 470
Browser Contents 470
Build Progress 470
Build Progress Window 470
Can’t Redo 441, 454
Can’t Undo 441, 454
Cascade 470
Change Program Counter 470
Check Syntax 471
Class Browser 471
Class Hierarchy 471
Class Hierarchy Window 471
Clear 471
Clear All Breakpoints 472
Clear All Watchpoints 472
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Clear Breakpoint 472
Clear Eventpoint 472
Clear Watchpoint 472
Close 473
Close All 473
Close All Editor Documents 473
Close Catalog 473
Close Workspace 473
CodeWarrior Help 474
Collapse Window 474
Commands & Key Bindings 473
Compare Files 147, 474
Compile 474
Complete Code 474
Connect 299, 474
Copy 475
Copy To Expression 475
Create Design 475
Create Group 475
Create Target 475
Cycle View 476
Debug 476
Delete 476
Disable Breakpoint 476
Disable Watchpoint 476
Disarm 300
Disassemble 477
Disconnect 301
Display Grid 477
Enable Breakpoint 477
Enable Watchpoint 477
Enter Find String 141, 477
Enter Replace String 478
Errors And Warnings 478
Errors And Warnings Window 478
Exit 478
Expand Window 479
Export Project 479, 484
Export Project as GNU Makefile 479
Expressions 479
Expressions Window 479
Find 123, 479
Find and Open ‘Filename’ 481
Find and Open File 481
Find And Replace 482
Find Definition 480
Find Definition & Reference 479
Find In Files 480
Find In Next File 480

Find In Previous File 480, 481
Find Next 140, 481
Find Previous 140, 481
Find Previous Selection 481
Find Reference 482
Find Selection 141, 482
Get Next Completion 482
Get Previous Completion 482
Global Variables 483
Global Variables Window 483
Go Back 483
Go Forward 483
Go To Line 483
Hide Breakpoints 483
Hide Window Toolbar 484
Import Components 484
Import Project 484
Insert Reference Template 119, 484
Kill 485
Make 485
Maximize Window 485
Metrowerks Website 485
Minimize Window 485
New 486
New Class 486
New Class Browser 486
New Data 486
New Event 486
New Event Set 486
New Expression 486
New Member Function 487
New Method 487
New Property 487
New Text File 487
Online Manuals 487
Open 487
Open Recent 488
Open Scripts Folder 488
Open Workspace 488
Page Setup 488
Precompile 488
Preferences 489
Print 489
Processes 489
Processes Window 489
Redo 490
Refresh All Data 490
Register Details Window 258, 490
Register Windows 490
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Registers 490
Remove Object Code 490
Remove Object Code & Compact 491
Remove Toolbar Item 332
Replace 126, 491, 492
Replace All 491
Replace and Find Next 491
Resume 494
Revert 494
Run 422, 494
Run To Cursor 494
Save Default Window 495
Save Workspace 495
Save Workspace As 495
Select All 495
Send To Back 495
Set Breakpoint 496
Set Default Project 496
Set Default Target 496
Set Eventpoint 496
Set Watchpoint 496
Shift Right 496, 497
Show Breakpoints 472, 497
Show Types 497
Show Window Toolbar 484
Stack Editor Windows 497
Step Over 498
Stop Build 498
Switch To Monitor 498
Symbolics 498
Symbolics Window 498
Synchronize Modification Dates 498
Toolbars 501
Unapply Difference 152
Update Data 300
View Array 503
View As Unsigned Decimal 503, 504, 505
View Disassembly 505
View Mixed 505
View Source 505
View Variable 505
Zoom Window 506

menu layouts
Macintosh 452
Windows 439

menu reference
for IDE 439

menus 165
contextual 209

VCS 173
Message text box 225
Metrowerks Website command 485
Minimize non-debugging windows option

Windowing panel 420
Minimize Window menu command 485
Monitor for debugging option

Windowing panel 420
most significant bit 294
Move open windows to debugging monitor when 

debugging starts option
Windowing panel 420

moving
build targets 50
dockable windows 75
files 50
groups 50
layouts 50
targets 50

MSB 294
Multi-Class Hierarchy window 175, 178
multi-core debugging 210
Multiple Document Interface. See MDI.
multiple files, searching 136
multiple folders, searching 130
multiple projects, searching 132
multiple Redo 490
multiple symbolics files, searching 134
multiple Undo 490
multiple-file Find and Replace window 127

N
Name field 319
Name text box 298
name, breakpoint property 217
navigating

browser data 160
Code Completion window 107
to markers 116

navigating data 160
navigating source code 111
New Binding 319, 336
New C++ Class window 187
New C++ Data Member window 194
New C++ Member Function window 192
New Class Browser menu command 486
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New Class menu command 486
New Class wizard 170, 185, 186
New Command 321
New command 59, 82
New Command Group

Create 319
New Connection dialog box 372
New Data Member 172, 191, 194
new data member functions

creating 193
New Data Member wizard 172, 193
New Data menu command 486
New Event menu command 486
New Event Set menu command 486
New Expression menu command 486
New Group 320
New Item 169
New Member Function menu command 487
New Member Function wizard 171, 190, 191
new member functions

creating 190
New Menu Command

Create 321, 325
New menu command 486
New Method menu command 487
New Property menu command 487
New Text File command 60
New Text File menu command 487
Next Result button 139
No Exceptions command 487
None option

of Plugin Diagnostics 418
None option, in Generate Browser Data From 

menu 414
non-modal, defined 69
notes

for the latest release 15
Numeric Keypad Bindings 336

O
Offset text box 280
OK button 274, 285
Ones Retention subtest 294
Online Manuals menu command 487
Only Show Different Files checkbox 147
Open command 60

Open File 173
Open In Windows Explorer command 47
Open menu command 487
Open Recent menu command 488
Open Scripts Folder menu command 488
Open windows on debugging monitor during debugging 

option
Windowing panel 421

Open Workspace menu command 488
opening 182

a recent workspace 80
a single-class hierarchical window 179
files 60
Flash Programmer window 273
Hardware Diagnostics window 284
IDE Preferences window 341
projects 33
projects from other hosts 34
subprojects 40
Symbolics window 267
symbols window 182
Variable window 241
workspaces 79

opening last project (default workspace) 430
opening last project, preventing (default 

workspace) 430
openings

registers in a separate Registers window 258
optimizations

Arithmetic Optimizations 390
Branch Optimizations 390
Common Subexpression Elimination 390
Copy And Expression Propagation 390
Copy Propagation 390
Dead Code Elimination 390
Dead Store Elimination 390
Expression Simplification 390
Global Register Allocation 390
Global Register Allocation Only For Temporary 

Values 390
Instruction Scheduling 391
Lifetime Based Register Allocation 391
Live Range Splitting 390
Loop Transformations 390
Loop Unrolling 391
Loop Unrolling (Opt For Speed Only) 391
Loop-Invariant Code Motion 390
Peephole Optimization 390
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Register Coloring 391
Repeated 391
Strength Reduction 390
Vectorization 391

option buttons
All text 122, 125, 128
Byte 288, 290, 292
Code Only 123, 125, 128
Comments Only 123, 125, 128
Entire Flash 284
File on Host 283
File on Target 283
Long Word 288, 290, 293
Memory Range on Target 284
Read 288, 290
Word 288, 290, 293
Write 288, 290

options 408
Access Paths settings panel 349, 379
Activate Browser 480
Activate Browser Coloring 399
Activate Syntax Coloring 399, 405
Add Default 399
Always Search User Paths 400
Application 400
Arguments 400
Attempt to use dynamic type of C++, Object Pascal 

and SOM objects 400
Auto Indent 400
Auto Target Libraries 400
Automatic Invocation 401
Automatically Launch Applications When SYM 

File Opened 401
Auto-target Libraries 400
Background 402
Balance Flash Delay 402
Balance while typing 402
Bring Up To Date 413
Browse in processes window 372, 373
Browser Commands 402
Browser Path 403
Build before running 403
Build Extras settings panel 382
Build Settings preference panel 341
Cache Edited Files Between Debug Sessions 403
Cache Subprojects 403
Cache symbolics between runs 404
Case Sensitive 404
Checksum panel 282

choosing host application for non-executable 
files 415

Classes 364
Close non-debugging windows 404
Code Completion Delay 404
Code Completion preference panel 355
Code Formatting preference panel 356
Code Generation settings panels 388
Collapse non-debugging windows 405
Comments 405
Compiler 405
Compiler thread stack 405
Concurrent Compiles preference panel 343
Configuration panel 286
Confirm “Kill Process” when closing or 

quitting 406
Confirm invalid file modification dates when 

debugging 405
Connection Type 372, 373
Constants 364
Context popup delay 406
Custom Keywords settings panel 391
Debugger Commands 406
Debugger preference panels 366
Debugger Settings 271
Debugger Settings panel 396
Debugger settings panels 393
Default File Format 406
Default size for unbounded arrays 407
Disable third party COM plugins 407
Display Deprecated Items 407
Display Settings preference panel 366
Do nothing 407
Do nothing to project windows 407
Drag and drop editing 408
Dump internal browse information after 

compile 408
Edit Commands 408
Edit Language 409
Editor preference panels 355
Editor settings panels 391
Editor Settings preference panel 358
Enable automatic Toolbar help 409
Enable remote debugging 409
Enable Virtual Space 409
Enums 364
Environment Settings 409
Erase / Blank Check panel 281
Failure 413
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File Mappings settings panel 386
File Type 405
Flash Configuration panel 277
Font & Tabs preference panel 360, 362
Functions 364
General preference panels 341
Generate Browser Data From 414
Global Optimizations settings panel 388
Globals 364
Help Preferences panel 348
IDE Extras preference panel 344
Import Panel 416
Macros 364
Maintain files in cache 403
Make 413
Memory Read / Write panel 287
Memory Tests panel 291
Other 364
Other Executables settings panel 393
Plugin Settings preference panel 348
Program / Verify panel 278
Purge Cache 403
Remote Connections preference panel 371
Remote Debugging settings panel 397
Require Framework Style Includes 424
Runtime Settings panel 384
Scope Loop panel 289
Set 1, Set 2, Set 3, Set 4 364
setting for browser 157
Shielded Folders preference panel 349
Source Trees preference panel 351
System Paths list 381
Target Configuration panel 275
Target Settings panel 378
Target settings panels 377
Templates 364
TypeDefs 364
Use Multiple Document Interface 67
User Paths list 381
User specified 397
Window Follows Insertion Point 434
Window Settings preference panel 368

Organization pane 278
original process, breakpoint property 217
original-target, breakpoint property 217
other editor windows 93
Other Executables settings panel 393
Other option 364
Output Directory option

Target Settings panel 421
Overlays tab 49
overstrike 99
overstriking text (Windows) 99
overtype. See overstrike.
overview

of browser 23
of build system 24
of CodeWarrior 19
of debugger 24
of editor 23
of IDE project manager and build targets 27
of IDE tools 22
of IDE User’s Guide 15
of project manager 23
of search engine 23

P
Page Setup command 488
pages

In Files 135
In Folders 129
in project window 45
In Projects 131
In Symbolics 133

PalmQuest reference 413
Pane Collapse 168
Pane Collapse box 153, 202
Pane Expand 168
Pane Expand box 153, 202
Pane resize bar 139, 150, 153, 202
pane resize bar

in File Compare Results window 150
in Folder Compare Results window 153

pane splitter controls, in editor window 94
panel

Display Settings 235
panels

Analyzer Connections 297
Font & Tabs 362
for IDE preferences 340
for targets 376

panes
adding to editor window 94
Destination 150
Device 278
Differences 151
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Files in Both Folders 154
Files Only in Destination 154
Files Only in Source 154
Flash Programmer 274
Hardware Diagnostics 285
Organization 278
removing from editor window 95
resizing in an editor window 95
Results 139
Sector Address Map 278
Source 150, 203
Source Code 139
Stack 202
Variables 202

parameter lists
completing code 109

Passes text box 293
path caption 93
Pause Point 223, 226
Pause Point, clearing 226
Pause Point, setting 226
Peephole Optimization 390
Play sound after ‘Bring Up To Date’ & ‘Make’ option

Build Settings panel 421
Plugin Diagnostics

All Info option 418
Errors Only option 418
None option 418

plug-in diagnostics
disabling 467
enabling 467

Plugin Settings panel
options

Level 418
Plugin Settings preference panel 348

options
Disable third party COM plugins 349
Level 349

plug-ins
saving information about those installed in 

IDE 467
viewing those installed in IDE 467

pop-up menus
document settings 92
functions 91
interfaces 91
markers 91
VCS 92

pop-ups
Ancestor 176
Browser Access Filters 165
Symbols 180
VCS 165

Post-linker option
Target Settings panel 421

Precompile menu command 488
Precompiled File flag 387
precompiled headers

caching 416
preference panel 340
preference panels

Build Settings 341
Code Completion 355
Code Formatting 356
Concurrent Compiles 343
Display Settings 366
Editor Settings 358
Font & Tabs 360, 362
Help Preferences 348
IDE Extras 344
Plugin Settings 348
Remote Connections 371
reverting 424
Shielded Folders 349
Source Trees 351
Window Settings 368

preferences
Activate Browser Coloring 364
Activate Syntax Coloring 363
Add 350, 352, 372
Apply button 341
Attempt to use dynamic type of C++, Object Pascal 

and SOM objects 368
Auto Indent 361
Auto Target Libraries 371
Automatic Invocation 356
Automatically launch applications when SYM file 

opened 370
Background 363
Balance Flash Delay 360
Balance while typing 360
Browser Commands 359
Browser Path 348
Build before running 343
Cache Edited Files Between Debug Sessions 370
Cancel button 341
Case sensitive 356
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Change 351, 352, 372
Choose 352
Classes 364
Close Braces, Brackets, And Parentheses 358
Close non-debugging windows 369
Code Completion Delay 356
Collapse non-debugging windows 369
Comments 364
Compiler thread stack 343
Confirm "Kill Process" when closing or 

quitting 370
Confirm invalid file modification dates when 

debugging 370
Constants 364
Context popup delay 346
Debugger 366
Debugger Commands 360
Default file format 360
Default size for unbounded arrays 368
Disable third party COM plugins 349
Display deprecated items 356
Do nothing 369
Do nothing to project windows 369
Documents 346
Don’t step into runtime support code 371
Drag and drop editing 360
Edit 364
Edit Commands 359
Editor 355
Enable automatic Toolbar help 347
Enable Virtual Space 360
Enums 364
Export Panel button 318, 340
Factory Settings button 318, 340
Failure 343
Find and compare operations 350
Find Reference using 347
Font 361
Font preferences 359
for IDE 339
Foreground 363
Format Braces 357
Functions 364
General 341
Globals 364
Hide non-debugging windows 369
IDE Preference Panels list 340
IDE window 339
Import Panel button 318, 340

Include file cache 343
Indent Braces 358
Indent Case Within Switch Statement 358
Indent Code Within Braces 358
Insert Template Commands 359
Keywords 364
Language Settings 357
Launch Editor 346
Launch Editor w/ Line # 346
Left margin click selects line 360
Level 349
Macros 364
Maintain files in cache 370
Menu bar layout 346
Minimize non-debugging windows 369
Monitor for debugging 369
Move open windows to debugging monitor when 

debugging starts 369
Name 352
OK button 341
Open windows on debugging monitor during 

debugging 369
Other 364
Place Else On Same Line As Closing Brace 358
Place Opening Brace On Separate Line 358
Play sound after ‘Bring Up To Date’ & ‘Make’ 343
Project Commands 360
Project operations 350
Projects 346
Purge Cache 370
Recent symbolics 346
Recommended 344
Regular Expression 350
Relaxed C popup parsing 360
Remote Connection list 372
Remove 351, 352, 372
Revert Panel button 318, 340
Save button 318, 341
Save open files before build 343
Script 361
Select stack crawl window when task is 

stopped 370
Selection position 359
Set 348
Set 1, Set 2, Set 3, Set 4 364
Shielded folder list 350
Show all locals 368
Show message after building up-to-date 

project 343
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Show tasks in separate window 368
Show values as decimal instead of hex 368
Show variable location 367
Show variable types 367
Show variable values in source code 368
Size 361
Sort function popup 360
Sort functions by method name in symbolics 

window 368
Source Tree list 352
Strings 364
Success 343
Tab indents selection 361
Tab Inserts Spaces 361
Tab Size 361
Templates 364
Type 352
TypeDefs 364
Use Automatic Code Formatting 357
Use Concurrent Compiles 344
Use Debugging Monitor 369
Use Default workspace 347
Use External Editor 346
Use Local Project Data Storage 343
Use Multiple Document Interface 346
Use multiple undo 360
Use Script menu 346
Use Third Party Editor 346
Use ToolServer menu 346
User Specified 344
Variable values change 367
VCS Commands 360
Watchpoint indicator 367
Window follows insertion point 356
Window position and size 359
Zoom windows to full screen 346

Preferences menu command 489
Prefix file option, in Generate Browser Data From 

menu 415
Pre-linker option

Target Settings panel 422
Previous Result button 139
print

file selections 64
Print command 64, 489
printing

class hierarchies 177
files 64
projects 35

process
attaching debugger to 271

process cycle
of software development 19

Process pane
using 270

processes
related to machines 268
viewing global variables for 240

Processes menu command 489
Processes window 268, 372

opening 270
Processes Window menu command 489
products

saving information about those installed in 
IDE 467

viewing those installed in IDE 467
Profile window

opening 302
program

killing execution 207
resuming execution 206
running 207
stopping execution 206

Program / Verify panel 278
Program Arguments field

of Runtime Settings panel (Windows) 422
Program Arguments option

Runtime Settings panel 422
Program button 281
Program Entry Point option

Debugger Settings panel 422
program execution, manipulating 211
project

configuring for a logic analyzer 297
Project Commands option

Editor Settings panel 422
project data folder 431
Project Headers checkbox 131
Project Inspector command 35
Project list box 131
project manager 27

overview 23
Project menu 422, 445, 457

Remove Object Code command 446, 459
Stop Build command 446, 458

Project operations option
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Shielded Folders panel 422
Project Sources checkbox 131
project stationery

creating 38
custom 38

Project window
about Files page 45
Current Target list pop-up 44
Files view

Checkout Status column 46
Code column 46
Data column 46
Debug column 46
File column 46
Interfaces list pop-up 46
Sort Order button 46
Target column 46
Touch column 46

Make toolbar button 44
Synchronize Modification Dates toolbar button 44
Target Settings toolbar button 44

project window 43
Link Order page 47
pages 45
Targets page 48

project window, about 43
project, defined 27
projects

about subprojects 39
advanced topics 38
choosing default 36
closing 37
creating custom stationery 38
creating empty 33
creating subprojects 39
creating using makefiles 32
creating using stationery 31
data folder 431
exporting to XML files 36
generating link maps for 314
importing XML versions of 37
inspecting files 35
linking 314
managing 31
opening 33
opening from other hosts 34
printing 35
project window 43
project window pages 45

project window, about 43
reopening last one used (default workspace) 430
reopening last one used, preventing (default 

workspace) 430
saving 34
searching (multiple) 132
strategies for 40
subprojects, strategies for 40
working with 27

Projects option
IDE Extras panel 422

properties
condition, breakpoint 217
file-info, breakpoint 217
hardware, breakpoint 218
hit count, breakpoint 217
name, breakpoint 217
original process, breakpoint 217
original-target, breakpoint 217
serial number, breakpoint 217
thread, breakpoint 218
times hit, breakpoint 217
times left, breakpoint 218
type, breakpoint 217

punctuation balancing, toggling 101
punctuation, balancing 101
pure virtual

icon for 171
Purge Cache button 422
Purge Cache option 403
purging cache 422
purpose

of breakpoints 211
of Browser Contents window 179
of Classes pane in browser 169
of Data Members pane 172
of eventpoints 211
of Member functions pane 171
of Multi-Class Hierarchy window 175
of Single-Class Hierarchy window 178
of Source pane 172
of special breakpoints 211
of status area in browser 173
of Symbols window 181
of watchpoints 211

Q
QuickDraw 420
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QuickHelp (Mac OS) 117
QuickView 117, 119, 413
QuickView, Mac OS 119
QuickView, THINK Reference 119

R
Read button 261
Read option button 288, 290
Recursive Search column, in Access Paths panel 382
Redo button 151
Redo menu command 490
reference information

for IDE menus 439
reference template 119
reference template, inserting 119
reference templates (Macintosh) 119
Refresh All Data menu command 490
Register Coloring 391
Register Description option

of Text View pop-up menu 263
Register Details option

of Text View pop-up menu 263
Register Details window 258

Address text box 259
Bit Value Modifier list box 261
Bit Value text box 260
Bitfield Description text view option 263
Bitfield Name list box 260
Browse button 259, 262
Description 261
Description File text box 259, 262
Format list box 260
Read button 261
Register Description text view option 263
Register Details text view option 263
Register display 260, 262
Register Name 259
Reset Value button 261
Revert button 261
Text View list box 261, 262
using 262
Write button 261
XML files 258

Register Details Window command 258
Register Details Window menu command 490
Register display 260, 262
Register Name 259

Register Windows menu command 490
registers

changing data views of 257
changing values of 256
FPU Registers 255
General Registers 255
host-specific 255
Register Details window 258
viewing 256
viewing details of 258

Registers folder 258
Registers menu command 490
Registers window 254

opening 256
opening more than one 258

Registry Key option
of Source Trees preference panel 429

Registry Key option, in Type pop-up menu 429
regular breakpoints 212
Regular Expression checkbox 122, 125, 128
Regular Expression option

Shielded Folders panel 423
regular expressions 142

.*[_]Data 351
\(.*\) 351
choosing one character from many 143
CVS 351
defined 142
grouping 143
matching any character 143
matching simple expressions 143
using the find string in the replace string 144

Relative to class field 187
Relaxed C popup parsing option

Editor Settings panel 423
release notes 15
remembering last project (default workspace) 430
remembering last project, turning off (default 

workspace) 430
remote connections

adding 372
changing 373
removing 354, 374

Remote Connections preference panel 371
options

Add 372
Change 372
Remote Connection list 372
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Remove 372
Remote Debugging settings panel 397

Connection pop-up menu 398
options

Launch remote host application 418
Remote download path 423

Remote Download Path option
Remote Debugging settings panel 423

Remove A Set button 136
Remove button 381
Remove button, in Remove Markers window 115
Remove command 49, 54
Remove Markers window 115

Cancel button 116
Done button 116
Markers list 115
Remove button 115

Remove Object Code & Compact menu command 491
Remove Object Code menu command 490
Remove Toolbar Item 332
removing

build targets 49, 54
desktop background from behind IDE. See Use 

Multiple Document Interface, turning on.
files 49
gray background from behind IDE. See Use 

Multiple Document Interface, turning off.
groups 49
layouts 49
remote connections 354, 374
source trees 354
targets 49, 54

Rename Breakpoint button 214
Rename command 51, 55
renaming

build targets 51, 55
files 51
groups 51
layouts 51
targets 51, 55

reopening last project used
in default workspace 430
suppressing in the default workspace 430

Repeated optimizations 391
Replace All button 124, 128
Replace All menu command 491
Replace and Find Next menu command 491
Replace and Find Previous command 491

Replace button 124, 128
Replace command 126
Replace menu command 491, 492
Replace With text/list box 124, 127
replacing

text in a single file 126
text, overview 121

Require Framework Style Includes 424
Reset Value button 261
Reset Window Toolbar command in Toolbar 

submenu 492, 493
resetting

toolbars 332
resize bars

Pane 139, 202
Resize submenu

To Smallest Height command 501
To Smallest Width command 502

resizing
panes in an editor window 95

Resource File flag 387
Restart command 207
restarting

debugger 207
Restore Window command (Windows) 493
Restrict Address Range checkbox 279
Result Count text box 138
results

of multi-item search 138
Results pane 139
Resume button 201
Resume command 206
Resume menu command 494
resuming program execution 206
Retention fault 294
Revert button 261
Revert command 65
Revert menu command 494
reverting

files 65
preference panels 424
settings panels 424

revision control 434, 464
routine

stepping into 205
stepping out of 205
stepping over 205
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routine, selecting entirely 99
Run App/Script 326
Run button 201
Run command 52, 53, 207
Run menu command 422, 494
Run To Cursor menu command 494
running

a program 207
Runtime Settings panel 384

Host Application For Libraries And Code 
Resources field 415

options
Add 385
Change 386
Environment Settings 385
Host Application for Libraries & Code 

Resources 385, 415
Program Arguments 385, 422
Remove 386
Value 386
Variable 386
Working Directory 385, 435

Program Arguments field (Windows) 422

S
Save a Copy As command 62
Save All command 62
Save command 61
Save Default Window menu command 495
Save open files before build option

Build Settings panel 424
Save project entries using relative paths option

Target Settings panel 424
Save Settings button 274, 285
Save This Set button 136
Save Workspace As menu command 495
Save Workspace menu command 495
saving

a copy of a workspace 79
all files 62
file copies 62
files 61
information about installed plug-ins 467
information about installed products 467
projects 34
workspaces 78

Scope Loop panel 289

Script Point 223, 226
Script Point Settings window

Stop in Debugger checkbox 227
Script Point, clearing 227
Script Point, setting 227
(Scripts) folder 465, 488
Scripts menu 465
Scripts option

Font & Tabs panel 425
search

single characters with regular expressions 143
using finds strings in replace strings with regular 

expressions 144
Search Cached Sub-Targets checkbox 131
Search Criteria text box 138
search engine

overview 23
Search In text/list box 129
Search menu 118, 443, 455
Search Results window 138

Next Result button 139
Pane resize bar 139
Previous Result button 139
Result Count text box 138
Results pane 139
Search Criteria text box 138
setting default size and position of 495
Source Code pane 139
Source Code Pane disclosure triangle 139
Stop button 139
Warnings button 139

Search Selection Only checkbox 122, 125
Search Status column, in Access Paths panel 381
Search Sub-Folders checkbox 129
Search Up checkbox 122, 125
searching

choosing one character from many in regular 
expressions 143

grouping regular expressions 143
multiple files 136
multiple folders 130
multiple projects 132
multiple symbolics files 134
single characters with regular expressions 143
single files 123
using finds strings in replace strings with regular 

expressions 144
using regular expressions 142
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with simple regular expressions 143
Sector Address Map pane 278
seeing desktop background behind IDE. See Use 

Multiple Document Interface, turning off.
Segments tab 49
Select All menu command 495
Select stack crawl window when task is stopped option

Global Settings panel 425
Selected Item group 154
selecting

Code Completion window items 108
text in editor windows 98

selecting entire routines 99
selecting lines 98
selecting multiple lines 98
selecting rectangular portions of lines 98
Selection position option

Editor Settings panel 425
selections

searching (text) 141
Send To Back menu command 495
Sequential subtest 295
serial number, breakpoint property 217
Set 1, Set 2, Set 3, Set 4 364
Set Breakpoint menu command 496
Set Default Breakpoint Template button 214
Set Default Project command 36
Set Default Project menu command 496
Set Default Target menu command 496
Set Eventpoint menu command 496
Set Watchpoint menu command 496
setting

browser options 157
temporary breakpoints 219

setting default size and position of windows 495
settings

Add 352, 381, 385, 387
Add Default 381
Always Search User Paths 381
Application 384
Apply button 377
Arguments 384
Auto-target Libraries 397
Cache subprojects 383
Cache symbolics between runs 397
Cancel button 377
Change 352, 381, 386, 388

Choose 352, 379
Clear 379
Code Generation 388
Compiler 387
Debugger 393
Default language entry point 397
Details 389
Dump internal browse information after 

compile 383
Edit Language 387
Editor 391
Environment Settings 385
Export Panel button 377
Extension 387
Factory Settings button 376
Faster Execution Speed 389
File Mappings list 387
File Type 387
Flags 387
Generate Browser Data From 383
Host Application for Libraries & Code 

Resources 385
Host Flags 381
IDE window 375
Ignored By Make flag 387
Import Panel button 377
Initial directory 384
Interpret DOS and Unix Paths 381
Launchable flag 387
Linker 378
Location of Relocated Libraries and Code 

Resources 397
Log System Messages 397
Name 352
OK button 377
Optimization Level slider 389
Output Directory 379
Post-linker 378
Precompiled File flag 387
Pre-linker 378
Program Arguments 385
Program entry point 397
Remove 352, 381, 386, 388
Require Framework Style Includes 381
Resource File flag 387
Revert Panel button 377
Save button 377
Save project entries using relative paths 379
Smaller Code Size 389
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Source Tree list 352
Stop at Watchpoints 397
Stop on application launch 397
System Paths 381
System Paths list 381
Target 377
Target Name 378
Target Settings Panels list 376
Type 352
Update data every n seconds 397
Use External Debugger 384
Use modification date caching 383
User Paths 381
User Paths list 381
User specified 397
Value 386
Variable 386
Working Directory 385

settings panel 376
settings panels

Access Paths 349, 379
Build Extras 382, 480
Custom Keywords 391
Debugger Settings 271, 396
File Mappings 386
Global Optimizations 388
Other Executables 393
Remote Debugging 397
reverting 424
Runtime Settings 384
Source Trees 351
Target Settings 378

setup
code completion 103

Shielded Folders panel
options

Find and compare operations 413
Project operations 422
Regular Expression 423

Shielded Folders preference panel 349
options

Add 350
Change 351
Find and compare operations 350
Project operations 350
Regular Expression 350
Remove 351
Shielded folder list 350

Shift Right menu command 496, 497

shortcut conventions 18
Show all locals option

Display Settings panel 426
Show Breakpoints menu command 472, 497
Show Classes 170
Show Classes pane 173
Show Floating Toolbar command 483
Show Floating Toolbar command in Toolbar 

submenu 497
Show Inherited 165
Show Log button 274, 293
Show Main Toolbar command 484
Show message after building up-to-date project option

Build Settings panel 426
Show private 166
Show protected 166
Show public 166
Show tasks in separate windows option

Display Settings panel 426
Show the component palette when opening a form 

option
Layout Editor panel 426

Show the object inspector when opening a form option
Layout Editor panel 426

Show Types menu command 497
Show values as decimal instead of hex option

Display Settings panel 426
Show variable location option

Display Settings panel 427
Show variable types option

Display Settings panel 427
Show variable values in source code option

Display Settings panel 427
Show Window Toolbar command 484
Show Window Toolbar command in Toolbar 

submenu 497
showing

classes pane 170
shrinking panes, in browser 168
Single Class Hierarchy Window 164
single files, searching 123
single-class hierarchical window

opening 179
Single-Class Hierarchy window 178

difference from Multi-Class Hierarchy 
window 178

single-file Find and Replace window 124
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single-file Find window 121
size

setting default for unbounded arrays 407
Size option

Font & Tabs panel 427
Size text box 284
Skip Point 223, 228
Skip Point, clearing 228
Skip Point, setting 228
software

development process cycle 19
Solaris

modifier key mappings 18
Sort Alphabetical 169, 170
Sort function popup option

Editor Settings panel 428
Sort functions by method name in symbolics window 

option
Display Settings panel 427

Sort Hierarchical 169, 170
Sort Order button

in Files view of Project window 46
sorting

classes list 170
Functions list pop-up (alphabetically) 113

Sound Point 223, 228
Sound Point Settings window

Stop in Debugger checkbox 229
Sound Point, clearing 229
Sound Point, setting 229
Sound Point, Speak Message 228
Source box 146
source code

disabling breakpoints 218
disabling eventpoints 231
disabling special breakpoints 238
disabling watchpoints 235
editing 97
enabling breakpoints 218, 232
enabling special breakpoints 238
enabling watchpoints 236
going to a particular line 114
locating 111
setting breakpoints in 216
setting watchpoints in 234
viewing breakpoint properties 217
viewing eventpoint properties 231

viewing watchpoint properties 235
Source Code pane 139
Source Code Pane disclosure triangle 139
source code, navigating 111
source file

adding markers to 116
Source File button 203
source files

removing all markers from 117
removing markers from 116

source item, for comparison 145
Source list box 204
Source pane 150, 172, 203

in Class Browser window 165
in Symbols window 183

Source Pane disclosure triangle 203
source trees

adding 353
changing 353
removing 354

Source Trees panel
options

Add 352
Change 352
Choose 352
Name 352
Remove 352
Source Tree list 352
Type 352, 429

Source Trees preference panel 351
Absolute Path option 429
Environment Variable option 429
Registry Key option 429

Source Trees settings panel 351
Speak Message checkbox 225
special breakpoints

defined 237
purpose of 211

special breakpoints, disabling 238
special breakpoints, enabling 238
Speed slider 291
Stack Editor Windows menu command 497
Stack pane 202
Start text box 280, 284, 292
starting

debugger 204
state
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disabled, for breakpoints 212, 234
disabled, for eventpoints 224
enabled, for breakpoints 212
enabled, for eventpoints 224
enabled, for watchpoints 234

static
icon for 171

stationery
creating for projects 38
creating projects 31
custom 38

Status 280, 282, 284, 289, 291, 293
Status area

in Class Browser window 165
status area 173
Step Into button 202
Step Into command 205
Step Out button 202
Step Out command 205
Step Over button 202
Step Over command 205
Step Over menu command 498
stepping into a routine 205
stepping out of a routine 205
stepping over a routine 205
Stop At End Of File checkbox 122, 125
Stop at Watchpoints option

Debugger Settings panel 427
Stop Build menu command 498
Stop button 128, 139, 201
Stop command 206, 498
Stop in Debugger checkbox 225, 227, 229
Stop On Application Launch option

Debugger Settings panel 428
stopping program execution 206
Straight Line 178
strategies

for build targets 40
for projects 40
for subprojects 40

Strength Reduction 390
Strings option

Text Colors panel 428
structure

of documentation 16
submenus

Align 468, 469

subproject, defined 39
subprojects

creating 39
opening 40
strategies for 40

Success option
Build Settings panel 428

summation, of two variables 246
Switch To Monitor menu command 498
symbol definitions 117, 118
symbol definitions, looking up 118
Symbol hint 207
symbol hint

toggling 208
turning off 208
turning on 208
using 208

symbol implementations
viewing all 182

symbol-editing shortcuts 100
Symbolics button 202
symbolics file, defined 200
symbolics files

choosing a debugger for 372
searching (multiple) 134

Symbolics list 133
Symbolics list box 133
Symbolics menu command 498
Symbolics option

IDE Extras panel 428
Symbolics window 265

opening 267
using the Executables pane 267, 268
using the Files pane 267
using the Functions pane 267

Symbolics Window menu command 498
symbols

shortcuts for editing 100
viewing all implementations 182

Symbols list
in Browser Contents window 180

Symbols pane 183
Symbols pop-up 180
Symbols window 181

Source pane 183
Symbols pane 183
toolbar 183
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symbols window 182
Synchronize Modification Dates command 48
Synchronize Modification Dates menu command 498
Synchronize Modification Dates toolbar button 44
System Headers checkbox 131
System Paths list 381

Framework column 382
Recursive Search column 382
Search Status column 381

System Paths option
Access Paths panel 428

T
Tab indents selection option

Font & Tabs panel 429
Tab Inserts Spaces option

Font & Tabs panel 429
Tab Size option

Font & Tabs panel 429
tabs

Groups 214
In Files 128
In Folders 128
In Projects 128
In Symbolics 128
Instances 214
Templates 214

Target Address text box 288, 290
Target Breakpoint Can Cause Analyzer Trigger 

checkbox 299
Target column

in Files view of Project window 46
Target Configuration panel 275
Target list box 131
target management 49
Target Memory Buffer Address text box 276
Target Memory Buffer Size text box 276
Target Name option

Target Settings panel 429
Target Processor text/list box 276, 287
Target Scratch Memory End text box 293
Target Scratch Memory Start text box 293
Target section, of Target Settings panels 377
target settings

Add 352, 381, 385, 387
Add Default 381
Always Search User Paths 381

Application 384
Apply button 377
Arguments 384
Auto-target Libraries 397
Cache subprojects 383
Cache symbolics between runs 397
Cancel button 377
Change 352, 381, 386, 388
Choose 352, 379
Clear 379
Compiler 387
Connection pop-up menu 398
Default language entry point 397
Details 389
Dump internal browse information after 

compile 383
Edit Language 387
Environment Settings 385
Export Panel button 377
Extension 387
Factory Settings button 376
Faster Execution Speed 389
File Mappings list 387
File Type 387
Flags 387
for IDE 375
Generate Browser Data From 383
Host Application for Libraries & Code 

Resources 385
Host Flags 381
Ignored By Make flag 387
Import Panel button 377
Initial directory 384
Interpret DOS and Unix Paths 381
Launchable flag 387
Linker 378
Location of Relocated Libraries and Code 

Resources 397
Log System Messages 397
Name 352
OK button 377
Optimization Level slider 389
Output Directory 379
Post-linker 378
Precompiled File flag 387
Pre-linker 378
Program Arguments 385
Program entry point 397
Remove 352, 381, 386, 388
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Require Framework Style Includes 381
Resource File flag 387
Revert Panel button 377
Save button 377
Save project entries using relative paths 379
Smaller Code Size 389
Source Tree list 352
Source Trees 351
Stop at Watchpoints 397
Stop on application launch 397
System Paths 381
System Paths list 381
Target Name 378
Target Settings Panels list 376
Type 352
Update data every n seconds 397
Use External Debugger 384
Use modification date caching 383
User Paths 381
User Paths list 381
User specified 397
Value 386
Variable 386
Working Directory 385

Target Settings command 499
Target Settings panel 56, 378

options
Choose 379
Clear 379
Linker 378, 419
Output Directory 379, 421
Post-linker 378, 421
Pre-linker 378, 422
Save project entries using relative paths 379, 

424
Target Name 378, 429

target settings panel 376
target settings panels

Access Paths 379
Analyzer Connections 297
Build Extras 382, 480
Custom Keywords 391
Debugger Settings 271, 396
File Mappings 386
Global Optimizations 388
Other Executables 393
Remote Debugging 397
Runtime Settings 384
Target Settings 378

Target Settings Panels list 376
Target Settings toolbar button 44
Target Settings window 375, 376

Apply button 377
Cancel button 377
Export Panel button 377
Factory Settings button 376
Import Panel button 377
OK button 377
opening 377
Revert Panel button 377
Save button 377
Target Settings Panels list 376

targets 29
configuring 56
creating 54
files 49
managing 53
moving 50
removing 49, 54
renaming 51, 55
setting default 55
strategies for 40

Targets page 48
Targets tab 55
Targets view 35, 50, 54
tasks

activating automatic code completion 103
adding a constant to a variable 245
adding a keyword to a keyword set 392
adding an executable file 395
adding expressions (Expressions window) 245
adding markers to a source file 116
adding panes to an editor window 94
adding remote connections 372
adding source trees 353
adding subprojects to a project 39
alphabetizing Functions list pop-up order 113
applying file differences 151
arming a logic analyzer 300
attaching the debugger to a process 271
balancing punctuation 101
changing an executable file 395
changing line views in a hierarchical window 178
changing register data views 257
changing register values 256
changing remote connections 373
changing source trees 353
changing the find string 141
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choosing a default project 36
choosing files to compare 147
choosing folders to compare 148
clearing a breakpoint 219
clearing a Log Point 225
clearing a Pause Point 226
clearing a Script Point 227
clearing a Skip Point 228
clearing a Sound Point 229
clearing a Trace Collection Off eventpoint 230
clearing a Trace Collection On eventpoint 231
clearing a watchpoint 236
clearing all breakpoints 219
clearing all watchpoints 236
closing a docked window 75
closing a workspace 80
closing projects 37
collapsing a docked window 74
collapsing browser panes 168
collapsing the editor window toolbar 90
completing code for data members 109
completing code for parameter lists 109
connecting to a logic analyzer 300
creating a breakpoint template 221
creating a console application 82
creating a new class 170, 185, 186
creating a new data member 172, 193
creating a new member function 171, 190, 191
creating custom project stationery 38
creating empty projects 33
creating new projects from makefiles 32
creating new projects using project stationery 31
deactivating automatic code completion 105
deleting a breakpoint template 222
disabling a breakpoint 218
disabling a watchpoint 235
disabling an eventpoint 231
disarming a logic analyzer 300
disconnecting from a logic analyzer 301
docking a window by using a contextual menu 70
docking a window by using drag and drop 70
docking windows of the same kind 71
enabling a breakpoint 218, 232
enabling a watchpoint 236
examining items in the Folder Compare Results 

window 154
expanding a docked window 75
expanding browser panes 168
expanding the editor window toolbar 90

exporting projects to XML files 36
floating a window 72
for managing files 59
generating project link maps 314
going to a particular line 114
hiding the classes pane 170
importing projects saved as XML files 37
indenting text blocks 100
inserting a reference template 119
issuing command lines 304
killing program execution 207
looking up symbol definitions 118
making a summation of two variables 246
making a window an MDI child 73
manipulating variable formats 242
moving a docked window 75
navigating browser data 160
navigating Code Completion window 107
navigating to a marker 116
opening a recent workspace 80
opening a single-class hierarchical window 179
opening a workspace 79
opening an Array window 254
opening projects 33
opening projects created on other hosts 34
opening registers in a separate Registers 

window 258
opening subprojects 40
opening the Breakpoints window 215
opening the Cache window 302
opening the Command window 304
opening the Expressions window 245
opening the Flash Programmer window 273
opening the Global Variables window 240
opening the Hardware Diagnostics window 284
opening the IDE Preferences window 341
opening the Log window 272
opening the Processes window 270
opening the Profile window 302
opening the Registers window 256
opening the Symbolics window 267
opening the symbols window 182
opening the Target Settings window 377
opening the Trace window 301
opening the Variable window 241
overstriking text (Windows) 99
printing class hierarchies 177
printing projects 35
removing a keyword from a keyword set 393
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removing a marker from a source file 116
removing all markers from a source file 117
removing an executable file 396
removing panes from an editor window 95
removing remote connections 354, 374
removing source trees 354
replacing text in a single file 126
resizing panes in an editor window 95
restarting the debugger 207
resuming program execution 206
running a program 207
saving a copy of a workspace 79
saving a workspace 78
saving projects 34
saving the contents of the Breakpoints window 215
searching a single file 123
searching for text across multiple files 136
searching for text across multiple folders 130
searching for text across multiple projects 132
searching for text across multiple symbolics 

files 134
searching with a text selection 141
selecting entire routines 99
selecting item in Code Completion window 108
selecting lines 98
selecting multiple lines 98
selecting rectangular portions of lines 98
selecting text in editor windows 98
setting a breakpoint 216
setting a conditional breakpoint 219
setting a conditional eventpoint 232
setting a conditional watchpoint 237
setting a Log Point 224
setting a Pause Point 226
setting a Script Point 227
setting a Skip Point 228
setting a Sound Point 229
setting a temporary breakpoint 219
setting a Trace Collection Off eventpoint 230
setting a Trace Collection On eventpoint 230
setting a watchpoint 234
showing the classes pane 170
sorting the classes list 170
specifying the default breakpoint template 222
starting the debugger 204
stepping into a routine 205
stepping out of a routine 205
stepping over a routine 205
stopping program execution 206

suppressing dockable windows 74
toggling automatic punctuation balancing 101
toggling the symbol hint 208
triggering code completion by keyboard 104
triggering code completion from IDE menu 

bar 104
unapplying file differences 152
undocking a window 72
unfloating a window 73
unindenting text blocks 100
updating data from a logic analyzer 300
using an external editor on the Macintosh 347
using contextual menus 210
using the browser contextual menu 161
using the default workspace 78
using the document settings pop-up 92
using the Executables pane in the Symbolics 

window 267, 268
using the Files pane in the Symbolics window 267
using the Find Next command 140
using the Find Previous command 140
using the Functions list pop-up 112
using the Functions pane in the Symbolics 

window 267
using the Interfaces list pop-up 112
using the Process pane 270
using the symbol hint 208
using the VCS pop-up 93
using virtual space 99
viewing a file path 47
viewing breakpoint properties 217
viewing browser data by contents 180
viewing browser data by inheritance 176
viewing class data from hierarchy windows 167
viewing eventpoint properties 231
viewing global variables for different 

processes 240
viewing registers 256
viewing watchpoint properties 235

template, default for breakpoints 220
template, for breakpoints 220
Templates option 364
Templates tab 214
templates, creating for breakpoints 221
templates, deleting for breakpoints 222
templates, reference (Macintosh) 119
templates, specifying the default for breakpoints 222
temporary breakpoint, defined 219
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temporary breakpoints 212
setting 219

text
changing a find string 141
find by selecting 140
finding 121
overstriking (Windows) 99
replacing 121
searching with a selection 141

text blocks, indenting 100
text blocks, unindenting 100
text boxes

Address 259
Analyzer Configuration File text box 298
Analyzer Slot 298
Bit Value 260
Description File 259, 262
End 280, 292
Flash Memory Base Address 278
Host Name 298
Message 225
Name 298
Offset 280
Passes 293
Result Count 138
Search Criteria 138
Size 284
Start 280, 284, 292
Target Address 288, 290
Target Memory Buffer Address 276
Target Memory Buffer Size 276
Target Scratch Memory End 293
Target Scratch Memory Start 293
Trace Support File 299
Use Selected File 279
Use Target Initialization 276, 287
Value to Write 289, 291

Text Colors panel
options

Activate Browser Coloring 414
Activate Syntax Coloring 414, 417, 428
Foreground 414
Keywords 417
Strings 428

Text Colors preference panel
options

Activate Browser Coloring 364
Activate Syntax Coloring 363
Background 363

Classes 364
Comments 364
Constants 364
Edit 364
Enums 364
Foreground 363
Functions 364
Globals 364
Keywords 364
Macros 364
Other 364
Set 1, Set 2, Set 3, Set 4 364
Strings 364
Templates 364
TypeDefs 364

text editing area, in editor window 94
text manipulation 97
Text View list box 261, 262

Auto 262
Text View pop-up menu

Bitfield Description option 263
Register Description option 263
Register Details option 263

text/list boxes
By Type 129
Find 122, 124, 127
Replace With 124, 127
Search in 129
Target Processor 276, 287

text-selection Find 140
THINK Reference 117, 119, 413
third-party editor support 432
third-party text editors

Emacs 417, 418
Thread window

Breakpoints button 202
current-statement arrow 203
dash 203
debug button 201
Expressions button 202
Functions list box 203
Kill button 201
Line And Column button 204
Pane Collapse box 202
Pane Expand box 202
Pane resize bar 202
Resume button 201
run button 201
555IDE 5.5 User’s Guide 



Source File button 203
Source list box 204
Source pane 203
Source Pane disclosure triangle 203
Stack pane 202
Step Into button 202
Step Out button 202
Step Over button 202
Stop button 201
Symbolics button 202
Variables pane 202
Variables Pane Listing button 203

thread window 200
thread, breakpoint property 218
threading in IDE 405
__throw() 469
Tile Editor Windows command 499
Tile Editor Windows Vertically command 499
Tile Horizontally command 499
Tile Vertically command 500
times hit, breakpoint property 217
times left, breakpoint property 218
To Smallest Height command in Resize submenu 501
To Smallest Width command in Resize submenu 502
toggling

symbol hint 208
toolbar

collapsing in editor window 90
expanding in editor window 90

Toolbar (Editor Window) Elements
Document Settings 331
File Dirty Indicator 331
File Path field 331
Functions 331
Header Files 331
Markers 331
Version Control Menus 331

toolbar buttons
Browser Contents 164
Class Hierarchy 164
Go Back 164
Go Forward 164
Make 44
Single Class Hierarchy Window 164
Synchronize Modification Dates 44
Target Settings 44

Toolbar Items 317, 330
Toolbar submenu

Anchor Floating Toolbar command 468
Clear Floating Toolbar command 472
Clear Main Toolbar command 472
Clear Window Toolbar command 473
Hide Floating Toolbar command 483
Hide Main Toolbar command 484
Reset Window Toolbar command 492, 493
Show Floating Toolbar command 483, 497
Show Main Toolbar command 484
Show Window Toolbar command 497

Toolbars
Add element 330
Clear Elements 332
Customize 328
Elements 328, 329
Icons 330
Instances of 329
Main (floating) 329
Modify 330
Project and Window 329
Remove element 331
Remove single element 330
Toolbar Items tab 330
Types 329

toolbars
editor 89
for Symbols window 183
resetting 332

Toolbars menu command 501
tools

browser 23
build system 24
debugger 24
editor 23
project manager 23
search engine 23

Tools menu 464
icon 464

tools, for hardware 273
ToolServer menu 433
ToolServer Worksheet command 501
ToolTip 330
touch

defined 46
Touch column 52, 53

in Files view of Project window 46
Touch command 52
touching
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all files 52
all groups 52
files 52
groups 52

trace
working with logic analyzer 297

Trace Collection Off 230
Trace Collection Off eventpoint 223
Trace Collection Off eventpoint, clearing 230
Trace Collection Off eventpoint, setting 230
Trace Collection On 230
Trace Collection On eventpoint 223
Trace Collection On eventpoint, clearing 231
Trace Collection On eventpoint, setting 230
Trace Support File text box 299
Trace window 301

opening 301
Treat as Expression checkbox 225
triggering

code completion by keyboard 104
code completion from IDE menu bar 104

turning off
symbol hint 208

turning on
symbol hint 208

Type list box
Absolute Path option 429

Type option
Source Trees panel 429

Type pop-up menu
Environment Variable option 429
Registry Key option 429

type, breakpoint property 217
TypeDefs option 364
types

of documentation 17

U
Unanchor Floating Toolbar command 502
Unapply button 150
Unapply Difference command 152, 502
unbounded arrays, setting default size for viewing 407
Uncaught Exceptions Only command 502
Undo button 151
Undo command 502
undocking windows 72

unfloating windows 73
Ungroup command 502
unindenting text blocks 100
Untouch command 53
untouching

a file 53
a group 53
all files 53
all groups 53

Update Data command 300
Update Data Every n Seconds option 430
Use Concurrent Compiles option 423, 430
Use Custom Settings checkbox 276, 287
Use Debugging Monitor option 430
Use Default Workspace option 430
Use External Debugger option 431
Use External Editor option 431
Use Local Project Data Storage option 431
Use modification date caching option 431
Use Multiple Document Interface option 67, 431

turning off 346
turning on 346

Use multiple undo option 502
in Editor Settings panel 432

Use Script menu option 432
Use Scripts Menu option 465
Use Selected File checkbox 279
Use Selected File text box 279
Use Target CPU checkbox 293
Use Target Initialization checkbox 276, 287
Use Target Initialization text box 276, 287
Use Third Party Editor option 432
Use ToolServer Menu option 464
Use ToolServer menu option

IDE Extras panel 433
User Paths list 381

Framework column 382
Recursive Search column 382
Search Status column 381

User Paths option 433
User Specified option 433
User specified option 397
using

document settings pop-up 92
Executables pane in the Symbolics window 267, 

268
Files pane in the Symbolics window 267
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Find Next command 140
Find Previous command 140
Functions list pop-up 112
Functions pane in the Symbolics window 267
Interfaces list pop-up 112
logic analyzer 299
Register Details window 262
symbol hint 208
VCS pop-up 93
virtual space 99
workspaces 77

V
Value to Write text box 289, 291
Variable Values Change option

Display Settings panel 434
Variable window 241

opening 241
variables

^var placeholder 244
adding a constant to 245
making a summation of 246
manipulating formats 242
symbol hint 207

Variables pane 202
Variables Pane Listing button 203
variables, working with 239
VCS 93

list pop-up 165
menu 464
pop-up 92

VCS Commands option
Editor Settings panel 434

VCS menu 173, 434
icon 464

VCS pop-up
using 93

Vectorization 391
Verify button 281
version control 434, 464
Version Control Settings command 503
Version Control System. See VCS.
Vertical Center command in Align submenu 494, 500, 

501, 503
View Array menu command 503
View as implementor 166
View as subclass 166

View As Unsigned Decimal menu command 503, 504, 
505

View as user 166
View Disassembly menu command 505
View Memory As command 505
View Memory command 505
View Mixed menu command 505
View Source menu command 505
View Target Memory Writes checkbox 277
View Variable menu command 505
viewing

all symbol implementations 182
breakpoints 215
browser data by contents 180
browser data by inheritance 176
file paths 47
register details 258
registers 256

viewing installed plug-ins 467
viewing installed products 467
virtual

icon for 171
virtual space, using 99

W
Walking 1’s checkbox 292
Walking Ones subtest 294
Walking Ones test

Address Line fault 294
Data Line fault 294
Retention fault 294
subtests

Ones Retention 294
Walking Ones 294
Walking Zeros 294
Zeros Retention 294

Walking Zeros subtest 294
Warnings button 139
Watchpoint Indicator option

Display Settings panel 434
watchpoints

clearing all 236
defined 233
enabled 234
purpose of 211
setting conditional 237

watchpoints, clearing 236
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watchpoints, disabling 235
watchpoints, enabling 236
watchpoints, setting 234
watchpoints, viewing properties for 235
what is

a debugger 199
a symbolics file 200

window
Customize IDE Commands 334

Window Follows Insertion Point option 434
Window menu 442, 450, 463

Restore Window command (Windows) 493
Window position and size option

Editor Settings panel 434
Window Settings preference panel 368

options
Close non-debugging windows 369
Collapse non-debugging windows 369
Do nothing 369
Do nothing to project windows 369
Hide non-debugging windows 369
Minimize non-debugging windows 369
Monitor for debugging 369
Move open windows to debugging monitor 

when debugging starts 369
Open windows on debugging monitor during 

debugging 369
Use Debugging Monitor 369

window types
docked 68
floating 68
MDI child 68

Windowing panel
options

Hide non-debugging windows 415
Minimize non-debugging windows 420
Monitor for debugging 420
Move open windows to debugging monitor 

when debugging starts 420
Open windows on debugging monitor during 

debugging 421
Use Debugging Monitor 430

Windows
creating files 59

windows 212
Array 252
Browser Contents 179
Cache 302

Class Browser 163
Code Completion 105
Command 303
Compare Files Setup 145
Customize IDE Commands 140
dock bars in dockable windows 74
dockable 67
dockable, about 67
dockable, turning off 74
dockable, working with 69
docking the same kind of 71
docking with a contextual menu 70
docking with drag and drop 70
editor 87
editor, other 93
Expressions 244
File Compare Results 149
Find (single-file) 121
Find and Replace (multiple-file) 127
Find and Replace (single-file) 124
Flash Programmer 273
floating 72
Folder Compare Results 152
Global Variables 239
Hardware Diagnostics 284
hierarchy 176
IDE Preferences 235, 339
Log 271
making MDI children of 73
Memory 247
New C++ Class 187
New C++ Data Member 194
New C++ Member Function 192
Processes 268
project window 43
Registers 254
remembering size and position of 495
Remove Markers 115
saving default size and position of 495
Search results 138
Symbolics 265
Target Settings 375
Trace 301
undocking 72
unfloating 73
variable 241

Windows menu layout 439
WinHelp (Windows) 117
Wizards
559IDE 5.5 User’s Guide 



Browser 185
wizards

New Class 170, 185, 186
New Data Member 172, 193
New Member Function 190, 191
New Member Functions 171

Word option button 288, 290, 293
working

with IDE preferences 339
with IDE target settings 375

Working Directory option
Runtime Settings panel 435

working with 69
browser 157
class browser windows 163
class hierarchy windows 175
IDE hardware tools 273
logic analyzer 297, 299

working with breakpoint templates 220
working with breakpoints 215
working with debugger data 265
working with dockable windows 69
working with eventpoints 231
working with files 59
working with memory 247
working with projects 27
working with variables 239
workspace, defined 77
workspaces 77

closing 80
opening 79
opening recent 80
saving 78
saving copies of 79
using 77
using default 78

Workspaces option
IDE Extras panel 435

workspaces, about 77
Write button 261
Write option button 288, 290

X
XML

exporting projects 36
files for Register Details window 258
importing projects 37

Z
Zeros Retention subtest 294
Zoom Window menu command 506
Zoom windows to full screen option

IDE Extras panel 435
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