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About this manual

The OrCAD Layout® for Windows® Visual CADD™ Tutorial contains information
about creating a printed circuit board outline and defining the board floor plan in
Visual CADD. This tutorial also describes how to convert outline and floor plan
information from another CAD or PCB design program, and how to prepare final
documentation in AutoCAD format.

Before you begin

Visual CADD does not run under Windows 3.1 or Windows for Workgroups, and it
requires a screen resolution of 800 by 600 pixels, or higher.



About this manual
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Symbols and conventions

OrCAD printed documentation uses a few special symbols and conventions.

The keyboard

� The keys on your keyboard may not be labeled exactly as they are in this
manual. All key names are shown using small capital letters. For example, the
Control key is shown as CTRL; the Escape key is shown as ESC.

� Keys are frequently used in combinations and sequences. For example,
SHIFT+F1 means to hold down the SHIFT key while pressing F1. ALT, F, A means
to press and release each of these keys in sequence: first ALT, then F, then A.

� Arrow keys is the collective name for the UP ARROW, DOWN ARROW, LEFT

ARROW, and RIGHT ARROW keys.

� To choose a command from a menu, you can use the mouse or press a key
sequence. For example: From the File menu, choose Open (ALT, F, O).

Text

� Text you need to type is shown in bold. For example, if the manual directs you
to type *.opj, you type an asterisk, a period, and the lowercase letters o, p, and
j. What you type is usually shown in lowercase letters, unless it must be typed
in uppercase letters to work properly.

� Placeholders for items such as filenames that you must supply are shown in
italic. These placeholders are used in some of the figures showing dialog boxes
and other elements of the user interface.

� Italics are also used to emphasize important points, to indicate references to
printed documents and named sections of this manual, and to identify
definitions of terms that may be unfamiliar.

� Examples of syntax and source code are displayed in monospace font—for
example: /N0001 U1(8) U2(1);

� Some of the figures and their descriptions refer to a “cursor.” In this tutorial, the
marker that moves as you move the mouse is called the pointer. The term cursor
refers to the insertion point for text you type, as in a text box.

� Some of the figures and their descriptions refer to “attributes.” This tutorial uses
the term properties, but the terms are synonymous.
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Starting the drawing

Although Visual CADD is used in many different industries and applications, in
these introductory lessons you will create a basic printed circuit board outline. This
first lesson shows you how to size the drawing area, how to set up a unit of
measurement to work in, and how to draw lines to create the board outline using
exact dimensions.

When you finish this lesson, the board outline will be done, you will know how to
use techniques essential to CAD drawing, and your drawing should look like the one
shown here.

Lesson 1
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Preparing to draw

The first task you undertake in any drawing is to set up the drawing area using the
required dimensions and measurement unit. You also set up drawing defaults, such
as line color and line type.

6 Tip    You can get help in any dialog box by clicking the Help button  and then
clicking on the option about which you want to know more.

To start a new drawing

1 If Visual CADD is not open, choose the Visual CADD command from the
Tools menu in the Layout session frame.

2 If a Visual CADD file is already open, save your work and close the file.

3 From the File menu, choose the New command.

To set the working environment

Before you begin drawing, set up drawing properties in the Settings dialog box.

1 From the Utilities menu, choose the Settings command.

2 In the Settings dialog box, choose the System tab.

3 From the Background drop-down list, select Black.

O Note    If you choose some other color for the background, be sure to select a
contrasting color for the pointer (Cursor).

4 From the Default Tool drop-down list, select Selection.
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5 Choose the Text/Atb Tab.

6 Under Attribute Settings, deselect the Display Labels option.

7 Choose the Numeric tab.

8 In the Numeric Dimension and Numeric Display group boxes, select .1234 from
both Decimal Places drop-down lists.

9 Select Decimal Inches from the Dimension Unit, Secondary Unit, and Entry &
Display Unit drop-down lists.

O Note    Visual CADD retains these settings from one session to the next.

10 Choose the OK button to close the dialog box.

11 Type AP and check the status bar at the bottom of the window.

At the left end of the status bar, you should see the words “Convert Acad
Polyline Width ON.” The AP shortcut is a toggle, so you may have turned it off.

If the status bar shows “Convert Acad Polyline Width OFF” type AP again.
This setting controls how line widths display in Visual CADD.
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To create the drawing window

In this lesson, you will zoom in and out of various areas of the drawing to complete
your work. In the beginning, though, you should adjust the view of the drawing area
so that the entire drawing fits on the screen and the origin point (0,0) is in the bottom
left corner.

1 From the Snaps menu, choose Manual Entry, and then choose Absolute.

When you enter X,Y coordinates in absolute mode, they are interpreted as an
offset from the origin (0,0).

2 From the Zooms menu, choose Window.

3 Type –1,–1 (no spaces) and press ENTER to define the lower left corner of the
window.

As you type the coordinates, they display at the left end of the status bar at the
bottom of the window.

4 Type 6,6 and press ENTER to define the upper right corner of the window.

The drawing window now can accommodate a 6" by 6" printed circuit board.

To turn on ortho mode

In ortho mode, Visual CADD constrains lines to 90° increments of a specified angle.
This ensures square corners, accurate horizontal and vertical lines, and true
perpendicular lines at all angles. Visual CADD uses polar coordinate notation, in
which 0° corresponds to 3 o’clock and 90° corresponds to 12 o’clock.

1 From the Snaps menu, choose Ortho Angle.

2 In the Ortho Angle text box, type 0 (zero).

3 Make sure the Ortho Mode option is selected and the Cursor Free option is not,
then choose the OK button.
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Creating the board outline

You can draw the board outline by several methods:

� Using absolute and relative coordinates.

� Snapping lines to existing objects.

� Using direct-distance entry with ortho mode.

To insert a board outline

All the objects you use to create a PCB floor plan are found on the Insert menu.

1 From the Insert menu, choose Board Outline.

2 Move the pointer over the drawing area, click the right mouse button, and
choose the Edit Object command from the pop-up menu.

O Note    Throughout these lessons, the term pop-up menu refers to the menu that
appears when you click the right mouse button.

3 In the Width text box, type .025 and then choose the OK button.

6 Tip    Whatever width you specify, the edge of the board is at the center of the line
representing the board outline. The inner half of the width is the pullback; it is not
accessible for autorouting. The outer half of the width is a visual artifact.
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To set the grid spacing and display

1 From the Snaps menu, choose the Grid command, then choose Grid Size.

2 In the X text box, type .01 and then move the pointer over the Y text box.

The Y text box automatically updates to match the X value.

3 Make sure both the Snap to Grid Point and the Display Grid options are
selected.

4 Choose the OK button.

6 Tip    Using snaps in Visual CADD, you don’t need to know the absolute location
of a point you want to place. Instead, you place the point in relation to an existing
point in the drawing.

To draw using X,Y coordinates

To begin drawing the outline, you use absolute mode first and then switch to relative
mode. When you enter X,Y coordinates in relative mode, they are interpreted as an
offset from the last point drawn, rather than from the origin.

1 Note the “ABS” in the status bar at the bottom of the screen, indicating that you
are still in absolute mode.

2 Type 0,0 and press ENTER.

The pointer moves to the origin (0,0).

3 From the Snaps menu, choose Manual Entry, then choose Relative.

4 Type 0.85,0 and press ENTER.

5 Type 0,–0.2 and press ENTER.
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To draw using direct-distance entry

You can also draw by specifying a direction and entering the distance.

1 Move the pointer to the right to specify the direction.

6 Tip    In cursor-free mode, the line follows your initial movement away from the
starting point. If you accidentally move the pointer in the wrong direction, just
move back toward the starting point, and then move to the right.

2 Type 4 and press ENTER to specify the distance.
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To draw an angled line using X,Y coordinates

1 Type 0.1,0.1 and press ENTER.

Because relative mode is active, the new end point is offset by 0.1,0.1 from the
previous point. This creates a 45° line with a length of 0.1414.

6 Tip    If you make a mistake, click the Undo button  on the toolbar near the top
of the window.

2 Use direct-distance entry to continue with the board outline: move the pointer
up, type 4.3 and press ENTER.
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To draw an angled line using ortho mode

Ortho mode is especially useful when you know the angle and length of a line.

1 From the Snaps menu, choose Ortho Angle.

2 In the Ortho Angle text box, type 45.

3 Make sure the Ortho Mode option is selected and the Cursor Free option is not,
then choose the OK button.

Now you can draw a 45° line easily using direct-distance entry.

4 Move the pointer up and to the left.

Notice that the pointer’s movement is constrained to 90° increments of the new
ortho angle.

5 Type .1414 and press ENTER.

Now reset the ortho angle to 0°.

6 Type OA0 (the Ortho Angle text box is automatically active) and press ENTER.
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To draw a line by referencing existing points

1 From the Snaps menu, choose Cursor Free.

2 Move the pointer to the left.

Notice that the line is still constrained to 90° increments of the ortho angle, but
the pointer is no longer “attached” to the line.

3 Move the pointer down and to the left until it is near the second vertex you
placed in the board outline.

4 Type NP to end the segment at the same X coordinate as the near point.

Now you can finish the board outline.

5 Move the pointer down, type .2 and press ENTER.

6 Move the pointer to the left to start the constrained line in the appropriate
direction.

7 Move the pointer down toward the point where you started the board outline.

8 Hold down the SHIFT key while you click the right mouse button.

6 Tip    Holding down the SHIFT key and clicking the right mouse button has the
same effect as typing NP.

9 From the pop-up menu, choose Pen Up to stop drawing the board outline.
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To change the properties of an object

1 Click on the board outline to select it.

2 From the pop-up menu, choose Change Properties.

3 Set the layer to Board_Outline and the color to 9 (blue).

4 Choose the OK button.

To save your work

1 From the File menu, choose Save As.

2 Open the TUTORIAL folder.

3 In the File name text box, type Outline and then choose the Save button.

Adding crop marks

You can also place a vertex at a precise distance from an existing point in your
drawing. If this reference point is the origin (0,0), you switch to relative mode and
specify the X,Y offset; otherwise, you use tracking.

Tracking temporarily suspends drawing while you position the pointer relative to an
existing reference point. Using tracking, you follow these general steps: select the
line object you want to insert, suspend drawing, specify the reference point, specify
the X and Y offsets (one at a time), and resume drawing.

In this section, you use tracking to place crop marks (also called shear marks) at a
precise distance from the board outline.

To set properties for the first crop mark

1 From the Insert menu, choose Free Track.

2 From the pop-up menu, choose Edit Object.

3 Set the width to .05 and the object layer to Top.

4 Choose the OK button.
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To draw the first crop mark

1 From the Snaps menu, choose Track to suspend drawing.

2 Move the pointer to the lower-left corner of the board outline, then type NP to
use the intersection as a reference point.

3 Move the pointer to the left, then type .025 and press ENTER to set the X
coordinate of the crop mark’s starting point.

4 Move the pointer up, then type .175 and press ENTER to set the Y coordinate.

O Note    Until you end tracking, rubber-band lines show your current position.

5 From the pop-up menu, choose Track End to resume drawing.

6 Move the pointer down, then type .2 and press ENTER.

7 Move the pointer to the right, then type .2 and press ENTER.

8 From the pop-up menu, choose Pen Up to stop drawing the free track.

To zoom in on part of the board

You can get a closer look at the lower-left corner of the board by specifying the
corners of a small area that you want to fill the window.

1 From the Zooms menu, choose Window.

2 Type –.5,.5 and press ENTER.

3 Type 1.5,–.75 and press ENTER.

6 Tip    These “zoom window” coordinates are interpreted as an offset from the
origin (0,0), regardless of the manual entry mode.
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To draw the next crop mark

1 From the Insert menu, choose Free Track.

2 From the pop-up menu, choose Edit Object.

3 Make sure the width is .05 and the layer is Top, then choose the OK button.

4 From the Snaps menu, choose Track to suspend drawing.

5 Move the pointer near the second vertex that you placed in the board outline,
and type NP to specify the reference point.

6 Move the pointer to the left, then type .225 and press ENTER to set the X offset.

7 Move the pointer down, then type .025 and press ENTER to set the Y offset.

8 From the pop-up menu, choose Track End to resume drawing.

9 Move the pointer to the right, then type .2 and press ENTER.

10 Move the pointer down, then type .2 and press ENTER.

11 Move the pointer to the right, then type .2 and press ENTER.

12 From the pop-up menu, choose Pen Up.
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To draw the third crop mark

1 Use the scroll bar at the bottom of the window to scroll right until the lower-
right corner of the board comes into view.

2 From the Insert menu, choose Free Track.

3 Edit the object, and make sure the properties match those of the two crop marks
you just drew.

4 From the pop-up menu, choose Track.

5 Move the pointer near the lower of the two points at this corner of the board,
then type NP.

6 Use direct-distance entry to move left by .1896, and then down by .025.

7 From the pop menu, choose Track End.

8 Draw right by .2.

9 Type OA45 and press ENTER.

This sets the ortho angle to 45°.

10 Draw up and right by .162.

11 Type OA0 and press ENTER to reset the ortho angle.

12 Draw up by .2.

13 From the pop-up menu, choose Pen Up.

14 Type ZA to view the entire board.

15 Type DS to save your work.
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To draw the final crop marks

Using mirroring, you can draw the three remaining crop marks in a single action.

1 From the Edit menu, choose Select, then choose Object.

2 Move the pointer over one of the three crop marks, and click the left mouse
button to select it.

3 Hold down the CTRL key while you select each of the other two crop marks.

O Note    If you accidentally select the wrong object, keep the pointer over it and
hold down the CTRL key while you click the left mouse button again to deselect
the object.

4 From the Modify menu, choose Mirror.

5 From the Snaps menu, choose Midpoint.

6 Move the pointer over the right edge of the board outline, then click the left
mouse button to snap to the midpoint of the right edge.

7 Move the pointer to the left.

An outline at the top of the board shows the placement of the mirrored
crop marks.

8 Click the left mouse button again to place the mirrored crop marks.
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To copy the crop marks to the bottom layer

1 From the Utilities menu, choose Layer Manager.

2 Make sure the Short List option is not selected.

3 From the scrollable list of layers, select 2.

4 Select 2 again. A text box displays over the layer name.

5 Type Free_Track_Bot and press ENTER to rename the layer.

6 From the list of layers, select Free_Track_Bot, then choose the Make Selected
Layer Current button. 

7 Choose the Close button  near the upper right corner of the Layer Manager.

8 From the Edit menu, select Select, then select Layer.

9 From the Enter Layer drop-down list, select Free_Track_Top to select all six
crop marks, which are the only objects on the top layer.

10 From the Modify menu, select Copy, then select Copy to Layer to copy the
selected crop marks to the bottom layer.

Summary

The board outline and crop marks are complete. In the next lesson, you add and
refine the details of the drawing.
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Editing the drawing

Once you finish the board outline, you can use Visual CADD to add and modify
objects in your drawing. This lesson describes how to add floor planning objects,
clean up lines and entities, place and edit text, create new objects from existing
objects, and round corners.

When you finish this lesson, the board should look like the one shown here.

Lesson 2
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Adding floor planning objects

In this part of the lesson, you add keepout and keepin areas and define the boundary
of a copper area.

To place a height keepout area

1 From the Insert menu, choose Comp Height Keepout.

2 From the pop-up menu, choose Edit Object.

3 Set the height to .025 and the object layer to Top, then choose the OK button.

4 From the Snaps menu, choose Manual Entry, then choose Absolute.

5 Type .5,.2 and press ENTER.

6 From the Snaps menu, choose Manual Entry, then choose Relative.

7 Move the pointer to the right, type .6 and press ENTER.

O Note    Remember, this technique of specifying a direction and then a distance is
called direct-distance entry.

8 Continue using direct-distance entry to draw up by 3.7, then left by .6.

9 From the pop-up menu, choose Pen Up to stop drawing the keepout area.
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To place a group keepin area

1 From the Insert menu, choose Comp Group Keepin.

2 From the pop-up menu, choose Edit Object.

3 Set the height to .015 and the object layer to Top, then choose the OK button.

4 On the status bar at the bottom of the window, select REL and then BPT to
change the manual entry mode to absolute (ABS).

5 Type 1.175,–.2 and press ENTER.

6 Type MR  to change the manual entry mode back to relative.

7 Use direct-distance entry to draw right by 1.15, up by .85, and left by 1.15.

8 From the pop-up menu, choose Pen Up to stop drawing the keepin area.

9 Type MO  to change the manual entry mode to absolute.

10 From the Zooms menu, choose Window.

11 Type .5,4.5 and press ENTER.

12 Type 1.4,3.75 and press ENTER.
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To create a chassis ground pad

1 From the Insert menu, choose Comp Group Keepout.

2 From the pop-up menu, choose Edit Object.

3 Set the height to .015 and the object layer to Top, then choose the OK button.

4 Move the pointer inside the board outline, near the upper-left corner.

5 Hold down the SHIFT key while you click the right mouse button.

The pointer snaps to the nearest vertex.

6 Use direct-distance entry to draw right by .3, down by .3, and left by .3.

7 From the pop-up menu, choose Pen Up to stop drawing the keepout area.

To set the current layer and line properties

1 Choose the Properties button on the toolbar at the top of the window.

2 In the Layer combo box, type PLATED_HOLES.

3 Make sure the color is set to 9 (blue), and the line type is set to 0 (SOLID).

4 In the Width text box, type 0 and then choose the OK button.

O Note    These settings apply to objects drawn (not inserted) on layers that do not
have color assignments. Board outlines and other objects on the Insert menu also
have default color assignments, which are not affected by these settings.
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To create a mounting hole

1 From the Draw menu, choose Circle, then choose 2-point (Center-Radius).

2 From the Snaps menu, choose Track.

3 Move the pointer near the lower-right corner of the chassis ground pad, then
hold down the SHIFT key while you click the right mouse button.

4 Use direct-distance entry to move up by .1 and then left by .1.

5 From the pop-up menu, choose Track End to set the reference point for tracking.

6 Use direct-distance entry to draw the radius to the right by .025.

To create the next pad and mounting hole using mirroring

1 Select the chassis ground pad, then hold down the CTRL key while you select the
mounting hole.

2 Type ZA to view the entire board.

3 From the Modify menu, choose Mirror.

4 From the Snaps menu, choose Midpoint.

5 Move the pointer to the right edge of the board outline, then click the left
mouse button.

6 Move the pointer to the left.

This creates a horizontal axis for mirroring.

7 Click the left mouse button again to place the mirrored pad and hole where the
outline indicates their location.
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To create the last chassis ground pad and hole

1 Select the second pad, then hold down the CTRL key while you select the second
mounting hole.

2 From the Modify menu, choose Mirror.

3 Type SM to enable snap midpoint.

4 Move the pointer to the bottom edge of the board outline, then click the left
mouse button.

5 Move the pointer up.

This creates a vertical axis for mirroring.

6 Click the left mouse button again to place the mirrored pad and hole where the
outline indicates their location.

To chamfer the last chassis ground pad

You use the Chamfer command to fit the third pad to the existing corner.

1 From the Zooms menu, choose Window.

2 Type 4,.25 and press ENTER, then type 5,–.3 and press ENTER again.

3 From the Modify menu, choose Chamfer.

4 From the pop-up menu, choose Chamfer Dist.

5 Set Dist 1 to .1, then move the pointer over the Dist 2 text box.

The Dist 2 text box automatically updates to match the Dist 1 value.

6 Choose the OK button.

7 Move the pointer to the bottom edge of the pad, then click the left mouse button.

The bottom edge of the chassis ground pad is selected.
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8 Move the pointer to the right edge of the pad, then click the left mouse button
again.

The lower-right corner of the chassis ground pad now has a 45° chamfer.

To move the chassis ground pad

1 From the Edit menu, choose Select, then choose Adjoining.

2 Select the pad, and use the CTRL key to select the mounting hole.

O Note    Using the CTRL key in this manner called adding to the selection set.

3 From the Modify menu, choose Move.

4 Move the pointer just to the left of the pad, then click the left mouse button to
designate a reference point for moving the selection set.

5 Move the pointer to the right, type .1 and press ENTER.
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Placing and editing text

You can use the Text Line tool and the Array Copy command to label the chassis
ground pads for documentation purposes.

O Note    These labels are not reference designators for the pads.

To label the first chassis ground pad

1 From the Zooms menu, choose Window.

2 Type .5,4.5 and press ENTER, then type 1.4,3.75 and press ENTER again.

3 From the tool palette at the left side of the window, choose the Text Line
tool. 

4 From the pop-up menu, choose Text Settings.

5 Make sure the font is set to Arial.

6 In the Ht text box, type .075 and then choose the OK button.

7 In the Text text box, type MTH1.

8 Move the pointer to the top-left corner of the pad, then click the left mouse
button to place the text above the mounting hole.

To move the text, select the text outline, then move it to another location.

9 When the text outline is placed correctly, choose the OK button at the top of
the window.
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To label the remaining pads using array copy

1 Select the MTH1 label you just placed.

2 From the Modify menu, choose Copy, then choose Array Copy.

3 Set the number of copies to 1 and the number of rows to 2, then choose the
OK button.

4 Move the pointer near the first text label you placed, then click the left mouse
button to set a reference point.

5 Type ZA to view the entire board.

6 Move the pointer down, then type 4.35 and press ENTER.

This sets the distance between rows of the array.

7 Move the pointer up to the original label, and then to the right; then type 3.75
and press ENTER.

This sets the distance between columns of the array and places the copies.

8 Select the unneeded label in the upper-right corner of the board, and press the
DELETE key.

To edit the second and third labels

1 Select the label in the lower-left corner of the board.

2 From the pop-up menu, choose Text Line.

3 Change the text string to MTH2, then choose the OK button.

4 Repeat the process to change the lower-right label to MTH3.
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Creating new objects from existing objects

Using the Match Entity command, you can easily create a notch with the same
drawing properties as the board outline.

To match the existing board outline

1 From the Utilities menu, choose Match Entity.

2 Select the board outline.

To draw the notch

1 From the Draw menu, choose Line, then choose Continuous.

2 From the Snaps menu, choose Object.

3 Move the pointer to the top edge of the board outline, about one-third of the
way in from the left edge, then click the left mouse button.

4 Use direct-distance entry to draw down by .25, right by 1.5, and up by .25.

5 From the pop-up menu, choose Pen Up to stop drawing the line.
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Finishing the notch

To finish the notch, you trim the existing board outline to a path. A path is a group
of objects joined by their endpoints—in this case, the notch you just placed. Then
you round the corners of the notch.

To open the notch

1 From the Edit menu, choose Select, then choose Adjoining.

2 Select the top edge of the board.

3 From the Modify menu, choose Trim, then choose Multiple.

4 Move the pointer to the bottom edge of the notch, then click the left
mouse button.

This defines the bottom edge as the trim boundary.

5 Move the pointer toward the center of the board outline until the preview shows
the notched area open.

6 Click the left mouse button again to complete the trim operation.
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To round the corners of the notch

A fillet is an arc that replaces the intersection of two lines.

1 From the tool palette, choose the Fillet tool. 

6 Tip    The Fillet tool is persistent—you can keep using it until you press the ESC
key or select another tool or command.

2 From the pop-up menu, choose Fillet Radius.

3 Set the fillet radius to .062, and make sure the Preview Fillet option is selected,
then choose the OK button.

4 Move the pointer near the intersection at the upper-left corner of the notch, then
click the left mouse button.

5 Move the pointer down and to the left until the correct fillet appears, then click
the left mouse button to place the fillet.

6 Repeat steps 4 and 5 to place fillets at the three other vertices on the notch.

7 Press the ESC button twice to activate the selection tool.

8 Choose the Save Drawing button  at the top of the window to save your work.
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Creating a circular notch

For this exercise, draw a rectangle anywhere inside the board outline. You can delete
it after you learn the technique.

                  

To draw a rectangle

1 From the tool palette at the left edge of the window, choose the 2 point
Rectangle tool. 

2 Move the pointer to a clear space inside the board outline, then click the left
mouse button to define one corner of the rectangle.

3 Move the pointer diagonally to define a rectangle, then click the left mouse
button again to define the opposite corner of the rectangle.

To add a circular notch

1 From the tool palette, choose the 2 point Circle tool. 

2 Move the pointer to any edge of the rectangle you just drew, then click the left
mouse button to define the center of the circle.

3 Move the pointer away from the center point, then click the left mouse button
again to define the radius of the circle.

O Note    You can also use direct-distance entry to define the radius of a circle.

4 Select the circle and the rectangle.

5 From the Modify menu, choose Boolean.

6 Move the pointer in and out of the rectangle, then in and out of the circle, noting
the four available shapes.

7 When the notch displays, click the left mouse button again to complete the
Boolean operation.

O Note    Now that you’ve learned how to create a circular notch, be sure to delete
the notched rectangle you just created, and then save your work.
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Summary

The drawing is complete. In the next lesson, you move the floor plan into Layout to
complete the board design.
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Moving the drawing
to Layout

To finish your board design, you save the drawing as a DXF file, then use
MAXDXF to import the DXF file into Layout. MAXDXF converts DXF to Layout
format, and back. You learn more about MAXDXF in later lessons.

Completing the board design

To create a DXF file

1 Type AP and make sure the words “Convert Acad Polyline Width ON” display
in the status bar at the bottom of the window.

If they don’t, type AP again.

2 From the File menu, select Save As.

3 From the Save as type drop-down list, select AutoCAD DXF.

The File name text box changes to Outline.dxf.

4 Choose the Save button.

Lesson 3



Lesson 3   Moving the drawing to Layout

32    OrCAD Layout for Windows Visual CADD Tutorial

To translate the DXF file to Layout format

1 Open the Layout session frame.

2 From the File menu, choose Import, then choose DXF to MAX.

3 Choose the Browse button next to the Input DXF File text box.

4 In the VCADD folder, choose TUTORIAL, then choose OUTLINE.DXF.

The DXF to MAX dialog box displays, with the text boxes filled in. For this
exercise, do not change the default filename in the Output Layout File text box.

You can also accept the default filenames in the lower pair of text boxes.

5 For this exercise, select the Overwrite existing files option.

6 Make sure the Remove Existing Obstacles and Text option is not selected.

7 Choose the Translate button.

MAXDXF translates the input DXF file to Layout format, and Notepad displays
any warning or error messages generated.

To complete the board design

1 From the File menu, choose Open.

2 In the VCADD folder, choose TUTORIAL, then choose OUTLINE.MAX.

3 From the File menu, choose Save As.

4 In the File name text box, type outline1.max.

6 Tip    By using a different name for the Layout file where you finish the design,
you retain OUTLINE.MAX as a backup.
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To translate the finished design to DXF

Once you complete the board design, you need to create a DXF version that you can
open with Visual CADD for printing and plotting.

1 From the File menu, choose Save, then choose the Close button  to display the
Layout session frame.

2 From the File menu, choose Export, then choose MAX to DXF.

3 Choose the Browse button next to the Input Layout File text box.

4 In the VCADD folder, choose TUTORIAL, then choose OUTLINE1.MAX.

The MAX to DXF dialog box displays, with the text boxes filled in. For this
exercise, do not change the default filename in the Output DXF File text box.

You can also accept the default filename in the DXF ini File text box.

OUTLINE1.DXF probably doesn’t exist yet, so you can ignore the Overwrite
existing files option for this exercise.

5 Choose the Translate button.

MAXDXF creates the output DXF file, and Notepad displays any warning or
error messages generated.

Summary

The design is complete. In the next lesson, you learn several ways to print drafts and
final documentation.
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Printing the drawing

This lesson describes how to print your drawing to fit a specific paper size or at a
specific scale. It also introduces reference frames and describes how to use them to
print your drawing within a prepared title block at three different scales.

When you finish this lesson and print your drawing using reference frames, the
output should look similar to this illustration.

Lesson 4
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Setting up your printer

Visual CADD uses the default printer and paper size that you have set up in
Windows. In this lesson, the instructions create output for 8.5 by 11–inch paper.
If your default printer is not set up to print at this size, you should change it before
starting the exercises. Also check that your printer is properly connected and
functioning.

O Note    In Visual CADD, the page size equals the paper size minus the margins.
For example, 8.5 by 11–inch paper with .25-inch margins yields a page size of
8 by 10.5 inches.

Printing your drawing

The easiest and most common way to print your drawing on any output device is to
use the Fit to Paper option, which scales the drawing to fit the defined page size.
This is useful when you are creating drafts of your drawing.

To print to fit the page

1 Open OUTLINE1.DXF, the file you created in the preceding chapter.

2 From the toolbar at the top of the window, choose the Print Drawing button. 

3 In the Print dialog box, choose the Preview button.

4 Verify the page size, and make sure the Portrait option is selected.

5 Select the Fit to Paper option, then choose the Update button to make sure all
your changes take effect.

6 Choose the Print button to send your drawing to the printer and close the Print
dialog box.
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6 Tip    To print a drawing containing color to a black-and-white output device, just
select the All Colors to Black option in the Print dialog box.

To print to scale

You can also print your drawing at a specific scale, which is often necessary for
technical drawings such as your board outline.

1 From the toolbar at the top of the window, choose the Print Drawing button.

2 Choose the Preview button.

3 Select the Scale option, and type .75 in the Real World text box.

O Note    In this context, real world means “as specified in your drawing,” so a
0.75-inch line in your drawing will take up 1 inch on the printed page.

4 Choose the Center button.

This centers the drawing on the page and updates the preview to match the
specified scale.

5 Choose the Print button.

6 From the File menu, choose Save.
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Printing your drawing using reference frames

Reference frames, which create links to any drawings accessible from your
computer, also make it easy to print a single drawing at multiple scales. When a file
linked to a reference frame changes, the file containing the reference frame
automatically updates to reflect the change.

In this exercise, you open a title block drawing customized for 8.5 by 11–inch paper
and add three reference frames linked to your drawing, OUTLINE1.VCD.

O Note    You may prefer to save the title block and board information in a single
file, rather than use reference frames as shown in this exercise. If you decide to do
so, be sure to put the title block on an appropriate documentation layer, such as the
assembly top or drill drawing layer.

To create a reference frame

1 From the toolbar at the top of the window, choose the Open Drawing button. 

2 In the VCADD folder, open TUTORIAL, then open TITLBLOK.VCD.

3 From the Draw menu, choose Reference Frame, then choose Create.

4 Type MO.75,9.75 and press ENTER to designate the upper-left corner of the
reference frame.

5 Type MR7,–3 and press ENTER to designate the lower-right corner.

6 Near the top of the window, choose the MDI tab.

7 Make sure OUTLINE1.VCD is selected in the MDI Drawing drop-down list,
then choose the OK button.

8 Select the reference frame you just created.

9 From the pop-up menu, choose RF Zoom All.

O Note    Reference frames have a separate set of zoom commands, available only
from the pop-up menu.
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To insert a detail

1 From the Draw menu, choose Reference Frame, then choose Create.

2 Type MO.75,2.25 and press ENTER to designate the lower-left corner of the
reference frame.

3 Type MR2.5,2.5 and press ENTER to designate the upper-right corner.

4 Near the top of the window, choose the MDI tab.

5 Make sure OUTLINE1.VCD is still selected in the MDI Drawing drop-down
list, then choose the OK button.

6 Select the reference frame, then choose RF Zoom All from the pop-up menu.

7 From the pop-up menu, choose RF Zoom Window, then draw a window around
the lower-left corner of the board in the new reference frame.

6 Tip    To define the window, just click the left mouse button at opposite corners of
the area you want to enclose.
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To insert a detail to scale

1 From the Draw menu, choose Reference Frame, then choose Create.

2 Type MO7.75,2.25 and press ENTER to designate the lower-right corner of the
reference frame.

3 Type MR–2.5,2.5 and press ENTER to designate the upper-left corner.

4 Near the top of the window, choose the MDI tab.

5 Make sure OUTLINE1.VCD is still selected in the MDI Drawing drop-down
list, then choose the OK button.

6 Select the reference frame, then choose RF Zoom Scale from the pop-up menu.

7 In the text box, type 1"  and then choose the OK button.
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To bring part of the board into the reference frame

1 From the pop-up menu, choose RF Pan.

2 Move the pointer near the upper-left corner of the reference frame, then click
the left mouse button.

The selected point moves to the center of the frame.

3 Press the spacebar to repeat the RF Pan command, then select another point near
the upper-left corner of the reference frame.

The mounting hole labeled MTH1 moves into the reference frame.

To print to scale using reference frames

The reference frames are already scaled, so you can print the title block drawing at
full size.

1 From the toolbar at the top of the window, choose the Print Drawing button.

2 In the Real World text box, type 1 and then make sure the Scale option is
selected.

3 Choose the Center button, then choose the Print button.

Summary

Your introduction to the basics of using Visual CADD is complete. The remaining
lessons describe how to move designs between Visual CADD, Layout, and other
PCB design and CAD programs.

You are also finished working with OUTLINE.VCD, OUTLINE1.VCD, and
TITLBLOK.VCD, so close them before you go on.
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Creating fabrication drawings

You can use Visual CADD to create drill plots and assembly drawings from DXF
files produced by Layout or MAXDXF. You print or plot these drawings using
Visual CADD.

Creating fabrication drawings from Layout DXF

To create a drill plot

1 In Layout, use batch post processing to create a DXF file, called DRD.DXF, for
the drill drawing layer.

O Note    See the OrCAD Layout for Windows User’s Guide for information about
post processing.

2 Start Visual CADD, then choose the Open command from the File menu.

3 In the Open File dialog box, select AutoCAD DXF from the Files of type drop-
down list.

4 Select DRD.DXF, then choose the OK button.

5 From the File menu, choose Print or Plot.

To create assembly drawings

¬ Use the process described above to create DXF files for the assembly top (AST)
and assembly bottom (ASB) layers, and send them to the printer or plotter.

Lesson 5



Lesson 5   Creating fabrication drawings

44    OrCAD Layout for Windows Visual CADD Tutorial

Creating assembly drawings from MAXDXF output

You can also use the output from MAXDXF as input to Visual CADD to create
assembly drawings.

The DXF output from MAXDXF is designed for use with thermal analysis tools, so
the DXF retains the structure of your board file. Pads and vias are represented as
padstacks and viastacks. Padstacks are grouped into symbols called footprints, and
footprints are referenced by symbols called components.

To gain control of the printing and plotting process within Visual CADD you must
flatten the DXF by exploding the symbols onto their respective layers. Because these
symbols are nested three levels deep—padstacks, footprints, and components—you
must explode them three times. You can then hide or display layers to set up the
desired plots.

To explode nested symbols

1 From the Utilities menu, choose Settings, and select the General tab.

2 Make sure the Explode on Placement option is not selected.

3 Under Explode Symbol To, select the Individual layers option.

4 Choose the OK button.

O Note    Visual CADD retains these settings between sessions. You should set
them once and leave them.

5 From the pop-up menu, choose Select By, then choose All to select the entire
drawing.

6 From the Symbol menu, choose Explode Symbol.

7 Repeat steps 5 and 6 two more times to explode the remaining nesting levels.
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Visual CADD offers several ways to explode symbols. In addition to the menu
commands already described, you can use the context-sensitive toolbar (also called
the speedbar), keyboard shortcuts, and scripts.

To use the context-sensitive toolbar

1 Press ESC a few times to make sure nothing is selected, then type EX.

2 In the toolbar near the top of the window, hold the pointer over each button
momentarily and read the explanation of the button’s function.

3 Choose the button at the far left to select all objects in the drawing.

The total number of objects selected displays in the toolbar.

4 Choose the OK button to explode all objects.

5 Repeat the process two more times.

To use keyboard shortcuts

1 Type SA to select everything in the drawing.

2 Type EX to explode all symbols.

3 Repeat the process two more times.

To use a script

You can create a script, which is a sequence of Visual CADD commands, and assign
it to an unused function key or hot key. Scripts are a convenient way to automate
repetitive or frequently used processes.

1 From the Utilities menu, choose Tools, then choose Assign Script.

2 From the drop-down list of available keys, select F3:.

3 In the Edit Script Line text box, type SA;EX;SA;EX;SA;EX; (notice that a
semicolon [;] follows each command, including the last).

4 Choose the Update button, then choose the OK button.

5 Press F3 to flatten the DXF file.
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To hide unneeded layers

Once you have flattened the DXF file created by MAXDXF, you can hide all the
layers but the assembly top to create an assembly drawing.

1 From the Utilities menu, choose Layer Manager.

2 Make sure the Short List option is selected.

This limits the layer list to just those layers which contain objects.

3 Hold the pointer over each button in the Layer Manager toolbar to read a brief
description of its function.

The far left button is for hiding or displaying selected layers. If all the selected
layers are currently displayed, a gray light bulb on the button indicates that you
can choose the button to hide them. If all the selected layers are hidden, a
yellow light bulb indicates that you can choose the button to display them.

O Note    You cannot hide the current layer. Instead, make some other layer current,
then hide the layer that was current before.

4 Select the ASYTOP layer, then choose the button with the yellow light bulb (or
make sure the light bulb is gray, indicating the layer is already visible).

5 Choose the Make Selected Layer Current button.

6 Select the other listed layers, then choose the button with the gray light bulb
(or make sure the light bulb is yellow).
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To hide layers using the pop-up menu

When some of the selected layers are hidden and some are displayed, Visual CADD
tries to determine the appropriate action and set the light bulb color (in other words,
the button’s function) accordingly. If the light bulb is the wrong color for what you
want to do, you can use the Layer Manager pop-up menu.

1 Move the pointer over ASYTOP in the list, then click the right mouse button.

2 From the pop-up menu, choose Current.

3 Display the pop-up menu again, then choose Select All in List.

4 Display the pop-up menu again, then choose Hide.

5 In the list, double-click on OBS_ASYTOP and then on TEXT_ASYTOP.

Double clicking on a layer makes it immediately visible.

O Note    If your assembly drawing had no special instructions as text on it, you
may not have a TEXT_ASYTOP layer.

6 In the list, double-click on BOARD_OUTLINE to include the board outline in
your assembly drawing.

7 In the list, double-click on COMPONENT_TOP to include component text in
your assembly drawing.

To print or plot the drawing

¬ From the File menu, choose Print or Plot.

Summary

This lesson described how to convert Layout information to DXF. In the remaining
lessons you learn how to convert DXF files from different sources to Layout format.
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Translating mechanical
drawings

Besides creating DXF files for use in solid modeling and thermal analysis,
MAXDXF provides a mechanism for importing PCB design data in DXF  format
into Layout. The MAXDXF initialization file (typically called MAXDXF.INI)
specifies the mapping of data between DXF and Layout format.

The file contains much of its own documentation in comments (characters following
a semicolon), which are ignored by MAXDXF.

This lesson describes the initialization file and some of its uses.

Lesson 6



Lesson 6   Translating mechanical drawings

50    OrCAD Layout for Windows Visual CADD Tutorial

The MAXDXF initialization file

The initialization file begins as shown below and on the following page.

;   Special control variables can be set within the INI file.  The control
;   variables remain in effect for all of the layers which follow it until
;   the control variable is encountered again.
;
  UNITS_DIVISOR=1.0
;
;   When the UNITS_DIVISOR option is present, the coordinates and widths in
;   the input DXF file are divided by the number indicated to convert them
;   to inches.  If the input MAX technology file is in metric, MAXDXF will
;   then translate the inch value into millimeters as each object is placed
;   in the MAX file.
;   Examples:
;       UNITS_DIVISOR=1     ; DXF file is in inches
;       UNITS_DIVISOR=1000  ; DXF file is in mils
;       UNITS_DIVISOR=25.4  ; DXF file is in millimeters
;       UNITS_DIVISOR=2.54  ; DXF file is in centimeters
;       UNITS_DIVISOR=X.XX  ; DXF file is in some arbitrary unit of measure
;
  DEFAULT_TRACK_WIDTH=0.010
;
;   When the DEFAULT_TRACK_WIDTH option is present, translated arcs and
;   lines which have no width in AutoCAD will be given this default width.
;   AutoCAD TRACES and POLYLINES which have a defined width retain the
;   width set in the DXF file.  The specified width must be in the same
;   units as the DXF file itself.
;
; OVERRIDE_TRACK_WIDTH=0.015
;
;   When the OVERRIDE_TRACK_WIDTH option is present, all translated objects
;   are given the indicated width, even TRACES and POLYLINES which already
;   have an AutoCAD width.  The specified width must be in the same units
;   as the DXF file itself.
;
  CONTINUATION_CAPTURE_RANGE=0.02
;
;   When the CONTINUATION_CAPTURE_RANGE option is present, lines and arcs
;   whose endpoints are within the indicated distance are joined into a
;   single continuous Layout obstacle.  This can be important with some CAD
;   tools which express the start and stop angle of an arc to only the
;   nearest degree.  For an arc with a large radius, the endpoints of the
;   arc may be offset relative to the line to which they should join.  The
;   specified range must be in the same units as the DXF file itself.
;
;
;   The following section defines the versions of the files and software
;   with which MAXDXF must interact.  This section must be present to run
;   MAXDXF.  Dependencies discovered with specific versions of CAD
;   software are documented in this section.

[VERSION]

INI_VERSION = 2.00

VISUALCADD_DIRECTORY = .\VCADD
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;   In the remainder of this file, the left hand column is the Layout layer
;   name and the right hand column is the corresponding AutoCAD layer name.
;   Note that this is the reverse of the first version of the MAXDXF
;   software.
;
;   The following section defines the default layer setup of the DXF to MAX
;   translator for objects not explicitly called out in the later sections.

[LAYER]

GLOBAL_LAYER    = GLOBAL_LAYER
TOP             = TOP
BOTTOM          = BOTTOM
GND             = GND
INNER           = INNER
PLANE           = PLANE
POWER           = POWER
INNER1          = INNER1
INNER2          = INNER2
INNER3          = INNER3
INNER4          = INNER4
INNER5          = INNER5
INNER6          = INNER6
INNER7          = INNER7
INNER8          = INNER8
INNER9          = INNER9
INNER10         = INNER10
INNER11         = INNER11
INNER12         = INNER12
INNER13         = INNER13
INNER14         = INNER14
INNER15         = INNER15
INNER16         = INNER16
SMTOP           = SMTOP
SMBOT           = SMBOT
SPTOP           = SPTOP
SPBOT           = SPBOT
SSTOP           = SSTOP
SSBOT           = SSBOT
ASYTOP          = ASYTOP
ASYBOT          = ASYBOT
DRLDWG          = DRLDWG
DRILL           = DRILL
FABDWG          = FABDWG
PHOTO           = PHOTO
HOLES           = HOLES
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The MECHANICAL section

For translations from DXF to Layout, such as translating DXF files created by your
mechanical engineering group for use by Layout, the last section near the bottom of
the MAXDXF.INI file is most important. The pertinent lines follow.

;   In the mechanical section, you have the opportunity to map an AutoCAD
;   layer on the right of the equal sign to the Layout layer and object
;   type on the left of the equal sign.
;
;   Only circles have meaning on the Mounting Hole layers.

[MECHANICAL]

BOARD_OUTLINE           = BOARD_OUTLINE
ROUTE_KEEPOUT_TOP               = ROUTE_KEEPOUT_TOP
ROUTE_KEEPOUT_BOT               = ROUTE_KEEPOUT_BOT
ROUTE_KEEPOUT_ALL               = ROUTE_KEEPOUT_ALL
NO_VIA_TOP                      = NO_VIA_TOP
NO_VIA_BOT                      = NO_VIA_BOT
NO_VIA_ALL                      = NO_VIA_ALL
PLATED_MOUNTING_HOLES   = PLATED_HOLES
UNPLATED_MOUNTING_HOLES = HOLES
HEIGHT_RESTRICTED_TOP   = HEIGHT_RESTRICT_TOP
HEIGHT_RESTRICTED_BOT   = HEIGHT_RESTRICT_BOT
COMP_KEEPOUT_ALL        = KEEPOUT_ALL
COMP_KEEPOUT_TOP        = KEEPOUT_TOP
COMP_KEEPOUT_BOT        = KEEPOUT_BOT
COMP_GROUP_KEEPIN_ALL   = GROUP_KEEPIN_ALL
COMP_GROUP_KEEPIN_TOP   = GROUP_KEEPIN_TOP
COMP_GROUP_KEEPIN_BOT   = GROUP_KEEPIN_BOT
; Use these keywords to create a component/footprint from DXF input.
; Currently only circles can be converted into pads during batch
; translation. Visual CADD symbols (AutoCAD blocks) can be converted
; into pads during interactive translation.
; The component name and origin should precede all other
; comp_ objects associated with the component.

COMP_NAME           = U1
COMP_ORIGIN         = 0,0
COMP_PADS_TOP       = COMP_PADS_TOP_LAYER   ; SMT pads on TOP layer
COMP_PADS_BOT       = COMP_PADS_BOT_LAYER   ; SMT pads on BOT layer
COMP_PADS_THRU      = COMP_PADS_ALL_LAYERS  ; THRU hole pads
                                            ;   on all copper layers



Lesson 6   Translating mechanical drawings

OrCAD Layout for Windows Visual CADD Tutorial    53

COMP_SILKSCREEN_TOP = COMP_SILKSCREEN_TOP
COMP_SILKSCREEN_BOT = COMP_SILKSCREEN_BOT

COMP_FREE_TRACK_TOP = COMP_FREE_TRACK_TOP
COMP_FREE_TRACK_BOT = COMP_FREE_TRACK_BOT
COMP_FREE_TRACK_IN1 = COMP_FREE_TRACK_IN1
COMP_FREE_TRACK_IN2 = COMP_FREE_TRACK_IN2
COMP_FREE_TRACK_IN3 = COMP_FREE_TRACK_IN3
COMP_FREE_TRACK_IN4 = COMP_FREE_TRACK_IN4
COMP_FREE_TRACK_IN5 = COMP_FREE_TRACK_IN5
COMP_FREE_TRACK_IN6 = COMP_FREE_TRACK_IN6
COMP_FREE_TRACK_IN7 = COMP_FREE_TRACK_IN7
COMP_FREE_TRACK_IN8 = COMP_FREE_TRACK_IN8
COMP_FREE_TRACK_IN9 = COMP_FREE_TRACK_IN9
COMP_FREE_TRACK_I10 = COMP_FREE_TRACK_I10
COMP_FREE_TRACK_I11 = COMP_FREE_TRACK_I11
COMP_FREE_TRACK_I12 = COMP_FREE_TRACK_I12
COMP_FREE_TRACK_I13 = COMP_FREE_TRACK_I13
COMP_FREE_TRACK_I14 = COMP_FREE_TRACK_I14

COMP_COPPER_TOP     = COMP_COPPER_TOP
COMP_COPPER_BOT     = COMP_COPPER_BOT
COMP_COPPER_IN1     = COMP_COPPER_IN1
COMP_COPPER_IN2     = COMP_COPPER_IN2
COMP_COPPER_IN3     = COMP_COPPER_IN3
COMP_COPPER_IN4     = COMP_COPPER_IN4
COMP_COPPER_IN5     = COMP_COPPER_IN5
COMP_COPPER_IN6     = COMP_COPPER_IN6
COMP_COPPER_IN7     = COMP_COPPER_IN7
COMP_COPPER_IN8     = COMP_COPPER_IN8
COMP_COPPER_IN9     = COMP_COPPER_IN9
COMP_COPPER_I10     = COMP_COPPER_I10
COMP_COPPER_I11     = COMP_COPPER_I11
COMP_COPPER_I12     = COMP_COPPER_I12
COMP_COPPER_I13     = COMP_COPPER_I13
COMP_COPPER_I14     = COMP_COPPER_I14

; ’UNMAPPED_AUTOCAD_LAYERS’ is a special keyword recognized by MAXDXF
; to represent all AutoCAD layers in the DXF which have not been mapped
; anywhere earlier in this INI file.  If you want AutoCAD entities on
; these unmapped layers to be translated, you must specify the Layout
; layer on the left of the equal sign.

ASYBOT                  = UNMAPPED_AUTOCAD_LAYERS
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Manipulating the MECHANICAL mappings

If your mechanical engineering group placed the board outline on a DXF layer
called BOARD_OUTLINE, then the translation will proceed normally. If they
placed it on some other layer (PERIMETER, in this example), change the
appropriate line in MAXDXF.INI to read:

BOARD_OUTLINE = PERIMETER

If there is a keepout zone on DXF layer 2, then change the appropriate line in
MAXDXF.INI to read:

COMP_KEEPOUT_ALL = 2

Any plated mounting holes stored in the DXF as circles drawn on layer HOLES
would require a line in MAXDXF.INI such as:

PLATED_MOUNTING_HOLES = HOLES
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Automatic translation

Once you have mapped all the layers in your design to standard Layout layer names,
it’s easy to translate DXF files to Layout format.

6 Tip    If you use only the standard Layout layer names in a new design (or rename
layers in an existing DXF file so they match the Layout naming scheme), you
don’t need to map layers in the initialization file.

To translate objects automatically

1 Open the Layout session frame.

2 From the File menu, choose Import, then choose DXF to MAX.

3 In the upper pair of text boxes, type the names of your input DXF file and the
output Layout file (or accept the default output filename).

You can accept the default filenames in the lower pair of text boxes.

4 Choose the Translate button.

MAXDXF translates the input DXF file, and Notepad displays any warning or
error messages generated.
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Interactive translation

If all the objects are on one DXF layer, translation is more complicated. MAXDXF
cannot distinguish one kind of object from another, but you can use interactive
translation to filter groups of objects for MAXDXF.

To translate objects interactively

1 Open the Layout session frame.

2 From the File menu, choose Import, then choose DXF to MAX.

3 In the upper pair of text boxes, type the names of your input DXF file and the
output Layout file (or accept the default output filename).

You can accept the default filenames in the lower pair of text boxes.

4 Choose the Interact button.

The screen clears, then Visual CADD opens displaying the input DXF file.

O Note    It may take a few moments for Visual CADD to process all the
information in the DXF file.

5 Choose the Selection tool  from the tool palette at the left edge of the window,
then select the board outline.

If the board outline is built up of individual lines and arcs, follow these steps to
select the entire outline:

a From the pop-up menu, choose Select By, then choose Adjoining.

b Select any part of the board outline.

c Inspect the selected outline. Add lines and arcs to the selection set, or
remove them, as needed.
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6 From the tool palette at the left edge of the window, choose the Convert to
MAX tool. 

7 From the drop-down lists, select Board Outline and Global Layer.

8 Select the Delete selected entities after conversion option.

This will help you keep track of your progress as you translate the DXF.

9 Choose the OK button.

10 Repeat this process for other objects you want to translate.

11 When you finish, exit Visual CADD but do not save the modified DXF file.

If you have been deleting objects as your translate them, the DXF file is mostly
empty at this point, and saving it would replace your existing file with the
empty version.

The translation process completes, and Notepad displays any warning or error
messages generated.

Summary

This lesson described how to convert DXF files such as you might receive from your
mechanical engineering group to Layout format. In the final lesson you learn how to
convert DXF files from an external PCB design program for use in Layout.
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Translating external PCB formats

When you translate a printed circuit board from some other PCB design program for
use in OrCAD Layout for Windows, it is always best to use a translator specifically
created for this purpose. If such a translator is not available, or if the board was
actually designed in AutoCAD, it is possible to reconstruct the board from one or
more DXF files.

This lesson describes the process.

Importing the DXF file

In Layout, all tracks must begin and end on a pad, or they must end with a pending
unrouted connection to a pad. This means that you must translate component pads
before tracks. Vias, which must be circle objects (not simply four arcs), are always
translated as “through” vias.

Simple circular component pads in a DXF file are usually defined as circle objects,
while oval or rectangular pads are composed of several lines, arcs, or polylines
grouped as a Visual CADD symbol (equivalent to an AutoCAD block).

The following procedures use the term component pads, regardless of how they are
represented in your DXF file.

O Note    If you have only DWG files, you can load them into Visual CADD and
save them as DXF for interactive translation.

Lesson 7
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To translate the board outline and any zones

1 Open the Layout session frame.

2 From the File menu, choose Import, then choose DXF to MAX.

3 In the upper pair of text boxes, type the names of your input DXF file and the
output Layout file (or accept the default output filename).

You can accept the default filenames in the lower pair of text boxes.

4 Choose the Interact button.

The screen clears, then Visual CADD opens displaying the input DXF file.

5 Translate the board outline as described in the Interactive translation section of
Lesson 6: Translating mechanical drawings.

6 Tip    Remember to leave the Delete selected entities after conversion option
selected in the Translate Selections to MAX dialog box.

6 One at a time, translate any zones (keepout, keepin, copper pour, and so on) by
the same process.
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Translating components

One at a time, translate each component by setting the origin, translating the
component pads, and then translating the silkscreen lines and text.

To set the component origin

1 If your DXF is hierarchical and your component is a symbol unto itself, simply
select the component symbol.

or

If your DXF is not hierarchical or your component is not a symbol unto itself,
then from the pop-up menu choose Select By, then choose Window, and draw a
box around the component pads.

2 From the tool palette at the left edge of the window, choose the Convert to
MAX tool.

3 From the upper drop-down list, select Set Component Origin, then choose the
Options button.

4 In the Component Reference Designator text box, type a unique name.

6 Tip    Check the names in the drop-down list to make sure the name you enter
is unique.

5 Choose the OK button in both of the open dialog boxes.

O Note    Even though the Delete selected entities after conversion option is
still selected, the translator does not delete any object used only to set the
component origin.
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To translate component pads

1 If your DXF is hierarchical and your component is a symbol unto itself, select
the component symbol, then type EX to explode it.

2 From the pop-up menu choose Select By, then choose Window, and draw a box
around the component pads.

O Note    The conversion is limited to circles and symbols, so don’t worry if you
accidentally select portions of tracks or silkscreen—they will be ignored.

3 From the tool palette at the left edge of the window, choose the Convert to
MAX tool.

4 From the upper drop-down list, select the appropriate type of conversion:

� Circles to SMT Pads � Symbols to SMT Pads

� Circles to THRU Pads � Symbols to THRU Pads

5 If you are translating SMT Pads, then select either TOP or BOTTOM from the
On MAX layer drop-down list.

6 Make sure the Delete selected entities after conversion option is selected, then
choose the OK button.

To translate the component silkscreen lines and text

1 From the pop-up menu, choose Select By, then choose Window, and draw a box
around the component silkscreen.

6 Tip    If the selection set includes tracks, just use the Layer Manager as described
in Lesson 5 to hide the track layers.

2 From the tool palette at the left edge of the window, choose the Convert to
MAX tool.

3 From the upper drop-down list, select Component Silkscreen.

4 From the lower drop-down list, select either SSTOP or SSBOT.

5 Make sure the Delete selected entities after conversion option is selected, then
choose the OK button.
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Translating remaining elements

Next, translate board silkscreen elements and tracks.

To translate silkscreen text

1 From the pop-up menu, choose Filter.

2 Set Entity to Text, and Layer to the silkscreen top layer for this component.

3 Make sure Color and Font are set to *All*.

4 Select the Filter option, and choose the OK button.

5 From the pop-up menu, choose Select By, then choose All.

6 From the tool palette at the left edge of the window, choose the Convert to
MAX tool.

7 From the upper drop-down list, select Text.

8 From the lower drop-down list, select SSTOP.

9 Make sure the Delete selected entities after conversion option is selected, then
choose the OK button.

10 Repeat steps 1 through 9 for the silkscreen bottom layer, selecting SSBOT at
step 8.

To translate silkscreen lines

1 From the pop-up menu, choose Filter.

2 Deselect the Filter option, and choose the OK button.

3 Use the same process to translate your board silkscreen lines, but convert them
to Free Track (step 7) on the SSTOP or SSBOT layer (step 8).
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To translate tracks

1 From the pop-up menu, choose Select By, then choose Layer.

2 Select the layer containing tracks for TOP.

3 From the tool palette at the left edge of the window, choose the Convert to
MAX tool.

4 From the upper drop-down list, select Tracks.

5 From the lower drop-down list, select TOP.

6 Make sure the Delete selected entities after conversion option is selected, then
choose the OK button.

7 Repeat steps 1 through 6 for the bottom layer and any inner copper layers,
selecting BOTTOM and INNERn at step 5.

To complete the translation

¬ When you finish, exit Visual CADD but do not save the modified DXF file.

The translation process completes, and Notepad displays any warning or error
messages generated.

O Note    For any track that ends inside a pad, but slightly off center, a small end
segment is added to the track to carry it to the center of the pad.

As your tracks are imported, nets are assigned the names N00001, N00002, and so
on. As tracks that begin on one layer join with tracks on other layers through vias,
some of the created netnames are no longer necessary and are eliminated. This
causes the “gaps” in the net naming sequence that you may notice in the translated
board file.
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Stopping and resuming an incomplete translation

The process described in this lesson can be time-consuming, and you may need to
stop the translation temporarily and complete it later.

To pause during translation

1 Save the DXF file you’re working from (MY-DESN.DXF, for this example),
using a name like TEMP.DXF.

2 Rename the MAX file you’ve created so far (MY-DESN.MAX), using a name
like INTERMED.MAX.

This will be the technology file when you resume the translation.

M Caution    It is rarely advisable to use the same name for the output Layout file
and the technology file (skipping step 2, above). The DXF translation is
irreversible, and a system failure or other problem could corrupt all the work you
had done before pausing, as well as after resuming. By using a different name for
the output Layout file in the next procedure, your loss would be limited to work
done after resuming the translation.
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To resume the translation process

1 Open the Layout session frame.

2 From the File menu, choose Import, then choose DXF to MAX.

3 In the Input DXF File text box, type the name of the temporary DXF file
(from step 1 of the preceding process).

4 In the Output Layout File text box, type the name of the MAX file you were
creating when you paused.

5 In the Technology File text box, type the name of the intermediate MAX file
(from step 2 of the preceding process).

6 Make sure the Remove Existing Obstacles and Text option is not selected.

M Caution    Selecting this option will destroy your previous work.

7 Choose the Interact button.

The screen clears, then Visual CADD opens displaying the input DXF file.

8 Continue the translation where you left off.
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Importing a design from multiple DXF files

If the printed circuit board exists in DXF format spread across several files, your
work follows the same general flow: translate the components first, then the tracks.
Each DXF file requires a separate execution of the DXF-to-MAX translator, and you
should use a separate intermediate MAX file for each DXF file.

6 Tip    If the pad definitions are in the same DXF file as tracks, but the silkscreen
elements are in a separate DXF file, you can postpone component silkscreen
translation until after the copper layers are translated.

As long as the component pads are translated before the tracks are translated, you
are free to reorder the rest of the process to suit the manner in which your board
file has been split across DXF files.

To import a multiple-file DXF design

1 Translate the first DXF file, using these settings:

� Output Layout File: INTRMED1.MAX

� Technology File: DEFAULT.MAX

2 Translate the second DXF file, using these settings:

� Output Layout File: INTRMED2.MAX

� Technology File: INTRMED1.MAX

3 Translate the third DXF file, using these settings:

� Output Layout File: INTRMED3.MAX

� Technology File: INTRMED2.MAX

4 Continue in this manner, using the output file from one translation as the
technology file for the next, until you have processed all of the DXF files.

The last file cited in the Output Layout File text box (INTRMEDn.MAX)
contains the completed design.

Summary

This concludes the Visual CADD tutorial. Before you go on, take a few minutes to
look over the appendix of frequently asked questions and pick up more useful tips
for using Visual CADD.
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Frequently asked questions

This appendix provides tips and suggestions to help you get the most out of
Visual CADD and Layout. The information is set out as a series of questions
and answers.

You may want to glance over this section once, then refer to it as needed.

How do I stretch a board outline?

It may help you to think of stretching a board outline or other object in terms of
moving vertices.

1 From the Utilities menu, choose Settings, then choose the System tab.

2 Make sure that the Default Tool is set to Selection, then choose the OK button.

3 From the pop-up menu, choose Select By, then choose Object.

4 Select the board outline or other object you want to stretch.

5 From the pop-up menu, choose Modify, then choose Stretch.

6 Draw a selection window around the one or two vertices defining the section
you want to move.

They do not highlight, but they are selected for the stretch operation.

7 Move the pointer just outside the outline, near the selected segment or vertices,
then click the left mouse button to set a reference point for the stretch.

8 Move the pointer to stretch the board outline as needed.

9 Click the left mouse button again to confirm the change.

O Note    If you skip step 4 (by choosing Modify, then Stretch, from the pop-up
menu without first selecting the object), Visual CADD displays the Stretch
toolbar. Press ESC to dismiss the toolbar, then start over at step 4.

Appendix
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How do I rotate a board outline?

Rotating a board outline or other object follows the same pattern as stretching one.

1 Select the board outline or other object you want to rotate.

2 From the pop-up menu, choose Modify, then choose Rotate.

3 Move the pointer to the location you want to use as the center of rotation, then
click the left mouse button.

4 Move the pointer just outside the outline, near the selected segment or vertices,
then click the left mouse button to set a reference point for the stretch.

5 Move the pointer around the center of rotation as needed, using the outline as a
guide to the finished position.

6 Click the left mouse button again to confirm the change.

How do I move a vertex in a board outline?

1 From the pop-up menu, choose Modify, then choose Move Point.

2 Move the pointer over the vertex you want to move, then click the left
mouse button.

3 Click and hold down the left mouse button, as you move the pointer a bit.

4 Release the mouse button, then move the vertex as needed.

5 Click the left mouse button again to confirm the change.

Why am I having trouble moving vertices, rotating, and stretching?

Visual CADD ships with the snap increment set to 1 inch. For many operations, a
smaller value, such as one tenth of an inch, gives you the control you need.

1 From the Utilities menu, choose Settings, then choose the Constraint tab.

2 In the Size text box under Increment Snap, type .1.

3 Make sure the other settings are appropriate. (For instance, the ortho angle has a
big effect on rotation operations.)

4 Choose the OK button.
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How do I group objects?

A group of related objects in Visual CADD is called a symbol (analogous to an
AutoCAD block). To create a Visual CADD symbol from a group of objects:

1 Select the objects you want to group.

2 From the Symbol menu, choose Create Symbol.

3 In the Symbol Name text box, type a unique and descriptive name.

4 Choose the OK button.

5 Move the pointer to the location you want to designate as the object’s handle
(its center for rotations), then click the left mouse button.

& See also    The Visual CADD User’s Guide contains a complete description of
symbols and how to attach attributes to symbols. Be sure to read about this
powerful and useful feature.

Why aren’t all the holes in my Visual CADD drawing listed in the Layout
drill chart?

Only circle objects can be imported as holes. Holes drawn with arcs, lines, and
polylines are imported as objects.

How do I specify a drill hole as a nonplated mounting hole or plated
through-hole?

Plated and nonplated holes are defined during translation and imported as padstacks.
In Layout, you can change the padstacks as needed, using the Padstacks spreadsheet.

Make sure you set the layer to Global Layer when you translate the holes, and
translate the holes first if you’re using interactive mode.
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Why can’t Visual CADD find fonts when it starts?

The Layout installation process registered an incorrect path for the Visual CADD
fonts. You can fix this easily.

1 Start Visual CADD.

2 From the Utilities menu, choose Settings, then choose the Path tab.

3 In the Font (VCF) text box, append FONTS\ to the path listed.

For example, if you installed Layout under the standard directory structure, the
Font (VCF) text box contains this:

C:\ORCADWIN\LAYOUT\VCADD\

You need to change it to this:

C:\ORCADWIN\LAYOUT\VCADD\FONTS\

4 Choose the OK button to record the change.

Visual CADD retains this setting, so you won’t have to change it again.

Can I use my Windows fonts in Visual CADD?

The TrueType and PostScript font standards are designed for raster devices. Vector
devices do not support raster fonts. When you plot to a vector output device, such as
a Hewlett-Packard™ pen plotter, Visual CADD substitutes vector fonts for any
raster fonts in your drawing.

O Note    Visual CADD vector fonts, like those for AutoCAD, differ from most
other vector fonts in that they are proportional (rather than fixed-width or
monospace).

What can I do about an AutoCAD font that won’t import?

Visual CADD can substitute one of its fonts for an AutoCAD font that doesn’t
translate correctly.

1 From the Utilities menu, choose Import/Export.

2 Choose the DWG Settings tab, and deselect the Ignore font map option.

3 Choose the DWG Font Import tab.

4 From the AutoCAD list, select the font that doesn’t translate correctly.

5 From the Visual CADD list, select a substitute font, then choose the –> button.

6 Choose the OK button.
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A
absolute mode, 4, 19
adjoining elements, selecting, 22
angle, ortho, 4, 9
array copy, 25
arrow keys, viii
assembly drawings, creating, 43, 44
attribute settings, 3

B
board outlines

adding notches, 26, 29
changing properties, 11
inserting, 5
moving a vertex, 70
rotating, 70
stretching, 69

C
chamfers, creating, 22
chassis ground pads, 20
circles, drawing, 21
color settings, 2
components

reference designator, 61
setting the origin, 61
symbols, 44
translating pads, 59, 62
translating silkscreen, 62

Control key, viii, 15
coordinates, drawing with, 6, 8
copying objects, 16
crop marks

adding, 11
copying, 16
mirroring, 15

cursor-free mode, 7, 10

I n d e x
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D
default tool, setting, 2
deselecting objects, 15
dimension unit, 3
direct-distance entry, 7
drawings

adding crop marks, 11
assembly, 43, 44
creating a drawing, 2
fabrication, 43
saving a drawing, 11, 14, 28
translating external PCB formats, 59
translating from DXF, 49, 59

drill chart, Layout, 71
drill holes, 71
drill plots, creating, 43
DXF

creating fabrication drawings, 43
moving drawings to Layout, 31
translating external PCB formats, 59
translating mechanical drawings, 49
translating multiple-file designs, 67

E
editing

objects, 5
text, 24

Escape key, viii
exploding symbols, 44

F
files

creating a drawing, 2
multiple, translating from DXF, 67
saving a drawing, 11, 14, 28

fillets, creating, 28
final documentation, an example, 38
fonts

importing, 72
installation path, 72
raster and vector, 72
substituting, 72

footprints, 44
frequently asked questions, 69

G
grid settings, 6
ground pads, 20
group keepin areas, 19
grouping objects, 71

H
height keepout areas, 18
hiding layers, 46, 47
holes

drill, 71
mounting, 21, 71
through, 71

I–J
importing. see also Translating

fonts, 72
inserting

board outlines, 5
free tracks, 11

K
keepin and keepout areas, 18, 19
keyboard keys, viii

L
labels

displaying, 3
placing and editing, 24

layers
assigning objects to, 11
copying objects to, 16
hiding, 46, 47
mapping DXF to Layout, 50–54
properties, 20

lines
drawing, 26
properties, 3, 5, 20
translating, 63
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M
manual entry, 4, 6
matching existing objects, 26
MAXDXF

.INI file, 49
creating assembly drawings, 44
moving drawings to Layout, 31
translating external PCB formats, 59
translating mechanical drawings, 49

measure, units of, 3
menus, pop-up, 5
mirroring objects, 15, 21
modes

absolute, 4, 19
cursor-free, 7, 10
ortho, 4, 9
relative, 6, 19

modifying objects, 15, 16, 21, 22, 23, 27
mounting holes

creating, 21
mirroring, 21

moving objects, 23
multiple-file designs, translating from DXF, 67

N
near point, 10
new drawings, creating, 2
notches

adding fillets, 28
circular, 29
creating, 26, 29

numeric settings, 3

O
objects

changing properties, 11
grouping, 71
line width, 5
properties, 20

ortho angle, 4, 9
ortho mode, 4, 9

P–Q
pads

chassis ground, 20
translating, 59, 62

padstacks, 44
page size, 36
placing

multiple copies, 25
text, 24

polyline width, 3
pop-up menus, 5
previewing print output, 36
printer setup, 36
printing

centering output, 37
fit to paper, 36
to scale, 37, 40
using reference frames, 38

properties, layer and line, 20

R
reference designator, assigning, 61
reference frames

printing with, 38
zooming in and out, 38

relative mode, 6, 19
requirements, vii
resolution, screen, vii
resuming paused translations, 65–66
rotating board outlines, 70
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S
saving drawings, 11, 14, 28
screen resolution, vii
scripts, 45
selecting

adjoining elements, 22
objects, 15

setup, printing, 36
silkscreen, translating, 62, 63
snapping

to midpoint, 15, 22
to near point, 10
to tracks, 12

stretching board outlines, 69
symbols, exploding, 44
system requirements, vii
system settings, 2

T
text

translating, 63
typing, viii

title blocks, an example, 38
tracking, 11
tracks

inserting, 11
snapping to, 12
translating, 64

translating
automatic translation, 55
components, 59, 62
from DXF, 49, 59, 67
interactive translation, 56, 59
multiple-file designs, 67
pads, 62
pausing and resuming, 65–66
silkscreen lines and text, 63
tracks, 64

trimming objects, 27
troubleshooting, 69
typing text, viii

U
units of measure, 3

V
vias, translating, 59
viastacks, 44

W
window, zoom to fill, 4

X–Y
X,Y coordinates, drawing with, 6

Z
zooming in and out, 4, 12, 25, 38
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